Attention is currently required from: jolly.
dexter has posted comments on this change by jolly. ( https://gerrit.osmocom.org/c/onomondo-ipa/+/43060?usp=email )
Change subject: V1.2: Add function to set Device Capabilities
......................................................................
Patch Set 1: Code-Review+1
(1 comment)
File src/ipa/main.c:
https://gerrit.osmocom.org/c/onomondo-ipa/+/43060/comment/04720e8d_74ac1a90… :
PS1, Line 264: case 'D':
I wonder if it would make sense to accept a string like "00001111". A one byte hex number would also be ok.
Somewhat unrelated, but helpful when fixed/improved:
One thing that would be really helpful would be a converter that converts from ASCII hex digits to binary hex. This would solve a very annoying problem: The eIM generates an eIM configuration and outputs it as ASCII hex digits on the REST API. To use this output we have to convert it to binary using external tools to get the sample_eim_cfg.ber file you find in contrib. When we have a conveter, we could just use a text file with the ASCII hex string or even switch to a commandline parameter.
After all, you could then use the converter here to set cfg.device_capabilities from a 2-hex-digit string (If you think this would make sense).
--
To view, visit https://gerrit.osmocom.org/c/onomondo-ipa/+/43060?usp=email
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings?usp=email
Gerrit-MessageType: comment
Gerrit-Project: onomondo-ipa
Gerrit-Branch: master
Gerrit-Change-Id: I866787b8cda9a87a9f2e0db4965fbb554d339a6c
Gerrit-Change-Number: 43060
Gerrit-PatchSet: 1
Gerrit-Owner: jolly <andreas(a)eversberg.eu>
Gerrit-Reviewer: Jenkins Builder
Gerrit-Reviewer: dexter <pmaier(a)sysmocom.de>
Gerrit-Attention: jolly <andreas(a)eversberg.eu>
Gerrit-Comment-Date: Thu, 23 Jul 2026 09:11:32 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: Yes
Attention is currently required from: jolly.
dexter has posted comments on this change by jolly. ( https://gerrit.osmocom.org/c/onomondo-ipa/+/43058?usp=email )
Change subject: V1.2: Change field name in InitiateAuthenticationOkEsipa
......................................................................
Patch Set 1: Code-Review+2
--
To view, visit https://gerrit.osmocom.org/c/onomondo-ipa/+/43058?usp=email
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings?usp=email
Gerrit-MessageType: comment
Gerrit-Project: onomondo-ipa
Gerrit-Branch: master
Gerrit-Change-Id: I68d59b44bd8b5dd23ae070d42dab9727c0da5272
Gerrit-Change-Number: 43058
Gerrit-PatchSet: 1
Gerrit-Owner: jolly <andreas(a)eversberg.eu>
Gerrit-Reviewer: Jenkins Builder
Gerrit-Reviewer: dexter <pmaier(a)sysmocom.de>
Gerrit-Attention: jolly <andreas(a)eversberg.eu>
Gerrit-Comment-Date: Thu, 23 Jul 2026 08:47:30 +0000
Gerrit-HasComments: No
Gerrit-Has-Labels: Yes
Attention is currently required from: jolly.
dexter has posted comments on this change by jolly. ( https://gerrit.osmocom.org/c/onomondo-ipa/+/43056?usp=email )
Change subject: V1.2: Add eimTransactionId to InitiateAuthenticationRequestEsipa
......................................................................
Patch Set 1:
(3 comments)
File src/ipa/libipa/esipa_init_auth.h:
https://gerrit.osmocom.org/c/onomondo-ipa/+/43056/comment/e80c9040_f2430c2c… :
PS1, Line 19: TransactionId_t *eim_transaction_id;
As it seems there is a tab instead of a space between type and member name. The member name is consistent, however in other code locations we use struct OCTET_STRING to declare the type.
(here the name of the struct meber is consistent)
File src/ipa/libipa/proc_cmn_mtl_auth.h:
https://gerrit.osmocom.org/c/onomondo-ipa/+/43056/comment/35c58fc0_6b9ed194… :
PS1, Line 19: TransactionId_t *eim_transaction_id;
maybe declare this as struct OCTET_STRING *eim_transaction_id?
It could also make sense to apply some refactoring, so that we consistently use TransactionId_t throughout the entire codebase. What we should not do is to mix the two type names, even when they are the same under to hood.
We may also check if it would work to declare the eim_transaction_id as const n the pars and req structs.
File src/ipa/libipa/proc_indirect_prfle_dwnld.h:
https://gerrit.osmocom.org/c/onomondo-ipa/+/43056/comment/d7702c23_4a653703… :
PS1, Line 18: TransactionId_t *eim_transaction_id;
(see the other comments)
--
To view, visit https://gerrit.osmocom.org/c/onomondo-ipa/+/43056?usp=email
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings?usp=email
Gerrit-MessageType: comment
Gerrit-Project: onomondo-ipa
Gerrit-Branch: master
Gerrit-Change-Id: I1c8ef6fc0a3f7ab5735e401597fc8c6b2021fc09
Gerrit-Change-Number: 43056
Gerrit-PatchSet: 1
Gerrit-Owner: jolly <andreas(a)eversberg.eu>
Gerrit-Reviewer: Jenkins Builder
Gerrit-CC: dexter <pmaier(a)sysmocom.de>
Gerrit-Attention: jolly <andreas(a)eversberg.eu>
Gerrit-Comment-Date: Thu, 23 Jul 2026 08:45:07 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Attention is currently required from: jolly.
dexter has posted comments on this change by jolly. ( https://gerrit.osmocom.org/c/onomondo-ipa/+/43055?usp=email )
Change subject: V1.2: Change fields in ProvideEimPackage(Result)
......................................................................
Patch Set 1:
(1 comment)
File src/ipa/libipa/esipa_prvde_eim_pkg_rslt.h:
https://gerrit.osmocom.org/c/onomondo-ipa/+/43055/comment/826ae0e4_d15ed434… :
PS1, Line 20: struct OCTET_STRING *eim_trans_id;
I think its better to call it eim_transaction_id, because in other interfaces we have called it "transaction_id" already. We should have a consistent naming scheme.
(see esipa_cancel_session.h for an example)
--
To view, visit https://gerrit.osmocom.org/c/onomondo-ipa/+/43055?usp=email
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings?usp=email
Gerrit-MessageType: comment
Gerrit-Project: onomondo-ipa
Gerrit-Branch: master
Gerrit-Change-Id: I24baab4f9351aec27c58403b94974cba4b274c34
Gerrit-Change-Number: 43055
Gerrit-PatchSet: 1
Gerrit-Owner: jolly <andreas(a)eversberg.eu>
Gerrit-Reviewer: Jenkins Builder
Gerrit-CC: dexter <pmaier(a)sysmocom.de>
Gerrit-Attention: jolly <andreas(a)eversberg.eu>
Gerrit-Comment-Date: Thu, 23 Jul 2026 07:54:46 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No