lists.osmocom.org
Sign In Sign Up
Manage this list Sign In Sign Up

Keyboard Shortcuts

Thread View

  • j: Next unread message
  • k: Previous unread message
  • j a: Jump to all threads
  • j l: Jump to MailingList overview

gerrit-log

Thread Start a new thread
Download
Threads by month
  • ----- 2026 -----
  • November
  • October
  • September
  • August
  • July
  • June
  • May
  • April
  • March
  • February
  • January
  • ----- 2025 -----
  • December
  • November
  • October
  • September
  • August
  • July
  • June
  • May
  • April
  • March
  • February
  • January
  • ----- 2024 -----
  • December
  • November
  • October
  • September
  • August
  • July
  • June
  • May
  • April
  • March
  • February
  • January
  • ----- 2023 -----
  • December
  • November
  • October
  • September
  • August
  • July
  • June
  • May
  • April
  • March
  • February
  • January
  • ----- 2022 -----
  • December
  • November
  • October
  • September
  • August
  • July
  • June
  • May
  • April
  • March
  • February
  • January
gerrit-log@lists.osmocom.org

December 2025

  • 1 participants
  • 1175 discussions
[L] Change in pysim[master]: card_key_provider: add PostgreSQL support
by dexter 23 Dec '25

23 Dec '25
Attention is currently required from: daniel, fixeria, laforge. Hello Jenkins Builder, daniel, laforge, I'd like you to reexamine a change. Please visit https://gerrit.osmocom.org/c/pysim/+/41508?usp=email to look at the new patch set (#10). The following approvals got outdated and were removed: Code-Review+1 by daniel, Code-Review-1 by laforge Change subject: card_key_provider: add PostgreSQL support ...................................................................... card_key_provider: add PostgreSQL support The Card Key Provider currently only has support for CSV files as input. Unfortunately using CSV files does not scale very well when the card inventory is very large and continously updated. In this case a centralized storage in the form of a database is the more suitable approach. This patch adds PostgreSQL support next to the existing CSV file support. It also adds an importer tool to import existing CSV files into the database. Change-Id: Icba625c02a60d7e1f519b506a46bda5ded0537d3 Related: SYS#7725 --- A contrib/csv-to-pgsql.py M docs/card-key-provider.rst M pySim-shell.py M pySim/card_key_provider.py M setup.py 5 files changed, 587 insertions(+), 10 deletions(-) git pull ssh://gerrit.osmocom.org:29418/pysim refs/changes/08/41508/10 -- To view, visit https://gerrit.osmocom.org/c/pysim/+/41508?usp=email To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings?usp=email Gerrit-MessageType: newpatchset Gerrit-Project: pysim Gerrit-Branch: master Gerrit-Change-Id: Icba625c02a60d7e1f519b506a46bda5ded0537d3 Gerrit-Change-Number: 41508 Gerrit-PatchSet: 10 Gerrit-Owner: dexter <pmaier(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: daniel <dwillmann(a)sysmocom.de> Gerrit-Reviewer: laforge <laforge(a)osmocom.org> Gerrit-CC: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Attention: laforge <laforge(a)osmocom.org> Gerrit-Attention: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Attention: daniel <dwillmann(a)sysmocom.de>
1 0
0 0
[XS] Change in osmo-ttcn3-hacks[master]: 5gc: Document procedures not implemented in open5gs
by pespin 23 Dec '25

23 Dec '25
pespin has uploaded this change for review. ( https://gerrit.osmocom.org/c/osmo-ttcn3-hacks/+/41753?usp=email ) Change subject: 5gc: Document procedures not implemented in open5gs ...................................................................... 5gc: Document procedures not implemented in open5gs Change-Id: I1480dc8ee1f0db78c179406fa9090835364c01e8 --- M 5gc/C5G_Tests.ttcn 1 file changed, 3 insertions(+), 3 deletions(-) git pull ssh://gerrit.osmocom.org:29418/osmo-ttcn3-hacks refs/changes/53/41753/1 diff --git a/5gc/C5G_Tests.ttcn b/5gc/C5G_Tests.ttcn index 4076a09..e5128dd 100644 --- a/5gc/C5G_Tests.ttcn +++ b/5gc/C5G_Tests.ttcn @@ -524,9 +524,9 @@ } /* TODO: - * - 3GPP TS 23.502 4.2.2.2.3 Registration with AMF re-allocation - * - 3GPP TS 23.502 4.2.2.2.4 Registration with Onboarding SNPN - * - 3GPP TS 23.502 4.2.2.3.3 Network-initiated Deregistration + * - 3GPP TS 23.502 4.2.2.2.3 Registration with AMF re-allocation: Not supported by open5gs (https://github.com/open5gs/open5gs/issues/4214) + * - 3GPP TS 23.502 4.2.2.2.4 Registration with Onboarding SNPN: Not supported by open5gs (https://github.com/open5gs/open5gs/issues/4215) + * - 3GPP TS 23.502 4.2.2.3.3 Network-initiated Deregistration: Not supported by open5gs (https://github.com/open5gs/open5gs/issues/4216) * - 3GPP TS 23.502 4.2.3.3 Network Triggered Service Request * - 3GPP TS 23.502 4.2.4.3 UE Configuration Update procedure for transparent UE Policy delivery * - 3GPP TS 23.502 4.2.5.2 UE Reachability Notification Request procedure -- To view, visit https://gerrit.osmocom.org/c/osmo-ttcn3-hacks/+/41753?usp=email To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings?usp=email Gerrit-MessageType: newchange Gerrit-Project: osmo-ttcn3-hacks Gerrit-Branch: master Gerrit-Change-Id: I1480dc8ee1f0db78c179406fa9090835364c01e8 Gerrit-Change-Number: 41753 Gerrit-PatchSet: 1 Gerrit-Owner: pespin <pespin(a)sysmocom.de>
1 0
0 0
[S] Change in pysim[master]: pySim-shell: renovate version command
by fixeria 23 Dec '25

23 Dec '25
Attention is currently required from: dexter, laforge. fixeria has posted comments on this change by dexter. ( https://gerrit.osmocom.org/c/pysim/+/41738?usp=email ) Change subject: pySim-shell: renovate version command ...................................................................... Patch Set 5: Code-Review+1 -- To view, visit https://gerrit.osmocom.org/c/pysim/+/41738?usp=email To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings?usp=email Gerrit-MessageType: comment Gerrit-Project: pysim Gerrit-Branch: master Gerrit-Change-Id: I2b9038f88cfcaa07894a2f09c7f5ad8a5474083d Gerrit-Change-Number: 41738 Gerrit-PatchSet: 5 Gerrit-Owner: dexter <pmaier(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Reviewer: laforge <laforge(a)osmocom.org> Gerrit-Attention: laforge <laforge(a)osmocom.org> Gerrit-Attention: dexter <pmaier(a)sysmocom.de> Gerrit-Comment-Date: Tue, 23 Dec 2025 12:57:26 +0000 Gerrit-HasComments: No Gerrit-Has-Labels: Yes
1 0
0 0
[XS] Change in pysim[master]: pySim-shell/cosmetic: remove unnecessary brackets
by fixeria 23 Dec '25

23 Dec '25
Attention is currently required from: dexter. fixeria has posted comments on this change by dexter. ( https://gerrit.osmocom.org/c/pysim/+/41751?usp=email ) Change subject: pySim-shell/cosmetic: remove unnecessary brackets ...................................................................... Patch Set 1: Code-Review+2 -- To view, visit https://gerrit.osmocom.org/c/pysim/+/41751?usp=email To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings?usp=email Gerrit-MessageType: comment Gerrit-Project: pysim Gerrit-Branch: master Gerrit-Change-Id: I6929aa4fa189414217c05a4ef5180d4ed44eb3a4 Gerrit-Change-Number: 41751 Gerrit-PatchSet: 1 Gerrit-Owner: dexter <pmaier(a)sysmocom.de> Gerrit-Reviewer: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Attention: dexter <pmaier(a)sysmocom.de> Gerrit-Comment-Date: Tue, 23 Dec 2025 12:51:23 +0000 Gerrit-HasComments: No Gerrit-Has-Labels: Yes
1 0
0 0
[S] Change in pysim[master]: pySim-shell: renovate version command
by dexter 23 Dec '25

23 Dec '25
Attention is currently required from: dexter, fixeria, laforge. Hello Jenkins Builder, fixeria, laforge, I'd like you to reexamine a change. Please visit https://gerrit.osmocom.org/c/pysim/+/41738?usp=email to look at the new patch set (#5). Change subject: pySim-shell: renovate version command ...................................................................... pySim-shell: renovate version command In case pySim-shell is used directly from the git repository (not installed via a package manager), the version command fails with an exception because pkg_resources.get_distribution('pySim') fails. Let's renovate the version command and migrate from pkg_resources to importlib.resources. There are many users and developers out there who retrieve pySim-shell directly from the git repository and not via pip3. To accommodate for that, let's check if pySim-shell.py is located in a git repository and if so, let's display the HEAD commit hash instead. Since the version of the currently installed pyosmocom version also plays a critical role, let's display the pyosmocom version as well. Related: OS#6830 Change-Id: I2b9038f88cfcaa07894a2f09c7f5ad8a5474083d --- M pySim-shell.py 1 file changed, 11 insertions(+), 2 deletions(-) git pull ssh://gerrit.osmocom.org:29418/pysim refs/changes/38/41738/5 -- To view, visit https://gerrit.osmocom.org/c/pysim/+/41738?usp=email To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings?usp=email Gerrit-MessageType: newpatchset Gerrit-Project: pysim Gerrit-Branch: master Gerrit-Change-Id: I2b9038f88cfcaa07894a2f09c7f5ad8a5474083d Gerrit-Change-Number: 41738 Gerrit-PatchSet: 5 Gerrit-Owner: dexter <pmaier(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Reviewer: laforge <laforge(a)osmocom.org> Gerrit-Attention: laforge <laforge(a)osmocom.org> Gerrit-Attention: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Attention: dexter <pmaier(a)sysmocom.de>
1 0
0 0
[M] Change in osmo-hnbgw[master]: nft_kpi: add udp/2152 filtering rules separately
by pespin 23 Dec '25

23 Dec '25
Attention is currently required from: fixeria. pespin has posted comments on this change by fixeria. ( https://gerrit.osmocom.org/c/osmo-hnbgw/+/41752?usp=email ) Change subject: nft_kpi: add udp/2152 filtering rules separately ...................................................................... Patch Set 3: (1 comment) File src/osmo-hnbgw/nft_kpi.c: https://gerrit.osmocom.org/c/osmo-hnbgw/+/41752/comment/bfd7594e_7240d8b1?u… : PS3, Line 328: static int do_add_chain(bool uplink) While I agree with implementing a fix, I dislike the result as done in this patch because: * It mixes nftables rules for both directions into a function, which makes it more difficult to follow or grep in code for running ruleset. I'm totally fine with having a helper function (or 2, one per direction) as long as the nftables strings are kept as much clean as possible (eg. without "%srouting" uplink ? "ul" : "dl"). * It moves from 1 nft_run_now() calls to 3 of them. While peformance may not be that important here since this is called during startup, I think it's still nice to have all of it validated and applied atomically by running it with one nft_run_now(). -- To view, visit https://gerrit.osmocom.org/c/osmo-hnbgw/+/41752?usp=email To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings?usp=email Gerrit-MessageType: comment Gerrit-Project: osmo-hnbgw Gerrit-Branch: master Gerrit-Change-Id: I36eb3b18751fc029297fb91545af2d28e61067fd Gerrit-Change-Number: 41752 Gerrit-PatchSet: 3 Gerrit-Owner: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-CC: pespin <pespin(a)sysmocom.de> Gerrit-Attention: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Comment-Date: Tue, 23 Dec 2025 12:46:40 +0000 Gerrit-HasComments: Yes Gerrit-Has-Labels: No
1 0
0 0
[S] Change in osmo-ttcn3-hacks[master]: hnbgw: set different mgcp_params ports and ids for each subscriber
by fixeria 23 Dec '25

23 Dec '25
Attention is currently required from: pespin. fixeria has posted comments on this change by pespin. ( https://gerrit.osmocom.org/c/osmo-ttcn3-hacks/+/41749?usp=email ) Change subject: hnbgw: set different mgcp_params ports and ids for each subscriber ...................................................................... Patch Set 1: Code-Review+1 -- To view, visit https://gerrit.osmocom.org/c/osmo-ttcn3-hacks/+/41749?usp=email To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings?usp=email Gerrit-MessageType: comment Gerrit-Project: osmo-ttcn3-hacks Gerrit-Branch: master Gerrit-Change-Id: I32f644038d7e29b261ba3852583170a63544dae5 Gerrit-Change-Number: 41749 Gerrit-PatchSet: 1 Gerrit-Owner: pespin <pespin(a)sysmocom.de> Gerrit-Reviewer: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Attention: pespin <pespin(a)sysmocom.de> Gerrit-Comment-Date: Tue, 23 Dec 2025 12:42:34 +0000 Gerrit-HasComments: No Gerrit-Has-Labels: Yes
1 0
0 0
[M] Change in osmo-hnbgw[master]: nft_kpi: add udp/2152 filtering rules separately
by fixeria 23 Dec '25

23 Dec '25
fixeria has posted comments on this change by fixeria. ( https://gerrit.osmocom.org/c/osmo-hnbgw/+/41752?usp=email ) Change subject: nft_kpi: add udp/2152 filtering rules separately ...................................................................... Set Ready For Review -- To view, visit https://gerrit.osmocom.org/c/osmo-hnbgw/+/41752?usp=email To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings?usp=email Gerrit-MessageType: comment Gerrit-Project: osmo-hnbgw Gerrit-Branch: master Gerrit-Change-Id: I36eb3b18751fc029297fb91545af2d28e61067fd Gerrit-Change-Number: 41752 Gerrit-PatchSet: 3 Gerrit-Owner: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Comment-Date: Tue, 23 Dec 2025 11:38:15 +0000 Gerrit-HasComments: No Gerrit-Has-Labels: No
1 0
0 0
[S] Change in osmo-hnbgw[master]: nft_kpi: add udp/2152 filtering rules separately
by fixeria 23 Dec '25

23 Dec '25
fixeria has uploaded this change for review. ( https://gerrit.osmocom.org/c/osmo-hnbgw/+/41752?usp=email ) Change subject: nft_kpi: add udp/2152 filtering rules separately ...................................................................... nft_kpi: add udp/2152 filtering rules separately Change-Id: I36eb3b18751fc029297fb91545af2d28e61067fd Related: SYS#7808 --- M src/osmo-hnbgw/nft_kpi.c 1 file changed, 31 insertions(+), 14 deletions(-) git pull ssh://gerrit.osmocom.org:29418/osmo-hnbgw refs/changes/52/41752/1 diff --git a/src/osmo-hnbgw/nft_kpi.c b/src/osmo-hnbgw/nft_kpi.c index f8671fc..5121320 100644 --- a/src/osmo-hnbgw/nft_kpi.c +++ b/src/osmo-hnbgw/nft_kpi.c @@ -325,33 +325,50 @@ } /* worker thread */ -static int do_init_table(void) +static int do_add_chain(bool uplink) { char cmd[1024]; struct osmo_strbuf sb = { .buf = cmd, .len = sizeof(cmd) }; /* add global nftables structures */ - OSMO_STRBUF_PRINTF(sb, "add table inet %s { flags owner; };\n", g_nft_thread->table_name); OSMO_STRBUF_PRINTF(sb, - "add chain inet %s gtpu-ul {" - " type filter hook prerouting priority 0; policy accept;" - " ip protocol != udp accept;" - " udp dport != 2152 accept;" + "add chain inet %s gtpu-%s {" + " type filter hook %srouting priority 0; policy accept;" "};\n", - g_nft_thread->table_name); - OSMO_STRBUF_PRINTF(sb, - "add chain inet %s gtpu-dl {" - " type filter hook postrouting priority 0; policy accept;" - " ip protocol != udp accept;" - " udp dport != 2152 accept;" - "};\n", - g_nft_thread->table_name); + g_nft_thread->table_name, + uplink ? "ul" : "dl", + uplink ? "pre" : "post"); + OSMO_STRBUF_PRINTF(sb, "add rule inet %s gtpu-%s ip protocol != udp accept;\n", + g_nft_thread->table_name, + uplink ? "ul" : "dl"); + OSMO_STRBUF_PRINTF(sb, "add rule inet %s gtpu-%s udp dport != 2152 accept;\n", + g_nft_thread->table_name, + uplink ? "ul" : "dl"); OSMO_ASSERT(sb.chars_needed < sizeof(cmd)); return nft_run_now(cmd, NULL, NULL); } /* worker thread */ +static int do_init_table(void) +{ + int rc; + char cmd[1024]; + struct osmo_strbuf sb = { .buf = cmd, .len = sizeof(cmd) }; + + /* add global nftables structures */ + OSMO_STRBUF_PRINTF(sb, "add table inet %s { flags owner; };\n", g_nft_thread->table_name); + OSMO_ASSERT(sb.chars_needed < sizeof(cmd)); + if ((rc = nft_run_now(cmd, NULL, NULL)) != 0) + return rc; + if ((rc = do_add_chain(true)) != 0) /* gtpu-ul */ + return rc; + if ((rc = do_add_chain(false)) != 0) /* gtpu-dl */ + return rc; + return 0; +} + +/* worker thread */ static void nft_t2m_enqueue(struct nft_thread *t, struct nft_thread_req *req) { LOGP(DNFT, LOGL_DEBUG, "main() <- %s: %s rc=%d\n", t->label, nft_thread_req_type_name[req->type], req->rc); -- To view, visit https://gerrit.osmocom.org/c/osmo-hnbgw/+/41752?usp=email To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings?usp=email Gerrit-MessageType: newchange Gerrit-Project: osmo-hnbgw Gerrit-Branch: master Gerrit-Change-Id: I36eb3b18751fc029297fb91545af2d28e61067fd Gerrit-Change-Number: 41752 Gerrit-PatchSet: 1 Gerrit-Owner: fixeria <vyanitskiy(a)sysmocom.de>
1 0
0 0
[XS] Change in pysim[master]: esim.saip.FsProfileElement: Add file2pe() for single file conversion
by laforge 23 Dec '25

23 Dec '25
Attention is currently required from: dexter. laforge has posted comments on this change by laforge. ( https://gerrit.osmocom.org/c/pysim/+/41734?usp=email ) Change subject: esim.saip.FsProfileElement: Add file2pe() for single file conversion ...................................................................... Patch Set 3: (1 comment) File pySim/esim/saip/__init__.py: https://gerrit.osmocom.org/c/pysim/+/41734/comment/df7e1368_78bda566?usp=em… : PS3, Line 638: self.decoded[f.pe_name] = f.to_tuples() > There is something I am struggling with. There is already the add_file() method. […] we could a) make sure that the caller-provided file is actually contained in self.files (which is how I intended it to be used) and not some completely different source b) pass a path into this function, resolve the File from self.files and then update it. This would incur the look-up cost, which is why I decided to permit passing the file instance directly In any case, the fundamental problem is: * we have the decoded representation in self.files. It may not always be 100% correct yet as the code matures * we have very basic/inclomplete encoder capabilities, so re-encoding all the content (like files2pe below) is very likely to incur some losses in translation * during personalization, we still want to modify individual files. In case of EF.SMSP we want to replace the entire file contents, so calling a single-file `file2pe` sounds like the approach where at least we don't corrupt any other files Due to the many nasty details of the SAIP file format, and it's various encoding options, referral to [various differnt versions of] templates with default content, etc. I think it will be a long time until we have code that can reliably and loss-free translate decoded -> files -> decoded for the whole PE. -- To view, visit https://gerrit.osmocom.org/c/pysim/+/41734?usp=email To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings?usp=email Gerrit-MessageType: comment Gerrit-Project: pysim Gerrit-Branch: master Gerrit-Change-Id: I7b7f61aae6b7df6946dadf2f78fddf92995603ec Gerrit-Change-Number: 41734 Gerrit-PatchSet: 3 Gerrit-Owner: laforge <laforge(a)osmocom.org> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: dexter <pmaier(a)sysmocom.de> Gerrit-Reviewer: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Attention: dexter <pmaier(a)sysmocom.de> Gerrit-Comment-Date: Tue, 23 Dec 2025 10:02:28 +0000 Gerrit-HasComments: Yes Gerrit-Has-Labels: No Comment-In-Reply-To: dexter <pmaier(a)sysmocom.de>
1 0
0 0
  • ← Newer
  • 1
  • 2
  • 3
  • 4
  • 5
  • 6
  • 7
  • 8
  • 9
  • ...
  • 118
  • Older →

HyperKitty Powered by HyperKitty version 1.3.12.