lists.osmocom.org
Sign In Sign Up
Manage this list Sign In Sign Up

Keyboard Shortcuts

Thread View

  • j: Next unread message
  • k: Previous unread message
  • j a: Jump to all threads
  • j l: Jump to MailingList overview

gerrit-log

Thread Start a new thread
Download
Threads by month
  • ----- 2026 -----
  • November
  • October
  • September
  • August
  • July
  • June
  • May
  • April
  • March
  • February
  • January
  • ----- 2025 -----
  • December
  • November
  • October
  • September
  • August
  • July
  • June
  • May
  • April
  • March
  • February
  • January
  • ----- 2024 -----
  • December
  • November
  • October
  • September
  • August
  • July
  • June
  • May
  • April
  • March
  • February
  • January
  • ----- 2023 -----
  • December
  • November
  • October
  • September
  • August
  • July
  • June
  • May
  • April
  • March
  • February
  • January
  • ----- 2022 -----
  • December
  • November
  • October
  • September
  • August
  • July
  • June
  • May
  • April
  • March
  • February
  • January
gerrit-log@lists.osmocom.org

December 2025

  • 1 participants
  • 1175 discussions
[M] Change in osmo-hnbgw[master]: nft_kpi: add udp/2152 filtering rules separately
by laforge 23 Dec '25

23 Dec '25
Attention is currently required from: fixeria. laforge has posted comments on this change by fixeria. ( https://gerrit.osmocom.org/c/osmo-hnbgw/+/41752?usp=email ) Change subject: nft_kpi: add udp/2152 filtering rules separately ...................................................................... Patch Set 3: (1 comment) File src/osmo-hnbgw/nft_kpi.c: https://gerrit.osmocom.org/c/osmo-hnbgw/+/41752/comment/25dee18f_81433595?u… : PS3, Line 328: static int do_add_chain(bool uplink) > While I agree with implementing a fix, I dislike the result as done in this patch because: […] I particularly agree with pespin's second comment. There's no reason to change from a single atomic nft_run_now call to multiple iteratively. -- To view, visit https://gerrit.osmocom.org/c/osmo-hnbgw/+/41752?usp=email To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings?usp=email Gerrit-MessageType: comment Gerrit-Project: osmo-hnbgw Gerrit-Branch: master Gerrit-Change-Id: I36eb3b18751fc029297fb91545af2d28e61067fd Gerrit-Change-Number: 41752 Gerrit-PatchSet: 3 Gerrit-Owner: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-CC: Jenkins Builder Gerrit-CC: laforge <laforge(a)osmocom.org> Gerrit-CC: pespin <pespin(a)sysmocom.de> Gerrit-Attention: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Comment-Date: Tue, 23 Dec 2025 20:08:38 +0000 Gerrit-HasComments: Yes Gerrit-Has-Labels: No Comment-In-Reply-To: pespin <pespin(a)sysmocom.de>
1 0
0 0
[S] Change in pysim[master]: pySim.esim.saip.personalization: Support for EF.SMSP personalization
by laforge 23 Dec '25

23 Dec '25
Attention is currently required from: dexter, neels. laforge has posted comments on this change by laforge. ( https://gerrit.osmocom.org/c/pysim/+/41735?usp=email ) Change subject: pySim.esim.saip.personalization: Support for EF.SMSP personalization ...................................................................... Patch Set 7: (2 comments) File pySim/esim/saip/personalization.py: https://gerrit.osmocom.org/c/pysim/+/41735/comment/1b30d506_d18534c1?usp=em… : PS5, Line 129: for pe in pes.get_pes_for_type('usim'): > I am not 100% sure here, maybe our application does not even require this. […] youi are correct in that an EF.SMSP can separately exist for both ISIM and CSIM. The latter is currently not supported at all from our codebase, so I'm fine with that. For ISIM, it is potentially more intresting. In reality, I'd expect 99.9% of all IMS enabled eSIMs out there not to contain a separate EF.SMSP, at which point the UE falls back to ADF.USIM/EF.SMSP. If we had a requirement for different SMSP for USIM and ISIM (or multiple USIM and/or ISIM in the profile, which is permitted under the spec), the problem is: How would the user specify which of those he wants to set. As the entire ConfigurableParameter only exists once, we'd probably at least want to rename this to UsimSmspTpScAddr and add a similar IsimSmspTpScAddr, to cover the most common case. https://gerrit.osmocom.org/c/pysim/+/41735/comment/68188a7b_5abafee7?usp=em… : PS5, Line 132: #print("SMSP (orig): %s" % f_smsp.body) > Do you want to keep this commented out debug print? (there is another one below) I'll remove it in the next version, thanks. -- To view, visit https://gerrit.osmocom.org/c/pysim/+/41735?usp=email To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings?usp=email Gerrit-MessageType: comment Gerrit-Project: pysim Gerrit-Branch: master Gerrit-Change-Id: I6b0776c2e753e0a6d158a8cf65cb030977782ec2 Gerrit-Change-Number: 41735 Gerrit-PatchSet: 7 Gerrit-Owner: laforge <laforge(a)osmocom.org> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: dexter <pmaier(a)sysmocom.de> Gerrit-Reviewer: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Reviewer: neels <nhofmeyr(a)sysmocom.de> Gerrit-Attention: neels <nhofmeyr(a)sysmocom.de> Gerrit-Attention: dexter <pmaier(a)sysmocom.de> Gerrit-Comment-Date: Tue, 23 Dec 2025 20:06:30 +0000 Gerrit-HasComments: Yes Gerrit-Has-Labels: No Comment-In-Reply-To: dexter <pmaier(a)sysmocom.de>
1 0
0 0
[XS] Change in pysim[master]: esim.saip.FsProfileElement: Add file2pe() for single file conversion
by laforge 23 Dec '25

23 Dec '25
Attention is currently required from: dexter, fixeria. laforge has posted comments on this change by laforge. ( https://gerrit.osmocom.org/c/pysim/+/41734?usp=email ) Change subject: esim.saip.FsProfileElement: Add file2pe() for single file conversion ...................................................................... Patch Set 5: Code-Review+2 (3 comments) Patchset: PS5: re-adding the existing +2 before addressing latest feedback File pySim/esim/saip/__init__.py: https://gerrit.osmocom.org/c/pysim/+/41734/comment/232f7996_3416d33c?usp=em… : PS3, Line 636: def file2pe(self, f: File): > Maybe replace "f" with "file" to make it more uniform to the add_file method? done. https://gerrit.osmocom.org/c/pysim/+/41734/comment/b78cd03b_18c57aa1?usp=em… : PS3, Line 638: self.decoded[f.pe_name] = f.to_tuples() > Ah ok. I see. Its intentional. Then option a is probably the preferred one. […] I added a related check, i.e. we raise an exception if the passed file is not part of the PE's files dict. -- To view, visit https://gerrit.osmocom.org/c/pysim/+/41734?usp=email To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings?usp=email Gerrit-MessageType: comment Gerrit-Project: pysim Gerrit-Branch: master Gerrit-Change-Id: I7b7f61aae6b7df6946dadf2f78fddf92995603ec Gerrit-Change-Number: 41734 Gerrit-PatchSet: 5 Gerrit-Owner: laforge <laforge(a)osmocom.org> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: dexter <pmaier(a)sysmocom.de> Gerrit-Reviewer: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Reviewer: laforge <laforge(a)osmocom.org> Gerrit-Attention: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Attention: dexter <pmaier(a)sysmocom.de> Gerrit-Comment-Date: Tue, 23 Dec 2025 20:00:10 +0000 Gerrit-HasComments: Yes Gerrit-Has-Labels: Yes Comment-In-Reply-To: laforge <laforge(a)osmocom.org> Comment-In-Reply-To: dexter <pmaier(a)sysmocom.de>
1 0
0 0
[XS] Change in pysim[master]: esim.saip.FsProfileElement: Add file2pe() for single file conversion
by laforge 23 Dec '25

23 Dec '25
Attention is currently required from: dexter, fixeria, laforge. Hello Jenkins Builder, dexter, fixeria, I'd like you to reexamine a change. Please visit https://gerrit.osmocom.org/c/pysim/+/41734?usp=email to look at the new patch set (#5). The following approvals got outdated and were removed: Code-Review+1 by fixeria, Code-Review+2 by dexter Change subject: esim.saip.FsProfileElement: Add file2pe() for single file conversion ...................................................................... esim.saip.FsProfileElement: Add file2pe() for single file conversion We've had files2pe() for re-encoding all of the files, but let's add a specific one for re-encoding only one of the files (such as commonly needed during personalization) Change-Id: I7b7f61aae6b7df6946dadf2f78fddf92995603ec --- M pySim/esim/saip/__init__.py 1 file changed, 8 insertions(+), 1 deletion(-) git pull ssh://gerrit.osmocom.org:29418/pysim refs/changes/34/41734/5 -- To view, visit https://gerrit.osmocom.org/c/pysim/+/41734?usp=email To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings?usp=email Gerrit-MessageType: newpatchset Gerrit-Project: pysim Gerrit-Branch: master Gerrit-Change-Id: I7b7f61aae6b7df6946dadf2f78fddf92995603ec Gerrit-Change-Number: 41734 Gerrit-PatchSet: 5 Gerrit-Owner: laforge <laforge(a)osmocom.org> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: dexter <pmaier(a)sysmocom.de> Gerrit-Reviewer: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Attention: laforge <laforge(a)osmocom.org> Gerrit-Attention: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Attention: dexter <pmaier(a)sysmocom.de>
1 0
0 0
[S] Change in pysim[master]: unittests/test_utils: add unittests for enc_imsi and dec_imsi
by fixeria 23 Dec '25

23 Dec '25
Attention is currently required from: dexter. fixeria has posted comments on this change by dexter. ( https://gerrit.osmocom.org/c/pysim/+/41757?usp=email ) Change subject: unittests/test_utils: add unittests for enc_imsi and dec_imsi ...................................................................... Patch Set 1: Code-Review+1 -- To view, visit https://gerrit.osmocom.org/c/pysim/+/41757?usp=email To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings?usp=email Gerrit-MessageType: comment Gerrit-Project: pysim Gerrit-Branch: master Gerrit-Change-Id: Iae55485c5ec7763aa4aaa25fd1910b854adaab60 Gerrit-Change-Number: 41757 Gerrit-PatchSet: 1 Gerrit-Owner: dexter <pmaier(a)sysmocom.de> Gerrit-Reviewer: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Attention: dexter <pmaier(a)sysmocom.de> Gerrit-Comment-Date: Tue, 23 Dec 2025 19:36:03 +0000 Gerrit-HasComments: No Gerrit-Has-Labels: Yes
1 0
0 0
[S] Change in pysim[master]: Fix more odd-length digit sequences via PaddedBcdAdapter
by fixeria 23 Dec '25

23 Dec '25
Attention is currently required from: dexter, laforge. fixeria has posted comments on this change by laforge. ( https://gerrit.osmocom.org/c/pysim/+/41742?usp=email ) Change subject: Fix more odd-length digit sequences via PaddedBcdAdapter ...................................................................... Patch Set 4: Code-Review+1 -- To view, visit https://gerrit.osmocom.org/c/pysim/+/41742?usp=email To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings?usp=email Gerrit-MessageType: comment Gerrit-Project: pysim Gerrit-Branch: master Gerrit-Change-Id: I4571482da924a3d645caa297108279d182448d21 Gerrit-Change-Number: 41742 Gerrit-PatchSet: 4 Gerrit-Owner: laforge <laforge(a)osmocom.org> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: dexter <pmaier(a)sysmocom.de> Gerrit-Reviewer: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Attention: laforge <laforge(a)osmocom.org> Gerrit-Attention: dexter <pmaier(a)sysmocom.de> Gerrit-Comment-Date: Tue, 23 Dec 2025 19:34:26 +0000 Gerrit-HasComments: No Gerrit-Has-Labels: Yes
1 0
0 0
[XS] Change in pysim[master]: esim.saip.FsProfileElement: Add file2pe() for single file conversion
by dexter 23 Dec '25

23 Dec '25
Attention is currently required from: laforge. dexter has posted comments on this change by laforge. ( https://gerrit.osmocom.org/c/pysim/+/41734?usp=email ) Change subject: esim.saip.FsProfileElement: Add file2pe() for single file conversion ...................................................................... Patch Set 4: Code-Review+2 -- To view, visit https://gerrit.osmocom.org/c/pysim/+/41734?usp=email To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings?usp=email Gerrit-MessageType: comment Gerrit-Project: pysim Gerrit-Branch: master Gerrit-Change-Id: I7b7f61aae6b7df6946dadf2f78fddf92995603ec Gerrit-Change-Number: 41734 Gerrit-PatchSet: 4 Gerrit-Owner: laforge <laforge(a)osmocom.org> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: dexter <pmaier(a)sysmocom.de> Gerrit-Reviewer: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Attention: laforge <laforge(a)osmocom.org> Gerrit-Comment-Date: Tue, 23 Dec 2025 18:39:55 +0000 Gerrit-HasComments: No Gerrit-Has-Labels: Yes
1 0
0 0
[XS] Change in pysim[master]: esim.saip.FsProfileElement: Add file2pe() for single file conversion
by dexter 23 Dec '25

23 Dec '25
Attention is currently required from: laforge. dexter has posted comments on this change by laforge. ( https://gerrit.osmocom.org/c/pysim/+/41734?usp=email ) Change subject: esim.saip.FsProfileElement: Add file2pe() for single file conversion ...................................................................... Patch Set 4: Code-Review-1 (2 comments) Patchset: PS4: I accidentally pushed a change (Iae55485c5ec7763aa4aaa25fd1910b854adaab60) on top of this branch, I am sorry for the inconvenience that may be caused by this. File pySim/esim/saip/__init__.py: https://gerrit.osmocom.org/c/pysim/+/41734/comment/85b83f7d_acea57c5?usp=em… : PS3, Line 638: self.decoded[f.pe_name] = f.to_tuples() > we could […] Ah ok. I see. Its intentional. Then option a is probably the preferred one. Maybe a comment that explains that changes might be lost when files2pe is run would be a good idea I think. -- To view, visit https://gerrit.osmocom.org/c/pysim/+/41734?usp=email To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings?usp=email Gerrit-MessageType: comment Gerrit-Project: pysim Gerrit-Branch: master Gerrit-Change-Id: I7b7f61aae6b7df6946dadf2f78fddf92995603ec Gerrit-Change-Number: 41734 Gerrit-PatchSet: 4 Gerrit-Owner: laforge <laforge(a)osmocom.org> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: dexter <pmaier(a)sysmocom.de> Gerrit-Reviewer: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Attention: laforge <laforge(a)osmocom.org> Gerrit-Comment-Date: Tue, 23 Dec 2025 17:50:26 +0000 Gerrit-HasComments: Yes Gerrit-Has-Labels: Yes Comment-In-Reply-To: laforge <laforge(a)osmocom.org> Comment-In-Reply-To: dexter <pmaier(a)sysmocom.de>
1 0
0 0
[S] Change in pysim[master]: pySim.esim.saip.personalization: Support for EF.SMSP personalization
by dexter 23 Dec '25

23 Dec '25
Attention is currently required from: laforge, neels. dexter has uploaded a new patch set (#6) to the change originally created by laforge. ( https://gerrit.osmocom.org/c/pysim/+/41735?usp=email ) The following approvals got outdated and were removed: Verified+1 by Jenkins Builder The change is no longer submittable: Verified is unsatisfied now. Change subject: pySim.esim.saip.personalization: Support for EF.SMSP personalization ...................................................................... pySim.esim.saip.personalization: Support for EF.SMSP personalization It's a not-too-uncommon requirement to modify the SMSC address stored in EF.SMSP. This adds a ConfigurableParameter for this purpose. Change-Id: I6b0776c2e753e0a6d158a8cf65cb030977782ec2 --- M pySim/esim/saip/personalization.py 1 file changed, 43 insertions(+), 0 deletions(-) git pull ssh://gerrit.osmocom.org:29418/pysim refs/changes/35/41735/6 -- To view, visit https://gerrit.osmocom.org/c/pysim/+/41735?usp=email To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings?usp=email Gerrit-MessageType: newpatchset Gerrit-Project: pysim Gerrit-Branch: master Gerrit-Change-Id: I6b0776c2e753e0a6d158a8cf65cb030977782ec2 Gerrit-Change-Number: 41735 Gerrit-PatchSet: 6 Gerrit-Owner: laforge <laforge(a)osmocom.org> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: dexter <pmaier(a)sysmocom.de> Gerrit-Reviewer: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Reviewer: neels <nhofmeyr(a)sysmocom.de> Gerrit-Attention: neels <nhofmeyr(a)sysmocom.de> Gerrit-Attention: laforge <laforge(a)osmocom.org>
1 0
0 0
[S] Change in pysim[master]: unittests/test_utils: add unittests for enc_imsi and dec_imsi
by dexter 23 Dec '25

23 Dec '25
dexter has uploaded this change for review. ( https://gerrit.osmocom.org/c/pysim/+/41757?usp=email ) Change subject: unittests/test_utils: add unittests for enc_imsi and dec_imsi ...................................................................... unittests/test_utils: add unittests for enc_imsi and dec_imsi So far we seem to have no unittests for enc_imsi and dec_imsi. Change-Id: Iae55485c5ec7763aa4aaa25fd1910b854adaab60 --- M tests/unittests/test_utils.py 1 file changed, 24 insertions(+), 0 deletions(-) git pull ssh://gerrit.osmocom.org:29418/pysim refs/changes/57/41757/1 diff --git a/tests/unittests/test_utils.py b/tests/unittests/test_utils.py index 4cb9478..f0636c5 100755 --- a/tests/unittests/test_utils.py +++ b/tests/unittests/test_utils.py @@ -79,6 +79,30 @@ def testDecMNCfromPLMN_unused_str(self): self.assertEqual(utils.dec_mnc_from_plmn_str("00f0ff"), "") + def testEncImsi(self): + #Type IMSI, odd number of identity digits + self.assertEqual(utils.enc_imsi("228062800000208"), "082982608200002080") + self.assertEqual(utils.enc_imsi("001010000123456"), "080910100000214365") + self.assertEqual(utils.enc_imsi("0010100001234"), "0709101000002143ff") + + #Type IMSI, even number of identity digits + self.assertEqual(utils.enc_imsi("22806280000028"), "0821826082000020f8") + self.assertEqual(utils.enc_imsi("00101000012345"), "0801101000002143f5") + self.assertEqual(utils.enc_imsi("001010000123"), "07011010000021f3ff") + + def testDecImsi(self): + #Type IMSI, odd number of identity digits + self.assertEqual(utils.dec_imsi("082982608200002080"), "228062800000208") + self.assertEqual(utils.dec_imsi("080910100000214365"), "001010000123456") + self.assertEqual(utils.dec_imsi("0709101000002143ff"), "0010100001234") + self.assertEqual(utils.dec_imsi("0709101000002143"), "0010100001234") + + #Type IMSI, even number of identity digits + self.assertEqual(utils.dec_imsi("0821826082000020f8"), "22806280000028") + self.assertEqual(utils.dec_imsi("0801101000002143f5"), "00101000012345") + self.assertEqual(utils.dec_imsi("07011010000021f3ff"), "001010000123") + self.assertEqual(utils.dec_imsi("07011010000021f3"), "001010000123") + def test_enc_plmn(self): with self.subTest("2-digit MCC"): self.assertEqual(utils.enc_plmn("001", "01F"), "00F110") -- To view, visit https://gerrit.osmocom.org/c/pysim/+/41757?usp=email To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings?usp=email Gerrit-MessageType: newchange Gerrit-Project: pysim Gerrit-Branch: master Gerrit-Change-Id: Iae55485c5ec7763aa4aaa25fd1910b854adaab60 Gerrit-Change-Number: 41757 Gerrit-PatchSet: 1 Gerrit-Owner: dexter <pmaier(a)sysmocom.de>
1 0
0 0
  • ← Newer
  • 1
  • 2
  • 3
  • 4
  • 5
  • 6
  • 7
  • ...
  • 118
  • Older →

HyperKitty Powered by HyperKitty version 1.3.12.