lists.osmocom.org
Sign In Sign Up
Manage this list Sign In Sign Up

Keyboard Shortcuts

Thread View

  • j: Next unread message
  • k: Previous unread message
  • j a: Jump to all threads
  • j l: Jump to MailingList overview

gerrit-log

Thread Start a new thread
Download
Threads by month
  • ----- 2026 -----
  • November
  • October
  • September
  • August
  • July
  • June
  • May
  • April
  • March
  • February
  • January
  • ----- 2025 -----
  • December
  • November
  • October
  • September
  • August
  • July
  • June
  • May
  • April
  • March
  • February
  • January
  • ----- 2024 -----
  • December
  • November
  • October
  • September
  • August
  • July
  • June
  • May
  • April
  • March
  • February
  • January
  • ----- 2023 -----
  • December
  • November
  • October
  • September
  • August
  • July
  • June
  • May
  • April
  • March
  • February
  • January
  • ----- 2022 -----
  • December
  • November
  • October
  • September
  • August
  • July
  • June
  • May
  • April
  • March
  • February
  • January
gerrit-log@lists.osmocom.org

December 2025

  • 1 participants
  • 1175 discussions
[XS] Change in pysim[master]: pySim.esim.saip.ProfileElementSequence: Update type annotations
by fixeria 25 Dec '25

25 Dec '25
Attention is currently required from: laforge. fixeria has posted comments on this change by laforge. ( https://gerrit.osmocom.org/c/pysim/+/41736?usp=email ) Change subject: pySim.esim.saip.ProfileElementSequence: Update type annotations ...................................................................... Patch Set 4: Code-Review-1 (1 comment) Patchset: PS4: Not sure if `(...)` is a valid type-spec. for tuples. IIRC, it should be `tuple[...]` or `Tuple[...]` for older Python versions. -- To view, visit https://gerrit.osmocom.org/c/pysim/+/41736?usp=email To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings?usp=email Gerrit-MessageType: comment Gerrit-Project: pysim Gerrit-Branch: master Gerrit-Change-Id: Ib99c00a38bf009c63180b4a593d6cc796ff282d3 Gerrit-Change-Number: 41736 Gerrit-PatchSet: 4 Gerrit-Owner: laforge <laforge(a)osmocom.org> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Attention: laforge <laforge(a)osmocom.org> Gerrit-Comment-Date: Thu, 25 Dec 2025 11:00:34 +0000 Gerrit-HasComments: Yes Gerrit-Has-Labels: Yes
1 0
0 0
[M] Change in osmo-ttcn3-hacks[master]: 5gc: Network Triggered Service Request
by fixeria 25 Dec '25

25 Dec '25
Attention is currently required from: pespin. fixeria has posted comments on this change by pespin. ( https://gerrit.osmocom.org/c/osmo-ttcn3-hacks/+/41756?usp=email ) Change subject: 5gc: Network Triggered Service Request ...................................................................... Patch Set 1: Code-Review+1 (2 comments) Patchset: PS1: You're missing to update `expected-results.xml`. File 5gc/C5G_Tests.ttcn: https://gerrit.osmocom.org/c/osmo-ttcn3-hacks/+/41756/comment/41a9a0d7_3bd0… : PS1, Line 524: open5gs-amfd sends InitialContextSetupRequest instead of PDUSessionResourceSetupRequest Is this a bug or acceptable behavior? -- To view, visit https://gerrit.osmocom.org/c/osmo-ttcn3-hacks/+/41756?usp=email To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings?usp=email Gerrit-MessageType: comment Gerrit-Project: osmo-ttcn3-hacks Gerrit-Branch: master Gerrit-Change-Id: I42e422d104f254bc27d5f3bb3e8df0cba6380648 Gerrit-Change-Number: 41756 Gerrit-PatchSet: 1 Gerrit-Owner: pespin <pespin(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Attention: pespin <pespin(a)sysmocom.de> Gerrit-Comment-Date: Thu, 25 Dec 2025 10:56:22 +0000 Gerrit-HasComments: Yes Gerrit-Has-Labels: Yes
1 0
0 0
[XS] Change in osmo-ttcn3-hacks[master]: library/NGAP_Emulation: Route Paging through NGAP_UNIT
by fixeria 25 Dec '25

25 Dec '25
Attention is currently required from: pespin. fixeria has posted comments on this change by pespin. ( https://gerrit.osmocom.org/c/osmo-ttcn3-hacks/+/41755?usp=email ) Change subject: library/NGAP_Emulation: Route Paging through NGAP_UNIT ...................................................................... Patch Set 1: Code-Review+1 -- To view, visit https://gerrit.osmocom.org/c/osmo-ttcn3-hacks/+/41755?usp=email To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings?usp=email Gerrit-MessageType: comment Gerrit-Project: osmo-ttcn3-hacks Gerrit-Branch: master Gerrit-Change-Id: I93cf5e5779208f5e8c3b4d4acf0341c0e78d1ee8 Gerrit-Change-Number: 41755 Gerrit-PatchSet: 1 Gerrit-Owner: pespin <pespin(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Attention: pespin <pespin(a)sysmocom.de> Gerrit-Comment-Date: Thu, 25 Dec 2025 10:51:29 +0000 Gerrit-HasComments: No Gerrit-Has-Labels: Yes
1 0
0 0
[XS] Change in osmo-ttcn3-hacks[master]: library/NGAP_Functions: return NAS_PDU IE from InitialContextSetup if...
by fixeria 25 Dec '25

25 Dec '25
Attention is currently required from: pespin. fixeria has posted comments on this change by pespin. ( https://gerrit.osmocom.org/c/osmo-ttcn3-hacks/+/41754?usp=email ) Change subject: library/NGAP_Functions: return NAS_PDU IE from InitialContextSetup if present ...................................................................... Patch Set 1: Code-Review+1 -- To view, visit https://gerrit.osmocom.org/c/osmo-ttcn3-hacks/+/41754?usp=email To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings?usp=email Gerrit-MessageType: comment Gerrit-Project: osmo-ttcn3-hacks Gerrit-Branch: master Gerrit-Change-Id: I7fced3f920c2514f58711a2ca1cc60c8dc79e395 Gerrit-Change-Number: 41754 Gerrit-PatchSet: 1 Gerrit-Owner: pespin <pespin(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Attention: pespin <pespin(a)sysmocom.de> Gerrit-Comment-Date: Thu, 25 Dec 2025 10:51:04 +0000 Gerrit-HasComments: No Gerrit-Has-Labels: Yes
1 0
0 0
[XS] Change in osmo-ttcn3-hacks[master]: 5gc: Document procedures not implemented in open5gs
by fixeria 25 Dec '25

25 Dec '25
Attention is currently required from: pespin. fixeria has posted comments on this change by pespin. ( https://gerrit.osmocom.org/c/osmo-ttcn3-hacks/+/41753?usp=email ) Change subject: 5gc: Document procedures not implemented in open5gs ...................................................................... Patch Set 2: Code-Review+2 -- To view, visit https://gerrit.osmocom.org/c/osmo-ttcn3-hacks/+/41753?usp=email To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings?usp=email Gerrit-MessageType: comment Gerrit-Project: osmo-ttcn3-hacks Gerrit-Branch: master Gerrit-Change-Id: I1480dc8ee1f0db78c179406fa9090835364c01e8 Gerrit-Change-Number: 41753 Gerrit-PatchSet: 2 Gerrit-Owner: pespin <pespin(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Attention: pespin <pespin(a)sysmocom.de> Gerrit-Comment-Date: Thu, 25 Dec 2025 10:48:44 +0000 Gerrit-HasComments: No Gerrit-Has-Labels: Yes
1 0
0 0
[L] Change in osmo-ttcn3-hacks[master]: 5gc: Test UE Triggered Service Request
by fixeria 25 Dec '25

25 Dec '25
Attention is currently required from: pespin. fixeria has posted comments on this change by pespin. ( https://gerrit.osmocom.org/c/osmo-ttcn3-hacks/+/41747?usp=email ) Change subject: 5gc: Test UE Triggered Service Request ...................................................................... Patch Set 3: (3 comments) File 5gc/ConnHdlr.ttcn: https://gerrit.osmocom.org/c/osmo-ttcn3-hacks/+/41747/comment/a3ef860b_ada0… : PS3, Line 410: var PDUSessionResourceSetupItemSURes it_resp; : it_resp := f_pdu_handle_session_resource_setup_item_su(li_req[i]); : if (i == 0) { /* min 1 item in list doesn't allow previously allocating an empty list */ : li_resp := { it_resp }; : } else { : li_resp := li_resp & { it_resp }; : Assigning items via the index works fine: ```suggestion li_resp[i] := f_pdu_handle_session_resource_setup_item_su(li_req[i]); ``` TITAN takes care of resizing etc. https://gerrit.osmocom.org/c/osmo-ttcn3-hacks/+/41747/comment/77a43fdf_028f… : PS3, Line 691: var template (value) NGAP_PDU tx_pdu; unused https://gerrit.osmocom.org/c/osmo-ttcn3-hacks/+/41747/comment/d9ff34e3_d940… : PS3, Line 694: var NG_NAS_DL_Message_Type rx_nas; unused -- To view, visit https://gerrit.osmocom.org/c/osmo-ttcn3-hacks/+/41747?usp=email To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings?usp=email Gerrit-MessageType: comment Gerrit-Project: osmo-ttcn3-hacks Gerrit-Branch: master Gerrit-Change-Id: I65cf7844d11be55d9d5c8e31fd87a3c72e6a607b Gerrit-Change-Number: 41747 Gerrit-PatchSet: 3 Gerrit-Owner: pespin <pespin(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-CC: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Attention: pespin <pespin(a)sysmocom.de> Gerrit-Comment-Date: Thu, 25 Dec 2025 10:48:24 +0000 Gerrit-HasComments: Yes Gerrit-Has-Labels: No
1 0
0 0
[M] Change in osmo-ttcn3-hacks[master]: library/NGAP_Templates: PDUSessionResourceSetupRequest: Allow matchin...
by fixeria 25 Dec '25

25 Dec '25
Attention is currently required from: pespin. fixeria has posted comments on this change by pespin. ( https://gerrit.osmocom.org/c/osmo-ttcn3-hacks/+/41746?usp=email ) Change subject: library/NGAP_Templates: PDUSessionResourceSetupRequest: Allow matching optional IEs ...................................................................... Patch Set 1: Code-Review+1 (1 comment) File library/ngap/NGAP_Templates.ttcn: https://gerrit.osmocom.org/c/osmo-ttcn3-hacks/+/41746/comment/6735e372_c773… : PS1, Line 150: omit Why not `*`? -- To view, visit https://gerrit.osmocom.org/c/osmo-ttcn3-hacks/+/41746?usp=email To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings?usp=email Gerrit-MessageType: comment Gerrit-Project: osmo-ttcn3-hacks Gerrit-Branch: master Gerrit-Change-Id: I7a61b4d7a70994e35f2fa5cbadc90f1088b32e64 Gerrit-Change-Number: 41746 Gerrit-PatchSet: 1 Gerrit-Owner: pespin <pespin(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Attention: pespin <pespin(a)sysmocom.de> Gerrit-Comment-Date: Thu, 25 Dec 2025 09:36:58 +0000 Gerrit-HasComments: Yes Gerrit-Has-Labels: Yes
1 0
0 0
[S] Change in osmo-hnbgw[master]: nft_kpi: add udp/2152 filtering rules separately
by fixeria 24 Dec '25

24 Dec '25
Attention is currently required from: laforge, pespin. Hello Jenkins Builder, I'd like you to reexamine a change. Please visit https://gerrit.osmocom.org/c/osmo-hnbgw/+/41752?usp=email to look at the new patch set (#5). Change subject: nft_kpi: add udp/2152 filtering rules separately ...................................................................... nft_kpi: add udp/2152 filtering rules separately Mixing declarative and imperative syntax is supported by recent nftables versions, but is known to be broken in older releases. This affects the nftables version currently provided by Osmocom for Debian 12 (bookworm): 1.0.6.3~osmocom.429.7d98. As a result, the generated ruleset ends up accepting all packets rather than only udp/2152 as intended. Consequently, the nftables counters do not reflect GTP-U traffic alone, but also include signalling traffic. Let's work this around by adding the udp/2152 filtering rules separately using the imperative syntax. Split the logic for adding a chain into a separate function to avoid code duplication. Change-Id: I36eb3b18751fc029297fb91545af2d28e61067fd Related: SYS#7808 --- M src/osmo-hnbgw/nft_kpi.c 1 file changed, 19 insertions(+), 14 deletions(-) git pull ssh://gerrit.osmocom.org:29418/osmo-hnbgw refs/changes/52/41752/5 -- To view, visit https://gerrit.osmocom.org/c/osmo-hnbgw/+/41752?usp=email To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings?usp=email Gerrit-MessageType: newpatchset Gerrit-Project: osmo-hnbgw Gerrit-Branch: master Gerrit-Change-Id: I36eb3b18751fc029297fb91545af2d28e61067fd Gerrit-Change-Number: 41752 Gerrit-PatchSet: 5 Gerrit-Owner: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-CC: laforge <laforge(a)osmocom.org> Gerrit-CC: pespin <pespin(a)sysmocom.de> Gerrit-Attention: laforge <laforge(a)osmocom.org> Gerrit-Attention: pespin <pespin(a)sysmocom.de>
1 0
0 0
[S] Change in osmo-hnbgw[master]: nft_kpi: add udp/2152 filtering rules separately
by fixeria 24 Dec '25

24 Dec '25
Attention is currently required from: laforge, pespin. fixeria has posted comments on this change by fixeria. ( https://gerrit.osmocom.org/c/osmo-hnbgw/+/41752?usp=email ) Change subject: nft_kpi: add udp/2152 filtering rules separately ...................................................................... Patch Set 4: (1 comment) File src/osmo-hnbgw/nft_kpi.c: https://gerrit.osmocom.org/c/osmo-hnbgw/+/41752/comment/517bd30b_2ddbadaf?u… : PS3, Line 328: static int do_add_chain(bool uplink) > I particularly agree with pespin's second comment. […] I've addressed the second comment, but still kept the function to reduce code duplication. The chain name and hook are now passed as arguments. Hopefully, the new approach looks cleaner. -- To view, visit https://gerrit.osmocom.org/c/osmo-hnbgw/+/41752?usp=email To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings?usp=email Gerrit-MessageType: comment Gerrit-Project: osmo-hnbgw Gerrit-Branch: master Gerrit-Change-Id: I36eb3b18751fc029297fb91545af2d28e61067fd Gerrit-Change-Number: 41752 Gerrit-PatchSet: 4 Gerrit-Owner: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-CC: laforge <laforge(a)osmocom.org> Gerrit-CC: pespin <pespin(a)sysmocom.de> Gerrit-Attention: laforge <laforge(a)osmocom.org> Gerrit-Attention: pespin <pespin(a)sysmocom.de> Gerrit-Comment-Date: Wed, 24 Dec 2025 22:45:47 +0000 Gerrit-HasComments: Yes Gerrit-Has-Labels: No Comment-In-Reply-To: laforge <laforge(a)osmocom.org> Comment-In-Reply-To: pespin <pespin(a)sysmocom.de>
1 0
0 0
[S] Change in osmo-hnbgw[master]: nft_kpi: add udp/2152 filtering rules separately
by fixeria 24 Dec '25

24 Dec '25
Attention is currently required from: fixeria. Hello Jenkins Builder, I'd like you to reexamine a change. Please visit https://gerrit.osmocom.org/c/osmo-hnbgw/+/41752?usp=email to look at the new patch set (#4). The following approvals got outdated and were removed: Verified+1 by Jenkins Builder Change subject: nft_kpi: add udp/2152 filtering rules separately ...................................................................... nft_kpi: add udp/2152 filtering rules separately Mixing declarative and imperative syntax is supported by recent nftables versions, but is known to be broken in older releases. This affects the nftables version currently provided by Osmocom for Debian 12 (bookworm): 1.0.6.3~osmocom.429.7d98. As a result, the generated ruleset ends up accepting all packets rather than only udp/2152 as intended. Consequently, the nftables counters do not reflect GTP-U traffic alone, but also include signalling traffic. Let's work this around by adding the udp/2152 filtering rules separately using the imperative syntax. Split the logic for adding a chain into a separate function to avoid code duplication. Change-Id: I36eb3b18751fc029297fb91545af2d28e61067fd Related: SYS#7808 --- M src/osmo-hnbgw/nft_kpi.c 1 file changed, 19 insertions(+), 15 deletions(-) git pull ssh://gerrit.osmocom.org:29418/osmo-hnbgw refs/changes/52/41752/4 -- To view, visit https://gerrit.osmocom.org/c/osmo-hnbgw/+/41752?usp=email To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings?usp=email Gerrit-MessageType: newpatchset Gerrit-Project: osmo-hnbgw Gerrit-Branch: master Gerrit-Change-Id: I36eb3b18751fc029297fb91545af2d28e61067fd Gerrit-Change-Number: 41752 Gerrit-PatchSet: 4 Gerrit-Owner: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-CC: laforge <laforge(a)osmocom.org> Gerrit-CC: pespin <pespin(a)sysmocom.de> Gerrit-Attention: fixeria <vyanitskiy(a)sysmocom.de>
1 0
0 0
  • ← Newer
  • 1
  • 2
  • 3
  • 4
  • 5
  • 6
  • ...
  • 118
  • Older →

HyperKitty Powered by HyperKitty version 1.3.12.