lists.osmocom.org
Sign In Sign Up
Manage this list Sign In Sign Up

Keyboard Shortcuts

Thread View

  • j: Next unread message
  • k: Previous unread message
  • j a: Jump to all threads
  • j l: Jump to MailingList overview

gerrit-log

Thread Start a new thread
Download
Threads by month
  • ----- 2026 -----
  • November
  • October
  • September
  • August
  • July
  • June
  • May
  • April
  • March
  • February
  • January
  • ----- 2025 -----
  • December
  • November
  • October
  • September
  • August
  • July
  • June
  • May
  • April
  • March
  • February
  • January
  • ----- 2024 -----
  • December
  • November
  • October
  • September
  • August
  • July
  • June
  • May
  • April
  • March
  • February
  • January
  • ----- 2023 -----
  • December
  • November
  • October
  • September
  • August
  • July
  • June
  • May
  • April
  • March
  • February
  • January
  • ----- 2022 -----
  • December
  • November
  • October
  • September
  • August
  • July
  • June
  • May
  • April
  • March
  • February
  • January
gerrit-log@lists.osmocom.org

June 2023

  • 1 participants
  • 2480 discussions
[S] Change in osmo-bts[master]: l1sap: cosmetic: rename payload_len to rtp_pl_len
by dexter 14 Jun '23

14 Jun '23
dexter has posted comments on this change. ( https://gerrit.osmocom.org/c/osmo-bts/+/32752 ) Change subject: l1sap: cosmetic: rename payload_len to rtp_pl_len ...................................................................... Patch Set 4: (1 comment) Patchset: PS4: Now suddenly everything appears to be correct again - so we can restore this and abandon the patch that I have just re-pushed. -- To view, visit https://gerrit.osmocom.org/c/osmo-bts/+/32752 To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: osmo-bts Gerrit-Branch: master Gerrit-Change-Id: I8a0e0357aab2a78e25811f66b1b870e8c6ebffe9 Gerrit-Change-Number: 32752 Gerrit-PatchSet: 4 Gerrit-Owner: dexter <pmaier(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Reviewer: pespin <pespin(a)sysmocom.de> Gerrit-Comment-Date: Wed, 14 Jun 2023 08:32:24 +0000 Gerrit-HasComments: Yes Gerrit-Has-Labels: No Gerrit-MessageType: comment
1 0
0 0
[S] Change in osmo-bts[master]: l1sap: cosmetic: rename payload_len to rtp_pl_len
by dexter 14 Jun '23

14 Jun '23
dexter has abandoned this change. ( https://gerrit.osmocom.org/c/osmo-bts/+/33309 ) Change subject: l1sap: cosmetic: rename payload_len to rtp_pl_len ...................................................................... Abandoned This is a duplicate -- To view, visit https://gerrit.osmocom.org/c/osmo-bts/+/33309 To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: osmo-bts Gerrit-Branch: master Gerrit-Change-Id: I07c589246d0b116710b1587ff1f8cc285ebe240a Gerrit-Change-Number: 33309 Gerrit-PatchSet: 1 Gerrit-Owner: dexter <pmaier(a)sysmocom.de> Gerrit-CC: Jenkins Builder Gerrit-MessageType: abandon
1 0
0 0
[S] Change in osmo-bts[master]: l1sap: cosmetic: rename payload_len to rtp_pl_len
by dexter 14 Jun '23

14 Jun '23
dexter has restored this change. ( https://gerrit.osmocom.org/c/osmo-bts/+/32752 ) Change subject: l1sap: cosmetic: rename payload_len to rtp_pl_len ...................................................................... Restored -- To view, visit https://gerrit.osmocom.org/c/osmo-bts/+/32752 To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: osmo-bts Gerrit-Branch: master Gerrit-Change-Id: I8a0e0357aab2a78e25811f66b1b870e8c6ebffe9 Gerrit-Change-Number: 32752 Gerrit-PatchSet: 4 Gerrit-Owner: dexter <pmaier(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Reviewer: pespin <pespin(a)sysmocom.de> Gerrit-MessageType: restore
1 0
0 0
[S] Change in osmo-bts[master]: l1sap: cosmetic: rename payload_len to rtp_pl_len
by dexter 14 Jun '23

14 Jun '23
dexter has abandoned this change. ( https://gerrit.osmocom.org/c/osmo-bts/+/32752 ) Change subject: l1sap: cosmetic: rename payload_len to rtp_pl_len ...................................................................... Abandoned This looks messed up in gerrit (even though the patch is correct). Re-pushed this under: I07c589246d0b116710b1587ff1f8cc285ebe240a -- To view, visit https://gerrit.osmocom.org/c/osmo-bts/+/32752 To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: osmo-bts Gerrit-Branch: master Gerrit-Change-Id: I8a0e0357aab2a78e25811f66b1b870e8c6ebffe9 Gerrit-Change-Number: 32752 Gerrit-PatchSet: 4 Gerrit-Owner: dexter <pmaier(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Reviewer: pespin <pespin(a)sysmocom.de> Gerrit-MessageType: abandon
1 0
0 0
[S] Change in osmo-bts[master]: l1sap: cosmetic: rename payload_len to rtp_pl_len
by dexter 14 Jun '23

14 Jun '23
dexter has uploaded this change for review. ( https://gerrit.osmocom.org/c/osmo-bts/+/33309 ) Change subject: l1sap: cosmetic: rename payload_len to rtp_pl_len ...................................................................... l1sap: cosmetic: rename payload_len to rtp_pl_len The function signature of rtppayload_is_octet_aligned has a parameter rtp_pl for the payload and a parameter payload_len for the length of the payload, while other functions use rtp_pl and rtp_pl_len. Change-Id: I07c589246d0b116710b1587ff1f8cc285ebe240a --- M src/common/rtp_input_preen.c 1 file changed, 15 insertions(+), 2 deletions(-) git pull ssh://gerrit.osmocom.org:29418/osmo-bts refs/changes/09/33309/1 diff --git a/src/common/rtp_input_preen.c b/src/common/rtp_input_preen.c index c418e80..d42d24f 100644 --- a/src/common/rtp_input_preen.c +++ b/src/common/rtp_input_preen.c @@ -34,7 +34,7 @@ #include <osmo-bts/logging.h> #include <osmo-bts/rtp_input_preen.h> -static bool amr_is_octet_aligned(const uint8_t *rtp_pl, unsigned payload_len) +static bool amr_is_octet_aligned(const uint8_t *rtp_pl, unsigned rtp_pl_len) { /* * Logic: If 1st bit padding is not zero, packet is either: @@ -55,7 +55,7 @@ #define AMR_PADDING1(rtp_pl) (rtp_pl[0] & 0x0f) #define AMR_PADDING2(rtp_pl) (rtp_pl[1] & 0x03) - if (payload_len < 2 || AMR_PADDING1(rtp_pl) || AMR_PADDING2(rtp_pl)) + if (rtp_pl_len < 2 || AMR_PADDING1(rtp_pl) || AMR_PADDING2(rtp_pl)) return false; return true; -- To view, visit https://gerrit.osmocom.org/c/osmo-bts/+/33309 To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: osmo-bts Gerrit-Branch: master Gerrit-Change-Id: I07c589246d0b116710b1587ff1f8cc285ebe240a Gerrit-Change-Number: 33309 Gerrit-PatchSet: 1 Gerrit-Owner: dexter <pmaier(a)sysmocom.de> Gerrit-MessageType: newchange
1 0
0 0
[S] Change in osmo-bts[master]: l1sap: cosmetic: rename payload_len to rtp_pl_len
by dexter 14 Jun '23

14 Jun '23
Attention is currently required from: dexter. Hello Jenkins Builder, fixeria, pespin, I'd like you to reexamine a change. Please visit https://gerrit.osmocom.org/c/osmo-bts/+/32752 to look at the new patch set (#4). Change subject: l1sap: cosmetic: rename payload_len to rtp_pl_len ...................................................................... l1sap: cosmetic: rename payload_len to rtp_pl_len The function signature of rtppayload_is_octet_aligned has a parameter rtp_pl for the payload and a parameter payload_len for the length of the payload, while other functions use rtp_pl and rtp_pl_len. Change-Id: I8a0e0357aab2a78e25811f66b1b870e8c6ebffe9 --- M src/common/rtp_input_preen.c 1 file changed, 15 insertions(+), 2 deletions(-) git pull ssh://gerrit.osmocom.org:29418/osmo-bts refs/changes/52/32752/4 -- To view, visit https://gerrit.osmocom.org/c/osmo-bts/+/32752 To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: osmo-bts Gerrit-Branch: master Gerrit-Change-Id: I8a0e0357aab2a78e25811f66b1b870e8c6ebffe9 Gerrit-Change-Number: 32752 Gerrit-PatchSet: 4 Gerrit-Owner: dexter <pmaier(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Reviewer: pespin <pespin(a)sysmocom.de> Gerrit-Attention: dexter <pmaier(a)sysmocom.de> Gerrit-MessageType: newpatchset
1 0
0 0
[M] Change in osmo-bts[master]: l1sap: Accept RFC5993 and TS 101.318 HR GSM payload
by dexter 14 Jun '23

14 Jun '23
dexter has abandoned this change. ( https://gerrit.osmocom.org/c/osmo-bts/+/32630 ) Change subject: l1sap: Accept RFC5993 and TS 101.318 HR GSM payload ...................................................................... Abandoned This was solved differently by another patch -- To view, visit https://gerrit.osmocom.org/c/osmo-bts/+/32630 To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: osmo-bts Gerrit-Branch: master Gerrit-Change-Id: I9419b40c1171876879d41aba4f51c93e8ef5673c Gerrit-Change-Number: 32630 Gerrit-PatchSet: 5 Gerrit-Owner: dexter <pmaier(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: falconia <falcon(a)freecalypso.org> Gerrit-Reviewer: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Reviewer: pespin <pespin(a)sysmocom.de> Gerrit-MessageType: abandon
1 0
0 0
[S] Change in osmo-bts[master]: l1sap: Drop invalid HR GSM payload
by dexter 14 Jun '23

14 Jun '23
dexter has abandoned this change. ( https://gerrit.osmocom.org/c/osmo-bts/+/31417 ) Change subject: l1sap: Drop invalid HR GSM payload ...................................................................... Abandoned This was solved differently by another patch. -- To view, visit https://gerrit.osmocom.org/c/osmo-bts/+/31417 To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: osmo-bts Gerrit-Branch: master Gerrit-Change-Id: I453562da412fde5b928bd2b588129c58ec8e2a7e Gerrit-Change-Number: 31417 Gerrit-PatchSet: 12 Gerrit-Owner: dexter <pmaier(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: falconia <falcon(a)freecalypso.org> Gerrit-Reviewer: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Reviewer: jolly <andreas(a)eversberg.eu> Gerrit-Reviewer: laforge <laforge(a)osmocom.org> Gerrit-Reviewer: pespin <pespin(a)sysmocom.de> Gerrit-CC: neels <nhofmeyr(a)sysmocom.de> Gerrit-MessageType: abandon
1 0
0 0
[S] Change in libosmocore[master]: select: speed up osmo_fd_is_registered
by dexter 14 Jun '23

14 Jun '23
dexter has abandoned this change. ( https://gerrit.osmocom.org/c/libosmocore/+/32579 ) Change subject: select: speed up osmo_fd_is_registered ...................................................................... Abandoned -- To view, visit https://gerrit.osmocom.org/c/libosmocore/+/32579 To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: libosmocore Gerrit-Branch: master Gerrit-Change-Id: I1ce894da39e3f2329c88666a5dda594b8bce4228 Gerrit-Change-Number: 32579 Gerrit-PatchSet: 1 Gerrit-Owner: dexter <pmaier(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: laforge <laforge(a)osmocom.org> Gerrit-Reviewer: pespin <pespin(a)sysmocom.de> Gerrit-MessageType: abandon
1 0
0 0
[M] Change in libosmo-netif[master]: stream: Factor out reconnection handling
by dexter 14 Jun '23

14 Jun '23
Attention is currently required from: daniel, lynxis lazus. dexter has posted comments on this change. ( https://gerrit.osmocom.org/c/libosmo-netif/+/33253 ) Change subject: stream: Factor out reconnection handling ...................................................................... Patch Set 3: Code-Review+2 (1 comment) Patchset: PS3: The code was just moved, I think this should be all fine. -- To view, visit https://gerrit.osmocom.org/c/libosmo-netif/+/33253 To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: libosmo-netif Gerrit-Branch: master Gerrit-Change-Id: I418377eabd465ee4ffce9b4440e96287c7734924 Gerrit-Change-Number: 33253 Gerrit-PatchSet: 3 Gerrit-Owner: daniel <dwillmann(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: dexter <pmaier(a)sysmocom.de> Gerrit-Reviewer: lynxis lazus <lynxis(a)fe80.eu> Gerrit-Reviewer: pespin <pespin(a)sysmocom.de> Gerrit-Attention: daniel <dwillmann(a)sysmocom.de> Gerrit-Attention: lynxis lazus <lynxis(a)fe80.eu> Gerrit-Comment-Date: Wed, 14 Jun 2023 08:00:51 +0000 Gerrit-HasComments: Yes Gerrit-Has-Labels: Yes Gerrit-MessageType: comment
1 0
0 0
  • ← Newer
  • 1
  • ...
  • 127
  • 128
  • 129
  • 130
  • 131
  • 132
  • 133
  • ...
  • 248
  • Older →

HyperKitty Powered by HyperKitty version 1.3.12.