[S] Change in osmo-bts[master]: l1sap: cosmetic: rename payload_len to rtp_pl_len
dexter has uploaded this change for review. ( https://gerrit.osmocom.org/c/osmo-bts/+/33309 ) Change subject: l1sap: cosmetic: rename payload_len to rtp_pl_len ...................................................................... l1sap: cosmetic: rename payload_len to rtp_pl_len The function signature of rtppayload_is_octet_aligned has a parameter rtp_pl for the payload and a parameter payload_len for the length of the payload, while other functions use rtp_pl and rtp_pl_len. Change-Id: I07c589246d0b116710b1587ff1f8cc285ebe240a --- M src/common/rtp_input_preen.c 1 file changed, 15 insertions(+), 2 deletions(-) git pull ssh://gerrit.osmocom.org:29418/osmo-bts refs/changes/09/33309/1 diff --git a/src/common/rtp_input_preen.c b/src/common/rtp_input_preen.c index c418e80..d42d24f 100644 --- a/src/common/rtp_input_preen.c +++ b/src/common/rtp_input_preen.c @@ -34,7 +34,7 @@ #include <osmo-bts/logging.h> #include <osmo-bts/rtp_input_preen.h> -static bool amr_is_octet_aligned(const uint8_t *rtp_pl, unsigned payload_len) +static bool amr_is_octet_aligned(const uint8_t *rtp_pl, unsigned rtp_pl_len) { /* * Logic: If 1st bit padding is not zero, packet is either: @@ -55,7 +55,7 @@ #define AMR_PADDING1(rtp_pl) (rtp_pl[0] & 0x0f) #define AMR_PADDING2(rtp_pl) (rtp_pl[1] & 0x03) - if (payload_len < 2 || AMR_PADDING1(rtp_pl) || AMR_PADDING2(rtp_pl)) + if (rtp_pl_len < 2 || AMR_PADDING1(rtp_pl) || AMR_PADDING2(rtp_pl)) return false; return true; -- To view, visit https://gerrit.osmocom.org/c/osmo-bts/+/33309 To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: osmo-bts Gerrit-Branch: master Gerrit-Change-Id: I07c589246d0b116710b1587ff1f8cc285ebe240a Gerrit-Change-Number: 33309 Gerrit-PatchSet: 1 Gerrit-Owner: dexter <pmaier@sysmocom.de> Gerrit-MessageType: newchange
participants (1)
-
dexter