Attention is currently required from: daniel, fixeria.
Hello Jenkins Builder, fixeria,
I'd like you to reexamine a change. Please visit
https://gerrit.osmocom.org/c/osmo-ttcn3-hacks/+/42934?usp=email
to look at the new patch set (#2).
The following approvals got outdated and were removed:
Code-Review+1 by fixeria
Change subject: deps: use a fork of titan.ProtocolEmulations.SCCP
......................................................................
deps: use a fork of titan.ProtocolEmulations.SCCP
The fork adds support for sending UDTS via
ASP_SCCP_N_NOTICE_req.
Change-Id: I8c0de4dab088930d5d7a9febcbebcb5e1f9411e8
---
M deps/Makefile
1 file changed, 2 insertions(+), 2 deletions(-)
git pull ssh://gerrit.osmocom.org:29418/osmo-ttcn3-hacks refs/changes/34/42934/2
--
To view, visit https://gerrit.osmocom.org/c/osmo-ttcn3-hacks/+/42934?usp=email
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings?usp=email
Gerrit-MessageType: newpatchset
Gerrit-Project: osmo-ttcn3-hacks
Gerrit-Branch: master
Gerrit-Change-Id: I8c0de4dab088930d5d7a9febcbebcb5e1f9411e8
Gerrit-Change-Number: 42934
Gerrit-PatchSet: 2
Gerrit-Owner: daniel <dwillmann(a)sysmocom.de>
Gerrit-Reviewer: Jenkins Builder
Gerrit-Reviewer: fixeria <vyanitskiy(a)sysmocom.de>
Gerrit-CC: laforge <laforge(a)osmocom.org>
Gerrit-Attention: fixeria <vyanitskiy(a)sysmocom.de>
Gerrit-Attention: daniel <dwillmann(a)sysmocom.de>
daniel has submitted this change. ( https://gerrit.osmocom.org/c/osmo-ttcn3-hacks/+/42932?usp=email )
Change subject: STP_Tests_TCAP: Test routing of fragments in TC_tcap_loadshare_ipa_tcap_range_success_pc
......................................................................
STP_Tests_TCAP: Test routing of fragments in TC_tcap_loadshare_ipa_tcap_range_success_pc
A TCAP Begin will cause the stp to create a cache entry and route
according to that. Send only a TCAP Continue so we check the tcap range
routing logic.
Change-Id: I1cb47174b8f0e69970e75109b9d15b2012e150c3
---
M stp/STP_Tests_TCAP.ttcn
1 file changed, 22 insertions(+), 2 deletions(-)
Approvals:
laforge: Looks good to me, approved
Jenkins Builder: Verified
fixeria: Looks good to me, but someone else must approve
diff --git a/stp/STP_Tests_TCAP.ttcn b/stp/STP_Tests_TCAP.ttcn
index 5093b78..f8ba240 100644
--- a/stp/STP_Tests_TCAP.ttcn
+++ b/stp/STP_Tests_TCAP.ttcn
@@ -324,6 +324,24 @@
f_asp_tx_tcap_exp_any(tcap_msg, t_asp_idx);
}
+private function f_asp_tx_tcap_m3ua_ipa_continue(integer o_asp_idx,
+ integer t_asp_idx,
+ OCT4 o_tid,
+ OCT4 t_tid)
+runs on TCAP_CT
+{
+ var template (value) TCMessage tcap_msg;
+
+ /* TCAP Continue: O -> T */
+ tcap_msg := ts_TCAP_Continue(o_tid, t_tid);
+ f_asp_tx_tcap_exp(tcap_msg, o_asp_idx, t_asp_idx);
+
+ /* TCAP Continue: O <- T */
+ tcap_msg := ts_TCAP_Continue(t_tid, o_tid);
+ f_asp_tx_tcap_exp_any(tcap_msg, t_asp_idx);
+
+}
+
private function f_asp_tx_tcap_m3ua_ipa_transaction_alt(integer o_asp_idx,
OCT4 o_tid,
integer t_asp_idx1, OCT4 t_tid1,
@@ -632,6 +650,8 @@
*
* node a: 0..99
* node b: 60..80/pc (own)
+ * Don't test a complete tcap transaction because that will create a cache entry.
+ * Testing with a continue will definitely use the tcap range.
*/
testcase TC_tcap_loadshare_ipa_tcap_range_success_pc() runs on TCAP_CT {
var Misc_Helpers.ro_charstring tcap_asps := { "asp-m3ua-loadshare-0-0",
@@ -642,8 +662,8 @@
f_init_tcap(tcap_configs);
f_tcap_loadshare_ipa_tcap_range_success_pc(tcap_configs);
- f_asp_tx_tcap_m3ua_ipa_transaction(0, 2, int2oct(23, 4), int2oct(98, 4));
- f_asp_tx_tcap_m3ua_ipa_transaction(0, 3, int2oct(60, 4), int2oct(79, 4));
+ f_asp_tx_tcap_m3ua_ipa_continue(0, 2, int2oct(98, 4), int2oct(23, 4));
+ f_asp_tx_tcap_m3ua_ipa_continue(0, 3, int2oct(79, 4), int2oct(60, 4));
/* TODO: check traffic routing with the correct PC, but different SSN, otid := 60 */
setverdict(pass);
--
To view, visit https://gerrit.osmocom.org/c/osmo-ttcn3-hacks/+/42932?usp=email
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings?usp=email
Gerrit-MessageType: merged
Gerrit-Project: osmo-ttcn3-hacks
Gerrit-Branch: master
Gerrit-Change-Id: I1cb47174b8f0e69970e75109b9d15b2012e150c3
Gerrit-Change-Number: 42932
Gerrit-PatchSet: 1
Gerrit-Owner: daniel <dwillmann(a)sysmocom.de>
Gerrit-Reviewer: Jenkins Builder
Gerrit-Reviewer: daniel <dwillmann(a)sysmocom.de>
Gerrit-Reviewer: fixeria <vyanitskiy(a)sysmocom.de>
Gerrit-Reviewer: laforge <laforge(a)osmocom.org>
Gerrit-Reviewer: lynxis lazus <lynxis(a)fe80.eu>
Attention is currently required from: dexter.
Hello Jenkins Builder,
I'd like you to reexamine a change. Please visit
https://gerrit.osmocom.org/c/onomondo-eim/+/42950?usp=email
to look at the new patch set (#2).
The following approvals got outdated and were removed:
Verified-1 by Jenkins Builder
Change subject: esipa_asn1_handler: replace handle_asn1_notificationList
......................................................................
esipa_asn1_handler: replace handle_asn1_notificationList
The helper function handle_asn1_notificationList can also be
described using the comprehension syntax.
Change-Id: Ia95f56998b4f7a8b0f9fce727d82dedc942e5aeb
Related: SYS#8100
---
M src/esipa_asn1_handler.erl
1 file changed, 6 insertions(+), 9 deletions(-)
git pull ssh://gerrit.osmocom.org:29418/onomondo-eim refs/changes/50/42950/2
--
To view, visit https://gerrit.osmocom.org/c/onomondo-eim/+/42950?usp=email
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings?usp=email
Gerrit-MessageType: newpatchset
Gerrit-Project: onomondo-eim
Gerrit-Branch: master
Gerrit-Change-Id: Ia95f56998b4f7a8b0f9fce727d82dedc942e5aeb
Gerrit-Change-Number: 42950
Gerrit-PatchSet: 2
Gerrit-Owner: dexter <pmaier(a)sysmocom.de>
Gerrit-Reviewer: Jenkins Builder
Gerrit-Attention: dexter <pmaier(a)sysmocom.de>
Attention is currently required from: dexter.
Hello Jenkins Builder,
I'd like you to reexamine a change. Please visit
https://gerrit.osmocom.org/c/onomondo-eim/+/42952?usp=email
to look at the new patch set (#2).
The following approvals got outdated and were removed:
Verified-1 by Jenkins Builder
Change subject: esipa_asn1_handler: use eimTransactionId in EimPackageResultResponseError
......................................................................
esipa_asn1_handler: use eimTransactionId in EimPackageResultResponseError
EimPackageResultResponseError contains an eimTransactionId, let's use this
eimTransactionId and add a dedicated handler function for the
EimPackageResultResponseError to esipa_asn1_handler_utils
Change-Id: Iadd852a7531f180618cf12b314170ceea3f97615
Related: SYS#8100
---
M src/esipa_asn1_handler.erl
M src/esipa_asn1_handler_utils.erl
2 files changed, 17 insertions(+), 6 deletions(-)
git pull ssh://gerrit.osmocom.org:29418/onomondo-eim refs/changes/52/42952/2
--
To view, visit https://gerrit.osmocom.org/c/onomondo-eim/+/42952?usp=email
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings?usp=email
Gerrit-MessageType: newpatchset
Gerrit-Project: onomondo-eim
Gerrit-Branch: master
Gerrit-Change-Id: Iadd852a7531f180618cf12b314170ceea3f97615
Gerrit-Change-Number: 42952
Gerrit-PatchSet: 2
Gerrit-Owner: dexter <pmaier(a)sysmocom.de>
Gerrit-Reviewer: Jenkins Builder
Gerrit-Attention: dexter <pmaier(a)sysmocom.de>
Attention is currently required from: dexter.
Hello Jenkins Builder,
I'd like you to reexamine a change. Please visit
https://gerrit.osmocom.org/c/onomondo-eim/+/42951?usp=email
to look at the new patch set (#2).
The following approvals got outdated and were removed:
Verified-1 by Jenkins Builder
Change subject: esipa_asn1_handler: use eimTransactionId for ipaEuiccDataResponse
......................................................................
esipa_asn1_handler: use eimTransactionId for ipaEuiccDataResponse
The ipaEuiccDataResponse does currently not use the eimTransactionId,
which was added with SGP.32 V.1.2, let's make use of the eimTransactionId
and move the handler functionality to a dedicated helper function in
esipa_asn_handler_utils.
Change-Id: Ie414eef7fd5c8928dd611503f4dd8d67322c0e80
Related: SYS#8100
---
M src/esipa_asn1_handler.erl
M src/esipa_asn1_handler_utils.erl
M src/esipa_rest_utils.erl
3 files changed, 40 insertions(+), 13 deletions(-)
git pull ssh://gerrit.osmocom.org:29418/onomondo-eim refs/changes/51/42951/2
--
To view, visit https://gerrit.osmocom.org/c/onomondo-eim/+/42951?usp=email
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings?usp=email
Gerrit-MessageType: newpatchset
Gerrit-Project: onomondo-eim
Gerrit-Branch: master
Gerrit-Change-Id: Ie414eef7fd5c8928dd611503f4dd8d67322c0e80
Gerrit-Change-Number: 42951
Gerrit-PatchSet: 2
Gerrit-Owner: dexter <pmaier(a)sysmocom.de>
Gerrit-Reviewer: Jenkins Builder
Gerrit-Attention: dexter <pmaier(a)sysmocom.de>
Attention is currently required from: dexter.
Hello Jenkins Builder,
I'd like you to reexamine a change. Please visit
https://gerrit.osmocom.org/c/onomondo-eim/+/42946?usp=email
to look at the new patch set (#4).
The following approvals got outdated and were removed:
Verified-1 by Jenkins Builder
Change subject: mnesia_db: split functionality into dedicated modules
......................................................................
mnesia_db: split functionality into dedicated modules
The mnesia_db module is responsible to handle three different tables
with different scope. Let's split the functionality into separate
modules to make the code easier to maintain.
Change-Id: Ifc649337ab7ce7eb9dc602a1439293130f002f41
Related: SYS#8100
---
A include/mnesia_db_euicc.hrl
A include/mnesia_db_rest.hrl
A include/mnesia_db_work.hrl
M src/crypto_utils.erl
M src/esipa_asn1_handler.erl
M src/esipa_asn1_handler_utils.erl
M src/esipa_asn1_http_handler.erl
M src/esipa_rest_utils.erl
M src/mnesia_db.erl
A src/mnesia_db_euicc.erl
A src/mnesia_db_rest.erl
A src/mnesia_db_work.erl
M src/rest_handler.erl
13 files changed, 930 insertions(+), 854 deletions(-)
git pull ssh://gerrit.osmocom.org:29418/onomondo-eim refs/changes/46/42946/4
--
To view, visit https://gerrit.osmocom.org/c/onomondo-eim/+/42946?usp=email
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings?usp=email
Gerrit-MessageType: newpatchset
Gerrit-Project: onomondo-eim
Gerrit-Branch: master
Gerrit-Change-Id: Ifc649337ab7ce7eb9dc602a1439293130f002f41
Gerrit-Change-Number: 42946
Gerrit-PatchSet: 4
Gerrit-Owner: dexter <pmaier(a)sysmocom.de>
Gerrit-Reviewer: Jenkins Builder
Gerrit-Attention: dexter <pmaier(a)sysmocom.de>
Attention is currently required from: dexter.
Jenkins Builder has posted comments on this change by dexter. ( https://gerrit.osmocom.org/c/onomondo-eim/+/42946?usp=email )
Change subject: mnesia_db: split functionality into dedicated modules
......................................................................
Patch Set 3:
(2 comments)
File src/mnesia_db_rest.erl:
Robot Comment from checkpatch (run ID ):
https://gerrit.osmocom.org/c/onomondo-eim/+/42946/comment/8a9be05a_36a501af… :
PS3, Line 225: % (hours, days), than this may mean that the REST API user lost interest. In this case the related items shoud be
'shoud' may be misspelled - perhaps 'should'?
File src/mnesia_db_work.erl:
Robot Comment from checkpatch (run ID ):
https://gerrit.osmocom.org/c/onomondo-eim/+/42946/comment/e752619c_e183ae8d… :
PS3, Line 211: % Update a work item that is in progress. This fuction updates the state (any user defined term) of the work item.
'fuction' may be misspelled - perhaps 'function'?
--
To view, visit https://gerrit.osmocom.org/c/onomondo-eim/+/42946?usp=email
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings?usp=email
Gerrit-MessageType: comment
Gerrit-Project: onomondo-eim
Gerrit-Branch: master
Gerrit-Change-Id: Ifc649337ab7ce7eb9dc602a1439293130f002f41
Gerrit-Change-Number: 42946
Gerrit-PatchSet: 3
Gerrit-Owner: dexter <pmaier(a)sysmocom.de>
Gerrit-Reviewer: Jenkins Builder
Gerrit-Attention: dexter <pmaier(a)sysmocom.de>
Gerrit-Comment-Date: Wed, 08 Jul 2026 10:31:15 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Attention is currently required from: dexter.
Hello Jenkins Builder,
I'd like you to reexamine a change. Please visit
https://gerrit.osmocom.org/c/onomondo-eim/+/42946?usp=email
to look at the new patch set (#3).
The following approvals got outdated and were removed:
Verified-1 by Jenkins Builder
Change subject: mnesia_db: split functionality into dedicated modules
......................................................................
mnesia_db: split functionality into dedicated modules
The mnesia_db module is responsible to handle three different tables
with different scope. Let's split the functionality into separate
modules to make the code easier to maintain.
Change-Id: Ifc649337ab7ce7eb9dc602a1439293130f002f41
Related: SYS#8100
---
A include/mnesia_db_euicc.hrl
A include/mnesia_db_rest.hrl
A include/mnesia_db_work.hrl
M src/crypto_utils.erl
M src/esipa_asn1_handler.erl
M src/esipa_asn1_handler_utils.erl
M src/esipa_asn1_http_handler.erl
M src/esipa_rest_utils.erl
M src/mnesia_db.erl
A src/mnesia_db_euicc.erl
A src/mnesia_db_rest.erl
A src/mnesia_db_work.erl
M src/rest_handler.erl
13 files changed, 930 insertions(+), 854 deletions(-)
git pull ssh://gerrit.osmocom.org:29418/onomondo-eim refs/changes/46/42946/3
--
To view, visit https://gerrit.osmocom.org/c/onomondo-eim/+/42946?usp=email
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings?usp=email
Gerrit-MessageType: newpatchset
Gerrit-Project: onomondo-eim
Gerrit-Branch: master
Gerrit-Change-Id: Ifc649337ab7ce7eb9dc602a1439293130f002f41
Gerrit-Change-Number: 42946
Gerrit-PatchSet: 3
Gerrit-Owner: dexter <pmaier(a)sysmocom.de>
Gerrit-Reviewer: Jenkins Builder
Gerrit-Attention: dexter <pmaier(a)sysmocom.de>
dexter has uploaded this change for review. ( https://gerrit.osmocom.org/c/onomondo-eim/+/42948?usp=email )
Change subject: esipa: supply eimTransactionId in profileDownloadTriggerRequest
......................................................................
esipa: supply eimTransactionId in profileDownloadTriggerRequest
When we supply an eimTransactionId in profileDownloadTriggerRequest,
the IPAd will echo the same eimTransactionId in the
initiateAuthenticationRequestEsipa message. This allows the eIM
to distinguish to which transaction (work) the received
initiateAuthenticationRequestEsipa belongs. This was not possible
before. The eIM had to rely soly on the PID of the sub process
which is handling the HTTP connection.
Change-Id: I822d6b2bb51498713739671804b173260e9a28a3
Related: SYS#8100
---
M src/esipa_asn1_handler.erl
1 file changed, 10 insertions(+), 5 deletions(-)
git pull ssh://gerrit.osmocom.org:29418/onomondo-eim refs/changes/48/42948/1
diff --git a/src/esipa_asn1_handler.erl b/src/esipa_asn1_handler.erl
index 94389c7..1815499 100644
--- a/src/esipa_asn1_handler.erl
+++ b/src/esipa_asn1_handler.erl
@@ -19,7 +19,8 @@
%GSMA SGP.32, section 6.3.2.1
handle_asn1(Pid, {initiateAuthenticationRequestEsipa, EsipaReq}) ->
- {_, _, WorkState} = mnesia_db_work:pickup(Pid, none),
+ EimTransactionId = maps:get(eimTransactionId, EsipaReq, none),
+ {_, _, WorkState} = mnesia_db_work:pickup(Pid, EimTransactionId),
BaseUrl = maps:get(smdpAddress, EsipaReq),
NewWorkState = WorkState#{smdpAddress => BaseUrl},
mnesia_db_work:update(Pid, NewWorkState),
@@ -284,12 +285,16 @@
EsipaResp =
case Work of
{download, Order} ->
- % The first time we see a TransactionId is in the SMDP+ response to the
- % initiateAuthenticationRequest
- {[{<<"download">>, {[{<<"activationCode">>, ActivationCode}]}}]} = Order,
+ % The first time we see a transactionId from the SM-DP+ is in the SM-DP+ response to the
+ % initiateAuthenticationRequest. Until this point we will use an eimTransactionId as a
+ % temporary identifier.
+ EimTransactionId = rand:bytes(16),
+ mnesia_db_work:bind(Pid, EimTransactionId),
mnesia_db_work:update(Pid, #{}),
+ {[{<<"download">>, {[{<<"activationCode">>, ActivationCode}]}}]} = Order,
{profileDownloadTriggerRequest, #{
- profileDownloadData => {activationCode, ActivationCode}
+ profileDownloadData => {activationCode, ActivationCode},
+ eimTransactionId => EimTransactionId
}};
{psmo, Order} ->
EimTransactionId = rand:bytes(16),
--
To view, visit https://gerrit.osmocom.org/c/onomondo-eim/+/42948?usp=email
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings?usp=email
Gerrit-MessageType: newchange
Gerrit-Project: onomondo-eim
Gerrit-Branch: master
Gerrit-Change-Id: I822d6b2bb51498713739671804b173260e9a28a3
Gerrit-Change-Number: 42948
Gerrit-PatchSet: 1
Gerrit-Owner: dexter <pmaier(a)sysmocom.de>