Attention is currently required from: tnt.
jolly has posted comments on this change. ( https://gerrit.osmocom.org/c/osmo-e1d/+/35562?usp=email )
Change subject: Add command and client function to change transmitted Sa bits
......................................................................
Patch Set 3:
(1 comment)
File src/proto_clnt.c:
https://gerrit.osmocom.org/c/osmo-e1d/+/35562/comment/7d08c952_cda276f1
PS3, Line 420: if (msgb_l2len(msgb) != sizeof(struct osmo_e1dp_line_info))
> This looks like a cut and paste error. […]
Yes, this is a mess. I will do patches first and do tests before I can provide fixes for that.
--
To view, visit https://gerrit.osmocom.org/c/osmo-e1d/+/35562?usp=email
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings
Gerrit-Project: osmo-e1d
Gerrit-Branch: master
Gerrit-Change-Id: I2608af7bbb8092fddd68d4f3bb36b10a1100ce0f
Gerrit-Change-Number: 35562
Gerrit-PatchSet: 3
Gerrit-Owner: jolly <andreas(a)eversberg.eu>
Gerrit-Reviewer: Jenkins Builder
Gerrit-Reviewer: laforge <laforge(a)osmocom.org>
Gerrit-Reviewer: tnt <tnt(a)246tNt.com>
Gerrit-Attention: tnt <tnt(a)246tNt.com>
Gerrit-Comment-Date: Tue, 16 Jan 2024 21:00:24 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Comment-In-Reply-To: tnt <tnt(a)246tNt.com>
Gerrit-MessageType: comment
Attention is currently required from: pespin.
fixeria has posted comments on this change. ( https://gerrit.osmocom.org/c/osmocom-bb/+/35579?usp=email )
Change subject: mobile: init/deinit GAPK I/O based on CC transaction events
......................................................................
Patch Set 2:
(1 comment)
File src/host/layer23/src/mobile/gapk_io.c:
https://gerrit.osmocom.org/c/osmocom-bb/+/35579/comment/195c631e_62570078
PS2, Line 170: static int prepare_audio_source(struct gapk_io_state *state,
> this look unrelated, you are simply changing the name of the variable here. […]
https://gerrit.osmocom.org/c/osmocom-bb/+/35600
--
To view, visit https://gerrit.osmocom.org/c/osmocom-bb/+/35579?usp=email
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings
Gerrit-Project: osmocom-bb
Gerrit-Branch: master
Gerrit-Change-Id: I28f87f6a6de673611aa02a24e8985aee23d4498b
Gerrit-Change-Number: 35579
Gerrit-PatchSet: 2
Gerrit-Owner: fixeria <vyanitskiy(a)sysmocom.de>
Gerrit-Reviewer: Jenkins Builder
Gerrit-Reviewer: pespin <pespin(a)sysmocom.de>
Gerrit-Attention: pespin <pespin(a)sysmocom.de>
Gerrit-Comment-Date: Tue, 16 Jan 2024 20:43:13 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Comment-In-Reply-To: pespin <pespin(a)sysmocom.de>
Gerrit-MessageType: comment
Attention is currently required from: fixeria, pespin.
Hello Jenkins Builder, pespin,
I'd like you to reexamine a change. Please visit
https://gerrit.osmocom.org/c/osmocom-bb/+/35579?usp=email
to look at the new patch set (#3).
The following approvals got outdated and were removed:
Code-Review-1 by pespin, Verified+1 by Jenkins Builder
Change subject: mobile: init/deinit GAPK I/O based on CC transaction events
......................................................................
mobile: init/deinit GAPK I/O based on CC transaction events
Change-Id: I28f87f6a6de673611aa02a24e8985aee23d4498b
Related: OS#4396
---
M src/host/layer23/include/osmocom/bb/common/ms.h
M src/host/layer23/include/osmocom/bb/mobile/gapk_io.h
M src/host/layer23/include/osmocom/bb/mobile/tch.h
M src/host/layer23/src/mobile/app_mobile.c
M src/host/layer23/src/mobile/gapk_io.c
M src/host/layer23/src/mobile/gsm48_rr.c
M src/host/layer23/src/mobile/tch.c
7 files changed, 265 insertions(+), 122 deletions(-)
git pull ssh://gerrit.osmocom.org:29418/osmocom-bb refs/changes/79/35579/3
--
To view, visit https://gerrit.osmocom.org/c/osmocom-bb/+/35579?usp=email
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings
Gerrit-Project: osmocom-bb
Gerrit-Branch: master
Gerrit-Change-Id: I28f87f6a6de673611aa02a24e8985aee23d4498b
Gerrit-Change-Number: 35579
Gerrit-PatchSet: 3
Gerrit-Owner: fixeria <vyanitskiy(a)sysmocom.de>
Gerrit-Reviewer: Jenkins Builder
Gerrit-Reviewer: pespin <pespin(a)sysmocom.de>
Gerrit-Attention: pespin <pespin(a)sysmocom.de>
Gerrit-Attention: fixeria <vyanitskiy(a)sysmocom.de>
Gerrit-MessageType: newpatchset
Attention is currently required from: laforge, pespin.
fixeria has posted comments on this change. ( https://gerrit.osmocom.org/c/libosmocore/+/35587?usp=email )
Change subject: isdn: add a lookup table with E1/E2/E3 bits from Table 5/V.110
......................................................................
Patch Set 1:
(1 comment)
Patchset:
PS1:
> Sounds a bit overkill taking into account they could be stored in 1 byte per entry instead of 3, and […]
libosmoisdn's V.110 API operates on unpacked bits (each bit represented by a byte), so the new API is consistent with this concept. In osmocom-bb I am using it to initialize E1/E2/E3 bits in a `struct osmo_v110_decoded_frame`.
--
To view, visit https://gerrit.osmocom.org/c/libosmocore/+/35587?usp=email
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings
Gerrit-Project: libosmocore
Gerrit-Branch: master
Gerrit-Change-Id: I6d2f8e250df31c233a2741163113dc07515409ae
Gerrit-Change-Number: 35587
Gerrit-PatchSet: 1
Gerrit-Owner: fixeria <vyanitskiy(a)sysmocom.de>
Gerrit-Reviewer: Jenkins Builder
Gerrit-Reviewer: laforge <laforge(a)osmocom.org>
Gerrit-Reviewer: pespin <pespin(a)sysmocom.de>
Gerrit-Attention: laforge <laforge(a)osmocom.org>
Gerrit-Attention: pespin <pespin(a)sysmocom.de>
Gerrit-Comment-Date: Tue, 16 Jan 2024 20:03:42 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Comment-In-Reply-To: pespin <pespin(a)sysmocom.de>
Gerrit-MessageType: comment
Attention is currently required from: fixeria, laforge.
pespin has posted comments on this change. ( https://gerrit.osmocom.org/c/libosmocore/+/35587?usp=email )
Change subject: isdn: add a lookup table with E1/E2/E3 bits from Table 5/V.110
......................................................................
Patch Set 1: Code-Review+1
(1 comment)
Patchset:
PS1:
Sounds a bit overkill taking into account they could be stored in 1 byte per entry instead of 3, and the macros could do bitwise operations to compare and set. What do you think?
--
To view, visit https://gerrit.osmocom.org/c/libosmocore/+/35587?usp=email
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings
Gerrit-Project: libosmocore
Gerrit-Branch: master
Gerrit-Change-Id: I6d2f8e250df31c233a2741163113dc07515409ae
Gerrit-Change-Number: 35587
Gerrit-PatchSet: 1
Gerrit-Owner: fixeria <vyanitskiy(a)sysmocom.de>
Gerrit-Reviewer: Jenkins Builder
Gerrit-Reviewer: laforge <laforge(a)osmocom.org>
Gerrit-Reviewer: pespin <pespin(a)sysmocom.de>
Gerrit-Attention: laforge <laforge(a)osmocom.org>
Gerrit-Attention: fixeria <vyanitskiy(a)sysmocom.de>
Gerrit-Comment-Date: Tue, 16 Jan 2024 19:50:55 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: Yes
Gerrit-MessageType: comment