Attention is currently required from: pespin.
fixeria has posted comments on this change by fixeria. ( https://gerrit.osmocom.org/c/erlang/osmo-s1gw/+/38297?usp=email )
Change subject: s1gw_metrics: more precise type hints
......................................................................
Patch Set 2:
(1 comment)
File src/s1gw_metrics.erl:
https://gerrit.osmocom.org/c/erlang/osmo-s1gw/+/38297/comment/04631954_782f… :
PS2, Line 85: -type counter() :: [ctr | _].
> can you explain this to me? it kind of matches tokens starting with ctr?
Yes, exactly. It's basically the usual `[Head | Tail]` form, letting dialyzer know that the `Head` shall be `ctr` for counters and `gauge` for gauges. Try this in erlang shell:
```erlang
6> [ctr | _] = [ctr, 1, 2, 3].
[ctr,1,2,3]
7> [ctr | _] = [gauge, 1, 2, 3].
** exception error: no match of right hand side value [gauge,1,2,3]
```
--
To view, visit https://gerrit.osmocom.org/c/erlang/osmo-s1gw/+/38297?usp=email
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings?usp=email
Gerrit-MessageType: comment
Gerrit-Project: erlang/osmo-s1gw
Gerrit-Branch: master
Gerrit-Change-Id: I36eaa5e04037e165e43eb960c541f967c394a2ea
Gerrit-Change-Number: 38297
Gerrit-PatchSet: 2
Gerrit-Owner: fixeria <vyanitskiy(a)sysmocom.de>
Gerrit-Reviewer: Jenkins Builder
Gerrit-CC: pespin <pespin(a)sysmocom.de>
Gerrit-Attention: pespin <pespin(a)sysmocom.de>
Gerrit-Comment-Date: Thu, 26 Sep 2024 14:07:51 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Comment-In-Reply-To: pespin <pespin(a)sysmocom.de>
Attention is currently required from: fixeria, laforge.
pespin has posted comments on this change by fixeria. ( https://gerrit.osmocom.org/c/osmo-ttcn3-hacks/+/38277?usp=email )
Change subject: library/s1ap: comment out optional IE in tr_S1AP_InitialCtxSetupResp
......................................................................
Patch Set 1: Code-Review+1
(2 comments)
File library/s1ap/S1AP_Templates.ttcn:
https://gerrit.osmocom.org/c/osmo-ttcn3-hacks/+/38277/comment/e4334a6f_f62b… :
PS1, Line 734: /*, {
> > what's wrong with sending this? You are not explaining why. […]
Acknowledged
https://gerrit.osmocom.org/c/osmo-ttcn3-hacks/+/38277/comment/6331b039_7e47… :
PS1, Line 755: protocolIEs := {
> `superset()` removes the need to put the `*` at the end (which was there before my patches). […]
Acknowledged
--
To view, visit https://gerrit.osmocom.org/c/osmo-ttcn3-hacks/+/38277?usp=email
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings?usp=email
Gerrit-MessageType: comment
Gerrit-Project: osmo-ttcn3-hacks
Gerrit-Branch: master
Gerrit-Change-Id: I4765036be69ff10adb8c510d4092834c4e923229
Gerrit-Change-Number: 38277
Gerrit-PatchSet: 1
Gerrit-Owner: fixeria <vyanitskiy(a)sysmocom.de>
Gerrit-Reviewer: Jenkins Builder
Gerrit-Reviewer: laforge <laforge(a)osmocom.org>
Gerrit-Reviewer: pespin <pespin(a)sysmocom.de>
Gerrit-Attention: laforge <laforge(a)osmocom.org>
Gerrit-Attention: fixeria <vyanitskiy(a)sysmocom.de>
Gerrit-Comment-Date: Thu, 26 Sep 2024 14:07:40 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: Yes
Comment-In-Reply-To: fixeria <vyanitskiy(a)sysmocom.de>
Comment-In-Reply-To: pespin <pespin(a)sysmocom.de>
Attention is currently required from: fixeria.
pespin has posted comments on this change by fixeria. ( https://gerrit.osmocom.org/c/erlang/osmo-s1gw/+/38298?usp=email )
Change subject: s1ap_proxy: move sctp_proxy:handle_pdu() to proc_safe()
......................................................................
Patch Set 2:
(1 comment)
File src/s1ap_proxy.erl:
https://gerrit.osmocom.org/c/erlang/osmo-s1gw/+/38298/comment/c3a0e9d4_cef7… :
PS2, Line 129: proc_safe(OrigData, S) ->
again this is way too generic.
--
To view, visit https://gerrit.osmocom.org/c/erlang/osmo-s1gw/+/38298?usp=email
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings?usp=email
Gerrit-MessageType: comment
Gerrit-Project: erlang/osmo-s1gw
Gerrit-Branch: master
Gerrit-Change-Id: I16d4cf279a930d35ca179bd9b49234d10180e5c5
Gerrit-Change-Number: 38298
Gerrit-PatchSet: 2
Gerrit-Owner: fixeria <vyanitskiy(a)sysmocom.de>
Gerrit-Reviewer: Jenkins Builder
Gerrit-CC: pespin <pespin(a)sysmocom.de>
Gerrit-Attention: fixeria <vyanitskiy(a)sysmocom.de>
Gerrit-Comment-Date: Thu, 26 Sep 2024 14:04:26 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Attention is currently required from: fixeria.
pespin has posted comments on this change by fixeria. ( https://gerrit.osmocom.org/c/erlang/osmo-s1gw/+/38297?usp=email )
Change subject: s1gw_metrics: more precise type hints
......................................................................
Patch Set 2:
(1 comment)
File src/s1gw_metrics.erl:
https://gerrit.osmocom.org/c/erlang/osmo-s1gw/+/38297/comment/0fe924db_bc81… :
PS2, Line 85: -type counter() :: [ctr | _].
can you explain this to me? it kind of matches tokens starting with ctr?
--
To view, visit https://gerrit.osmocom.org/c/erlang/osmo-s1gw/+/38297?usp=email
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings?usp=email
Gerrit-MessageType: comment
Gerrit-Project: erlang/osmo-s1gw
Gerrit-Branch: master
Gerrit-Change-Id: I36eaa5e04037e165e43eb960c541f967c394a2ea
Gerrit-Change-Number: 38297
Gerrit-PatchSet: 2
Gerrit-Owner: fixeria <vyanitskiy(a)sysmocom.de>
Gerrit-Reviewer: Jenkins Builder
Gerrit-CC: pespin <pespin(a)sysmocom.de>
Gerrit-Attention: fixeria <vyanitskiy(a)sysmocom.de>
Gerrit-Comment-Date: Thu, 26 Sep 2024 14:03:03 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Attention is currently required from: laforge, lynxis lazus, pespin.
fixeria has posted comments on this change by pespin. ( https://gerrit.osmocom.org/c/erlang/osmo-s1gw/+/37924?usp=email )
Change subject: s1ap_proxy: Support replying errors
......................................................................
Patch Set 6:
(1 comment)
File src/s1ap_proxy.erl:
https://gerrit.osmocom.org/c/erlang/osmo-s1gw/+/37924/comment/770f3930_cefe… :
PS6, Line 92: proc(OrigData, S0) ->
> this function name is way too generic and I can imagine a total confusion if seeing this appear on e […]
Any naming suggestions? I was having hard time inventing something else than `handle_pdu`. BTW, the reason I had to rename this function is because it's of the same arity as the one in private API now, and Erlang complains about that...
--
To view, visit https://gerrit.osmocom.org/c/erlang/osmo-s1gw/+/37924?usp=email
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings?usp=email
Gerrit-MessageType: comment
Gerrit-Project: erlang/osmo-s1gw
Gerrit-Branch: master
Gerrit-Change-Id: I242e84fb09b00f4794b6e1aa770f348a0e60aea4
Gerrit-Change-Number: 37924
Gerrit-PatchSet: 6
Gerrit-Owner: pespin <pespin(a)sysmocom.de>
Gerrit-Reviewer: Jenkins Builder
Gerrit-Reviewer: fixeria <vyanitskiy(a)sysmocom.de>
Gerrit-Reviewer: laforge <laforge(a)osmocom.org>
Gerrit-Reviewer: lynxis lazus <lynxis(a)fe80.eu>
Gerrit-Attention: laforge <laforge(a)osmocom.org>
Gerrit-Attention: pespin <pespin(a)sysmocom.de>
Gerrit-Attention: lynxis lazus <lynxis(a)fe80.eu>
Gerrit-Comment-Date: Thu, 26 Sep 2024 14:01:57 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Comment-In-Reply-To: pespin <pespin(a)sysmocom.de>
Attention is currently required from: fixeria.
pespin has posted comments on this change by pespin. ( https://gerrit.osmocom.org/c/erlang/osmo-s1gw/+/37955?usp=email )
Change subject: Introduce initial metrics support
......................................................................
Patch Set 5: Code-Review+1
(2 comments)
File include/s1gw_metrics.hrl:
https://gerrit.osmocom.org/c/erlang/osmo-s1gw/+/37955/comment/f3584121_baee… :
PS3, Line 9: S1GW_CTR_S1AP_PROXY_IN_PKT
> This one was not referenced anywhere, so I removed it.
ACK
File src/sctp_proxy.erl:
https://gerrit.osmocom.org/c/erlang/osmo-s1gw/+/37955/comment/c976b90c_7bc3… :
PS4, Line 109: S1GW_CTR_S1AP_PROXY_UPLINK_PACKETS_QUEUED
> @pespin@sysmocom.de do we really want this as a counter? IMO, gauge alone would do the job. […]
The fact that is not special doesn't really mean to me that we should not be counting it. Some counters actually showcase the good usual behavior of the program, like calls being established, etc.
It can also be used for instance to get a glimpse on the amount of packets being forwarded over time, whether the traffic is bursty or not, etc.
--
To view, visit https://gerrit.osmocom.org/c/erlang/osmo-s1gw/+/37955?usp=email
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings?usp=email
Gerrit-MessageType: comment
Gerrit-Project: erlang/osmo-s1gw
Gerrit-Branch: master
Gerrit-Change-Id: I952e198238384dca4be94f91a01d7cfff0a1471f
Gerrit-Change-Number: 37955
Gerrit-PatchSet: 5
Gerrit-Owner: pespin <pespin(a)sysmocom.de>
Gerrit-Reviewer: Jenkins Builder
Gerrit-Reviewer: fixeria <vyanitskiy(a)sysmocom.de>
Gerrit-Reviewer: laforge <laforge(a)osmocom.org>
Gerrit-Reviewer: pespin <pespin(a)sysmocom.de>
Gerrit-Attention: fixeria <vyanitskiy(a)sysmocom.de>
Gerrit-Comment-Date: Thu, 26 Sep 2024 14:01:08 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: Yes
Comment-In-Reply-To: fixeria <vyanitskiy(a)sysmocom.de>
Attention is currently required from: fixeria, laforge, lynxis lazus.
pespin has posted comments on this change by pespin. ( https://gerrit.osmocom.org/c/erlang/osmo-s1gw/+/37924?usp=email )
Change subject: s1ap_proxy: Support replying errors
......................................................................
Patch Set 6:
(2 comments)
Patchset:
PS6:
+1 when you fix the function naming issue.
File src/s1ap_proxy.erl:
https://gerrit.osmocom.org/c/erlang/osmo-s1gw/+/37924/comment/57a456c7_9737… :
PS6, Line 92: proc(OrigData, S0) ->
this function name is way too generic and I can imagine a total confusion if seeing this appear on eg. a stacktrace.
--
To view, visit https://gerrit.osmocom.org/c/erlang/osmo-s1gw/+/37924?usp=email
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings?usp=email
Gerrit-MessageType: comment
Gerrit-Project: erlang/osmo-s1gw
Gerrit-Branch: master
Gerrit-Change-Id: I242e84fb09b00f4794b6e1aa770f348a0e60aea4
Gerrit-Change-Number: 37924
Gerrit-PatchSet: 6
Gerrit-Owner: pespin <pespin(a)sysmocom.de>
Gerrit-Reviewer: Jenkins Builder
Gerrit-Reviewer: fixeria <vyanitskiy(a)sysmocom.de>
Gerrit-Reviewer: laforge <laforge(a)osmocom.org>
Gerrit-Reviewer: lynxis lazus <lynxis(a)fe80.eu>
Gerrit-Attention: laforge <laforge(a)osmocom.org>
Gerrit-Attention: fixeria <vyanitskiy(a)sysmocom.de>
Gerrit-Attention: lynxis lazus <lynxis(a)fe80.eu>
Gerrit-Comment-Date: Thu, 26 Sep 2024 13:55:02 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No