lists.osmocom.org
Sign In Sign Up
Manage this list Sign In Sign Up

Keyboard Shortcuts

Thread View

  • j: Next unread message
  • k: Previous unread message
  • j a: Jump to all threads
  • j l: Jump to MailingList overview

gerrit-log

Thread Start a new thread
Download
Threads by month
  • ----- 2026 -----
  • November
  • October
  • September
  • August
  • July
  • June
  • May
  • April
  • March
  • February
  • January
  • ----- 2025 -----
  • December
  • November
  • October
  • September
  • August
  • July
  • June
  • May
  • April
  • March
  • February
  • January
  • ----- 2024 -----
  • December
  • November
  • October
  • September
  • August
  • July
  • June
  • May
  • April
  • March
  • February
  • January
  • ----- 2023 -----
  • December
  • November
  • October
  • September
  • August
  • July
  • June
  • May
  • April
  • March
  • February
  • January
  • ----- 2022 -----
  • December
  • November
  • October
  • September
  • August
  • July
  • June
  • May
  • April
  • March
  • February
  • January
gerrit-log@lists.osmocom.org

October 2024

  • 1 participants
  • 1631 discussions
[M] Change in osmo-ggsn[master]: ggsn: Avoid forwarding IPv6 solicited-node multicast addr to tun device
by pespin 24 Oct '24

24 Oct '24
pespin has submitted this change. ( https://gerrit.osmocom.org/c/osmo-ggsn/+/38505?usp=email ) Change subject: ggsn: Avoid forwarding IPv6 solicited-node multicast addr to tun device ...................................................................... ggsn: Avoid forwarding IPv6 solicited-node multicast addr to tun device There's no need to forward those. Morevoer, they cannot be forwarded when using gtpu kernel mode since it doesn't support reinjecting packets we got from it, so avoid erroring out when trying to inject them later on. Related: OS#6600 Related: OS#6382 Change-Id: Iac8f14083620d86f3872aa951930fbe8f680ff24 --- M ggsn/ggsn.c M lib/icmpv6.c M lib/icmpv6.h 3 files changed, 82 insertions(+), 4 deletions(-) Approvals: Jenkins Builder: Verified laforge: Looks good to me, but someone else must approve fixeria: Looks good to me, but someone else must approve osmith: Looks good to me, but someone else must approve pespin: Looks good to me, approved diff --git a/ggsn/ggsn.c b/ggsn/ggsn.c index c73a46d..a02b97f 100644 --- a/ggsn/ggsn.c +++ b/ggsn/ggsn.c @@ -782,10 +782,15 @@ return -1; } - /* daddr: all-routers multicast addr */ - if (IN6_ARE_ADDR_EQUAL(&ip6h->ip6_dst, &all_router_mcast_addr)) - return handle_router_mcast(pdp->gsn, pdp, &peer->addr.v6, - &apn->v6_lladdr, apn->cfg.mtu, pack, len); + if (IN6_IS_ADDR_MULTICAST(&ip6h->ip6_dst)) { + /* daddr: all-routers multicast addr */ + if (IN6_ARE_ADDR_EQUAL(&ip6h->ip6_dst, &all_router_mcast_addr)) + return handle_router_mcast(pdp->gsn, pdp, &peer->addr.v6, + &apn->v6_lladdr, apn->cfg.mtu, pack, len); + /* daddr: solicited-node multicast addr */ + if (memcmp(&ip6h->ip6_dst.s6_addr, solicited_node_mcast_addr_prefix, sizeof(solicited_node_mcast_addr_prefix)) == 0) + return handle_solicited_node_mcast(pack, len); + } break; case 4: peer = pdp_get_peer_ipv(pdp, false); diff --git a/lib/icmpv6.c b/lib/icmpv6.c index e74fb70..4226fc0 100644 --- a/lib/icmpv6.c +++ b/lib/icmpv6.c @@ -42,6 +42,14 @@ .s6_addr = { 0xff,0x02,0,0, 0,0,0,0, 0,0,0,0, 0,0,0,2 } }; +/* RFC4291 link-local solicited-node multicast address, FF02:0:0:0:0:1:FF, 104 bits = 13 bytes */ +const uint8_t solicited_node_mcast_addr_prefix[13] = { + 0xff, 0x02, 0x00, 0x00, + 0x00, 0x00, 0x00, 0x00, + 0x00, 0x00, 0x00, 0x01, + 0xFF +}; + /* Prepends the ipv6 header and returns checksum content */ uint16_t icmpv6_prepend_ip6hdr(struct msgb *msg, const struct in6_addr *saddr, const struct in6_addr *daddr) @@ -180,6 +188,25 @@ return true; } +/* Validate an ICMPv6 neighbor solicitation according to RFC4861 7.1.1 */ +static bool icmpv6_validate_neigh_solicit(const uint8_t *pack, unsigned len) +{ + const struct ip6_hdr *ip6h = (struct ip6_hdr *)pack; + + /* Hop limit field must have 255 */ + if (ip6h->ip6_ctlun.ip6_un1.ip6_un1_hlim != 255) + return false; + /* FIXME: ICMP checksum is valid */ + /* ICMP length (derived from IP length) is 24 or more octets */ + if (ip6h->ip6_ctlun.ip6_un1.ip6_un1_plen < 24) + return false; + /* FIXME: All included options have a length > 0 */ + /* FIXME: If the IP source address is the unspecified address, the IP + * destination address is a solicited-node multicast address. */ + /* FIXME: If IP source is unspecified, no source link-layer addr option */ + return true; +} + /* Validate an ICMPv6 router advertisement according to RFC4861 6.1.2. Returns pointer packet header on success, NULL otherwise. */ struct icmpv6_radv_hdr *icmpv6_validate_router_adv(const uint8_t *pack, unsigned len) @@ -263,3 +290,46 @@ } return 0; } + +/* handle incoming packets to the solicited-node multicast address */ +int handle_solicited_node_mcast(const uint8_t *pack, unsigned len) +{ + const struct ip6_hdr *ip6h = (struct ip6_hdr *)pack; + const struct icmpv6_hdr *ic6h = (struct icmpv6_hdr *) (pack + sizeof(*ip6h)); + + if (len < sizeof(*ip6h)) { + LOGP(DICMP6, LOGL_NOTICE, "Packet too short: %u bytes\n", len); + return -1; + } + + /* we only treat ICMPv6 here */ + if (ip6h->ip6_ctlun.ip6_un1.ip6_un1_nxt != IPPROTO_ICMPV6) { + LOGP(DICMP6, LOGL_DEBUG, "Ignoring non-ICMP solicited-node mcast\n"); + return 0; + } + + if (len < sizeof(*ip6h) + sizeof(*ic6h)) { + LOGP(DICMP6, LOGL_NOTICE, "Short ICMPv6 packet: %s\n", osmo_hexdump(pack, len)); + return -1; + } + + switch (ic6h->type) { + case 135: /* Neighbor Solicitation. RFC2461, RFC2462 */ + if (ic6h->code != 0) { + LOGP(DICMP6, LOGL_NOTICE, "ICMPv6 type 135 but code %d\n", ic6h->code); + return -1; + } + if (!icmpv6_validate_neigh_solicit(pack, len)) { + LOGP(DICMP6, LOGL_NOTICE, "Invalid Neighbor Solicitation: %s\n", + osmo_hexdump(pack, len)); + return -1; + } + /* RFC 2462: Ignore Neighbor (Duplicate Address Detection) */ + LOGP(DICMP6, LOGL_DEBUG, "Ignoring Rx ICMPv6 Neighbor Soliciation: %s\n", osmo_hexdump(pack, len)); + break; + default: + LOGP(DICMP6, LOGL_DEBUG, "Unknown ICMPv6 type %u\n", ic6h->type); + break; + } + return 0; +} diff --git a/lib/icmpv6.h b/lib/icmpv6.h index 1040600..2469ed0 100644 --- a/lib/icmpv6.h +++ b/lib/icmpv6.h @@ -98,9 +98,12 @@ const struct in6_addr *own_ll_addr, uint32_t mtu, const uint8_t *pack, unsigned len); +int handle_solicited_node_mcast(const uint8_t *pack, unsigned len); struct icmpv6_radv_hdr *icmpv6_validate_router_adv(const uint8_t *pack, unsigned len); /* RFC3307 link-local scope multicast address */ extern const struct in6_addr all_router_mcast_addr; + +extern const uint8_t solicited_node_mcast_addr_prefix[13]; -- To view, visit https://gerrit.osmocom.org/c/osmo-ggsn/+/38505?usp=email To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings?usp=email Gerrit-MessageType: merged Gerrit-Project: osmo-ggsn Gerrit-Branch: master Gerrit-Change-Id: Iac8f14083620d86f3872aa951930fbe8f680ff24 Gerrit-Change-Number: 38505 Gerrit-PatchSet: 1 Gerrit-Owner: pespin <pespin(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Reviewer: laforge <laforge(a)osmocom.org> Gerrit-Reviewer: lynxis lazus <lynxis(a)fe80.eu> Gerrit-Reviewer: osmith <osmith(a)sysmocom.de> Gerrit-Reviewer: pespin <pespin(a)sysmocom.de>
1 0
0 0
[XS] Change in osmo-ggsn[master]: tun.h: Remove non-existent tun_decaps()
by pespin 24 Oct '24

24 Oct '24
pespin has submitted this change. ( https://gerrit.osmocom.org/c/osmo-ggsn/+/38507?usp=email ) Change subject: tun.h: Remove non-existent tun_decaps() ...................................................................... tun.h: Remove non-existent tun_decaps() Change-Id: If9cc5d2d54b87e38feefa55cb9410715fa9bd11f --- M lib/tun.h 1 file changed, 0 insertions(+), 1 deletion(-) Approvals: osmith: Looks good to me, approved Jenkins Builder: Verified diff --git a/lib/tun.h b/lib/tun.h index 544e56a..a6b6181 100644 --- a/lib/tun.h +++ b/lib/tun.h @@ -47,7 +47,6 @@ extern int tun_new(struct tun_t **tun, const char *dev_name, bool use_kernel, int fd0, int fd1u); extern int tun_free(struct tun_t *tun); -extern int tun_decaps(struct tun_t *this); extern int tun_encaps(struct tun_t *tun, void *pack, unsigned len); extern int tun_addaddr(struct tun_t *this, struct in46_addr *addr, size_t prefixlen); -- To view, visit https://gerrit.osmocom.org/c/osmo-ggsn/+/38507?usp=email To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings?usp=email Gerrit-MessageType: merged Gerrit-Project: osmo-ggsn Gerrit-Branch: master Gerrit-Change-Id: If9cc5d2d54b87e38feefa55cb9410715fa9bd11f Gerrit-Change-Number: 38507 Gerrit-PatchSet: 1 Gerrit-Owner: pespin <pespin(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: osmith <osmith(a)sysmocom.de> Gerrit-Reviewer: pespin <pespin(a)sysmocom.de>
1 0
0 0
[XS] Change in osmo-ggsn[master]: Rename tun_encaps -> tun_inject_pkt
by pespin 24 Oct '24

24 Oct '24
pespin has submitted this change. ( https://gerrit.osmocom.org/c/osmo-ggsn/+/38508?usp=email ) Change subject: Rename tun_encaps -> tun_inject_pkt ...................................................................... Rename tun_encaps -> tun_inject_pkt The terminology of "encapsulating" used in tun_encaps is confusing, since in this case we are not really encapsulating anything, but actually delivering ("injecting") the packet to the system network stack. Using the "encapsulating" term is also confusing because readers may think it may be doing the GTP-U encapsulation, which is not. Change-Id: Ibb17c792b81668571e69d79918f3adf0e9e0f6c8 --- M ggsn/ggsn.c M lib/tun.c M lib/tun.h M sgsnemu/sgsnemu.c 4 files changed, 4 insertions(+), 4 deletions(-) Approvals: Jenkins Builder: Verified osmith: Looks good to me, approved laforge: Looks good to me, but someone else must approve diff --git a/ggsn/ggsn.c b/ggsn/ggsn.c index 6b51bbc..062e542 100644 --- a/ggsn/ggsn.c +++ b/ggsn/ggsn.c @@ -815,7 +815,7 @@ osmo_hexdump(pack, len)); return -1; } - return tun_encaps((struct tun_t *)pdp->ipif, pack, len); + return tun_inject_pkt((struct tun_t *)pdp->ipif, pack, len); } /* callback for libgtp osmocom select loop integration */ diff --git a/lib/tun.c b/lib/tun.c index 5f73d32..3cce3a5 100644 --- a/lib/tun.c +++ b/lib/tun.c @@ -200,7 +200,7 @@ return 0; } -int tun_encaps(struct tun_t *tun, void *pack, unsigned len) +int tun_inject_pkt(struct tun_t *tun, void *pack, unsigned len) { struct msgb *msg; int rc; diff --git a/lib/tun.h b/lib/tun.h index a6b6181..4d41eb8 100644 --- a/lib/tun.h +++ b/lib/tun.h @@ -47,7 +47,7 @@ extern int tun_new(struct tun_t **tun, const char *dev_name, bool use_kernel, int fd0, int fd1u); extern int tun_free(struct tun_t *tun); -extern int tun_encaps(struct tun_t *tun, void *pack, unsigned len); +extern int tun_inject_pkt(struct tun_t *tun, void *pack, unsigned len); extern int tun_addaddr(struct tun_t *this, struct in46_addr *addr, size_t prefixlen); diff --git a/sgsnemu/sgsnemu.c b/sgsnemu/sgsnemu.c index c592aa9..d195fab 100644 --- a/sgsnemu/sgsnemu.c +++ b/sgsnemu/sgsnemu.c @@ -1827,7 +1827,7 @@ } /* printf("cb_gtpu_data_ind. Packet received: forwarding to tun\n"); */ - return tun_encaps((struct tun_t *)pdp->ipif, pack, len); + return tun_inject_pkt((struct tun_t *)pdp->ipif, pack, len); } int main(int argc, char **argv) -- To view, visit https://gerrit.osmocom.org/c/osmo-ggsn/+/38508?usp=email To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings?usp=email Gerrit-MessageType: merged Gerrit-Project: osmo-ggsn Gerrit-Branch: master Gerrit-Change-Id: Ibb17c792b81668571e69d79918f3adf0e9e0f6c8 Gerrit-Change-Number: 38508 Gerrit-PatchSet: 1 Gerrit-Owner: pespin <pespin(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: laforge <laforge(a)osmocom.org> Gerrit-Reviewer: osmith <osmith(a)sysmocom.de> Gerrit-Reviewer: pespin <pespin(a)sysmocom.de>
1 0
0 0
[M] Change in osmo-ttcn3-hacks[master]: ctrl, hnbgw: access rate counter groups by given ID instead of index
by osmith 24 Oct '24

24 Oct '24
osmith has abandoned this change. ( https://gerrit.osmocom.org/c/osmo-ttcn3-hacks/+/37882?usp=email ) Change subject: ctrl, hnbgw: access rate counter groups by given ID instead of index ...................................................................... Abandoned (SYS#7165) from reading the discussion it sounds like this patch is not needed anymore and Neels has ideas for a nicer API -> abandoning this patch. I've rebased the next patch in this series as: https://gerrit.osmocom.org/c/osmo-ttcn3-hacks/+/37883 -- To view, visit https://gerrit.osmocom.org/c/osmo-ttcn3-hacks/+/37882?usp=email To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings?usp=email Gerrit-MessageType: abandon Gerrit-Project: osmo-ttcn3-hacks Gerrit-Branch: master Gerrit-Change-Id: I70e74e7554482df67aa1d90bc04314124dea444f Gerrit-Change-Number: 37882 Gerrit-PatchSet: 4 Gerrit-Owner: neels <nhofmeyr(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: laforge <laforge(a)osmocom.org> Gerrit-Reviewer: pespin <pespin(a)sysmocom.de>
1 0
0 0
[M] Change in osmo-ggsn[master]: ggsn: Avoid forwarding IPv6 solicited-node multicast addr to tun device
by pespin 24 Oct '24

24 Oct '24
Attention is currently required from: lynxis lazus. pespin has posted comments on this change by pespin. ( https://gerrit.osmocom.org/c/osmo-ggsn/+/38505?usp=email ) Change subject: ggsn: Avoid forwarding IPv6 solicited-node multicast addr to tun device ...................................................................... Patch Set 1: Code-Review+2 -- To view, visit https://gerrit.osmocom.org/c/osmo-ggsn/+/38505?usp=email To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings?usp=email Gerrit-MessageType: comment Gerrit-Project: osmo-ggsn Gerrit-Branch: master Gerrit-Change-Id: Iac8f14083620d86f3872aa951930fbe8f680ff24 Gerrit-Change-Number: 38505 Gerrit-PatchSet: 1 Gerrit-Owner: pespin <pespin(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Reviewer: laforge <laforge(a)osmocom.org> Gerrit-Reviewer: lynxis lazus <lynxis(a)fe80.eu> Gerrit-Reviewer: osmith <osmith(a)sysmocom.de> Gerrit-Reviewer: pespin <pespin(a)sysmocom.de> Gerrit-Attention: lynxis lazus <lynxis(a)fe80.eu> Gerrit-Comment-Date: Thu, 24 Oct 2024 11:10:25 +0000 Gerrit-HasComments: No Gerrit-Has-Labels: Yes
1 0
0 0
[S] Change in osmo-ttcn3-hacks[master]: ctrl: tweak errmsg for counter mismatch
by osmith 24 Oct '24

24 Oct '24
Attention is currently required from: laforge, neels, pespin. osmith has uploaded a new patch set (#6) to the change originally created by neels. ( https://gerrit.osmocom.org/c/osmo-ttcn3-hacks/+/37883?usp=email ) The following approvals got outdated and were removed: Code-Review+1 by laforge, Code-Review+2 by pespin, Verified+1 by Jenkins Builder The change is no longer submittable: Code-Review and Verified are unsatisfied now. Change subject: ctrl: tweak errmsg for counter mismatch ...................................................................... ctrl: tweak errmsg for counter mismatch - instead of "-1", print "not present", so humans know what is happening. - the comma separated args in setverdict() create a lot of weird quotes. Use string concatenation to have only one set of quotes around the entire error message. Related: OS#6545 Tweaked-by: Oliver Smith <osmith(a)sysmocom.de> Change-Id: I672fcef819a6542a5b3bcfa0a6d9c84d34b468f3 --- M library/Osmocom_CTRL_Functions.ttcn 1 file changed, 11 insertions(+), 2 deletions(-) git pull ssh://gerrit.osmocom.org:29418/osmo-ttcn3-hacks refs/changes/83/37883/6 -- To view, visit https://gerrit.osmocom.org/c/osmo-ttcn3-hacks/+/37883?usp=email To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings?usp=email Gerrit-MessageType: newpatchset Gerrit-Project: osmo-ttcn3-hacks Gerrit-Branch: master Gerrit-Change-Id: I672fcef819a6542a5b3bcfa0a6d9c84d34b468f3 Gerrit-Change-Number: 37883 Gerrit-PatchSet: 6 Gerrit-Owner: neels <nhofmeyr(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: laforge <laforge(a)osmocom.org> Gerrit-Reviewer: pespin <pespin(a)sysmocom.de> Gerrit-Attention: neels <nhofmeyr(a)sysmocom.de> Gerrit-Attention: laforge <laforge(a)osmocom.org> Gerrit-Attention: pespin <pespin(a)sysmocom.de>
1 0
0 0
[S] Change in libosmocore[master]: gsm48_encode_bearer_cap(): properly set 'Structure' in octet 4
by osmith 24 Oct '24

24 Oct '24
Attention is currently required from: fixeria, manawyrm. osmith has posted comments on this change by fixeria. ( https://gerrit.osmocom.org/c/libosmocore/+/38509?usp=email ) Change subject: gsm48_encode_bearer_cap(): properly set 'Structure' in octet 4 ...................................................................... Patch Set 1: Code-Review+2 -- To view, visit https://gerrit.osmocom.org/c/libosmocore/+/38509?usp=email To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings?usp=email Gerrit-MessageType: comment Gerrit-Project: libosmocore Gerrit-Branch: master Gerrit-Change-Id: I563becfdae75e22de3b5e5de3c810334a74e7ffb Gerrit-Change-Number: 38509 Gerrit-PatchSet: 1 Gerrit-Owner: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: laforge <laforge(a)osmocom.org> Gerrit-Reviewer: manawyrm <osmocom.account(a)tbspace.de> Gerrit-Reviewer: osmith <osmith(a)sysmocom.de> Gerrit-Attention: manawyrm <osmocom.account(a)tbspace.de> Gerrit-Attention: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Comment-Date: Thu, 24 Oct 2024 10:34:57 +0000 Gerrit-HasComments: No Gerrit-Has-Labels: Yes
1 0
0 0
[S] Change in osmo-ci[master]: jobs/ttcn3-testsuites: run pcap-client with testenv
by fixeria 24 Oct '24

24 Oct '24
Attention is currently required from: osmith. fixeria has posted comments on this change by osmith. ( https://gerrit.osmocom.org/c/osmo-ci/+/38523?usp=email ) Change subject: jobs/ttcn3-testsuites: run pcap-client with testenv ...................................................................... Patch Set 1: Code-Review+1 -- To view, visit https://gerrit.osmocom.org/c/osmo-ci/+/38523?usp=email To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings?usp=email Gerrit-MessageType: comment Gerrit-Project: osmo-ci Gerrit-Branch: master Gerrit-Change-Id: Iba974e6c247008e2d220a11b402291b9f944820c Gerrit-Change-Number: 38523 Gerrit-PatchSet: 1 Gerrit-Owner: osmith <osmith(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Attention: osmith <osmith(a)sysmocom.de> Gerrit-Comment-Date: Thu, 24 Oct 2024 10:18:19 +0000 Gerrit-HasComments: No Gerrit-Has-Labels: Yes
1 0
0 0
[M] Change in osmo-ci[master]: jobs/ttcn3-testsuites: run bsc with testenv
by fixeria 24 Oct '24

24 Oct '24
Attention is currently required from: osmith. fixeria has posted comments on this change by osmith. ( https://gerrit.osmocom.org/c/osmo-ci/+/38522?usp=email ) Change subject: jobs/ttcn3-testsuites: run bsc with testenv ...................................................................... Patch Set 1: Code-Review+1 -- To view, visit https://gerrit.osmocom.org/c/osmo-ci/+/38522?usp=email To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings?usp=email Gerrit-MessageType: comment Gerrit-Project: osmo-ci Gerrit-Branch: master Gerrit-Change-Id: I327d0e0bf816b84bd04448d23aab16b5264c6a77 Gerrit-Change-Number: 38522 Gerrit-PatchSet: 1 Gerrit-Owner: osmith <osmith(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Attention: osmith <osmith(a)sysmocom.de> Gerrit-Comment-Date: Thu, 24 Oct 2024 10:17:47 +0000 Gerrit-HasComments: No Gerrit-Has-Labels: Yes
1 0
0 0
[S] Change in osmo-ci[master]: jobs/ttcn3-testsuites: run pcu with testenv
by fixeria 24 Oct '24

24 Oct '24
Attention is currently required from: osmith, pespin. fixeria has posted comments on this change by osmith. ( https://gerrit.osmocom.org/c/osmo-ci/+/38521?usp=email ) Change subject: jobs/ttcn3-testsuites: run pcu with testenv ...................................................................... Patch Set 1: Code-Review+1 -- To view, visit https://gerrit.osmocom.org/c/osmo-ci/+/38521?usp=email To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings?usp=email Gerrit-MessageType: comment Gerrit-Project: osmo-ci Gerrit-Branch: master Gerrit-Change-Id: I950e39e5d5527fa44adda1497eb0738377fe5001 Gerrit-Change-Number: 38521 Gerrit-PatchSet: 1 Gerrit-Owner: osmith <osmith(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Reviewer: pespin <pespin(a)sysmocom.de> Gerrit-Attention: osmith <osmith(a)sysmocom.de> Gerrit-Attention: pespin <pespin(a)sysmocom.de> Gerrit-Comment-Date: Thu, 24 Oct 2024 10:16:56 +0000 Gerrit-HasComments: No Gerrit-Has-Labels: Yes
1 0
0 0
  • ← Newer
  • 1
  • ...
  • 47
  • 48
  • 49
  • 50
  • 51
  • 52
  • 53
  • ...
  • 164
  • Older →

HyperKitty Powered by HyperKitty version 1.3.12.