lists.osmocom.org
Sign In Sign Up
Manage this list Sign In Sign Up

Keyboard Shortcuts

Thread View

  • j: Next unread message
  • k: Previous unread message
  • j a: Jump to all threads
  • j l: Jump to MailingList overview

gerrit-log

Thread Start a new thread
Download
Threads by month
  • ----- 2026 -----
  • November
  • October
  • September
  • August
  • July
  • June
  • May
  • April
  • March
  • February
  • January
  • ----- 2025 -----
  • December
  • November
  • October
  • September
  • August
  • July
  • June
  • May
  • April
  • March
  • February
  • January
  • ----- 2024 -----
  • December
  • November
  • October
  • September
  • August
  • July
  • June
  • May
  • April
  • March
  • February
  • January
  • ----- 2023 -----
  • December
  • November
  • October
  • September
  • August
  • July
  • June
  • May
  • April
  • March
  • February
  • January
  • ----- 2022 -----
  • December
  • November
  • October
  • September
  • August
  • July
  • June
  • May
  • April
  • March
  • February
  • January
gerrit-log@lists.osmocom.org

March 2023

  • 1 participants
  • 3642 discussions
[S] Change in osmo-ci[master]: obs: wireshark: remove laforge/amr-2023 branch
by osmith 22 Mar '23

22 Mar '23
osmith has uploaded this change for review. ( https://gerrit.osmocom.org/c/osmo-ci/+/32012 ) Change subject: obs: wireshark: remove laforge/amr-2023 branch ...................................................................... obs: wireshark: remove laforge/amr-2023 branch Remove it, as the AMR patches have been upstreamed \o/ Related: https://gitlab.com/wireshark/wireshark/-/merge_requests/10025 Change-Id: I7f3f06bc5390ffac9b3760035831ae17d28b744e --- M scripts/obs/update_obs_wireshark.sh 1 file changed, 12 insertions(+), 1 deletion(-) git pull ssh://gerrit.osmocom.org:29418/osmo-ci refs/changes/12/32012/1 diff --git a/scripts/obs/update_obs_wireshark.sh b/scripts/obs/update_obs_wireshark.sh index 70a0392..3c067cf 100755 --- a/scripts/obs/update_obs_wireshark.sh +++ b/scripts/obs/update_obs_wireshark.sh @@ -4,7 +4,6 @@ BRANCHES=" osmith/deb-packaging - laforge/amr-2023 laforge/doc-fixes osmocom/qcdiag laforge/rspro -- To view, visit https://gerrit.osmocom.org/c/osmo-ci/+/32012 To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: osmo-ci Gerrit-Branch: master Gerrit-Change-Id: I7f3f06bc5390ffac9b3760035831ae17d28b744e Gerrit-Change-Number: 32012 Gerrit-PatchSet: 1 Gerrit-Owner: osmith <osmith(a)sysmocom.de> Gerrit-MessageType: newchange
1 0
0 0
[S] Change in osmo-ttcn3-hacks[master]: library/DIAMETER_Emulation: add API for generating Session-Id AVP
by laforge 22 Mar '23

22 Mar '23
Attention is currently required from: fixeria, pespin. laforge has posted comments on this change. ( https://gerrit.osmocom.org/c/osmo-ttcn3-hacks/+/31455 ) Change subject: library/DIAMETER_Emulation: add API for generating Session-Id AVP ...................................................................... Patch Set 1: Code-Review+1 -- To view, visit https://gerrit.osmocom.org/c/osmo-ttcn3-hacks/+/31455 To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: osmo-ttcn3-hacks Gerrit-Branch: master Gerrit-Change-Id: I0fbd271ad123e9663aab5163915e1edbf5915bb6 Gerrit-Change-Number: 31455 Gerrit-PatchSet: 1 Gerrit-Owner: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: laforge <laforge(a)osmocom.org> Gerrit-CC: pespin <pespin(a)sysmocom.de> Gerrit-Attention: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Attention: pespin <pespin(a)sysmocom.de> Gerrit-Comment-Date: Wed, 22 Mar 2023 09:59:51 +0000 Gerrit-HasComments: No Gerrit-Has-Labels: Yes Gerrit-MessageType: comment
1 0
0 0
[M] Change in osmo-bsc[master]: add location_services_fsm_bsc.dot
by laforge 22 Mar '23

22 Mar '23
laforge has submitted this change. ( https://gerrit.osmocom.org/c/osmo-bsc/+/31634 ) Change subject: add location_services_fsm_bsc.dot ...................................................................... add location_services_fsm_bsc.dot Change-Id: I3bdcc90c59459473a5f2e06d9018a2a98147a6b9 --- M doc/Makefile.am A doc/location_services_fsm_bsc.dot 2 files changed, 50 insertions(+), 0 deletions(-) Approvals: laforge: Looks good to me, approved pespin: Looks good to me, but someone else must approve Jenkins Builder: Verified diff --git a/doc/Makefile.am b/doc/Makefile.am index 32d06c1..3324d46 100644 --- a/doc/Makefile.am +++ b/doc/Makefile.am @@ -28,6 +28,7 @@ $(builddir)/handover-inter-bsc-out-fsm.png \ $(builddir)/handover-inter-bsc-in-fsm.png \ $(builddir)/mscpool-attach.png \ + $(builddir)/location_services_fsm_bsc.png \ $(NULL) $(builddir)/%.png: $(srcdir)/%.msc diff --git a/doc/location_services_fsm_bsc.dot b/doc/location_services_fsm_bsc.dot new file mode 100644 index 0000000..f369c63 --- /dev/null +++ b/doc/location_services_fsm_bsc.dot @@ -0,0 +1,40 @@ +digraph G { +rankdir=TB +labelloc=t; label="Location Services FSMs in OsmoBSC" + + MSC [label="MSC\nvia\nA interface",shape=box3d] + SMLC [label="SMLC\nvia\nLb interface",shape=box3d] + SMLC2 [label="SMLC\nvia\nLb interface",shape=box3d] + Paging [shape=box3d] + + subgraph cluster_LCS_LOC_REQ_FSM { + label="lcs_loc_req_fsm" + INIT -> WAIT_LOCATION_RESPONSE + WAIT_LOCATION_RESPONSE -> BSSLAP_TA_REQ_ONGOING -> GOT_LOCATION_RESPONSE -> terminate + WAIT_LOCATION_RESPONSE -> GOT_LOCATION_RESPONSE + terminate [shape=octagon] + } + + MSC -> INIT [label="BSSAP Perform\nLocation Request",style=dashed] + WAIT_LOCATION_RESPONSE -> SMLC [label="BSSMAP-LE Perform\nLocation Req",style=dashed] + SMLC -> WAIT_LOCATION_RESPONSE [label="BSSMAP-LE Perform\nLocation Resp",style=dashed] + GOT_LOCATION_RESPONSE -> MSC [label="BSSAP Perform\nLocation Response",style=dashed] + + subgraph cluster_LCS_TA_REQ_FSM { + label="lcs_ta_req_fsm" + INIT2 [label="INIT"] + INIT2 -> WAIT_TA [label="MS idle"] + WAIT_TA -> GOT_TA + INIT2 -> GOT_TA [label="MS active"] + GOT_TA -> terminate2 + terminate2 [label="terminate",shape=octagon] + } + + SMLC2 -> INIT2 [label="TA Request",style=dashed] + WAIT_TA -> Paging [label="launch Paging",style=dashed] + Paging -> WAIT_TA [label="EV_TA",style=dashed] + GOT_TA -> SMLC2 [label="TA Response",style=dashed] + + WAIT_TA -> BSSLAP_TA_REQ_ONGOING [label="EV_TA_REQ_START",style=dashed] + terminate2 -> BSSLAP_TA_REQ_ONGOING [label="EV_TA_REQ_END",style=dashed,constraint=false] +} -- To view, visit https://gerrit.osmocom.org/c/osmo-bsc/+/31634 To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: osmo-bsc Gerrit-Branch: master Gerrit-Change-Id: I3bdcc90c59459473a5f2e06d9018a2a98147a6b9 Gerrit-Change-Number: 31634 Gerrit-PatchSet: 2 Gerrit-Owner: neels <nhofmeyr(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: laforge <laforge(a)osmocom.org> Gerrit-Reviewer: pespin <pespin(a)sysmocom.de> Gerrit-MessageType: merged
1 0
0 0
[M] Change in osmo-bsc[master]: add location_services_fsm_bsc.dot
by laforge 22 Mar '23

22 Mar '23
Attention is currently required from: neels. laforge has posted comments on this change. ( https://gerrit.osmocom.org/c/osmo-bsc/+/31634 ) Change subject: add location_services_fsm_bsc.dot ...................................................................... Patch Set 1: Code-Review+2 -- To view, visit https://gerrit.osmocom.org/c/osmo-bsc/+/31634 To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: osmo-bsc Gerrit-Branch: master Gerrit-Change-Id: I3bdcc90c59459473a5f2e06d9018a2a98147a6b9 Gerrit-Change-Number: 31634 Gerrit-PatchSet: 1 Gerrit-Owner: neels <nhofmeyr(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: laforge <laforge(a)osmocom.org> Gerrit-Reviewer: pespin <pespin(a)sysmocom.de> Gerrit-Attention: neels <nhofmeyr(a)sysmocom.de> Gerrit-Comment-Date: Wed, 22 Mar 2023 09:58:45 +0000 Gerrit-HasComments: No Gerrit-Has-Labels: Yes Gerrit-MessageType: comment
1 0
0 0
[S] Change in osmo-mgw[master]: mgcp_e1: cosmetic: rewrite comment
by laforge 22 Mar '23

22 Mar '23
laforge has submitted this change. ( https://gerrit.osmocom.org/c/osmo-mgw/+/31637 ) Change subject: mgcp_e1: cosmetic: rewrite comment ...................................................................... mgcp_e1: cosmetic: rewrite comment Change-Id: I405cf464c052a2ab1461c3a8ba96665a3bc30341 --- M src/libosmo-mgcp/mgcp_e1.c 1 file changed, 10 insertions(+), 1 deletion(-) Approvals: laforge: Looks good to me, approved Jenkins Builder: Verified diff --git a/src/libosmo-mgcp/mgcp_e1.c b/src/libosmo-mgcp/mgcp_e1.c index 6d1f891..40f976b 100644 --- a/src/libosmo-mgcp/mgcp_e1.c +++ b/src/libosmo-mgcp/mgcp_e1.c @@ -361,7 +361,7 @@ /* Trigger sending of pending E1 traffic */ e1_send_ts_frame(ts, trunk); - /* e1inp_rx_ts() does not free() msgb */ + /* e1inp_rx_ts(), the caller of this callback does not free() msgb. */ msgb_free(msg); } -- To view, visit https://gerrit.osmocom.org/c/osmo-mgw/+/31637 To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: osmo-mgw Gerrit-Branch: master Gerrit-Change-Id: I405cf464c052a2ab1461c3a8ba96665a3bc30341 Gerrit-Change-Number: 31637 Gerrit-PatchSet: 3 Gerrit-Owner: dexter <pmaier(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: laforge <laforge(a)osmocom.org> Gerrit-CC: pespin <pespin(a)sysmocom.de> Gerrit-MessageType: merged
1 0
0 0
[S] Change in osmo-mgw[master]: mgcp_e1: rename e1_send to e1_send_ts_frame
by laforge 22 Mar '23

22 Mar '23
laforge has submitted this change. ( https://gerrit.osmocom.org/c/osmo-mgw/+/31636 ) Change subject: mgcp_e1: rename e1_send to e1_send_ts_frame ...................................................................... mgcp_e1: rename e1_send to e1_send_ts_frame The function name e1_send is very generic, lets make clear that one E1 timeslot frame is sent. Change-Id: I5fba7993860a63149a13d943edbfabc4008680ef --- M src/libosmo-mgcp/mgcp_e1.c 1 file changed, 14 insertions(+), 2 deletions(-) Approvals: laforge: Looks good to me, approved pespin: Looks good to me, but someone else must approve Jenkins Builder: Verified diff --git a/src/libosmo-mgcp/mgcp_e1.c b/src/libosmo-mgcp/mgcp_e1.c index 80a48ab..6d1f891 100644 --- a/src/libosmo-mgcp/mgcp_e1.c +++ b/src/libosmo-mgcp/mgcp_e1.c @@ -310,7 +310,7 @@ } /* handle outgoing E1 traffic */ -static void e1_send(struct e1inp_ts *ts, struct mgcp_trunk *trunk) +static void e1_send_ts_frame(struct e1inp_ts *ts, struct mgcp_trunk *trunk) { struct msgb *msg = msgb_alloc_c(trunk, E1_TS_BYTES, "E1-TX-timeslot-bytes"); uint8_t *ptr; @@ -359,7 +359,7 @@ osmo_i460_demux_in(&trunk->e1.i460_ts[ts->num - 1], msgb_data(msg), msgb_length(msg)); /* Trigger sending of pending E1 traffic */ - e1_send(ts, trunk); + e1_send_ts_frame(ts, trunk); /* e1inp_rx_ts() does not free() msgb */ msgb_free(msg); -- To view, visit https://gerrit.osmocom.org/c/osmo-mgw/+/31636 To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: osmo-mgw Gerrit-Branch: master Gerrit-Change-Id: I5fba7993860a63149a13d943edbfabc4008680ef Gerrit-Change-Number: 31636 Gerrit-PatchSet: 2 Gerrit-Owner: dexter <pmaier(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: laforge <laforge(a)osmocom.org> Gerrit-Reviewer: pespin <pespin(a)sysmocom.de> Gerrit-MessageType: merged
1 0
0 0
[S] Change in osmo-mgw[master]: mgcp_e1: cosmetic: rewrite comment
by laforge 22 Mar '23

22 Mar '23
Attention is currently required from: pespin, dexter. laforge has posted comments on this change. ( https://gerrit.osmocom.org/c/osmo-mgw/+/31637 ) Change subject: mgcp_e1: cosmetic: rewrite comment ...................................................................... Patch Set 2: (1 comment) Commit Message: https://gerrit.osmocom.org/c/osmo-mgw/+/31637/comment/cfef233f_2794c7dd PS1, Line 7: mgcp_e1: cosmetic: reqrite comment > typo Done -- To view, visit https://gerrit.osmocom.org/c/osmo-mgw/+/31637 To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: osmo-mgw Gerrit-Branch: master Gerrit-Change-Id: I405cf464c052a2ab1461c3a8ba96665a3bc30341 Gerrit-Change-Number: 31637 Gerrit-PatchSet: 2 Gerrit-Owner: dexter <pmaier(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: laforge <laforge(a)osmocom.org> Gerrit-CC: pespin <pespin(a)sysmocom.de> Gerrit-Attention: pespin <pespin(a)sysmocom.de> Gerrit-Attention: dexter <pmaier(a)sysmocom.de> Gerrit-Comment-Date: Wed, 22 Mar 2023 09:58:31 +0000 Gerrit-HasComments: Yes Gerrit-Has-Labels: No Comment-In-Reply-To: pespin <pespin(a)sysmocom.de> Gerrit-MessageType: comment
1 0
0 0
[S] Change in osmo-mgw[master]: mgcp_e1: cosmetic: rewrite comment
by laforge 22 Mar '23

22 Mar '23
Attention is currently required from: dexter. laforge has posted comments on this change. ( https://gerrit.osmocom.org/c/osmo-mgw/+/31637 ) Change subject: mgcp_e1: cosmetic: rewrite comment ...................................................................... Patch Set 2: Code-Review+2 -- To view, visit https://gerrit.osmocom.org/c/osmo-mgw/+/31637 To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: osmo-mgw Gerrit-Branch: master Gerrit-Change-Id: I405cf464c052a2ab1461c3a8ba96665a3bc30341 Gerrit-Change-Number: 31637 Gerrit-PatchSet: 2 Gerrit-Owner: dexter <pmaier(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: laforge <laforge(a)osmocom.org> Gerrit-CC: pespin <pespin(a)sysmocom.de> Gerrit-Attention: dexter <pmaier(a)sysmocom.de> Gerrit-Comment-Date: Wed, 22 Mar 2023 09:58:21 +0000 Gerrit-HasComments: No Gerrit-Has-Labels: Yes Gerrit-MessageType: comment
1 0
0 0
[S] Change in osmo-mgw[master]: mgcp_e1: rename e1_send to e1_send_ts_frame
by laforge 22 Mar '23

22 Mar '23
Attention is currently required from: dexter. laforge has posted comments on this change. ( https://gerrit.osmocom.org/c/osmo-mgw/+/31636 ) Change subject: mgcp_e1: rename e1_send to e1_send_ts_frame ...................................................................... Patch Set 1: Code-Review+2 -- To view, visit https://gerrit.osmocom.org/c/osmo-mgw/+/31636 To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: osmo-mgw Gerrit-Branch: master Gerrit-Change-Id: I5fba7993860a63149a13d943edbfabc4008680ef Gerrit-Change-Number: 31636 Gerrit-PatchSet: 1 Gerrit-Owner: dexter <pmaier(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: laforge <laforge(a)osmocom.org> Gerrit-Reviewer: pespin <pespin(a)sysmocom.de> Gerrit-Attention: dexter <pmaier(a)sysmocom.de> Gerrit-Comment-Date: Wed, 22 Mar 2023 09:58:00 +0000 Gerrit-HasComments: No Gerrit-Has-Labels: Yes Gerrit-MessageType: comment
1 0
0 0
[S] Change in pysim[master]: pySim-shell.py: add a command for RUN GSM ALGORITHM
by laforge 22 Mar '23

22 Mar '23
laforge has submitted this change. ( https://gerrit.osmocom.org/c/pysim/+/31815 ) Change subject: pySim-shell.py: add a command for RUN GSM ALGORITHM ...................................................................... pySim-shell.py: add a command for RUN GSM ALGORITHM Change-Id: Id7876d83d018aca79253784411d3a9d54a249a0a --- M pySim/ts_51_011.py 1 file changed, 25 insertions(+), 0 deletions(-) Approvals: laforge: Looks good to me, approved fixeria: Looks good to me, but someone else must approve Jenkins Builder: Verified diff --git a/pySim/ts_51_011.py b/pySim/ts_51_011.py index 96de241..b9e19b2 100644 --- a/pySim/ts_51_011.py +++ b/pySim/ts_51_011.py @@ -1102,6 +1102,8 @@ class DF_GSM(CardDF): def __init__(self, fid='7f20', name='DF.GSM', desc='GSM Network related files'): super().__init__(fid=fid, name=name, desc=desc) + self.shell_commands += [self.AddlShellCommands()] + files = [ EF_LP(), EF_IMSI(), @@ -1171,6 +1173,20 @@ ] self.add_files(files) + @with_default_category('Application-Specific Commands') + class AddlShellCommands(CommandSet): + def __init__(self): + super().__init__() + + authenticate_parser = argparse.ArgumentParser() + authenticate_parser.add_argument('rand', help='Random challenge') + + @cmd2.with_argparser(authenticate_parser) + def do_authenticate(self, opts): + """Perform GSM Authentication.""" + (data, sw) = self._cmd.card._scc.run_gsm(opts.rand) + self._cmd.poutput_json(data) + class CardProfileSIM(CardProfile): -- To view, visit https://gerrit.osmocom.org/c/pysim/+/31815 To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: pysim Gerrit-Branch: master Gerrit-Change-Id: Id7876d83d018aca79253784411d3a9d54a249a0a Gerrit-Change-Number: 31815 Gerrit-PatchSet: 2 Gerrit-Owner: laforge <laforge(a)osmocom.org> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Reviewer: laforge <laforge(a)osmocom.org> Gerrit-MessageType: merged
1 0
0 0
  • ← Newer
  • 1
  • ...
  • 98
  • 99
  • 100
  • 101
  • 102
  • 103
  • 104
  • ...
  • 365
  • Older →

HyperKitty Powered by HyperKitty version 1.3.12.