Attention is currently required from: neels.
pespin has posted comments on this change. ( https://gerrit.osmocom.org/c/osmo-mgw/+/37282?usp=email )
Change subject: do not FAIL on CRCX in sendrecv mode
......................................................................
Patch Set 1: Code-Review+2
--
To view, visit https://gerrit.osmocom.org/c/osmo-mgw/+/37282?usp=email
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings
Gerrit-Project: osmo-mgw
Gerrit-Branch: master
Gerrit-Change-Id: Ic089485543c5c97a35c7ae24fe0f622bf57d1976
Gerrit-Change-Number: 37282
Gerrit-PatchSet: 1
Gerrit-Owner: neels <nhofmeyr(a)sysmocom.de>
Gerrit-Reviewer: Jenkins Builder
Gerrit-Reviewer: fixeria <vyanitskiy(a)sysmocom.de>
Gerrit-Reviewer: pespin <pespin(a)sysmocom.de>
Gerrit-Attention: neels <nhofmeyr(a)sysmocom.de>
Gerrit-Comment-Date: Tue, 25 Jun 2024 10:08:22 +0000
Gerrit-HasComments: No
Gerrit-Has-Labels: Yes
Gerrit-MessageType: comment
Attention is currently required from: falconia.
fixeria has posted comments on this change. ( https://gerrit.osmocom.org/c/libosmo-abis/+/37287?usp=email )
Change subject: trau_rtp_conv: add support for HRv1 in 8k format
......................................................................
Patch Set 2: Code-Review+1
(2 comments)
File src/trau/trau_rtp_conv.c:
https://gerrit.osmocom.org/c/libosmo-abis/+/37287/comment/fb5f8523_89cca9f6
PS2, Line 258: if (xc_bits[i])
: sum++;
Can we do `sum += xc_bits[i]` here? Theoretically, this should be better in terms of performance. But we need to be sure that `xc_bits[i]` is either 0 or 1, otherwise the logic is wrong. Alternatively: `sum += (xc_bits[i] > 0)`.
https://gerrit.osmocom.org/c/libosmo-abis/+/37287/comment/bf268b54_74af4765
PS2, Line 669: tf->xc_bits[0] = 0;
cosmetic: maybe use designated initializers to make it shorter / more readable?
```
if (osmo_hr_check_sid(data, data_len))
tf->xc_bits = { [3] = 1 };
else
tf->xc_bits = { [5] = 1 };
```
Not critical, you can keep it as-is.
--
To view, visit https://gerrit.osmocom.org/c/libosmo-abis/+/37287?usp=email
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings
Gerrit-Project: libosmo-abis
Gerrit-Branch: master
Gerrit-Change-Id: I8ee01b73360501ca380a8695cbc7070ceaaba1be
Gerrit-Change-Number: 37287
Gerrit-PatchSet: 2
Gerrit-Owner: falconia <falcon(a)freecalypso.org>
Gerrit-Reviewer: Jenkins Builder
Gerrit-Reviewer: fixeria <vyanitskiy(a)sysmocom.de>
Gerrit-Reviewer: pespin <pespin(a)sysmocom.de>
Gerrit-Attention: falconia <falcon(a)freecalypso.org>
Gerrit-Comment-Date: Tue, 25 Jun 2024 10:06:18 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: Yes
Gerrit-MessageType: comment
Attention is currently required from: falconia, laforge.
fixeria has posted comments on this change. ( https://gerrit.osmocom.org/c/libosmo-abis/+/37285?usp=email )
Change subject: {de,en}code8_hr: fix totally broken functions
......................................................................
Patch Set 1: Code-Review+1
(1 comment)
Patchset:
PS1:
Looks good to me, but the final word needs to be said by @laforge@osmocom.org here.
--
To view, visit https://gerrit.osmocom.org/c/libosmo-abis/+/37285?usp=email
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings
Gerrit-Project: libosmo-abis
Gerrit-Branch: master
Gerrit-Change-Id: I7cf0275f2ff212e001db38d7b090f222f292cdb0
Gerrit-Change-Number: 37285
Gerrit-PatchSet: 1
Gerrit-Owner: falconia <falcon(a)freecalypso.org>
Gerrit-Reviewer: Jenkins Builder
Gerrit-Reviewer: fixeria <vyanitskiy(a)sysmocom.de>
Gerrit-Reviewer: laforge <laforge(a)osmocom.org>
Gerrit-Reviewer: pespin <pespin(a)sysmocom.de>
Gerrit-Attention: falconia <falcon(a)freecalypso.org>
Gerrit-Attention: laforge <laforge(a)osmocom.org>
Gerrit-Comment-Date: Tue, 25 Jun 2024 09:49:51 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: Yes
Gerrit-MessageType: comment