pespin has uploaded this change for review. ( https://gerrit.osmocom.org/c/docker-playground/+/37293?usp=email )
Change subject: asterisk-master: Build from jolly/work branch by default
......................................................................
asterisk-master: Build from jolly/work branch by default
That one will not be the final branch, but it's the one where most of
the development is happening. Hence, switch to that branch by default
for now, so that jenkins nightly job runs that branch.
Change-Id: Iabf141ae0b997f9707a7dbd555307e052b92d355
---
M make/Makefile
1 file changed, 15 insertions(+), 2 deletions(-)
git pull ssh://gerrit.osmocom.org:29418/docker-playground refs/changes/93/37293/1
diff --git a/make/Makefile b/make/Makefile
index 24308e5..4ee4525 100644
--- a/make/Makefile
+++ b/make/Makefile
@@ -17,7 +17,7 @@
USERNAME?=$(USER)
UID=$(shell id -u)
NAME?=$(shell basename $(CURDIR))
-ASTERISK_BRANCH?=sysmocom/master
+ASTERISK_BRANCH?=jolly/work
LIBOSMOCORE_BRANCH?=master
OSMO_TTCN3_BRANCH?=master
OSMO_BB_BRANCH?=master
@@ -42,7 +42,7 @@
OSMO_STP_BRANCH?=master
OSMO_UECUPS_BRANCH?=master
OPEN5GS_BRANCH?=main
-PJPROJECT_BRANCH?=sysmocom/2.14
+PJPROJECT_BRANCH?=jolly/work
BUILD_ARGS?=
RUN_ARGS?=-it
UPSTREAM_DISTRO?=debian:bookworm
--
To view, visit https://gerrit.osmocom.org/c/docker-playground/+/37293?usp=email
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings
Gerrit-Project: docker-playground
Gerrit-Branch: master
Gerrit-Change-Id: Iabf141ae0b997f9707a7dbd555307e052b92d355
Gerrit-Change-Number: 37293
Gerrit-PatchSet: 1
Gerrit-Owner: pespin <pespin(a)sysmocom.de>
Gerrit-MessageType: newchange
pespin has uploaded this change for review. ( https://gerrit.osmocom.org/c/docker-playground/+/37292?usp=email )
Change subject: asterisk-master: Fetch required branch directly
......................................................................
asterisk-master: Fetch required branch directly
When I added the Dockerfile I initially wrote it in a 2 step fetch &
build, to try to avoid recompiling the whole thing every time some patch
from one of the devs was pushed to our building branch.
This, whoever, creates problems sometimes due to how the build system
for pjproject is generated when building asterisk, so let's drop the
2stage setup to avoid problems fetching from different branches, etc.
Change-Id: Id9fbee9cdb8f9387e0daefd7925df2542d384a91
---
M asterisk-master/Dockerfile
1 file changed, 20 insertions(+), 12 deletions(-)
git pull ssh://gerrit.osmocom.org:29418/docker-playground refs/changes/92/37292/1
diff --git a/asterisk-master/Dockerfile b/asterisk-master/Dockerfile
index 8e508e4..8ddbaa0 100644
--- a/asterisk-master/Dockerfile
+++ b/asterisk-master/Dockerfile
@@ -60,10 +60,13 @@
# clone asterisk
ARG ASTERISK_REMOTE=https://gitea.sysmocom.de/sysmocom/asterisk.git
+ARG ASTERISK_BRANCH=sysmocom/master
RUN git clone $ASTERISK_REMOTE
+ADD https://gitea.sysmocom.de/api/v1/repos/sysmocom/asterisk/git/refs/heads/$AS… /tmp/asterisk-ver
+
RUN cd asterisk && \
- git fetch && git checkout -f -B sysmocom/master origin/sysmocom/master
+ git fetch && git checkout -f -B $ASTERISK_BRANCH origin/$ASTERISK_BRANCH
# Use pjproject from git repo above instead of downloading tar.gz:
RUN cd asterisk/third-party/pjproject && \
@@ -72,17 +75,6 @@
RUN cd asterisk && \
./bootstrap.sh && \
./configure && \
- make "-j$(nproc)"
-
-ARG ASTERISK_BRANCH=sysmocom/master
-
-ADD https://gitea.sysmocom.de/api/v1/repos/sysmocom/asterisk/git/refs/heads/$AS… /tmp/asterisk-ver
-
-# update the source code (if needed)
-RUN cd asterisk && \
- git fetch && git checkout -B $ASTERISK_BRANCH origin/$ASTERISK_BRANCH
-
-RUN cd asterisk && \
make "-j$(nproc)" && \
make install && \
make samples && \
--
To view, visit https://gerrit.osmocom.org/c/docker-playground/+/37292?usp=email
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings
Gerrit-Project: docker-playground
Gerrit-Branch: master
Gerrit-Change-Id: Id9fbee9cdb8f9387e0daefd7925df2542d384a91
Gerrit-Change-Number: 37292
Gerrit-PatchSet: 1
Gerrit-Owner: pespin <pespin(a)sysmocom.de>
Gerrit-MessageType: newchange
Attention is currently required from: falconia, pespin.
fixeria has posted comments on this change. ( https://gerrit.osmocom.org/c/libosmo-abis/+/37287?usp=email )
Change subject: trau_rtp_conv: add support for HRv1 in 8k format
......................................................................
Patch Set 3: Code-Review+2
(1 comment)
File src/trau/trau_rtp_conv.c:
https://gerrit.osmocom.org/c/libosmo-abis/+/37287/comment/aa433bea_9db21fa0
PS2, Line 258: if (xc_bits[i])
: sum++;
> Given that the input bits come from other Osmocom library layers (osmo_i460 demux followed by trau_s […]
Done
--
To view, visit https://gerrit.osmocom.org/c/libosmo-abis/+/37287?usp=email
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings
Gerrit-Project: libosmo-abis
Gerrit-Branch: master
Gerrit-Change-Id: I8ee01b73360501ca380a8695cbc7070ceaaba1be
Gerrit-Change-Number: 37287
Gerrit-PatchSet: 3
Gerrit-Owner: falconia <falcon(a)freecalypso.org>
Gerrit-Reviewer: Jenkins Builder
Gerrit-Reviewer: fixeria <vyanitskiy(a)sysmocom.de>
Gerrit-Reviewer: pespin <pespin(a)sysmocom.de>
Gerrit-Attention: falconia <falcon(a)freecalypso.org>
Gerrit-Attention: pespin <pespin(a)sysmocom.de>
Gerrit-Comment-Date: Tue, 25 Jun 2024 18:41:56 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: Yes
Comment-In-Reply-To: falconia <falcon(a)freecalypso.org>
Comment-In-Reply-To: fixeria <vyanitskiy(a)sysmocom.de>
Gerrit-MessageType: comment
Attention is currently required from: falconia, pespin.
falconia has posted comments on this change. ( https://gerrit.osmocom.org/c/libosmo-abis/+/37287?usp=email )
Change subject: trau_rtp_conv: add support for HRv1 in 8k format
......................................................................
Patch Set 3:
(1 comment)
File src/trau/trau_rtp_conv.c:
https://gerrit.osmocom.org/c/libosmo-abis/+/37287/comment/ccf532f4_a121c090
PS2, Line 258: if (xc_bits[i])
: sum++;
> Given that the input bits come from other Osmocom library layers (osmo_i460 demux followed by trau_s […]
Done
--
To view, visit https://gerrit.osmocom.org/c/libosmo-abis/+/37287?usp=email
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings
Gerrit-Project: libosmo-abis
Gerrit-Branch: master
Gerrit-Change-Id: I8ee01b73360501ca380a8695cbc7070ceaaba1be
Gerrit-Change-Number: 37287
Gerrit-PatchSet: 3
Gerrit-Owner: falconia <falcon(a)freecalypso.org>
Gerrit-Reviewer: Jenkins Builder
Gerrit-Reviewer: fixeria <vyanitskiy(a)sysmocom.de>
Gerrit-Reviewer: pespin <pespin(a)sysmocom.de>
Gerrit-Attention: falconia <falcon(a)freecalypso.org>
Gerrit-Attention: pespin <pespin(a)sysmocom.de>
Gerrit-Comment-Date: Tue, 25 Jun 2024 18:41:44 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Comment-In-Reply-To: falconia <falcon(a)freecalypso.org>
Comment-In-Reply-To: fixeria <vyanitskiy(a)sysmocom.de>
Gerrit-MessageType: comment
Attention is currently required from: falconia, pespin.
fixeria has posted comments on this change. ( https://gerrit.osmocom.org/c/libosmo-abis/+/37287?usp=email )
Change subject: trau_rtp_conv: add support for HRv1 in 8k format
......................................................................
Patch Set 2: Code-Review+1
(1 comment)
File src/trau/trau_rtp_conv.c:
https://gerrit.osmocom.org/c/libosmo-abis/+/37287/comment/20a3b2d6_b5d058c5
PS2, Line 669: tf->xc_bits[0] = 0;
> I tried doing this: […]
Oh, then my approach would not work either. AFAIU, array assignment is only possible during the definition, but not after that. I did an experiment, and even with `-std=c89` both gcc and clang refuse to compile the following code:
```
int main(void)
{
char data[6];
data = { 0, 0, 0, 1, 0, 0 };
data = { [3] = 1 };
return 0;
}
```
So yeah, let's keep this as-is then.
--
To view, visit https://gerrit.osmocom.org/c/libosmo-abis/+/37287?usp=email
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings
Gerrit-Project: libosmo-abis
Gerrit-Branch: master
Gerrit-Change-Id: I8ee01b73360501ca380a8695cbc7070ceaaba1be
Gerrit-Change-Number: 37287
Gerrit-PatchSet: 2
Gerrit-Owner: falconia <falcon(a)freecalypso.org>
Gerrit-Reviewer: Jenkins Builder
Gerrit-Reviewer: fixeria <vyanitskiy(a)sysmocom.de>
Gerrit-Reviewer: pespin <pespin(a)sysmocom.de>
Gerrit-Attention: falconia <falcon(a)freecalypso.org>
Gerrit-Attention: pespin <pespin(a)sysmocom.de>
Gerrit-Comment-Date: Tue, 25 Jun 2024 18:41:31 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: Yes
Comment-In-Reply-To: falconia <falcon(a)freecalypso.org>
Comment-In-Reply-To: fixeria <vyanitskiy(a)sysmocom.de>
Gerrit-MessageType: comment
Attention is currently required from: fixeria, pespin.
Hello Jenkins Builder, fixeria, pespin,
I'd like you to reexamine a change. Please visit
https://gerrit.osmocom.org/c/libosmo-abis/+/37287?usp=email
to look at the new patch set (#3).
The following approvals got outdated and were removed:
Code-Review+1 by fixeria, Code-Review+1 by pespin, Verified+1 by Jenkins Builder
Change subject: trau_rtp_conv: add support for HRv1 in 8k format
......................................................................
trau_rtp_conv: add support for HRv1 in 8k format
GSM 08.61 defines two alternative Abis transport formats for
HRv1 codec, using either 16 kbit/s or 8 kbit/s submultiplexing,
as chosen by each BSS hardware manufacturer. libosmotrau previously
supported TRAU<->RTP conversion only for 16k format - add support
for HRv1 in 8k submux format.
Change-Id: I8ee01b73360501ca380a8695cbc7070ceaaba1be
---
M src/trau/trau_rtp_conv.c
1 file changed, 186 insertions(+), 0 deletions(-)
git pull ssh://gerrit.osmocom.org:29418/libosmo-abis refs/changes/87/37287/3
--
To view, visit https://gerrit.osmocom.org/c/libosmo-abis/+/37287?usp=email
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings
Gerrit-Project: libosmo-abis
Gerrit-Branch: master
Gerrit-Change-Id: I8ee01b73360501ca380a8695cbc7070ceaaba1be
Gerrit-Change-Number: 37287
Gerrit-PatchSet: 3
Gerrit-Owner: falconia <falcon(a)freecalypso.org>
Gerrit-Reviewer: Jenkins Builder
Gerrit-Reviewer: fixeria <vyanitskiy(a)sysmocom.de>
Gerrit-Reviewer: pespin <pespin(a)sysmocom.de>
Gerrit-Attention: pespin <pespin(a)sysmocom.de>
Gerrit-Attention: fixeria <vyanitskiy(a)sysmocom.de>
Gerrit-MessageType: newpatchset
Attention is currently required from: fixeria.
falconia has posted comments on this change. ( https://gerrit.osmocom.org/c/libosmo-abis/+/37287?usp=email )
Change subject: trau_rtp_conv: add support for HRv1 in 8k format
......................................................................
Patch Set 2:
(1 comment)
File src/trau/trau_rtp_conv.c:
https://gerrit.osmocom.org/c/libosmo-abis/+/37287/comment/bc035ff5_01447673
PS2, Line 669: tf->xc_bits[0] = 0;
> Shorter != more readable in this case, I would argue. […]
I tried doing this:
```
if (osmo_hr_check_sid(data, data_len))
tf->xc_bits = {0, 0, 0, 1, 0, 0};
else
tf->xc_bits = {0, 0, 0, 0, 0, 1};
```
but the compiler is barfing at me:
```
trau/trau_rtp_conv.c:669:17: error: expected expression before '{' token
tf->xc_bits = {0, 0, 0, 1, 0, 0};
```
I am afraid this old hag of K&R C and Ancient UNIX upbringing is not up to speed with modern C tricks. I'll put my original code back in for the next patch iteration, and leave it there until/unless someone shows me a way to do what I was trying above.
--
To view, visit https://gerrit.osmocom.org/c/libosmo-abis/+/37287?usp=email
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings
Gerrit-Project: libosmo-abis
Gerrit-Branch: master
Gerrit-Change-Id: I8ee01b73360501ca380a8695cbc7070ceaaba1be
Gerrit-Change-Number: 37287
Gerrit-PatchSet: 2
Gerrit-Owner: falconia <falcon(a)freecalypso.org>
Gerrit-Reviewer: Jenkins Builder
Gerrit-Reviewer: fixeria <vyanitskiy(a)sysmocom.de>
Gerrit-Reviewer: pespin <pespin(a)sysmocom.de>
Gerrit-Attention: fixeria <vyanitskiy(a)sysmocom.de>
Gerrit-Comment-Date: Tue, 25 Jun 2024 18:22:18 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Comment-In-Reply-To: falconia <falcon(a)freecalypso.org>
Comment-In-Reply-To: fixeria <vyanitskiy(a)sysmocom.de>
Gerrit-MessageType: comment
Attention is currently required from: fixeria.
falconia has posted comments on this change. ( https://gerrit.osmocom.org/c/libosmo-abis/+/37287?usp=email )
Change subject: trau_rtp_conv: add support for HRv1 in 8k format
......................................................................
Patch Set 2:
(2 comments)
File src/trau/trau_rtp_conv.c:
https://gerrit.osmocom.org/c/libosmo-abis/+/37287/comment/0892ab9b_6b4aea97
PS2, Line 258: if (xc_bits[i])
: sum++;
> Can we do `sum += xc_bits[i]` here? Theoretically, this should be better in terms of performance. […]
Given that the input bits come from other Osmocom library layers (osmo_i460 demux followed by trau_sync module), I would say that requiring each ubit_t to be strictly either 0 or 1 (for performance benefit) is fine. I'll change the code to do direct summation like you suggested.
https://gerrit.osmocom.org/c/libosmo-abis/+/37287/comment/9ae58d6e_fe0a6172
PS2, Line 669: tf->xc_bits[0] = 0;
> cosmetic: maybe use designated initializers to make it shorter / more readable? […]
Shorter != more readable in this case, I would argue. The way I have each bit explicitly broken out, with a comment on xc_bits[5] saying that it is odd parity, makes it much easier IMO to visually verify correctness against the official word of the spec.
However, I just thought of another way to make the code shorter, yet retain direct correspondence (perhaps even more direct) to how the table appears in the TS 48.061 spec - see the next patchset iteration.
--
To view, visit https://gerrit.osmocom.org/c/libosmo-abis/+/37287?usp=email
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings
Gerrit-Project: libosmo-abis
Gerrit-Branch: master
Gerrit-Change-Id: I8ee01b73360501ca380a8695cbc7070ceaaba1be
Gerrit-Change-Number: 37287
Gerrit-PatchSet: 2
Gerrit-Owner: falconia <falcon(a)freecalypso.org>
Gerrit-Reviewer: Jenkins Builder
Gerrit-Reviewer: fixeria <vyanitskiy(a)sysmocom.de>
Gerrit-Reviewer: pespin <pespin(a)sysmocom.de>
Gerrit-Attention: fixeria <vyanitskiy(a)sysmocom.de>
Gerrit-Comment-Date: Tue, 25 Jun 2024 17:57:49 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Comment-In-Reply-To: fixeria <vyanitskiy(a)sysmocom.de>
Gerrit-MessageType: comment