pespin has posted comments on this change by neels. ( https://gerrit.osmocom.org/c/osmo-hnbgw/+/37996?usp=email )
Change subject: coverity CID#358071
......................................................................
Patch Set 1:
(1 comment)
File src/osmo-hnbgw/hnbgw_hnbap.c:
https://gerrit.osmocom.org/c/osmo-hnbgw/+/37996/comment/37f98701_170db85e?u… :
PS1, Line 657: cause.present = HNBAP_Cause_PR_protocol;
> The effect of our two variants is identical, it's a bikeshed.
No, it's not. In one you are writing all memory of the struct first and then again overwriting some fields, while in the other you do less writing. Please stop naming everything as bikeshed as a means to discard others comments systematically.
--
To view, visit https://gerrit.osmocom.org/c/osmo-hnbgw/+/37996?usp=email
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings?usp=email
Gerrit-MessageType: comment
Gerrit-Project: osmo-hnbgw
Gerrit-Branch: master
Gerrit-Change-Id: I8237bf7d4985e993bb10aaaa9370cde2ece3d812
Gerrit-Change-Number: 37996
Gerrit-PatchSet: 1
Gerrit-Owner: neels <nhofmeyr(a)sysmocom.de>
Gerrit-Reviewer: Jenkins Builder
Gerrit-Reviewer: fixeria <vyanitskiy(a)sysmocom.de>
Gerrit-Reviewer: laforge <laforge(a)osmocom.org>
Gerrit-Reviewer: neels <nhofmeyr(a)sysmocom.de>
Gerrit-Reviewer: pespin <pespin(a)sysmocom.de>
Gerrit-Comment-Date: Wed, 04 Sep 2024 11:35:00 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Comment-In-Reply-To: neels <nhofmeyr(a)sysmocom.de>
Comment-In-Reply-To: pespin <pespin(a)sysmocom.de>
Attention is currently required from: neels.
pespin has posted comments on this change by neels. ( https://gerrit.osmocom.org/c/osmo-ttcn3-hacks/+/37882?usp=email )
Change subject: ctrl, hnbgw: access rate counter groups by given ID instead of index
......................................................................
Patch Set 4: Code-Review+1
--
To view, visit https://gerrit.osmocom.org/c/osmo-ttcn3-hacks/+/37882?usp=email
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings?usp=email
Gerrit-MessageType: comment
Gerrit-Project: osmo-ttcn3-hacks
Gerrit-Branch: master
Gerrit-Change-Id: I70e74e7554482df67aa1d90bc04314124dea444f
Gerrit-Change-Number: 37882
Gerrit-PatchSet: 4
Gerrit-Owner: neels <nhofmeyr(a)sysmocom.de>
Gerrit-Reviewer: Jenkins Builder
Gerrit-Reviewer: laforge <laforge(a)osmocom.org>
Gerrit-Reviewer: pespin <pespin(a)sysmocom.de>
Gerrit-Attention: neels <nhofmeyr(a)sysmocom.de>
Gerrit-Comment-Date: Wed, 04 Sep 2024 11:29:56 +0000
Gerrit-HasComments: No
Gerrit-Has-Labels: Yes
Attention is currently required from: laforge, neels.
pespin has posted comments on this change by neels. ( https://gerrit.osmocom.org/c/libosmocore/+/37881?usp=email )
Change subject: rate_ctr,CTRL[1/2]: GET using rate_ctr_group_set_name()
......................................................................
Patch Set 5:
(1 comment)
Patchset:
PS5:
Please fix whatever and let us review this one before +2.
--
To view, visit https://gerrit.osmocom.org/c/libosmocore/+/37881?usp=email
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings?usp=email
Gerrit-MessageType: comment
Gerrit-Project: libosmocore
Gerrit-Branch: master
Gerrit-Change-Id: I841a12f76e6fcb2bd7aecb5f4b1707d9ec927137
Gerrit-Change-Number: 37881
Gerrit-PatchSet: 5
Gerrit-Owner: neels <nhofmeyr(a)sysmocom.de>
Gerrit-Reviewer: Jenkins Builder
Gerrit-Reviewer: neels <nhofmeyr(a)sysmocom.de>
Gerrit-Reviewer: pespin <pespin(a)sysmocom.de>
Gerrit-CC: laforge <laforge(a)osmocom.org>
Gerrit-Attention: neels <nhofmeyr(a)sysmocom.de>
Gerrit-Attention: laforge <laforge(a)osmocom.org>
Gerrit-Comment-Date: Wed, 04 Sep 2024 11:23:31 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
laforge has submitted this change. ( https://gerrit.osmocom.org/c/pysim/+/38022?usp=email )
Change subject: suci-tutorial: fix typo s/symo/sysmo/
......................................................................
suci-tutorial: fix typo s/symo/sysmo/
Change-Id: I0d3bdcf590e8dfef6deabc9967fd2f04152e1020
---
M docs/suci-tutorial.rst
1 file changed, 1 insertion(+), 1 deletion(-)
Approvals:
Jenkins Builder: Verified
fixeria: Looks good to me, but someone else must approve
laforge: Looks good to me, approved
diff --git a/docs/suci-tutorial.rst b/docs/suci-tutorial.rst
index f1aef5b..cdf44c9 100644
--- a/docs/suci-tutorial.rst
+++ b/docs/suci-tutorial.rst
@@ -30,7 +30,7 @@
For specific information on sysmocom SIM cards, refer to
-* the `symoISIM-SJA5 User Manual <https://sysmocom.de/manuals/sysmoisim-sja5-manual.pdf>`__ for the curent
+* the `sysmoISIM-SJA5 User Manual <https://sysmocom.de/manuals/sysmoisim-sja5-manual.pdf>`__ for the curent
sysmoISIM-SJA5 product
* the `sysmoISIM-SJA2 User Manual <https://sysmocom.de/manuals/sysmousim-manual.pdf>`__ for the older
sysmoISIM-SJA2 product
--
To view, visit https://gerrit.osmocom.org/c/pysim/+/38022?usp=email
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings?usp=email
Gerrit-MessageType: merged
Gerrit-Project: pysim
Gerrit-Branch: master
Gerrit-Change-Id: I0d3bdcf590e8dfef6deabc9967fd2f04152e1020
Gerrit-Change-Number: 38022
Gerrit-PatchSet: 1
Gerrit-Owner: laforge <laforge(a)osmocom.org>
Gerrit-Reviewer: Jenkins Builder
Gerrit-Reviewer: fixeria <vyanitskiy(a)sysmocom.de>
Gerrit-Reviewer: laforge <laforge(a)osmocom.org>
Attention is currently required from: fixeria.
Hello fixeria,
I'd like you to reexamine a change. Please visit
https://gerrit.osmocom.org/c/python/pyosmocom/+/38023?usp=email
to look at the new patch set (#2).
Change subject: Introduce a new 'hexstr' type to represent hex-strings
......................................................................
Introduce a new 'hexstr' type to represent hex-strings
hexstr differs from str in that comparisons are case-insensitive, and it
offers encoding-free conversion from hexstr to bytes and vice-versa.
Change-Id: I16c0df809bc11ec0f98e8ade404f9b82072e3a06
---
M src/osmocom/utils.py
A tests/test_utils.py
2 files changed, 88 insertions(+), 0 deletions(-)
git pull ssh://gerrit.osmocom.org:29418/python/pyosmocom refs/changes/23/38023/2
--
To view, visit https://gerrit.osmocom.org/c/python/pyosmocom/+/38023?usp=email
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings?usp=email
Gerrit-MessageType: newpatchset
Gerrit-Project: python/pyosmocom
Gerrit-Branch: master
Gerrit-Change-Id: I16c0df809bc11ec0f98e8ade404f9b82072e3a06
Gerrit-Change-Number: 38023
Gerrit-PatchSet: 2
Gerrit-Owner: laforge <laforge(a)osmocom.org>
Gerrit-Reviewer: fixeria <vyanitskiy(a)sysmocom.de>
Gerrit-CC: Jenkins Builder
Gerrit-Attention: fixeria <vyanitskiy(a)sysmocom.de>
Attention is currently required from: dexter, fixeria.
laforge has posted comments on this change by dexter. ( https://gerrit.osmocom.org/c/pysim/+/38001?usp=email )
Change subject: pySim-shell: print cardinfo hexstrings in lowercase
......................................................................
Patch Set 3:
(1 comment)
Patchset:
PS2:
> I also don't like having to use `.lower()` everywhere and would proceed as suggested above. […]
trying to address this in https://gerrit.osmocom.org/c/python/pyosmocom/+/38023
--
To view, visit https://gerrit.osmocom.org/c/pysim/+/38001?usp=email
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings?usp=email
Gerrit-MessageType: comment
Gerrit-Project: pysim
Gerrit-Branch: master
Gerrit-Change-Id: Ia6a8bd0e700c7fd933fb6c1b1050ed9494462d60
Gerrit-Change-Number: 38001
Gerrit-PatchSet: 3
Gerrit-Owner: dexter <pmaier(a)sysmocom.de>
Gerrit-Reviewer: Jenkins Builder
Gerrit-CC: fixeria <vyanitskiy(a)sysmocom.de>
Gerrit-CC: laforge <laforge(a)osmocom.org>
Gerrit-Attention: fixeria <vyanitskiy(a)sysmocom.de>
Gerrit-Attention: dexter <pmaier(a)sysmocom.de>
Gerrit-Comment-Date: Wed, 04 Sep 2024 10:08:15 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Comment-In-Reply-To: laforge <laforge(a)osmocom.org>
Comment-In-Reply-To: fixeria <vyanitskiy(a)sysmocom.de>
laforge has uploaded this change for review. ( https://gerrit.osmocom.org/c/python/pyosmocom/+/38023?usp=email )
Change subject: Introduce a new 'hexstr' type to represent hex-strings
......................................................................
Introduce a new 'hexstr' type to represent hex-strings
hexstr differs from str in that comparisons are case-insensitive, and it offers encoding-free
conversion from hexstr to bytes and vice-versa.
Change-Id: I16c0df809bc11ec0f98e8ade404f9b82072e3a06
---
M src/osmocom/utils.py
A tests/test_utils.py
2 files changed, 88 insertions(+), 0 deletions(-)
git pull ssh://gerrit.osmocom.org:29418/python/pyosmocom refs/changes/23/38023/1
diff --git a/src/osmocom/utils.py b/src/osmocom/utils.py
index cbcdd46..96476f1 100644
--- a/src/osmocom/utils.py
+++ b/src/osmocom/utils.py
@@ -138,6 +138,36 @@
except:
return False
+class hexstr(str):
+ """Class derived from 'str', represeting a string of hexadecimal digits. It differs in that
+ comparisons are case-insensitive, and it offers encoding-free conversion from hexstr to bytes
+ and vice-versa."""
+ def __new__(cls, s: str):
+ if not all(c in string.hexdigits for c in s):
+ raise ValueError('Input must be hexadecimal digits only')
+ # store as lower case digits
+ return super().__new__(cls, s.lower())
+
+ def __eq__(self, other):
+ # make sure comparison is done case-insensitive
+ return str(self) == other.lower()
+
+ def __getitem__(self, val):
+ # make sure slicing a hexstr will return a hexstr
+ return hexstr(super().__getitem__(val))
+
+ def to_bytes(self):
+ """return hex-string converted to bytes"""
+ s = str(self)
+ if len(s) & 1:
+ raise ValueError('Cannot convert hex string with odd number of digits')
+ return h2b(s)
+
+ @classmethod
+ def from_bytes(cls, bt: bytes) -> 'hexstr':
+ """instantiate hex-string from bytes"""
+ return cls(b2h(bt))
+
#########################################################################
# ARGPARSE HELPERS
#########################################################################
diff --git a/tests/test_utils.py b/tests/test_utils.py
new file mode 100755
index 0000000..8e4732f
--- /dev/null
+++ b/tests/test_utils.py
@@ -0,0 +1,58 @@
+#!/usr/bin/env python3
+
+# (C) 2022 by Harald Welte <laforge(a)osmocom.org>
+# All Rights Reserved
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+
+import unittest
+
+from osmocom.utils import *
+
+class TestHexstr(unittest.TestCase):
+ def test_cmp(self):
+ s = hexstr('aBcD')
+ self.assertEqual(s, 'abcd')
+ self.assertEqual(s, 'ABCD')
+ self.assertEqual(s, 'AbCd')
+ self.assertEqual(s, hexstr('AbCd'))
+
+ def test_tobytes(self):
+ s = hexstr('aBcDeF')
+ self.assertEqual(s.to_bytes(), b'\xab\xcd\xef')
+
+ def test_tobytes_odd(self):
+ s2 = hexstr('aBc')
+ with self.assertRaises(ValueError):
+ s2.to_bytes()
+
+ def test_frombytes(self):
+ s = hexstr.from_bytes(b'\x01\x02\xaa')
+ self.assertEqual(s, '0102aa')
+
+ def test_slice(self):
+ s = hexstr('abcdef')
+ slice1 = s[-2:]
+ self.assertTrue(isinstance(slice1, hexstr))
+ self.assertEqual(slice1, 'ef')
+ slice2 = s[1]
+ self.assertTrue(isinstance(slice2, hexstr))
+ self.assertEqual(slice2, 'b')
+
+ def test_str_lower(self):
+ self.assertEqual(str(hexstr('ABCD')), 'abcd')
+
+
+if __name__ == "__main__":
+ unittest.main()
--
To view, visit https://gerrit.osmocom.org/c/python/pyosmocom/+/38023?usp=email
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings?usp=email
Gerrit-MessageType: newchange
Gerrit-Project: python/pyosmocom
Gerrit-Branch: master
Gerrit-Change-Id: I16c0df809bc11ec0f98e8ade404f9b82072e3a06
Gerrit-Change-Number: 38023
Gerrit-PatchSet: 1
Gerrit-Owner: laforge <laforge(a)osmocom.org>
Attention is currently required from: dexter, laforge.
fixeria has posted comments on this change by dexter. ( https://gerrit.osmocom.org/c/pysim/+/38001?usp=email )
Change subject: pySim-shell: print cardinfo hexstrings in lowercase
......................................................................
Patch Set 3:
(1 comment)
Patchset:
PS2:
> this smells a bit like: […]
I also don't like having to use `.lower()` everywhere and would proceed as suggested above. That class should likely go to the newly born https://gitea.osmocom.org/osmocom/pyosmocom?
--
To view, visit https://gerrit.osmocom.org/c/pysim/+/38001?usp=email
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings?usp=email
Gerrit-MessageType: comment
Gerrit-Project: pysim
Gerrit-Branch: master
Gerrit-Change-Id: Ia6a8bd0e700c7fd933fb6c1b1050ed9494462d60
Gerrit-Change-Number: 38001
Gerrit-PatchSet: 3
Gerrit-Owner: dexter <pmaier(a)sysmocom.de>
Gerrit-Reviewer: Jenkins Builder
Gerrit-CC: fixeria <vyanitskiy(a)sysmocom.de>
Gerrit-CC: laforge <laforge(a)osmocom.org>
Gerrit-Attention: laforge <laforge(a)osmocom.org>
Gerrit-Attention: dexter <pmaier(a)sysmocom.de>
Gerrit-Comment-Date: Wed, 04 Sep 2024 08:07:20 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Comment-In-Reply-To: laforge <laforge(a)osmocom.org>