Attention is currently required from: lynxis lazus.
fixeria has posted comments on this change by lynxis lazus. ( https://gerrit.osmocom.org/c/osmo-ttcn3-hacks/+/38404?usp=email )
Change subject: SGSN: f_TC_cell_change_different_*: always expect the auth
......................................................................
Patch Set 6:
(1 comment)
Commit Message:
https://gerrit.osmocom.org/c/osmo-ttcn3-hacks/+/38404/comment/466f0d37_6fce… :
PS6, Line 9: The new SGSN will always ask for authentication
... while the -latest osmo-sgsn will not, so will these TCs fail?
--
To view, visit https://gerrit.osmocom.org/c/osmo-ttcn3-hacks/+/38404?usp=email
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings?usp=email
Gerrit-MessageType: comment
Gerrit-Project: osmo-ttcn3-hacks
Gerrit-Branch: master
Gerrit-Change-Id: I24579b5fc843caf68e035e106cee4e4ec0a3c735
Gerrit-Change-Number: 38404
Gerrit-PatchSet: 6
Gerrit-Owner: lynxis lazus <lynxis(a)fe80.eu>
Gerrit-Reviewer: Jenkins Builder
Gerrit-Reviewer: laforge <laforge(a)osmocom.org>
Gerrit-Reviewer: pespin <pespin(a)sysmocom.de>
Gerrit-CC: fixeria <vyanitskiy(a)sysmocom.de>
Gerrit-Attention: lynxis lazus <lynxis(a)fe80.eu>
Gerrit-Comment-Date: Sun, 24 Nov 2024 18:52:07 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Attention is currently required from: lynxis lazus, pespin.
fixeria has posted comments on this change by lynxis lazus. ( https://gerrit.osmocom.org/c/osmo-ttcn3-hacks/+/38401?usp=email )
Change subject: SGSN: TC_attach_auth_id_timeout: set TMSI to provoke a ID Request
......................................................................
Patch Set 6:
(1 comment)
File sgsn/SGSN_Tests.ttcn:
https://gerrit.osmocom.org/c/osmo-ttcn3-hacks/+/38401/comment/6872f41c_5fdf… :
PS1, Line 653: g_pars.p_tmsi := 'c000004a'O;
> Add a comment here explaining that you do an attach with tmsi so that it requests the IMSI.
Acknowledged
--
To view, visit https://gerrit.osmocom.org/c/osmo-ttcn3-hacks/+/38401?usp=email
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings?usp=email
Gerrit-MessageType: comment
Gerrit-Project: osmo-ttcn3-hacks
Gerrit-Branch: master
Gerrit-Change-Id: I5a860582aa57ebc073e4c33f3f2f8884e360edef
Gerrit-Change-Number: 38401
Gerrit-PatchSet: 6
Gerrit-Owner: lynxis lazus <lynxis(a)fe80.eu>
Gerrit-Reviewer: Jenkins Builder
Gerrit-Reviewer: daniel <dwillmann(a)sysmocom.de>
Gerrit-Reviewer: laforge <laforge(a)osmocom.org>
Gerrit-CC: fixeria <vyanitskiy(a)sysmocom.de>
Gerrit-CC: pespin <pespin(a)sysmocom.de>
Gerrit-Attention: pespin <pespin(a)sysmocom.de>
Gerrit-Attention: lynxis lazus <lynxis(a)fe80.eu>
Gerrit-Comment-Date: Sun, 24 Nov 2024 18:49:27 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Comment-In-Reply-To: pespin <pespin(a)sysmocom.de>
Attention is currently required from: lynxis lazus.
fixeria has posted comments on this change by lynxis lazus. ( https://gerrit.osmocom.org/c/osmo-ttcn3-hacks/+/38400?usp=email )
Change subject: SGSN: f_TC_attach_rau: do a periodic RA update instead of RA change
......................................................................
Patch Set 6: Code-Review+1
--
To view, visit https://gerrit.osmocom.org/c/osmo-ttcn3-hacks/+/38400?usp=email
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings?usp=email
Gerrit-MessageType: comment
Gerrit-Project: osmo-ttcn3-hacks
Gerrit-Branch: master
Gerrit-Change-Id: Ic33687c55915d883b6d9a9a0d640a11588e1d1a0
Gerrit-Change-Number: 38400
Gerrit-PatchSet: 6
Gerrit-Owner: lynxis lazus <lynxis(a)fe80.eu>
Gerrit-Reviewer: Jenkins Builder
Gerrit-Reviewer: fixeria <vyanitskiy(a)sysmocom.de>
Gerrit-Reviewer: laforge <laforge(a)osmocom.org>
Gerrit-Reviewer: pespin <pespin(a)sysmocom.de>
Gerrit-Attention: lynxis lazus <lynxis(a)fe80.eu>
Gerrit-Comment-Date: Sun, 24 Nov 2024 18:47:54 +0000
Gerrit-HasComments: No
Gerrit-Has-Labels: Yes
Attention is currently required from: lynxis lazus, pespin.
fixeria has posted comments on this change by lynxis lazus. ( https://gerrit.osmocom.org/c/osmo-ttcn3-hacks/+/38398?usp=email )
Change subject: SGSN: BSSGP_ConnHdlr: f_gmm_attach(): allow the SGSN to request the IMEI
......................................................................
Patch Set 6: Code-Review-1
(4 comments)
File sgsn/BSSGP_ConnHdlr.ttcn:
https://gerrit.osmocom.org/c/osmo-ttcn3-hacks/+/38398/comment/396ec4f1_40c5… :
PS6, Line 240: as_mm_identity
Maybe deriving two smaller altsteps (`as_mm_identity_imsi` and `as_mm_identity_imei`) from this one would be more flexible? The existing `as_mm_identity` would just combine both like this:
```
altstep as_mm_identity(integer ran_index := 0) runs on BSSGP_ConnHdlr {
[] as_mm_identity_imsi(ran_index);
[] as_mm_identity_imei(ran_index);
}
```
This would allow the API user to expect (or not expect) specific identity, e.g. you could use `as_mm_identity_imei` below to expect the IMEI request specifically.
https://gerrit.osmocom.org/c/osmo-ttcn3-hacks/+/38398/comment/083f37a4_f7a1… :
PS6, Line 265: as_receive_l3
This again looks 99% identical to the existing `f_receive_l3()`, so again code duplication. An altstep is indeed more flexible, but having more than one API doing the same thing is not good. I suggest removing `f_receive_l3()` and changing the code to use your new altstep.
https://gerrit.osmocom.org/c/osmo-ttcn3-hacks/+/38398/comment/d22ac246_96e4… :
PS6, Line 578: allow_id_imei_req
We may still receive an identity request here (regardless of the expectations), and this would block the altstep until `Tguard` fires... With the approach of two smaller altsteps I suggested above, you could do something like this:
```
[allow_id_imei_req] as_mm_identity_imei(ran_index) { repeat; }
[] as_mm_identity(ran_index) {
setverdict(fail, "Rx unexpected MM IDENTITY Req");
}
[] as_receive_l3(tr_GMM_ATTACH_ACCEPT('001'B, ?, ?), l3_mt, ran_index) { ... }
}
```
https://gerrit.osmocom.org/c/osmo-ttcn3-hacks/+/38398/comment/c663b540_e8af… :
PS6, Line 579: f_process_attach_accept
(cosmetic, but) please move the function call to its own line.
--
To view, visit https://gerrit.osmocom.org/c/osmo-ttcn3-hacks/+/38398?usp=email
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings?usp=email
Gerrit-MessageType: comment
Gerrit-Project: osmo-ttcn3-hacks
Gerrit-Branch: master
Gerrit-Change-Id: Id49c9e6ef7517a6a831315ac1f9915c50b88beb6
Gerrit-Change-Number: 38398
Gerrit-PatchSet: 6
Gerrit-Owner: lynxis lazus <lynxis(a)fe80.eu>
Gerrit-Reviewer: Jenkins Builder
Gerrit-Reviewer: fixeria <vyanitskiy(a)sysmocom.de>
Gerrit-CC: pespin <pespin(a)sysmocom.de>
Gerrit-Attention: pespin <pespin(a)sysmocom.de>
Gerrit-Attention: lynxis lazus <lynxis(a)fe80.eu>
Gerrit-Comment-Date: Sun, 24 Nov 2024 18:45:05 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: Yes
Attention is currently required from: laforge, lynxis lazus, pespin.
fixeria has posted comments on this change by lynxis lazus. ( https://gerrit.osmocom.org/c/osmo-ttcn3-hacks/+/38396?usp=email )
Change subject: SGSN: BSSGP_ConnHdlr: GMM Service Request: add support to expect authentication
......................................................................
Patch Set 4: Code-Review-1
(3 comments)
Patchset:
PS4:
CR-1 due to potential API duplication.
File sgsn/BSSGP_ConnHdlr.ttcn:
https://gerrit.osmocom.org/c/osmo-ttcn3-hacks/+/38396/comment/08083a0d_c033… :
PS4, Line 358: as_gmm_auth
You're adding this altstep, but not using it? Is it for a follow-up patch? I see there's also `f_gmm_auth()` below, so what's the difference between the two?
I may be wrong, but I smell code duplication... If your new API is supposed to replace the `f_gmm_auth()`, then the later should be removed.
https://gerrit.osmocom.org/c/osmo-ttcn3-hacks/+/38396/comment/da229720_6b83… :
PS4, Line 363: Ignoring autn for now
TODO? `f_gmm_auth()` does handle AUTN, by the way.
--
To view, visit https://gerrit.osmocom.org/c/osmo-ttcn3-hacks/+/38396?usp=email
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings?usp=email
Gerrit-MessageType: comment
Gerrit-Project: osmo-ttcn3-hacks
Gerrit-Branch: master
Gerrit-Change-Id: I9ed08160bf5413e3a30d6e90eb947d4d799e1058
Gerrit-Change-Number: 38396
Gerrit-PatchSet: 4
Gerrit-Owner: lynxis lazus <lynxis(a)fe80.eu>
Gerrit-Reviewer: Jenkins Builder
Gerrit-Reviewer: fixeria <vyanitskiy(a)sysmocom.de>
Gerrit-Reviewer: laforge <laforge(a)osmocom.org>
Gerrit-Reviewer: pespin <pespin(a)sysmocom.de>
Gerrit-Attention: laforge <laforge(a)osmocom.org>
Gerrit-Attention: pespin <pespin(a)sysmocom.de>
Gerrit-Attention: lynxis lazus <lynxis(a)fe80.eu>
Gerrit-Comment-Date: Sun, 24 Nov 2024 18:17:55 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: Yes
Attention is currently required from: laforge, lynxis lazus.
fixeria has posted comments on this change by lynxis lazus. ( https://gerrit.osmocom.org/c/osmo-ttcn3-hacks/+/38397?usp=email )
Change subject: SGSN: BSSGP_ConnHdlr: GMM Service Request: handle PMM IDLE UE correct
......................................................................
Patch Set 4:
(2 comments)
File sgsn/BSSGP_ConnHdlr.ttcn:
https://gerrit.osmocom.org/c/osmo-ttcn3-hacks/+/38397/comment/c1b417e4_66f8… :
PS4, Line 629: setverdict(fail, "Unexpected Service Reject");
Should we still fail here if the API user passes `exp_service_acc := false`?
https://gerrit.osmocom.org/c/osmo-ttcn3-hacks/+/38397/comment/e234902d_74a4… :
PS4, Line 640: } else {
So in the case of `exp_service_acc := false`, this altstep repeats and will keep waiting for what kind of event? We will never catch `tr_GMM_SERVICE_ACC` because of the guard statement you're adding, and receiving `tr_GMM_SERVICE_REJ` would cause the testcase to fail. I am trying to understand the logic...
--
To view, visit https://gerrit.osmocom.org/c/osmo-ttcn3-hacks/+/38397?usp=email
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings?usp=email
Gerrit-MessageType: comment
Gerrit-Project: osmo-ttcn3-hacks
Gerrit-Branch: master
Gerrit-Change-Id: I29237997e414aea80f254247da54f909410a4b36
Gerrit-Change-Number: 38397
Gerrit-PatchSet: 4
Gerrit-Owner: lynxis lazus <lynxis(a)fe80.eu>
Gerrit-Reviewer: Jenkins Builder
Gerrit-Reviewer: laforge <laforge(a)osmocom.org>
Gerrit-Reviewer: pespin <pespin(a)sysmocom.de>
Gerrit-CC: fixeria <vyanitskiy(a)sysmocom.de>
Gerrit-Attention: laforge <laforge(a)osmocom.org>
Gerrit-Attention: lynxis lazus <lynxis(a)fe80.eu>
Gerrit-Comment-Date: Sun, 24 Nov 2024 18:05:07 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No