Attention is currently required from: lynxis lazus, neels.
Hello Jenkins Builder, laforge, neels, pespin,
I'd like you to reexamine a change. Please visit
https://gerrit.osmocom.org/c/osmo-msc/+/43509?usp=email
to look at the new patch set (#2).
The following approvals got outdated and were removed:
Verified+1 by Jenkins Builder
The change is no longer submittable: Verified is unsatisfied now.
Change subject: libvlr: rename use_count to auth_use_count
......................................................................
libvlr: rename use_count to auth_use_count
In preparation to handle use_count for ciphering and auth differently.
Change-Id: I20d1b0a6403743c890010e17a63d25d006f471d5
---
M include/osmocom/vlr/vlr.h
M src/libmsc/msc_vty.c
M src/libvlr/vlr_auth_fsm.c
M tests/msc_vlr/msc_vlr_test_authen_reuse.c
M tests/msc_vlr/msc_vlr_test_authen_reuse.err
M tests/msc_vlr/msc_vlr_test_hlr_reject.c
M tests/msc_vlr/msc_vlr_test_hlr_reject.err
M tests/msc_vlr/msc_vlr_tests.c
8 files changed, 30 insertions(+), 30 deletions(-)
git pull ssh://gerrit.osmocom.org:29418/osmo-msc refs/changes/09/43509/2
--
To view, visit https://gerrit.osmocom.org/c/osmo-msc/+/43509?usp=email
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings?usp=email
Gerrit-MessageType: newpatchset
Gerrit-Project: osmo-msc
Gerrit-Branch: master
Gerrit-Change-Id: I20d1b0a6403743c890010e17a63d25d006f471d5
Gerrit-Change-Number: 43509
Gerrit-PatchSet: 2
Gerrit-Owner: lynxis lazus <lynxis(a)fe80.eu>
Gerrit-Reviewer: Jenkins Builder
Gerrit-Reviewer: laforge <laforge(a)osmocom.org>
Gerrit-Reviewer: neels <nhofmeyr(a)sysmocom.de>
Gerrit-Reviewer: pespin <pespin(a)sysmocom.de>
Gerrit-Attention: neels <nhofmeyr(a)sysmocom.de>
Gerrit-Attention: lynxis lazus <lynxis(a)fe80.eu>
Attention is currently required from: laforge, neels, pespin.
Hello Jenkins Builder, laforge, neels, pespin,
I'd like you to reexamine a change. Please visit
https://gerrit.osmocom.org/c/osmo-msc/+/43480?usp=email
to look at the new patch set (#4).
The following approvals got outdated and were removed:
Verified+1 by Jenkins Builder
Change subject: libvlr: allow to use the same key slot for multiple ciphering commands
......................................................................
libvlr: allow to use the same key slot for multiple ciphering commands
An established security context can be used multiple times.
In difference to re-use of the same auth tuple, which is a serious security
flaw, re-using a security context is completely fine as long the context
is not used forever.
Change-Id: I5c628ef4b43f7c22f62d1405cbe1f717a7918548
---
M include/osmocom/vlr/vlr.h
M src/libmsc/msc_vty.c
M src/libvlr/vlr_access_req_fsm.c
M src/libvlr/vlr_auth_fsm.c
M src/libvlr/vlr_auth_fsm.h
M src/libvlr/vlr_lu_fsm.c
M tests/msc_vlr/msc_vlr_test_authen_reuse.c
M tests/msc_vlr/msc_vlr_tests.c
8 files changed, 55 insertions(+), 2 deletions(-)
git pull ssh://gerrit.osmocom.org:29418/osmo-msc refs/changes/80/43480/4
--
To view, visit https://gerrit.osmocom.org/c/osmo-msc/+/43480?usp=email
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings?usp=email
Gerrit-MessageType: newpatchset
Gerrit-Project: osmo-msc
Gerrit-Branch: master
Gerrit-Change-Id: I5c628ef4b43f7c22f62d1405cbe1f717a7918548
Gerrit-Change-Number: 43480
Gerrit-PatchSet: 4
Gerrit-Owner: lynxis lazus <lynxis(a)fe80.eu>
Gerrit-Reviewer: Jenkins Builder
Gerrit-Reviewer: laforge <laforge(a)osmocom.org>
Gerrit-Reviewer: neels <nhofmeyr(a)sysmocom.de>
Gerrit-Reviewer: pespin <pespin(a)sysmocom.de>
Gerrit-Attention: neels <nhofmeyr(a)sysmocom.de>
Gerrit-Attention: laforge <laforge(a)osmocom.org>
Gerrit-Attention: pespin <pespin(a)sysmocom.de>
Attention is currently required from: laforge, lynxis lazus, neels.
Hello Jenkins Builder, laforge, neels, pespin,
I'd like you to reexamine a change. Please visit
https://gerrit.osmocom.org/c/osmo-msc/+/43510?usp=email
to look at the new patch set (#2).
The following approvals got outdated and were removed:
Code-Review+1 by laforge, Verified+1 by Jenkins Builder
Change subject: libvlr: auth_fsm: split off fsm creation and start of it
......................................................................
libvlr: auth_fsm: split off fsm creation and start of it
The auth fsm may destroy itself from a chain of fsm events by
VLR_AUTH_E_START. Resulting in an use-after-free of the fsm instance.
Change-Id: Ibad920676d9d4a8b7de4a820196385738764ffe9
---
M src/libvlr/vlr_access_req_fsm.c
M src/libvlr/vlr_auth_fsm.c
M src/libvlr/vlr_auth_fsm.h
M src/libvlr/vlr_lu_fsm.c
4 files changed, 20 insertions(+), 6 deletions(-)
git pull ssh://gerrit.osmocom.org:29418/osmo-msc refs/changes/10/43510/2
--
To view, visit https://gerrit.osmocom.org/c/osmo-msc/+/43510?usp=email
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings?usp=email
Gerrit-MessageType: newpatchset
Gerrit-Project: osmo-msc
Gerrit-Branch: master
Gerrit-Change-Id: Ibad920676d9d4a8b7de4a820196385738764ffe9
Gerrit-Change-Number: 43510
Gerrit-PatchSet: 2
Gerrit-Owner: lynxis lazus <lynxis(a)fe80.eu>
Gerrit-Reviewer: Jenkins Builder
Gerrit-Reviewer: laforge <laforge(a)osmocom.org>
Gerrit-Reviewer: neels <nhofmeyr(a)sysmocom.de>
Gerrit-Reviewer: pespin <pespin(a)sysmocom.de>
Gerrit-Attention: neels <nhofmeyr(a)sysmocom.de>
Gerrit-Attention: laforge <laforge(a)osmocom.org>
Gerrit-Attention: lynxis lazus <lynxis(a)fe80.eu>
Attention is currently required from: laforge, neels, pespin.
Hello Jenkins Builder, laforge, neels, pespin,
I'd like you to reexamine a change. Please visit
https://gerrit.osmocom.org/c/osmo-msc/+/43480?usp=email
to look at the new patch set (#3).
The following approvals got outdated and were removed:
Code-Review+1 by laforge, Verified+1 by Jenkins Builder
Change subject: libvlr: allow to use the same key slot for multiple ciphering commands
......................................................................
libvlr: allow to use the same key slot for multiple ciphering commands
An established security context can be used multiple times.
In difference to re-use of the same auth tuple, which is a serious security
flaw, re-using a security context is completely fine as long the context
is not used forever.
Change-Id: I5c628ef4b43f7c22f62d1405cbe1f717a7918548
---
M include/osmocom/vlr/vlr.h
M src/libmsc/msc_vty.c
M src/libvlr/vlr_access_req_fsm.c
M src/libvlr/vlr_auth_fsm.c
M src/libvlr/vlr_auth_fsm.h
M tests/msc_vlr/msc_vlr_test_authen_reuse.c
M tests/msc_vlr/msc_vlr_tests.c
7 files changed, 49 insertions(+), 2 deletions(-)
git pull ssh://gerrit.osmocom.org:29418/osmo-msc refs/changes/80/43480/3
--
To view, visit https://gerrit.osmocom.org/c/osmo-msc/+/43480?usp=email
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings?usp=email
Gerrit-MessageType: newpatchset
Gerrit-Project: osmo-msc
Gerrit-Branch: master
Gerrit-Change-Id: I5c628ef4b43f7c22f62d1405cbe1f717a7918548
Gerrit-Change-Number: 43480
Gerrit-PatchSet: 3
Gerrit-Owner: lynxis lazus <lynxis(a)fe80.eu>
Gerrit-Reviewer: Jenkins Builder
Gerrit-Reviewer: laforge <laforge(a)osmocom.org>
Gerrit-Reviewer: neels <nhofmeyr(a)sysmocom.de>
Gerrit-Reviewer: pespin <pespin(a)sysmocom.de>
Gerrit-Attention: neels <nhofmeyr(a)sysmocom.de>
Gerrit-Attention: laforge <laforge(a)osmocom.org>
Gerrit-Attention: pespin <pespin(a)sysmocom.de>
Attention is currently required from: neels, pespin.
lynxis lazus has posted comments on this change by lynxis lazus. ( https://gerrit.osmocom.org/c/osmo-msc/+/43480?usp=email )
Change subject: libvlr: allow to use the same key slot for multiple ciphering commands
......................................................................
Patch Set 2:
(7 comments)
File src/libmsc/msc_vty.c:
https://gerrit.osmocom.org/c/osmo-msc/+/43480/comment/0d7b4ce1_3d885af8?usp… :
PS2, Line 536: gsmnet->vlr->cfg.ciph_sec_ctx_max_reuse = atoi(argv[0]);
> This double assignment with on top super long lines and indentation looks confusing.
Done
File src/libvlr/vlr_access_req_fsm.c:
https://gerrit.osmocom.org/c/osmo-msc/+/43480/comment/81d17cfd_ad45a908?usp… :
PS2, Line 466: par->key_seq = par->vsub->last_tuple->key_seq;
> lots of indirection here, may make sense to add some intermediate ASSERT?
i've added assert. It can't be zero when auth was successful.
File src/libvlr/vlr_auth_fsm.h:
https://gerrit.osmocom.org/c/osmo-msc/+/43480/comment/38b8e62c_0d32829d?usp… :
PS2, Line 43: bool auth_ciph_sec_ctx_is_usable(struct vlr_subscr *vsub, uint8_t key_seq);
> const
Done
File src/libvlr/vlr_auth_fsm.c:
https://gerrit.osmocom.org/c/osmo-msc/+/43480/comment/0f6ef3e0_adf57b7f?usp… :
PS2, Line 697: bool auth_ciph_sec_ctx_is_usable(struct vlr_subscr *vsub, uint8_t key_seq)
> const vsub. […]
Done
https://gerrit.osmocom.org/c/osmo-msc/+/43480/comment/d35914cf_4e817d73?usp… :
PS2, Line 702: if (!at || key_seq == 0x7)
> so "at && key_seq == 0x7" is actually fine then? Or do you better need to split these cases?
(at && key_seq == 0x7) no that's not fine. but one of them is actually a false.
File tests/msc_vlr/msc_vlr_test_authen_reuse.c:
https://gerrit.osmocom.org/c/osmo-msc/+/43480/comment/b0d8a0fb_7b7396c7?usp… :
PS2, Line 40: net->vlr->cfg.auth_tuple_max_reuse_count = net->vlr->cfg.ciph_sec_ctx_max_reuse = set_max_reuse_count;
> let's please have these in separate lines!
Done
File tests/msc_vlr/msc_vlr_tests.c:
https://gerrit.osmocom.org/c/osmo-msc/+/43480/comment/f27e3073_183dd6ad?usp… :
PS2, Line 681: net->vlr->cfg.auth_tuple_max_reuse_count = net->vlr->cfg.ciph_sec_ctx_max_reuse = 0;
> separate lines!
My idea was to make sure it's coupled as long the MSC don't want to save auth tuple for ciphering.
--
To view, visit https://gerrit.osmocom.org/c/osmo-msc/+/43480?usp=email
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings?usp=email
Gerrit-MessageType: comment
Gerrit-Project: osmo-msc
Gerrit-Branch: master
Gerrit-Change-Id: I5c628ef4b43f7c22f62d1405cbe1f717a7918548
Gerrit-Change-Number: 43480
Gerrit-PatchSet: 2
Gerrit-Owner: lynxis lazus <lynxis(a)fe80.eu>
Gerrit-Reviewer: Jenkins Builder
Gerrit-Reviewer: laforge <laforge(a)osmocom.org>
Gerrit-Reviewer: neels <nhofmeyr(a)sysmocom.de>
Gerrit-Reviewer: pespin <pespin(a)sysmocom.de>
Gerrit-Attention: neels <nhofmeyr(a)sysmocom.de>
Gerrit-Attention: pespin <pespin(a)sysmocom.de>
Gerrit-Comment-Date: Wed, 02 Sep 2026 14:19:57 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Comment-In-Reply-To: pespin <pespin(a)sysmocom.de>