lists.osmocom.org
Sign In Sign Up
Manage this list Sign In Sign Up

Keyboard Shortcuts

Thread View

  • j: Next unread message
  • k: Previous unread message
  • j a: Jump to all threads
  • j l: Jump to MailingList overview

gerrit-log

Thread Start a new thread
Download
Threads by month
  • ----- 2026 -----
  • October
  • September
  • August
  • July
  • June
  • May
  • April
  • March
  • February
  • January
  • ----- 2025 -----
  • December
  • November
  • October
  • September
  • August
  • July
  • June
  • May
  • April
  • March
  • February
  • January
  • ----- 2024 -----
  • December
  • November
  • October
  • September
  • August
  • July
  • June
  • May
  • April
  • March
  • February
  • January
  • ----- 2023 -----
  • December
  • November
  • October
  • September
  • August
  • July
  • June
  • May
  • April
  • March
  • February
  • January
  • ----- 2022 -----
  • December
  • November
  • October
  • September
  • August
  • July
  • June
  • May
  • April
  • March
  • February
  • January
gerrit-log@lists.osmocom.org

July 2025

  • 1 participants
  • 1492 discussions
[M] Change in libosmo-sigtran[master]: xua_asp_fsm: Move helper function to ss7_asp internal API
by fixeria 15 Jul '25

15 Jul '25
Attention is currently required from: pespin. fixeria has posted comments on this change by pespin. ( https://gerrit.osmocom.org/c/libosmo-sigtran/+/40696?usp=email ) Change subject: xua_asp_fsm: Move helper function to ss7_asp internal API ...................................................................... Patch Set 1: Code-Review+1 (1 comment) File src/ss7_asp.c: https://gerrit.osmocom.org/c/libosmo-sigtran/+/40696/comment/d6ce444a_01c0d… : PS1, Line 1560: struct osmo_ss7_as *as; const -- To view, visit https://gerrit.osmocom.org/c/libosmo-sigtran/+/40696?usp=email To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings?usp=email Gerrit-MessageType: comment Gerrit-Project: libosmo-sigtran Gerrit-Branch: master Gerrit-Change-Id: I3eb57c3fb690e7486b52b2c433b25930d16599e5 Gerrit-Change-Number: 40696 Gerrit-PatchSet: 1 Gerrit-Owner: pespin <pespin(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Attention: pespin <pespin(a)sysmocom.de> Gerrit-Comment-Date: Tue, 15 Jul 2025 18:50:28 +0000 Gerrit-HasComments: Yes Gerrit-Has-Labels: Yes
1 0
0 0
[S] Change in libosmo-sigtran[master]: xua_as_fsm: Fix wrong pointer cast during XUA_ASPAS_ASP_DOWN_IND
by fixeria 15 Jul '25

15 Jul '25
Attention is currently required from: pespin. fixeria has posted comments on this change by pespin. ( https://gerrit.osmocom.org/c/libosmo-sigtran/+/40695?usp=email ) Change subject: xua_as_fsm: Fix wrong pointer cast during XUA_ASPAS_ASP_DOWN_IND ...................................................................... Patch Set 1: Code-Review+1 -- To view, visit https://gerrit.osmocom.org/c/libosmo-sigtran/+/40695?usp=email To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings?usp=email Gerrit-MessageType: comment Gerrit-Project: libosmo-sigtran Gerrit-Branch: master Gerrit-Change-Id: Ied523e080419723e0a3eb2f8103897b241bff41f Gerrit-Change-Number: 40695 Gerrit-PatchSet: 1 Gerrit-Owner: pespin <pespin(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Attention: pespin <pespin(a)sysmocom.de> Gerrit-Comment-Date: Tue, 15 Jul 2025 18:47:56 +0000 Gerrit-HasComments: No Gerrit-Has-Labels: Yes
1 0
0 0
[XS] Change in libosmo-sigtran[master]: sccp: MTP-TRANSFER.req: Trigger Routing Failure if no route available
by fixeria 15 Jul '25

15 Jul '25
Attention is currently required from: pespin. fixeria has posted comments on this change by pespin. ( https://gerrit.osmocom.org/c/libosmo-sigtran/+/40687?usp=email ) Change subject: sccp: MTP-TRANSFER.req: Trigger Routing Failure if no route available ...................................................................... Patch Set 3: Code-Review+1 -- To view, visit https://gerrit.osmocom.org/c/libosmo-sigtran/+/40687?usp=email To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings?usp=email Gerrit-MessageType: comment Gerrit-Project: libosmo-sigtran Gerrit-Branch: master Gerrit-Change-Id: I78b3ae84b5844d91d0c20e78df0bb1e792426f17 Gerrit-Change-Number: 40687 Gerrit-PatchSet: 3 Gerrit-Owner: pespin <pespin(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Attention: pespin <pespin(a)sysmocom.de> Gerrit-Comment-Date: Tue, 15 Jul 2025 18:47:03 +0000 Gerrit-HasComments: No Gerrit-Has-Labels: Yes
1 0
0 0
[XS] Change in libosmo-sigtran[master]: sccp: MTP-TRANSFER.req: Allow dpc 0.0.0
by fixeria 15 Jul '25

15 Jul '25
Attention is currently required from: daniel, laforge, pespin. fixeria has posted comments on this change by pespin. ( https://gerrit.osmocom.org/c/libosmo-sigtran/+/40686?usp=email ) Change subject: sccp: MTP-TRANSFER.req: Allow dpc 0.0.0 ...................................................................... Patch Set 3: Code-Review+1 -- To view, visit https://gerrit.osmocom.org/c/libosmo-sigtran/+/40686?usp=email To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings?usp=email Gerrit-MessageType: comment Gerrit-Project: libosmo-sigtran Gerrit-Branch: master Gerrit-Change-Id: I1a2390f5e5f8168093e281611a8aab905bf1d511 Gerrit-Change-Number: 40686 Gerrit-PatchSet: 3 Gerrit-Owner: pespin <pespin(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: daniel <dwillmann(a)sysmocom.de> Gerrit-Reviewer: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Reviewer: laforge <laforge(a)osmocom.org> Gerrit-Attention: laforge <laforge(a)osmocom.org> Gerrit-Attention: pespin <pespin(a)sysmocom.de> Gerrit-Attention: daniel <dwillmann(a)sysmocom.de> Gerrit-Comment-Date: Tue, 15 Jul 2025 18:46:40 +0000 Gerrit-HasComments: No Gerrit-Has-Labels: Yes
1 0
0 0
[XS] Change in libosmo-sigtran[master]: sccp: MTP-TRANSFER.req: Set OPC before route lookup
by fixeria 15 Jul '25

15 Jul '25
Attention is currently required from: pespin. fixeria has posted comments on this change by pespin. ( https://gerrit.osmocom.org/c/libosmo-sigtran/+/40694?usp=email ) Change subject: sccp: MTP-TRANSFER.req: Set OPC before route lookup ...................................................................... Patch Set 1: Code-Review+1 -- To view, visit https://gerrit.osmocom.org/c/libosmo-sigtran/+/40694?usp=email To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings?usp=email Gerrit-MessageType: comment Gerrit-Project: libosmo-sigtran Gerrit-Branch: master Gerrit-Change-Id: I85e1d6c48f3c9082dcfaaeaa97a805cc0a372463 Gerrit-Change-Number: 40694 Gerrit-PatchSet: 1 Gerrit-Owner: pespin <pespin(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Attention: pespin <pespin(a)sysmocom.de> Gerrit-Comment-Date: Tue, 15 Jul 2025 18:46:26 +0000 Gerrit-HasComments: No Gerrit-Has-Labels: Yes
1 0
0 0
[M] Change in libosmo-sigtran[master]: vty: Introduce cmd 'cs7 instance <0-15> asp NAME audit point-code POI...
by fixeria 15 Jul '25

15 Jul '25
Attention is currently required from: pespin. fixeria has posted comments on this change by pespin. ( https://gerrit.osmocom.org/c/libosmo-sigtran/+/40685?usp=email ) Change subject: vty: Introduce cmd 'cs7 instance <0-15> asp NAME audit point-code POINT_CODE' ...................................................................... Patch Set 2: (4 comments) Commit Message: https://gerrit.osmocom.org/c/libosmo-sigtran/+/40685/comment/aa032dbb_ba77f… : PS2, Line 10: when response arrive : in case we run under some sort of misalignment with peer. I find this part of the statement hard to read/understand. Could you rephrase please? What response? The response to DAUD? Maybe "... to manually update the local state in situations when the (what?) response arrives during some sort of misalignment with the peer"? File src/ss7_asp_vty.c: https://gerrit.osmocom.org/c/libosmo-sigtran/+/40685/comment/48a553e2_6bf47… : PS2, Line 110: osmo_ss7_pointcode_print_buf Why not using `osmo_ss7_pointcode_print()` here? Does not seem like you have to use a local buffer here... https://gerrit.osmocom.org/c/libosmo-sigtran/+/40685/comment/1f75d70b_087e4… : PS2, Line 118: audit point-code Are you planning to add more commands related to `audit`? If not, maybe make it a single term like `audit-point-code` or `audit-pc`? https://gerrit.osmocom.org/c/libosmo-sigtran/+/40685/comment/1eb0326d_899d9… : PS2, Line 132: vty_out cosmetic: here and below: missing `%%` -- To view, visit https://gerrit.osmocom.org/c/libosmo-sigtran/+/40685?usp=email To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings?usp=email Gerrit-MessageType: comment Gerrit-Project: libosmo-sigtran Gerrit-Branch: master Gerrit-Change-Id: I607df3d84562e56d329bea1a730e26c8cdaae591 Gerrit-Change-Number: 40685 Gerrit-PatchSet: 2 Gerrit-Owner: pespin <pespin(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-CC: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Attention: pespin <pespin(a)sysmocom.de> Gerrit-Comment-Date: Tue, 15 Jul 2025 18:45:50 +0000 Gerrit-HasComments: Yes Gerrit-Has-Labels: No
1 0
0 0
[M] Change in libosmo-sigtran[master]: asp: Support Tx DAUD when ASP becomes activated
by fixeria 15 Jul '25

15 Jul '25
Attention is currently required from: laforge, osmith, pespin. fixeria has posted comments on this change by pespin. ( https://gerrit.osmocom.org/c/libosmo-sigtran/+/40501?usp=email ) Change subject: asp: Support Tx DAUD when ASP becomes activated ...................................................................... Patch Set 5: Code-Review+1 (2 comments) File src/xua_asp_fsm.c: https://gerrit.osmocom.org/c/libosmo-sigtran/+/40501/comment/8c35239c_c1d1b… : PS5, Line 161: llist_for_each_entry cosmetic: maybe add a comment that here you count affected PCs in order to allocate enough memory? https://gerrit.osmocom.org/c/libosmo-sigtran/+/40501/comment/0494ed6d_71088… : PS5, Line 172: talloc_size(asp, sizeof(*aff_pc) * num_aff_pc); ``` talloc_array(asp, uint32_t, num_aff_pc); ``` (not critical) -- To view, visit https://gerrit.osmocom.org/c/libosmo-sigtran/+/40501?usp=email To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings?usp=email Gerrit-MessageType: comment Gerrit-Project: libosmo-sigtran Gerrit-Branch: master Gerrit-Change-Id: I7c8c5099d4d00ea6f4a8db59ed6b833fb0ffa43d Gerrit-Change-Number: 40501 Gerrit-PatchSet: 5 Gerrit-Owner: pespin <pespin(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Reviewer: laforge <laforge(a)osmocom.org> Gerrit-Reviewer: osmith <osmith(a)sysmocom.de> Gerrit-Attention: osmith <osmith(a)sysmocom.de> Gerrit-Attention: laforge <laforge(a)osmocom.org> Gerrit-Attention: pespin <pespin(a)sysmocom.de> Gerrit-Comment-Date: Tue, 15 Jul 2025 18:30:18 +0000 Gerrit-HasComments: Yes Gerrit-Has-Labels: Yes
1 0
0 0
[M] Change in libosmo-sigtran[master]: xua: Introduce internal APIs to transmit DAUD
by fixeria 15 Jul '25

15 Jul '25
Attention is currently required from: pespin. fixeria has posted comments on this change by pespin. ( https://gerrit.osmocom.org/c/libosmo-sigtran/+/40684?usp=email ) Change subject: xua: Introduce internal APIs to transmit DAUD ...................................................................... Patch Set 2: Code-Review+1 -- To view, visit https://gerrit.osmocom.org/c/libosmo-sigtran/+/40684?usp=email To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings?usp=email Gerrit-MessageType: comment Gerrit-Project: libosmo-sigtran Gerrit-Branch: master Gerrit-Change-Id: Iab6126f1a9eac1a66bb8ec362b87e20a5eb795ff Gerrit-Change-Number: 40684 Gerrit-PatchSet: 2 Gerrit-Owner: pespin <pespin(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Attention: pespin <pespin(a)sysmocom.de> Gerrit-Comment-Date: Tue, 15 Jul 2025 18:17:16 +0000 Gerrit-HasComments: No Gerrit-Has-Labels: Yes
1 0
0 0
[S] Change in osmo-sgsn[master]: ranap: split mmctx related iu events into own function
by lynxis lazus 15 Jul '25

15 Jul '25
lynxis lazus has uploaded this change for review. ( https://gerrit.osmocom.org/c/osmo-sgsn/+/40699?usp=email ) Change subject: ranap: split mmctx related iu events into own function ...................................................................... ranap: split mmctx related iu events into own function In preparation of Routing Areas for Iu, split off mmctx related events into an own function. All mmctx related events must contain a valid ctx or are otherwise invalid. Change-Id: Ie6f131d29da299f09e897240ec5c39a395ce6f1b --- M src/sgsn/gprs_ranap.c 1 file changed, 24 insertions(+), 1 deletion(-) git pull ssh://gerrit.osmocom.org:29418/osmo-sgsn refs/changes/99/40699/1 diff --git a/src/sgsn/gprs_ranap.c b/src/sgsn/gprs_ranap.c index af764de..d721255 100644 --- a/src/sgsn/gprs_ranap.c +++ b/src/sgsn/gprs_ranap.c @@ -137,11 +137,17 @@ return -1; } -int sgsn_ranap_iu_event(struct ranap_ue_conn_ctx *ctx, enum ranap_iu_event_type type, void *data) +static int sgsn_ranap_iu_event_mmctx(struct ranap_ue_conn_ctx *ctx, enum ranap_iu_event_type type, void *data) { struct sgsn_mm_ctx *mm; int rc = -1; + if (!ctx) { + LOGIUP(ctx, LOGL_ERROR, "NULL ctx given for IU event %s\n", + ranap_iu_event_type_str(type)); + return rc; + } + mm = sgsn_mm_ctx_by_ue_ctx(ctx); if (!mm) { LOGIUP(ctx, LOGL_NOTICE, "Cannot find mm ctx for IU event %s\n", @@ -193,6 +199,23 @@ return rc; } + +int sgsn_ranap_iu_event(struct ranap_ue_conn_ctx *ctx, enum ranap_iu_event_type type, void *data) +{ + struct ranap_iu_event_new_area *new_area; + + switch (type) { + case RANAP_IU_EVENT_RAB_ASSIGN: + case RANAP_IU_EVENT_IU_RELEASE: + case RANAP_IU_EVENT_LINK_INVALIDATED: + case RANAP_IU_EVENT_SECURITY_MODE_COMPLETE: + return sgsn_ranap_iu_event_mmctx(ctx, type, data); + default: + LOGP(DRANAP, LOGL_NOTICE, "Iu: Unknown event received: type: %d\n", type); + return -1; + } +} + void sgsn_ranap_iu_free(struct sgsn_mm_ctx *ctx) { if (!ctx) -- To view, visit https://gerrit.osmocom.org/c/osmo-sgsn/+/40699?usp=email To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings?usp=email Gerrit-MessageType: newchange Gerrit-Project: osmo-sgsn Gerrit-Branch: master Gerrit-Change-Id: Ie6f131d29da299f09e897240ec5c39a395ce6f1b Gerrit-Change-Number: 40699 Gerrit-PatchSet: 1 Gerrit-Owner: lynxis lazus <lynxis(a)fe80.eu>
1 0
0 0
[XS] Change in osmo-sgsn[master]: mmctx: LOGIUP: allow ue to be NULL
by lynxis lazus 15 Jul '25

15 Jul '25
lynxis lazus has uploaded this change for review. ( https://gerrit.osmocom.org/c/osmo-sgsn/+/40698?usp=email ) Change subject: mmctx: LOGIUP: allow ue to be NULL ...................................................................... mmctx: LOGIUP: allow ue to be NULL In certain cases, the ue can be NULL. E.g. when receiving a new Iu event without a context. Change-Id: Ie569fa100abe518cb63c1b918ad7748a7ea3bb99 --- M include/osmocom/sgsn/mmctx.h 1 file changed, 6 insertions(+), 1 deletion(-) git pull ssh://gerrit.osmocom.org:29418/osmo-sgsn refs/changes/98/40698/1 diff --git a/include/osmocom/sgsn/mmctx.h b/include/osmocom/sgsn/mmctx.h index 9fa06dc..7c4764e 100644 --- a/include/osmocom/sgsn/mmctx.h +++ b/include/osmocom/sgsn/mmctx.h @@ -231,7 +231,12 @@ #ifdef BUILD_IU #define LOGIUP(ue, level, fmt, args...) \ - LOGP(DMM, level, "UE(0x%x){%s} " fmt, ue->conn_id, osmo_rai_name(&(ue)->ra_id), ## args) + do { \ + if (ue) \ + LOGP(DMM, level, "UE(0x%x){%s} " fmt, ue->conn_id, osmo_rai_name(&(ue)->ra_id), ## args); \ + else \ + LOGP(DMM, level, "UE(NULL){} " fmt, ## args); \ + } while (0) #else #define LOGIUP(ue, level, fmt, args...) \ LOGP(DMM, level, "UE(%p){NOTSUPPORTED} " fmt, ue, ## args) -- To view, visit https://gerrit.osmocom.org/c/osmo-sgsn/+/40698?usp=email To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings?usp=email Gerrit-MessageType: newchange Gerrit-Project: osmo-sgsn Gerrit-Branch: master Gerrit-Change-Id: Ie569fa100abe518cb63c1b918ad7748a7ea3bb99 Gerrit-Change-Number: 40698 Gerrit-PatchSet: 1 Gerrit-Owner: lynxis lazus <lynxis(a)fe80.eu>
1 0
0 0
  • ← Newer
  • 1
  • ...
  • 74
  • 75
  • 76
  • 77
  • 78
  • 79
  • 80
  • ...
  • 150
  • Older →

HyperKitty Powered by HyperKitty version 1.3.12.