Attention is currently required from: pespin.
laforge has posted comments on this change. ( https://gerrit.osmocom.org/c/osmo-ttcn3-hacks/+/35226?usp=email )
Change subject: ggsn: Fix restriction type on several template definitions
......................................................................
Patch Set 1: Code-Review+1
--
To view, visit https://gerrit.osmocom.org/c/osmo-ttcn3-hacks/+/35226?usp=email
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings
Gerrit-Project: osmo-ttcn3-hacks
Gerrit-Branch: master
Gerrit-Change-Id: I47a0c3fbf1b4078c2d8157b148330f7750cc3266
Gerrit-Change-Number: 35226
Gerrit-PatchSet: 1
Gerrit-Owner: pespin <pespin(a)sysmocom.de>
Gerrit-Reviewer: Jenkins Builder
Gerrit-Reviewer: laforge <laforge(a)osmocom.org>
Gerrit-Attention: pespin <pespin(a)sysmocom.de>
Gerrit-Comment-Date: Tue, 05 Dec 2023 17:08:48 +0000
Gerrit-HasComments: No
Gerrit-Has-Labels: Yes
Gerrit-MessageType: comment
Attention is currently required from: pespin.
laforge has posted comments on this change. ( https://gerrit.osmocom.org/c/osmo-ttcn3-hacks/+/35225?usp=email )
Change subject: ggsn: Early exit test if f_wait_icmp6() fails
......................................................................
Patch Set 1: Code-Review+1
--
To view, visit https://gerrit.osmocom.org/c/osmo-ttcn3-hacks/+/35225?usp=email
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings
Gerrit-Project: osmo-ttcn3-hacks
Gerrit-Branch: master
Gerrit-Change-Id: Ida6be6194f98de44dca804759c85016031cae61c
Gerrit-Change-Number: 35225
Gerrit-PatchSet: 1
Gerrit-Owner: pespin <pespin(a)sysmocom.de>
Gerrit-Reviewer: Jenkins Builder
Gerrit-Reviewer: laforge <laforge(a)osmocom.org>
Gerrit-Attention: pespin <pespin(a)sysmocom.de>
Gerrit-Comment-Date: Tue, 05 Dec 2023 17:08:27 +0000
Gerrit-HasComments: No
Gerrit-Has-Labels: Yes
Gerrit-MessageType: comment
laforge has submitted this change. ( https://gerrit.osmocom.org/c/pysim/+/35215?usp=email )
Change subject: perform multiple GET RESPONSE cycles if more data is available
......................................................................
perform multiple GET RESPONSE cycles if more data is available
So far we implemented only one round of "Send the APDU, get SW=61xx,
call GET RESPONSE". This permitted us to receive only data up to 256
bytes.
Let's extend that to doing multiple rounds, concatenating the result.
This allows us to obtain arbitrary-length data from the card.
See Annex C.1 of ETSI TS 102 221 for examples showing multiple 61xx
iterations.
Change-Id: Ib17da655aa0b0eb203c29dc92690c81bd1300778
Closes: OS#6287
---
M pySim/transport/__init__.py
1 file changed, 23 insertions(+), 2 deletions(-)
Approvals:
Jenkins Builder: Verified
laforge: Looks good to me, approved
diff --git a/pySim/transport/__init__.py b/pySim/transport/__init__.py
index e90ced6..2ffb9c3 100644
--- a/pySim/transport/__init__.py
+++ b/pySim/transport/__init__.py
@@ -137,11 +137,12 @@
# xx is the number of response bytes available.
# See also:
if (sw is not None):
- if ((sw[0:2] == '9f') or (sw[0:2] == '61')):
+ while ((sw[0:2] == '9f') or (sw[0:2] == '61')):
# SW1=9F: 3GPP TS 51.011 9.4.1, Responses to commands which are correctly executed
# SW1=61: ISO/IEC 7816-4, Table 5 — General meaning of the interindustry values of SW1-SW2
pdu_gr = pdu[0:2] + 'c00000' + sw[2:4]
- data, sw = self.send_apdu_raw(pdu_gr)
+ d, sw = self.send_apdu_raw(pdu_gr)
+ data += d
if sw[0:2] == '6c':
# SW1=6C: ETSI TS 102 221 Table 7.1: Procedure byte coding
pdu_gr = pdu[0:8] + sw[2:4]
--
To view, visit https://gerrit.osmocom.org/c/pysim/+/35215?usp=email
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings
Gerrit-Project: pysim
Gerrit-Branch: master
Gerrit-Change-Id: Ib17da655aa0b0eb203c29dc92690c81bd1300778
Gerrit-Change-Number: 35215
Gerrit-PatchSet: 1
Gerrit-Owner: laforge <laforge(a)osmocom.org>
Gerrit-Reviewer: Jenkins Builder
Gerrit-Reviewer: laforge <laforge(a)osmocom.org>
Gerrit-MessageType: merged
laforge has posted comments on this change. ( https://gerrit.osmocom.org/c/pysim/+/35215?usp=email )
Change subject: perform multiple GET RESPONSE cycles if more data is available
......................................................................
Patch Set 1: Code-Review+2
(1 comment)
Patchset:
PS1:
rather trivial change, going ahead and merging it.
--
To view, visit https://gerrit.osmocom.org/c/pysim/+/35215?usp=email
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings
Gerrit-Project: pysim
Gerrit-Branch: master
Gerrit-Change-Id: Ib17da655aa0b0eb203c29dc92690c81bd1300778
Gerrit-Change-Number: 35215
Gerrit-PatchSet: 1
Gerrit-Owner: laforge <laforge(a)osmocom.org>
Gerrit-Reviewer: Jenkins Builder
Gerrit-Reviewer: laforge <laforge(a)osmocom.org>
Gerrit-Comment-Date: Tue, 05 Dec 2023 17:07:55 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: Yes
Gerrit-MessageType: comment
laforge has submitted this change. ( https://gerrit.osmocom.org/c/osmo-pcu/+/35224?usp=email )
Change subject: bts: rename struct member gen_idle_blocks to gen_idle_blocks_C0
......................................................................
bts: rename struct member gen_idle_blocks to gen_idle_blocks_C0
The struct member gen_idle_blocks controls whether the the PCU has to
generate dummy blocks to fill idle periods or if this task is left to
the BTS hardware.
Since idle dummy blocks only have to be transmitted on the C0 carrier,
we should rename the gen_idle_blocks struct member to
gen_idle_blocks_C0.
Related: OS#6198
Change-Id: If9511ed911f9c5d6d463881a387a9e7d11a15465
---
M src/bts.h
M src/gprs_rlcmac_sched.cpp
M src/pcu_l1_if.cpp
3 files changed, 22 insertions(+), 4 deletions(-)
Approvals:
osmith: Looks good to me, but someone else must approve
pespin: Looks good to me, but someone else must approve
laforge: Looks good to me, approved
Jenkins Builder: Verified
diff --git a/src/bts.h b/src/bts.h
index 86c161b..380c47c 100644
--- a/src/bts.h
+++ b/src/bts.h
@@ -282,7 +282,7 @@
/* When the PDCH is idle, the timeslot is expected to transmit dummy blocks. Some BTS models will generate
* those dummy blocks automatically when no data is transmitted. In contrast, other BTS models may require a
* continuous stream of PDCH blocks that already has the gaps filled with dummy blocks. */
- bool gen_idle_blocks;
+ bool gen_idle_blocks_C0;
};
struct paging_req_cs {
diff --git a/src/gprs_rlcmac_sched.cpp b/src/gprs_rlcmac_sched.cpp
index 12b9e50..ac58121 100644
--- a/src/gprs_rlcmac_sched.cpp
+++ b/src/gprs_rlcmac_sched.cpp
@@ -488,7 +488,7 @@
+ pdch->num_tbfs(GPRS_RLCMAC_UL_TBF);
bool skip_idle = (num_tbfs == 0);
- if (bts->gen_idle_blocks)
+ if (bts->gen_idle_blocks_C0)
skip_idle = skip_idle && trx != 0;
if (!skip_idle && (msg = sched_dummy())) {
diff --git a/src/pcu_l1_if.cpp b/src/pcu_l1_if.cpp
index 07082d3..fb44bd8 100644
--- a/src/pcu_l1_if.cpp
+++ b/src/pcu_l1_if.cpp
@@ -552,7 +552,7 @@
+ pdch->num_tbfs(GPRS_RLCMAC_UL_TBF);
bool skip_idle = (num_tbfs == 0);
- if (bts->gen_idle_blocks)
+ if (bts->gen_idle_blocks_C0)
skip_idle = skip_idle && trx != 0;
if (skip_idle) {
@@ -966,7 +966,7 @@
LOGP(DL1IF, LOGL_INFO, "BTS model: %s\n", get_value_string(gsm_pcuif_bts_model_names, info_ind->bts_model));
bts->bts_model = info_ind->bts_model;
- bts->gen_idle_blocks = decide_gen_idle_blocks(bts);
+ bts->gen_idle_blocks_C0 = decide_gen_idle_blocks(bts);
bts->active = true;
return rc;
--
To view, visit https://gerrit.osmocom.org/c/osmo-pcu/+/35224?usp=email
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings
Gerrit-Project: osmo-pcu
Gerrit-Branch: master
Gerrit-Change-Id: If9511ed911f9c5d6d463881a387a9e7d11a15465
Gerrit-Change-Number: 35224
Gerrit-PatchSet: 1
Gerrit-Owner: dexter <pmaier(a)sysmocom.de>
Gerrit-Reviewer: Jenkins Builder
Gerrit-Reviewer: fixeria <vyanitskiy(a)sysmocom.de>
Gerrit-Reviewer: laforge <laforge(a)osmocom.org>
Gerrit-Reviewer: osmith <osmith(a)sysmocom.de>
Gerrit-Reviewer: pespin <pespin(a)sysmocom.de>
Gerrit-MessageType: merged
Attention is currently required from: lynxis lazus, pespin.
laforge has posted comments on this change. ( https://gerrit.osmocom.org/c/erlang/osmo-epdg/+/35218?usp=email )
Change subject: epdg_gtpc_s2b: add TLV Serving Network
......................................................................
Patch Set 2:
(1 comment)
File src/epdg_gtpc_s2b.erl:
https://gerrit.osmocom.org/c/erlang/osmo-epdg/+/35218/comment/6fadb5c7_f6bb…
PS2, Line 64: -define(MNC_SIZE, 42).
I don't really understand the MNC_SIZE. Is that some kind of length? and why would that be 42 bytes?
--
To view, visit https://gerrit.osmocom.org/c/erlang/osmo-epdg/+/35218?usp=email
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings
Gerrit-Project: erlang/osmo-epdg
Gerrit-Branch: master
Gerrit-Change-Id: I2a9459859fc660e6433cd8178ab9d1f92ae74fc0
Gerrit-Change-Number: 35218
Gerrit-PatchSet: 2
Gerrit-Owner: lynxis lazus <lynxis(a)fe80.eu>
Gerrit-Reviewer: Jenkins Builder
Gerrit-Reviewer: pespin <pespin(a)sysmocom.de>
Gerrit-CC: laforge <laforge(a)osmocom.org>
Gerrit-Attention: pespin <pespin(a)sysmocom.de>
Gerrit-Attention: lynxis lazus <lynxis(a)fe80.eu>
Gerrit-Comment-Date: Tue, 05 Dec 2023 17:02:10 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Gerrit-MessageType: comment