laforge has posted comments on this change. ( https://gerrit.osmocom.org/c/pysim/+/35282?usp=email )
Change subject: bertlv_parse_len: Fix input data is smaller than num length octets
......................................................................
Patch Set 1: Code-Review+2
--
To view, visit https://gerrit.osmocom.org/c/pysim/+/35282?usp=email
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings
Gerrit-Project: pysim
Gerrit-Branch: master
Gerrit-Change-Id: Ic44557368a6034dbf4bb021ab23a57927c22def0
Gerrit-Change-Number: 35282
Gerrit-PatchSet: 1
Gerrit-Owner: laforge <laforge(a)osmocom.org>
Gerrit-Reviewer: Jenkins Builder
Gerrit-Reviewer: fixeria <vyanitskiy(a)sysmocom.de>
Gerrit-Reviewer: laforge <laforge(a)osmocom.org>
Gerrit-Comment-Date: Sun, 17 Dec 2023 10:46:21 +0000
Gerrit-HasComments: No
Gerrit-Has-Labels: Yes
Gerrit-MessageType: comment
Attention is currently required from: fixeria, neels, pespin.
laforge has posted comments on this change. ( https://gerrit.osmocom.org/c/osmo-sip-connector/+/35308?usp=email )
Change subject: verbosely log MNCC and SDP
......................................................................
Patch Set 2:
(1 comment)
File src/mncc.c:
https://gerrit.osmocom.org/c/osmo-sip-connector/+/35308/comment/dc1d6c2c_1f…
PS2, Line 1059: Log about the received MNCC message
> A static function used by only one function would most likely be inlined anyway... […]
so we have two different suggestions here:
1) move the switch statement / log related code into a [static inline] function
2) calling log_check_level
I think nobody is arguing about '1' (it makes sense, IMHO), while '2' is debatable.
--
To view, visit https://gerrit.osmocom.org/c/osmo-sip-connector/+/35308?usp=email
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings
Gerrit-Project: osmo-sip-connector
Gerrit-Branch: master
Gerrit-Change-Id: Ie923117929c6b79b1eb61e5a9f02a169edabc599
Gerrit-Change-Number: 35308
Gerrit-PatchSet: 2
Gerrit-Owner: neels <nhofmeyr(a)sysmocom.de>
Gerrit-Reviewer: Jenkins Builder
Gerrit-Reviewer: laforge <laforge(a)osmocom.org>
Gerrit-Reviewer: pespin <pespin(a)sysmocom.de>
Gerrit-CC: fixeria <vyanitskiy(a)sysmocom.de>
Gerrit-Attention: neels <nhofmeyr(a)sysmocom.de>
Gerrit-Attention: fixeria <vyanitskiy(a)sysmocom.de>
Gerrit-Attention: pespin <pespin(a)sysmocom.de>
Gerrit-Comment-Date: Sun, 17 Dec 2023 10:45:31 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Comment-In-Reply-To: fixeria <vyanitskiy(a)sysmocom.de>
Comment-In-Reply-To: pespin <pespin(a)sysmocom.de>
Gerrit-MessageType: comment
Attention is currently required from: fixeria, neels.
laforge has posted comments on this change. ( https://gerrit.osmocom.org/c/libosmocore/+/35312?usp=email )
Change subject: utils: fix OSMO_STRBUF_REMAIN to handle sb.pos == NULL correctly
......................................................................
Patch Set 1:
(1 comment)
File include/osmocom/core/utils.h:
https://gerrit.osmocom.org/c/libosmocore/+/35312/comment/230870b1_dad5ec7e
PS1, Line 284: /*! Get remaining space for characters and terminating nul in the given struct osmo_strbuf.
> I'd expect the linker will throw out any unused functions anyway. […]
Note that my comment doesn's take a position on whether or not it should be an inline function. I'm just saying repeat compilation + drop by linker if unneeded is not a problem.
--
To view, visit https://gerrit.osmocom.org/c/libosmocore/+/35312?usp=email
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings
Gerrit-Project: libosmocore
Gerrit-Branch: master
Gerrit-Change-Id: I294a74a99c40995cf7fb5520d61f697d967be5a4
Gerrit-Change-Number: 35312
Gerrit-PatchSet: 1
Gerrit-Owner: fixeria <vyanitskiy(a)sysmocom.de>
Gerrit-Reviewer: Jenkins Builder
Gerrit-Reviewer: laforge <laforge(a)osmocom.org>
Gerrit-Reviewer: neels <nhofmeyr(a)sysmocom.de>
Gerrit-Reviewer: pespin <pespin(a)sysmocom.de>
Gerrit-Attention: neels <nhofmeyr(a)sysmocom.de>
Gerrit-Attention: fixeria <vyanitskiy(a)sysmocom.de>
Gerrit-Comment-Date: Sun, 17 Dec 2023 10:43:27 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Comment-In-Reply-To: neels <nhofmeyr(a)sysmocom.de>
Comment-In-Reply-To: laforge <laforge(a)osmocom.org>
Gerrit-MessageType: comment
Attention is currently required from: fixeria, neels.
laforge has posted comments on this change. ( https://gerrit.osmocom.org/c/libosmocore/+/35313?usp=email )
Change subject: utils: improve readability of OSMO_STRBUF_CHAR_COUNT
......................................................................
Patch Set 1: Code-Review+1
(1 comment)
File include/osmocom/core/utils.h:
https://gerrit.osmocom.org/c/libosmocore/+/35313/comment/22efcc37_d97d3068
PS1, Line 300: /*! Get number of actual characters (without terminating nul) in the given struct osmo_strbuf.
> (same as prev patch, maybe just normal function in utils. […]
I'd expect the linker will throw out any unused functions anyway. So I don't seee any problem/overhead at runtime.
Optimization for compile speed is not a goal.
--
To view, visit https://gerrit.osmocom.org/c/libosmocore/+/35313?usp=email
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings
Gerrit-Project: libosmocore
Gerrit-Branch: master
Gerrit-Change-Id: I71f24b87c13fd83952029171a6993f8da5e32e5b
Gerrit-Change-Number: 35313
Gerrit-PatchSet: 1
Gerrit-Owner: fixeria <vyanitskiy(a)sysmocom.de>
Gerrit-Reviewer: Jenkins Builder
Gerrit-Reviewer: laforge <laforge(a)osmocom.org>
Gerrit-Reviewer: neels <nhofmeyr(a)sysmocom.de>
Gerrit-Reviewer: pespin <pespin(a)sysmocom.de>
Gerrit-Attention: neels <nhofmeyr(a)sysmocom.de>
Gerrit-Attention: fixeria <vyanitskiy(a)sysmocom.de>
Gerrit-Comment-Date: Sun, 17 Dec 2023 10:42:15 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: Yes
Comment-In-Reply-To: neels <nhofmeyr(a)sysmocom.de>
Gerrit-MessageType: comment