Attention is currently required from: laforge, pespin.
fixeria has posted comments on this change. ( https://gerrit.osmocom.org/c/libosmo-sccp/+/35796?usp=email )
Change subject: Implement M3UA-over-TCP (in addition to SCTP)
......................................................................
Patch Set 1:
(6 comments)
Patchset:
PS1:
> I wonder whether we really want to add/maintain a "OSMO_SS7_ASP_PROT_M3UA_TCP" type ...
I am open for suggestions. I see nothing wrong with adding a new `OSMO_SS7_ASP_PROT_*` entry, because it's more linear and comfortable to use than additionally having to check for some boolean flag across the structure(s). This also let's the VTY users to select M3UA-over-TCP using the existing VTY command(s). Adding a boolean flag means adding more VTY commands (not just one) for selecting the transport, which would only apply to `OSMO_SS7_ASP_PROT_M3UA`.
File src/osmo_ss7_vty.c:
https://gerrit.osmocom.org/c/libosmo-sccp/+/35796/comment/5a4be849_33f8b54e
PS1, Line 62: "MTP3 User Adaptation (SCTP)\n" \
> As mentioned in earlier patches, you can remove the "SCTP" stuff. […]
IMO, it does not hurt to clarify in command documentation which option of the two with similar names is using which transport.
https://gerrit.osmocom.org/c/libosmo-sccp/+/35796/comment/abfcda5a_2803213a
PS1, Line 1994: "Display all M3UA (SCTP and TCP) ASs\n"
> drop "SCTP and TCP".
Likewise here, I wanted to make it clear that all M3UA entries are shown, not only those using SCTP as the transport. Because in other commands `m3ua` means M3UA-over-SCTP, and it may be confusing to those using SCTP-over-TCP.
https://gerrit.osmocom.org/c/libosmo-sccp/+/35796/comment/c8a1948c_499a1666
PS1, Line 2013: if (filter && !strcmp(filter, "m3ua")) {
> sounds like this can be moved into a "bool only_m3ua" out of the loop. […]
Sounds like it, but should I really spend more time optimizing this code path?
File src/osmo_ss7_xua_srv.c:
https://gerrit.osmocom.org/c/libosmo-sccp/+/35796/comment/c9a5ee4c_9ed5b640
PS1, Line 168: if (ss7_asp_proto_to_ip_proto(asp->cfg.proto) == IPPROTO_SCTP) {
> you wanna name this probably "ss7_asp_proto_to_ipproto" (see "ipproto" instead of "ip_proto")
Why would I name something that already exists? So you suggest to rename existing API? Sounds like a purely cosmetic change to me, which is not directly related to this patch.
File src/xua_rkm.c:
https://gerrit.osmocom.org/c/libosmo-sccp/+/35796/comment/cb772cc9_058a008f
PS1, Line 240: M3UA-over-SCTP or M3UA-over-TCP? Can we use asp->cfg.proto maybe?
> I'd keep the usual one to mean sctp, and probably add something else for tcp.
The question here is not whether we leave `OSMO_SS7_ASP_PROT_*` unchanged and add a boolean flag. It's a more fundamental question why are we hard-coding M3UA here, while there can also be XUA and IPA. I am not familiar with the code base, so I am asking for clarification. I can only guess that dynamic RKM allow is only allowed for M3UA?
--
To view, visit https://gerrit.osmocom.org/c/libosmo-sccp/+/35796?usp=email
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings
Gerrit-Project: libosmo-sccp
Gerrit-Branch: master
Gerrit-Change-Id: I8c76d271472befacbeb998a93bbdc9e8660d9b5d
Gerrit-Change-Number: 35796
Gerrit-PatchSet: 1
Gerrit-Owner: fixeria <vyanitskiy(a)sysmocom.de>
Gerrit-Reviewer: Jenkins Builder
Gerrit-Reviewer: laforge <laforge(a)osmocom.org>
Gerrit-Reviewer: pespin <pespin(a)sysmocom.de>
Gerrit-Attention: laforge <laforge(a)osmocom.org>
Gerrit-Attention: pespin <pespin(a)sysmocom.de>
Gerrit-Comment-Date: Sat, 03 Feb 2024 10:28:44 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Comment-In-Reply-To: pespin <pespin(a)sysmocom.de>
Comment-In-Reply-To: fixeria <vyanitskiy(a)sysmocom.de>
Gerrit-MessageType: comment
Attention is currently required from: fixeria, laforge.
pespin has posted comments on this change. ( https://gerrit.osmocom.org/c/libosmo-sccp/+/35796?usp=email )
Change subject: Implement M3UA-over-TCP (in addition to SCTP)
......................................................................
Patch Set 1:
(7 comments)
Patchset:
PS1:
I wonder whether we really want to add/maintain a "OSMO_SS7_ASP_PROT_M3UA_TCP" type, or whether both tcp and sctp should be "OSMO_SS7_ASP_PROT_M3UA" and maybe add a boolean/int ipproto in the asp object which really specified the detail about the transport protocol used beneath it.
Otherwise you are mixing layers there for no good reason?
File src/osmo_ss7_asp.c:
https://gerrit.osmocom.org/c/libosmo-sccp/+/35796/comment/4caed6c8_590b0afa
PS1, Line 853: ss7_asp_m3ua_tcp_srv_conn_cb
> This function is 90% identical to `m3ua_tcp_cli_read_cb()`. […]
You can move most of it to a m3ua_tcp_asp_read_cb(struct osmo_ss7_asp *asp) and use asp->is_server to do the different stuff in the same function.
File src/osmo_ss7_vty.c:
https://gerrit.osmocom.org/c/libosmo-sccp/+/35796/comment/cbab4302_314af15e
PS1, Line 62: "MTP3 User Adaptation (SCTP)\n" \
As mentioned in earlier patches, you can remove the "SCTP" stuff.
"Maybe use for the other one: MTP3 User Adaptation (over TCP)".
https://gerrit.osmocom.org/c/libosmo-sccp/+/35796/comment/59043139_afe10b9a
PS1, Line 1994: "Display all M3UA (SCTP and TCP) ASs\n"
drop "SCTP and TCP".
https://gerrit.osmocom.org/c/libosmo-sccp/+/35796/comment/7eceb507_20b5cfa1
PS1, Line 2013: if (filter && !strcmp(filter, "m3ua")) {
sounds like this can be moved into a "bool only_m3ua" out of the loop. Will make te code clear and avoid calling it each time.
File src/osmo_ss7_xua_srv.c:
https://gerrit.osmocom.org/c/libosmo-sccp/+/35796/comment/7f86f4b7_f1117cb5
PS1, Line 168: if (ss7_asp_proto_to_ip_proto(asp->cfg.proto) == IPPROTO_SCTP) {
you wanna name this probably "ss7_asp_proto_to_ipproto" (see "ipproto" instead of "ip_proto")
File src/xua_rkm.c:
https://gerrit.osmocom.org/c/libosmo-sccp/+/35796/comment/c1765494_a08fe3fe
PS1, Line 240: M3UA-over-SCTP or M3UA-over-TCP? Can we use asp->cfg.proto maybe?
> @laforge@osmocom.org your feedback would be welcome here.
I'd keep the usual one to mean sctp, and probably add something else for tcp.
--
To view, visit https://gerrit.osmocom.org/c/libosmo-sccp/+/35796?usp=email
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings
Gerrit-Project: libosmo-sccp
Gerrit-Branch: master
Gerrit-Change-Id: I8c76d271472befacbeb998a93bbdc9e8660d9b5d
Gerrit-Change-Number: 35796
Gerrit-PatchSet: 1
Gerrit-Owner: fixeria <vyanitskiy(a)sysmocom.de>
Gerrit-Reviewer: Jenkins Builder
Gerrit-Reviewer: laforge <laforge(a)osmocom.org>
Gerrit-Reviewer: pespin <pespin(a)sysmocom.de>
Gerrit-Attention: laforge <laforge(a)osmocom.org>
Gerrit-Attention: fixeria <vyanitskiy(a)sysmocom.de>
Gerrit-Comment-Date: Sat, 03 Feb 2024 01:36:37 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Comment-In-Reply-To: fixeria <vyanitskiy(a)sysmocom.de>
Gerrit-MessageType: comment
Attention is currently required from: fixeria, laforge.
pespin has posted comments on this change. ( https://gerrit.osmocom.org/c/libosmo-sccp/+/35795?usp=email )
Change subject: cosmetic: rename OSMO_SS7_ASP_PROT_M3UA[_SCTP]
......................................................................
Patch Set 1:
(2 comments)
Patchset:
PS1:
I think this patch can be actually dropped?
File examples/sccp_demo_user.c:
https://gerrit.osmocom.org/c/libosmo-sccp/+/35795/comment/ecabf819_81bc8ba9
PS1, Line 188: enum osmo_ss7_asp_protocol protocol = OSMO_SS7_ASP_PROT_M3UA_SCTP;
I'd leave the existing proto as it is, since the regular one is expected to be over SCTP.
--
To view, visit https://gerrit.osmocom.org/c/libosmo-sccp/+/35795?usp=email
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings
Gerrit-Project: libosmo-sccp
Gerrit-Branch: master
Gerrit-Change-Id: Ife0ae7a4956980da40ee045b0b7eb5cd0ccd1aef
Gerrit-Change-Number: 35795
Gerrit-PatchSet: 1
Gerrit-Owner: fixeria <vyanitskiy(a)sysmocom.de>
Gerrit-Reviewer: Jenkins Builder
Gerrit-Reviewer: laforge <laforge(a)osmocom.org>
Gerrit-CC: pespin <pespin(a)sysmocom.de>
Gerrit-Attention: laforge <laforge(a)osmocom.org>
Gerrit-Attention: fixeria <vyanitskiy(a)sysmocom.de>
Gerrit-Comment-Date: Sat, 03 Feb 2024 01:20:29 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Gerrit-MessageType: comment
Attention is currently required from: fixeria, laforge.
pespin has posted comments on this change. ( https://gerrit.osmocom.org/c/osmo-bsc/+/35791?usp=email )
Change subject: abis_nm: fix -Wunused-but-set-variable (bug)
......................................................................
Patch Set 2:
(2 comments)
File src/osmo-bsc/abis_nm.c:
https://gerrit.osmocom.org/c/osmo-bsc/+/35791/comment/f17f796b_ed559ed9
PS2, Line 2168: const uint8_t *attr, int attr_len)
what about converting attr_len to 0? it makes no sense to have a negative len to start with....
https://gerrit.osmocom.org/c/osmo-bsc/+/35791/comment/4706e235_c15c43f4
PS2, Line 2175: if (attr_len < 0)
and using unsigned, then suddently this is not needed.
--
To view, visit https://gerrit.osmocom.org/c/osmo-bsc/+/35791?usp=email
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings
Gerrit-Project: osmo-bsc
Gerrit-Branch: master
Gerrit-Change-Id: I3ca8e761fdf99dd498a979ccc9d53c6c3e03e2cc
Gerrit-Change-Number: 35791
Gerrit-PatchSet: 2
Gerrit-Owner: fixeria <vyanitskiy(a)sysmocom.de>
Gerrit-Reviewer: Jenkins Builder
Gerrit-CC: laforge <laforge(a)osmocom.org>
Gerrit-CC: pespin <pespin(a)sysmocom.de>
Gerrit-Attention: laforge <laforge(a)osmocom.org>
Gerrit-Attention: fixeria <vyanitskiy(a)sysmocom.de>
Gerrit-Comment-Date: Sat, 03 Feb 2024 01:18:45 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Gerrit-MessageType: comment
Attention is currently required from: laforge, pespin.
fixeria has posted comments on this change. ( https://gerrit.osmocom.org/c/libosmo-sccp/+/35796?usp=email )
Change subject: Implement M3UA-over-TCP (in addition to SCTP)
......................................................................
Patch Set 1:
(2 comments)
File src/osmo_ss7_asp.c:
https://gerrit.osmocom.org/c/libosmo-sccp/+/35796/comment/64440ba2_a564468f
PS1, Line 853: ss7_asp_m3ua_tcp_srv_conn_cb
This function is 90% identical to `m3ua_tcp_cli_read_cb()`.
I would of course like to reduce code duplication.
Suggestions are welcome!
File src/xua_rkm.c:
https://gerrit.osmocom.org/c/libosmo-sccp/+/35796/comment/5572ab10_6745cc88
PS1, Line 240: M3UA-over-SCTP or M3UA-over-TCP? Can we use asp->cfg.proto maybe?
@laforge@osmocom.org your feedback would be welcome here.
--
To view, visit https://gerrit.osmocom.org/c/libosmo-sccp/+/35796?usp=email
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings
Gerrit-Project: libosmo-sccp
Gerrit-Branch: master
Gerrit-Change-Id: I8c76d271472befacbeb998a93bbdc9e8660d9b5d
Gerrit-Change-Number: 35796
Gerrit-PatchSet: 1
Gerrit-Owner: fixeria <vyanitskiy(a)sysmocom.de>
Gerrit-Reviewer: Jenkins Builder
Gerrit-Reviewer: laforge <laforge(a)osmocom.org>
Gerrit-Reviewer: pespin <pespin(a)sysmocom.de>
Gerrit-Attention: laforge <laforge(a)osmocom.org>
Gerrit-Attention: pespin <pespin(a)sysmocom.de>
Gerrit-Comment-Date: Sat, 03 Feb 2024 00:01:41 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Gerrit-MessageType: comment