Attention is currently required from: dexter, laforge.
Hello Jenkins Builder, dexter, jolly,
I'd like you to reexamine a change. Please visit
https://gerrit.osmocom.org/c/osmo-mgw/+/36142?usp=email
to look at the new patch set (#2).
The following approvals got outdated and were removed:
Code-Review+1 by dexter, Verified+1 by Jenkins Builder, Verified+1 by dexter
Change subject: migrate mgcp_client from osmo_wqueue to osmo_io
......................................................................
migrate mgcp_client from osmo_wqueue to osmo_io
The new osmo_io framework means that we can [optionally] make use
of the io_uring backend, which greatly reduces the syscall load
compared to the legacy osmo_wqueue + osmo_select_main + read/write.
We only use features already present in the intiial osmo_io support
of libosmocore 1.9.0, so no entry in TODO-RELEASE is needed.
Closes: OS#5754
Related: OS#5755
Change-Id: I766224da4691695c023d4d08d042a4bbeba05e47
---
M include/osmocom/mgcp_client/mgcp_client_internal.h
M src/libosmo-mgcp-client/mgcp_client.c
M src/libosmo-mgcp-client/mgcp_client_vty.c
3 files changed, 75 insertions(+), 55 deletions(-)
git pull ssh://gerrit.osmocom.org:29418/osmo-mgw refs/changes/42/36142/2
--
To view, visit https://gerrit.osmocom.org/c/osmo-mgw/+/36142?usp=email
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings
Gerrit-Project: osmo-mgw
Gerrit-Branch: master
Gerrit-Change-Id: I766224da4691695c023d4d08d042a4bbeba05e47
Gerrit-Change-Number: 36142
Gerrit-PatchSet: 2
Gerrit-Owner: laforge <laforge(a)osmocom.org>
Gerrit-Reviewer: Jenkins Builder
Gerrit-Reviewer: dexter <pmaier(a)sysmocom.de>
Gerrit-Reviewer: jolly <andreas(a)eversberg.eu>
Gerrit-Attention: laforge <laforge(a)osmocom.org>
Gerrit-Attention: dexter <pmaier(a)sysmocom.de>
Gerrit-MessageType: newpatchset
Attention is currently required from: pespin.
laforge has posted comments on this change. ( https://gerrit.osmocom.org/c/osmo-hnbgw/+/36081?usp=email )
Change subject: Introduce concept of per-HNB persistent data structure
......................................................................
Patch Set 3:
(1 comment)
File src/osmo-hnbgw/hnbgw_vty.c:
https://gerrit.osmocom.org/c/osmo-hnbgw/+/36081/comment/0aabdb1d_8b2ff2a6
PS2, Line 825: "hnb UMTS_CELL_ID",
> Also not blocking, but I have to say I'm not really liking this concept of "persistent structure" you are adding. I'd probably go for something more similar to what we do with ASPs in libosmo-sccp. The same structure is used to handle everything related to that entity, and if it is dynamically created then a "hnb->dynamic=true" is added to it, so that it is not written back to the config file.
I actually like the approach here. Sure, one can rename structures to improve naming if that's a concern. But fundamentally the persistent ddata like counters is different from the dynamic (connection) part. I see no reason to mix those two.
btw: in libosmo-sigtran the dynamic ASP is also gone after it has disconnected, therefore no persistent counters. So it's not a solution.
Having another syntax to enter the hnb node on the VTY is fine with me, and one can even have multiple different formats to do that. But let's focus on the important part of implementing the persistent counters/statistics first.
--
To view, visit https://gerrit.osmocom.org/c/osmo-hnbgw/+/36081?usp=email
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings
Gerrit-Project: osmo-hnbgw
Gerrit-Branch: master
Gerrit-Change-Id: Ife89a7a206836bd89334d19d3cf8c92969dd74de
Gerrit-Change-Number: 36081
Gerrit-PatchSet: 3
Gerrit-Owner: laforge <laforge(a)osmocom.org>
Gerrit-Reviewer: Jenkins Builder
Gerrit-CC: pespin <pespin(a)sysmocom.de>
Gerrit-Attention: pespin <pespin(a)sysmocom.de>
Gerrit-Comment-Date: Thu, 07 Mar 2024 18:42:41 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Comment-In-Reply-To: laforge <laforge(a)osmocom.org>
Comment-In-Reply-To: pespin <pespin(a)sysmocom.de>
Gerrit-MessageType: comment
Attention is currently required from: laforge.
pespin has posted comments on this change. ( https://gerrit.osmocom.org/c/osmo-hnbgw/+/36081?usp=email )
Change subject: Introduce concept of per-HNB persistent data structure
......................................................................
Patch Set 3:
(1 comment)
File src/osmo-hnbgw/hnbgw_vty.c:
https://gerrit.osmocom.org/c/osmo-hnbgw/+/36081/comment/f3321b40_0d19a3ec
PS2, Line 825: "hnb UMTS_CELL_ID",
> Ack fine then. […]
Extra bonus for using several VTY parameters: You can specify the cmd so that it accepts both hex and dec format for any field.
--
To view, visit https://gerrit.osmocom.org/c/osmo-hnbgw/+/36081?usp=email
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings
Gerrit-Project: osmo-hnbgw
Gerrit-Branch: master
Gerrit-Change-Id: Ife89a7a206836bd89334d19d3cf8c92969dd74de
Gerrit-Change-Number: 36081
Gerrit-PatchSet: 3
Gerrit-Owner: laforge <laforge(a)osmocom.org>
Gerrit-Reviewer: Jenkins Builder
Gerrit-CC: pespin <pespin(a)sysmocom.de>
Gerrit-Attention: laforge <laforge(a)osmocom.org>
Gerrit-Comment-Date: Thu, 07 Mar 2024 18:02:36 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Comment-In-Reply-To: laforge <laforge(a)osmocom.org>
Comment-In-Reply-To: pespin <pespin(a)sysmocom.de>
Gerrit-MessageType: comment
Attention is currently required from: laforge.
pespin has posted comments on this change. ( https://gerrit.osmocom.org/c/osmo-hnbgw/+/36083?usp=email )
Change subject: Various new per-hnb RANAP and RUA counters
......................................................................
Patch Set 3: Code-Review+1
--
To view, visit https://gerrit.osmocom.org/c/osmo-hnbgw/+/36083?usp=email
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings
Gerrit-Project: osmo-hnbgw
Gerrit-Branch: master
Gerrit-Change-Id: I61bd4f51ec88fd93d8640d39228ac85f5ac5b69b
Gerrit-Change-Number: 36083
Gerrit-PatchSet: 3
Gerrit-Owner: laforge <laforge(a)osmocom.org>
Gerrit-Reviewer: Jenkins Builder
Gerrit-Reviewer: pespin <pespin(a)sysmocom.de>
Gerrit-Attention: laforge <laforge(a)osmocom.org>
Gerrit-Comment-Date: Thu, 07 Mar 2024 18:00:45 +0000
Gerrit-HasComments: No
Gerrit-Has-Labels: Yes
Gerrit-MessageType: comment
Attention is currently required from: laforge.
pespin has posted comments on this change. ( https://gerrit.osmocom.org/c/osmo-hnbgw/+/36082?usp=email )
Change subject: New per-hnb rate_ctr and stat_item groups; track uptime
......................................................................
Patch Set 3:
(1 comment)
Commit Message:
https://gerrit.osmocom.org/c/osmo-hnbgw/+/36082/comment/66ba0db6_3089ecec
PS3, Line 9: Let's asd a per-hnb rate_ctr and stat_item group. Only one initial
add
--
To view, visit https://gerrit.osmocom.org/c/osmo-hnbgw/+/36082?usp=email
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings
Gerrit-Project: osmo-hnbgw
Gerrit-Branch: master
Gerrit-Change-Id: I26d7c3657cdaf7c6ba5aa10a0677381ab099f8dd
Gerrit-Change-Number: 36082
Gerrit-PatchSet: 3
Gerrit-Owner: laforge <laforge(a)osmocom.org>
Gerrit-Reviewer: Jenkins Builder
Gerrit-CC: pespin <pespin(a)sysmocom.de>
Gerrit-Attention: laforge <laforge(a)osmocom.org>
Gerrit-Comment-Date: Thu, 07 Mar 2024 17:56:36 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Gerrit-MessageType: comment
Attention is currently required from: laforge.
pespin has posted comments on this change. ( https://gerrit.osmocom.org/c/osmo-hnbgw/+/36081?usp=email )
Change subject: Introduce concept of per-HNB persistent data structure
......................................................................
Patch Set 3:
(2 comments)
Patchset:
PS3:
I
File src/osmo-hnbgw/hnbgw_vty.c:
https://gerrit.osmocom.org/c/osmo-hnbgw/+/36081/comment/5a0ae855_8205f5d7
PS2, Line 825: "hnb UMTS_CELL_ID",
> the way we do it in the BSC was based around the idea that there is a 0-255 bts_nr, which in turn ha […]
Ack fine then. But the fact that xxx-yyy-Llac-Rrac-Ssac-Ccid needs to be passed as a string in VTY is a bit weird imho, since you are basically skipping the "vty parameter" functionality that VTY provides, which makes it easier for user to figure out each field by introspecting, etc.
Also not blocking, but I have to say I'm not really liking this concept of "persistent structure" you are adding. I'd probably go for something more similar to what we do with ASPs in libosmo-sccp. The same structure is used to handle everything related to that entity, and if it is dynamically created then a "hnb->dynamic=true" is added to it, so that it is not written back to the config file.
Maybe the problem is that we shouldn't be destroying the other structure upon reconnect, even for dynamic ones.
The difference is that dynamic ones become gone once the process exits.
Maybe the problem is that hnb_context should be renamed to hnb_conn and your persistent one be named hnb_context or simply "hnb".
--
To view, visit https://gerrit.osmocom.org/c/osmo-hnbgw/+/36081?usp=email
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings
Gerrit-Project: osmo-hnbgw
Gerrit-Branch: master
Gerrit-Change-Id: Ife89a7a206836bd89334d19d3cf8c92969dd74de
Gerrit-Change-Number: 36081
Gerrit-PatchSet: 3
Gerrit-Owner: laforge <laforge(a)osmocom.org>
Gerrit-Reviewer: Jenkins Builder
Gerrit-CC: pespin <pespin(a)sysmocom.de>
Gerrit-Attention: laforge <laforge(a)osmocom.org>
Gerrit-Comment-Date: Thu, 07 Mar 2024 17:54:42 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Comment-In-Reply-To: laforge <laforge(a)osmocom.org>
Comment-In-Reply-To: pespin <pespin(a)sysmocom.de>
Gerrit-MessageType: comment
laforge has posted comments on this change. ( https://gerrit.osmocom.org/c/osmo-hnbgw/+/36083?usp=email )
Change subject: Various new per-hnb RANAP and RUA counters
......................................................................
Set Ready For Review
--
To view, visit https://gerrit.osmocom.org/c/osmo-hnbgw/+/36083?usp=email
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings
Gerrit-Project: osmo-hnbgw
Gerrit-Branch: master
Gerrit-Change-Id: I61bd4f51ec88fd93d8640d39228ac85f5ac5b69b
Gerrit-Change-Number: 36083
Gerrit-PatchSet: 3
Gerrit-Owner: laforge <laforge(a)osmocom.org>
Gerrit-Reviewer: Jenkins Builder
Gerrit-Comment-Date: Thu, 07 Mar 2024 17:46:59 +0000
Gerrit-HasComments: No
Gerrit-Has-Labels: No
Gerrit-MessageType: comment
laforge has posted comments on this change. ( https://gerrit.osmocom.org/c/osmo-hnbgw/+/36082?usp=email )
Change subject: New per-hnb rate_ctr and stat_item groups; track uptime
......................................................................
Set Ready For Review
--
To view, visit https://gerrit.osmocom.org/c/osmo-hnbgw/+/36082?usp=email
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings
Gerrit-Project: osmo-hnbgw
Gerrit-Branch: master
Gerrit-Change-Id: I26d7c3657cdaf7c6ba5aa10a0677381ab099f8dd
Gerrit-Change-Number: 36082
Gerrit-PatchSet: 3
Gerrit-Owner: laforge <laforge(a)osmocom.org>
Gerrit-Reviewer: Jenkins Builder
Gerrit-Comment-Date: Thu, 07 Mar 2024 17:46:55 +0000
Gerrit-HasComments: No
Gerrit-Has-Labels: No
Gerrit-MessageType: comment
Attention is currently required from: pespin.
laforge has posted comments on this change. ( https://gerrit.osmocom.org/c/osmo-hnbgw/+/36081?usp=email )
Change subject: Introduce concept of per-HNB persistent data structure
......................................................................
Patch Set 3:
(1 comment)
File src/osmo-hnbgw/hnbgw_vty.c:
https://gerrit.osmocom.org/c/osmo-hnbgw/+/36081/comment/8ee08c8b_e745aa8d
PS2, Line 825: "hnb UMTS_CELL_ID",
> why doing it this way instead of doing it like in osmo-bsc? Just wondering, I'm fine with this too.
the way we do it in the BSC was based around the idea that there is a 0-255 bts_nr, which in turn has its basis in TS 12.21 OML. Here we don't have an equivalent to that. Any number/index we come up with is completely arbitrary.
So rather than inventing some new number that is not resembled anywhere, lets use something that appears in reality. That's either the umts cell identity, or the identity string sent during HNBAP register.
I originally had used the identity string in an earlier version of the patch, but during discussion with a customer I had to agree with them that the "UMTS CGI equivalent" is the better _primary key_, as it is unique for each cell in the network. The identity string of the hNodeB is something usually determined by the manufacturer, and it has no inherent meaning to the operator (like MAC-address derived strings, manufacturer serial numbers, ...)
--
To view, visit https://gerrit.osmocom.org/c/osmo-hnbgw/+/36081?usp=email
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings
Gerrit-Project: osmo-hnbgw
Gerrit-Branch: master
Gerrit-Change-Id: Ife89a7a206836bd89334d19d3cf8c92969dd74de
Gerrit-Change-Number: 36081
Gerrit-PatchSet: 3
Gerrit-Owner: laforge <laforge(a)osmocom.org>
Gerrit-Reviewer: Jenkins Builder
Gerrit-CC: pespin <pespin(a)sysmocom.de>
Gerrit-Attention: pespin <pespin(a)sysmocom.de>
Gerrit-Comment-Date: Thu, 07 Mar 2024 17:46:45 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Comment-In-Reply-To: pespin <pespin(a)sysmocom.de>
Gerrit-MessageType: comment