Attention is currently required from: osmith.
neels has posted comments on this change. ( https://gerrit.osmocom.org/c/osmo-hnbgw/+/36892?usp=email )
Change subject: add umts_cell_id_test.c
......................................................................
Patch Set 4:
(1 comment)
File tests/umts_cell_id/umts_cell_id_test.c:
https://gerrit.osmocom.org/c/osmo-hnbgw/+/36892/comment/bccda4de_bbf3d44c
PS4, Line 79: /* TODO? There is no bounds checking on RAC and SAC.
> do you want to keep this?
yes, it is a different "problem" in the current umts_cell_id implementation. I noticed while writing the test that we have no bounds checking there, but that's for a separate patch, and possibly not even a problem...
--
To view, visit https://gerrit.osmocom.org/c/osmo-hnbgw/+/36892?usp=email
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings
Gerrit-Project: osmo-hnbgw
Gerrit-Branch: master
Gerrit-Change-Id: Ibbb61a2c53a11dea794f451d3074bc9ba50862fe
Gerrit-Change-Number: 36892
Gerrit-PatchSet: 4
Gerrit-Owner: neels <nhofmeyr(a)sysmocom.de>
Gerrit-Reviewer: Jenkins Builder
Gerrit-Reviewer: osmith <osmith(a)sysmocom.de>
Gerrit-Attention: osmith <osmith(a)sysmocom.de>
Gerrit-Comment-Date: Thu, 06 Jun 2024 16:25:40 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Comment-In-Reply-To: osmith <osmith(a)sysmocom.de>
Gerrit-MessageType: comment
Attention is currently required from: laforge.
Hello Jenkins Builder,
I'd like you to reexamine a change. Please visit
https://gerrit.osmocom.org/c/osmocom-bb/+/36915?usp=email
to look at the new patch set (#3).
Change subject: trxcon/l1sched: refactor prim management in tx_tch[fh]_fn()
......................................................................
trxcon/l1sched: refactor prim management in tx_tch[fh]_fn()
The code path below the switch statement in tx_tch[fh]_fn() is no
longer common since we added CSD specific channel coding. This is
why we had to jump over it in several case statements.
This patch significantly reduces the number of goto statements
in these two functions and makes them easier to read/follow at
the price of code duplication, which is tolerable.
Change-Id: I5292abf6fcd308c9f7f12c7145d004103c9c7675
---
M src/host/trxcon/src/sched_lchan_tchf.c
M src/host/trxcon/src/sched_lchan_tchh.c
2 files changed, 87 insertions(+), 69 deletions(-)
git pull ssh://gerrit.osmocom.org:29418/osmocom-bb refs/changes/15/36915/3
--
To view, visit https://gerrit.osmocom.org/c/osmocom-bb/+/36915?usp=email
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings
Gerrit-Project: osmocom-bb
Gerrit-Branch: master
Gerrit-Change-Id: I5292abf6fcd308c9f7f12c7145d004103c9c7675
Gerrit-Change-Number: 36915
Gerrit-PatchSet: 3
Gerrit-Owner: fixeria <vyanitskiy(a)sysmocom.de>
Gerrit-Reviewer: Jenkins Builder
Gerrit-CC: laforge <laforge(a)osmocom.org>
Gerrit-Attention: laforge <laforge(a)osmocom.org>
Gerrit-MessageType: newpatchset
Attention is currently required from: fixeria, laforge, osmith.
Hello Jenkins Builder, laforge, osmith,
I'd like you to reexamine a change. Please visit
https://gerrit.osmocom.org/c/osmocom-bb/+/36914?usp=email
to look at the new patch set (#2).
The following approvals got outdated and were removed:
Code-Review+1 by laforge, Code-Review+1 by osmith
Change subject: trxcon/l1sched: make l1sched_lchan_emit_data_cnf() NULL-safe
......................................................................
trxcon/l1sched: make l1sched_lchan_emit_data_cnf() NULL-safe
Passing NULL to l1sched_lchan_emit_data_cnf() is not normal and
generally not expected, but definitely not fatal enough to abort
the process completely (due to assertion failure).
Change-Id: Ie64c176265f66a6c1515c66eb465d7e60f6768db
---
M src/host/trxcon/src/sched_prim.c
1 file changed, 15 insertions(+), 1 deletion(-)
git pull ssh://gerrit.osmocom.org:29418/osmocom-bb refs/changes/14/36914/2
--
To view, visit https://gerrit.osmocom.org/c/osmocom-bb/+/36914?usp=email
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings
Gerrit-Project: osmocom-bb
Gerrit-Branch: master
Gerrit-Change-Id: Ie64c176265f66a6c1515c66eb465d7e60f6768db
Gerrit-Change-Number: 36914
Gerrit-PatchSet: 2
Gerrit-Owner: fixeria <vyanitskiy(a)sysmocom.de>
Gerrit-Reviewer: Jenkins Builder
Gerrit-Reviewer: laforge <laforge(a)osmocom.org>
Gerrit-Reviewer: osmith <osmith(a)sysmocom.de>
Gerrit-Attention: osmith <osmith(a)sysmocom.de>
Gerrit-Attention: laforge <laforge(a)osmocom.org>
Gerrit-Attention: fixeria <vyanitskiy(a)sysmocom.de>
Gerrit-MessageType: newpatchset