Attention is currently required from: daniel, fixeria, laforge, lynxis lazus, pespin.
Hello Jenkins Builder, daniel, fixeria,
I'd like you to reexamine a change. Please visit
https://gerrit.osmocom.org/c/osmo-ttcn3-hacks/+/37646?usp=email
to look at the new patch set (#2).
The following approvals got outdated and were removed:
Code-Review+1 by fixeria, Verified+1 by Jenkins Builder
Change subject: sgsn: Introduce test TC_pmm_idle_rx_mt_data
......................................................................
sgsn: Introduce test TC_pmm_idle_rx_mt_data
Change-Id: I35d660b8e546f6ce0af8c05d7b5c56833a26fb76
---
M sgsn/BSSGP_ConnHdlr.ttcn
M sgsn/SGSN_Tests_Iu.ttcn
M sgsn/expected-results.xml
3 files changed, 75 insertions(+), 4 deletions(-)
git pull ssh://gerrit.osmocom.org:29418/osmo-ttcn3-hacks refs/changes/46/37646/2
--
To view, visit https://gerrit.osmocom.org/c/osmo-ttcn3-hacks/+/37646?usp=email
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings
Gerrit-Project: osmo-ttcn3-hacks
Gerrit-Branch: master
Gerrit-Change-Id: I35d660b8e546f6ce0af8c05d7b5c56833a26fb76
Gerrit-Change-Number: 37646
Gerrit-PatchSet: 2
Gerrit-Owner: pespin <pespin(a)sysmocom.de>
Gerrit-Reviewer: Jenkins Builder
Gerrit-Reviewer: daniel <dwillmann(a)sysmocom.de>
Gerrit-Reviewer: fixeria <vyanitskiy(a)sysmocom.de>
Gerrit-CC: laforge <laforge(a)osmocom.org>
Gerrit-CC: lynxis lazus <lynxis(a)fe80.eu>
Gerrit-Attention: laforge <laforge(a)osmocom.org>
Gerrit-Attention: fixeria <vyanitskiy(a)sysmocom.de>
Gerrit-Attention: pespin <pespin(a)sysmocom.de>
Gerrit-Attention: daniel <dwillmann(a)sysmocom.de>
Gerrit-Attention: lynxis lazus <lynxis(a)fe80.eu>
Gerrit-MessageType: newpatchset
osmith has posted comments on this change. ( https://gerrit.osmocom.org/c/osmo-ci/+/37633?usp=email )
Change subject: jobs/osmocom-depcheck: remove
......................................................................
Patch Set 1:
(1 comment)
Commit Message:
https://gerrit.osmocom.org/c/osmo-ci/+/37633/comment/a23c7d97_c1c45fde
PS1, Line 14: I thought this was used in the release
: process to make sure that e.g. programs that don't mention a new
: libosmocore in their TODO-RELEASE still build with the previous
: libosmocore. But what we actually do is just bump the required versions
: of the dependencies regardless
> this means our process is broken. […]
okay, created https://osmocom.org/issues/6513 to follow up with improving the release process
--
To view, visit https://gerrit.osmocom.org/c/osmo-ci/+/37633?usp=email
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings
Gerrit-Project: osmo-ci
Gerrit-Branch: master
Gerrit-Change-Id: I8b159ececaed86369fe272ae8a8bf0e88b0effa2
Gerrit-Change-Number: 37633
Gerrit-PatchSet: 1
Gerrit-Owner: osmith <osmith(a)sysmocom.de>
Gerrit-Reviewer: Jenkins Builder
Gerrit-Reviewer: laforge <laforge(a)osmocom.org>
Gerrit-Reviewer: pespin <pespin(a)sysmocom.de>
Gerrit-Comment-Date: Mon, 29 Jul 2024 08:33:28 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Comment-In-Reply-To: laforge <laforge(a)osmocom.org>
Gerrit-MessageType: comment
Attention is currently required from: fixeria, osmith.
pespin has posted comments on this change. ( https://gerrit.osmocom.org/c/osmo-ttcn3-hacks/+/37634?usp=email )
Change subject: Improve use of enumareted type GTP_Clause
......................................................................
Patch Set 1:
(1 comment)
File library/GTPv1C_Templates.ttcn:
https://gerrit.osmocom.org/c/osmo-ttcn3-hacks/+/37634/comment/0a080b5c_cdae…
PS1, Line 74: } with { encode "RAW"
:
> Is this really needed? doesn't `enum2int()` work without it?
I got a compilation error under some uses of this enum, and having the encode "RAW" fixed it. It may not be needed with final uses, but it doesn't hurt anyway.
--
To view, visit https://gerrit.osmocom.org/c/osmo-ttcn3-hacks/+/37634?usp=email
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings
Gerrit-Project: osmo-ttcn3-hacks
Gerrit-Branch: master
Gerrit-Change-Id: Ib071fa97a354cb27263cd46dba8f468b4ddc0018
Gerrit-Change-Number: 37634
Gerrit-PatchSet: 1
Gerrit-Owner: pespin <pespin(a)sysmocom.de>
Gerrit-Reviewer: Jenkins Builder
Gerrit-Reviewer: fixeria <vyanitskiy(a)sysmocom.de>
Gerrit-Reviewer: laforge <laforge(a)osmocom.org>
Gerrit-Reviewer: osmith <osmith(a)sysmocom.de>
Gerrit-Attention: osmith <osmith(a)sysmocom.de>
Gerrit-Attention: fixeria <vyanitskiy(a)sysmocom.de>
Gerrit-Comment-Date: Mon, 29 Jul 2024 08:29:53 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Comment-In-Reply-To: fixeria <vyanitskiy(a)sysmocom.de>
Gerrit-MessageType: comment
Attention is currently required from: fixeria.
pespin has posted comments on this change. ( https://gerrit.osmocom.org/c/osmo-ttcn3-hacks/+/37617?usp=email )
Change subject: sgsn: Introduce test TC_attach_pdp_act_pmm_idle
......................................................................
Patch Set 2:
(3 comments)
File sgsn/BSSGP_ConnHdlr.ttcn:
https://gerrit.osmocom.org/c/osmo-ttcn3-hacks/+/37617/comment/0c56b293_fac5…
PS2, Line 663: var RANAP_PDU ranap;
> unused
Ack
https://gerrit.osmocom.org/c/osmo-ttcn3-hacks/+/37617/comment/bc84fd05_493a…
PS2, Line 671: timer T := 5.0;
> you are not starting this timer?
Ack
https://gerrit.osmocom.org/c/osmo-ttcn3-hacks/+/37617/comment/1907e317_1e9c…
PS2, Line 784: var template Recovery_gtpc recovery := omit;
> It's always `omit` in this altstep, so just pass `omit` to `ts_GTPC_UpdatePdpRespGGSN`?
Ack
--
To view, visit https://gerrit.osmocom.org/c/osmo-ttcn3-hacks/+/37617?usp=email
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings
Gerrit-Project: osmo-ttcn3-hacks
Gerrit-Branch: master
Gerrit-Change-Id: Id46ccd9db11c8b792e1c071de91ef092ed1544c7
Gerrit-Change-Number: 37617
Gerrit-PatchSet: 2
Gerrit-Owner: pespin <pespin(a)sysmocom.de>
Gerrit-Reviewer: Jenkins Builder
Gerrit-Reviewer: fixeria <vyanitskiy(a)sysmocom.de>
Gerrit-Reviewer: laforge <laforge(a)osmocom.org>
Gerrit-Reviewer: osmith <osmith(a)sysmocom.de>
Gerrit-Reviewer: pespin <pespin(a)sysmocom.de>
Gerrit-Attention: fixeria <vyanitskiy(a)sysmocom.de>
Gerrit-Comment-Date: Mon, 29 Jul 2024 08:28:06 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Comment-In-Reply-To: fixeria <vyanitskiy(a)sysmocom.de>
Gerrit-MessageType: comment
Attention is currently required from: dexter.
fixeria has posted comments on this change. ( https://gerrit.osmocom.org/c/pysim/+/37643?usp=email )
Change subject: ara_m: add export support for the ARA-M application
......................................................................
Patch Set 1: Code-Review-1
(2 comments)
File pySim/ara_m.py:
https://gerrit.osmocom.org/c/pysim/+/37643/comment/9ebd59b3_ddd6a0de
PS1, Line 430: if res_do:
Too much nesting here, this is making the code harder to read/edit.
You can reduce it by inversing this condition and returning early.
You can also add a function for the inner loop body.
https://gerrit.osmocom.org/c/pysim/+/37643/comment/68c234fd_1c70ed59
PS1, Line 432: if 'response_all_ref_ar_do' in res_do_dict and res_do_dict['response_all_ref_ar_do']:
```
if not res_do_dict.get('response_all_ref_ar_do', False):
continue
```
--
To view, visit https://gerrit.osmocom.org/c/pysim/+/37643?usp=email
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings
Gerrit-Project: pysim
Gerrit-Branch: master
Gerrit-Change-Id: I811cb9d25cb8ee194b4ead5fb2cabf1fdc0c1c43
Gerrit-Change-Number: 37643
Gerrit-PatchSet: 1
Gerrit-Owner: dexter <pmaier(a)sysmocom.de>
Gerrit-Reviewer: Jenkins Builder
Gerrit-Reviewer: fixeria <vyanitskiy(a)sysmocom.de>
Gerrit-Attention: dexter <pmaier(a)sysmocom.de>
Gerrit-Comment-Date: Mon, 29 Jul 2024 08:21:51 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: Yes
Gerrit-MessageType: comment
Attention is currently required from: dexter.
fixeria has posted comments on this change. ( https://gerrit.osmocom.org/c/pysim/+/37641?usp=email )
Change subject: pySim-shell: enable export of DF and ADF files
......................................................................
Patch Set 1:
(1 comment)
File pySim-shell.py:
https://gerrit.osmocom.org/c/pysim/+/37641/comment/c4a04603_60af47ef
PS1, Line 651: include_df
let's stick to using dash in command line arguments
otherwise it's inconsistent with the existing arguments
--
To view, visit https://gerrit.osmocom.org/c/pysim/+/37641?usp=email
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings
Gerrit-Project: pysim
Gerrit-Branch: master
Gerrit-Change-Id: I3ee661dbae5c11fec23911775f352ac13bc2c6e5
Gerrit-Change-Number: 37641
Gerrit-PatchSet: 1
Gerrit-Owner: dexter <pmaier(a)sysmocom.de>
Gerrit-Reviewer: Jenkins Builder
Gerrit-CC: fixeria <vyanitskiy(a)sysmocom.de>
Gerrit-CC: laforge <laforge(a)osmocom.org>
Gerrit-Attention: dexter <pmaier(a)sysmocom.de>
Gerrit-Comment-Date: Mon, 29 Jul 2024 08:13:06 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Gerrit-MessageType: comment
Attention is currently required from: fixeria.
falconia has posted comments on this change. ( https://gerrit.osmocom.org/c/libosmocore/+/37558?usp=email )
Change subject: codec: add osmo_hr_sid_classify()
......................................................................
Patch Set 2:
(2 comments)
File src/codec/hr_sid_class.c:
https://gerrit.osmocom.org/c/libosmocore/+/37558/comment/817ad5f5_40c36ba5
PS2, Line 35: for (; byte; byte >>= 1) {
> This is absolutely fine for not so hot code paths, but if this is to be done for each byte of each R […]
Thanks for the recommendation - I will implement it in the next revision of this patch.
https://gerrit.osmocom.org/c/libosmocore/+/37558/comment/8839cf1e_7a40cc4c
PS2, Line 144: class1_ones = sid_field_ones - class2_ones;
> I am wondering if, in theory, `class2_ones` can be greater than `sid_field_ones`? […]
No, `class2_ones` can never be greater than `sid_field_ones` because the definition of SID field for HRv1 (GSM 06.22) includes all 17 class 2 bits plus some (62 out of 95) class 1 bits.
--
To view, visit https://gerrit.osmocom.org/c/libosmocore/+/37558?usp=email
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings
Gerrit-Project: libosmocore
Gerrit-Branch: master
Gerrit-Change-Id: I5f4eb65379646125b966cf182775b6e9348900bd
Gerrit-Change-Number: 37558
Gerrit-PatchSet: 2
Gerrit-Owner: falconia <falcon(a)freecalypso.org>
Gerrit-Reviewer: Jenkins Builder
Gerrit-Reviewer: laforge <laforge(a)osmocom.org>
Gerrit-CC: fixeria <vyanitskiy(a)sysmocom.de>
Gerrit-Attention: fixeria <vyanitskiy(a)sysmocom.de>
Gerrit-Comment-Date: Mon, 29 Jul 2024 08:12:34 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Comment-In-Reply-To: fixeria <vyanitskiy(a)sysmocom.de>
Gerrit-MessageType: comment