Attention is currently required from: neels.
laforge has posted comments on this change by neels. ( https://gerrit.osmocom.org/c/osmo-upf/+/37830?usp=email )
Change subject: add VTY 'gtp-echo' command
......................................................................
Patch Set 1: Code-Review+1
(1 comment)
File src/osmo-upf/upf_gtpu_echo.c:
https://gerrit.osmocom.org/c/osmo-upf/+/37830/comment/bc291ff2_34eb2e44?usp… :
PS1, Line 151: rc = sendto(dev->gtpv1.ofd.fd, msgbuf, GTP_ECHO_REQ_SIZE, 0, &remote->u.sa, sizeof(*remote));
this is introducing even more direct socket interaction without going through osmo_io. One can of course do that, but all of this code IMHO is lacking the use of abstractions. Why don't we have separate functions to encode/decode GTP-U packets, including the IEs? Why are we having low-level code to puzzle together a message header bit by bit and calling sendto in the same function? We're not using msgb, not osmo_io, and neither some kind of gtp-u custom abstraction. Yes, one can do all that, and it will work. but for osmo-*, it's unusual, IMHO. We usually build infrastructure/abstraction and then use that.
--
To view, visit https://gerrit.osmocom.org/c/osmo-upf/+/37830?usp=email
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings?usp=email
Gerrit-MessageType: comment
Gerrit-Project: osmo-upf
Gerrit-Branch: master
Gerrit-Change-Id: I970dccd7a27b098eea9e660822e24e2c4b059fc6
Gerrit-Change-Number: 37830
Gerrit-PatchSet: 1
Gerrit-Owner: neels <nhofmeyr(a)sysmocom.de>
Gerrit-Reviewer: Jenkins Builder
Gerrit-Reviewer: laforge <laforge(a)osmocom.org>
Gerrit-Attention: neels <nhofmeyr(a)sysmocom.de>
Gerrit-Comment-Date: Sat, 17 Aug 2024 05:16:43 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: Yes
Attention is currently required from: neels.
laforge has posted comments on this change by neels. ( https://gerrit.osmocom.org/c/osmo-upf/+/37827?usp=email )
Change subject: contrib/pfcp-tool-scripts: adjust tunend_session_est.vty and upf cfg to match up
......................................................................
Patch Set 1: Code-Review+1
--
To view, visit https://gerrit.osmocom.org/c/osmo-upf/+/37827?usp=email
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings?usp=email
Gerrit-MessageType: comment
Gerrit-Project: osmo-upf
Gerrit-Branch: master
Gerrit-Change-Id: I3d6a26b45f084c281887bee541cf01b690c9d1de
Gerrit-Change-Number: 37827
Gerrit-PatchSet: 1
Gerrit-Owner: neels <nhofmeyr(a)sysmocom.de>
Gerrit-Reviewer: Jenkins Builder
Gerrit-Reviewer: laforge <laforge(a)osmocom.org>
Gerrit-Attention: neels <nhofmeyr(a)sysmocom.de>
Gerrit-Comment-Date: Sat, 17 Aug 2024 05:09:40 +0000
Gerrit-HasComments: No
Gerrit-Has-Labels: Yes
Attention is currently required from: neels.
laforge has posted comments on this change by neels. ( https://gerrit.osmocom.org/c/osmo-upf/+/37826?usp=email )
Change subject: drop unreachable statement
......................................................................
Patch Set 1: Code-Review+1
(1 comment)
Patchset:
PS1:
lets hope this doesn't generate warnings in some compiler versions or coverity...
--
To view, visit https://gerrit.osmocom.org/c/osmo-upf/+/37826?usp=email
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings?usp=email
Gerrit-MessageType: comment
Gerrit-Project: osmo-upf
Gerrit-Branch: master
Gerrit-Change-Id: I0710fd0e38a5ce26ac532ab7150e285f171accfb
Gerrit-Change-Number: 37826
Gerrit-PatchSet: 1
Gerrit-Owner: neels <nhofmeyr(a)sysmocom.de>
Gerrit-Reviewer: Jenkins Builder
Gerrit-Reviewer: laforge <laforge(a)osmocom.org>
Gerrit-Attention: neels <nhofmeyr(a)sysmocom.de>
Gerrit-Comment-Date: Sat, 17 Aug 2024 05:09:22 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: Yes
Attention is currently required from: neels.
laforge has posted comments on this change by neels. ( https://gerrit.osmocom.org/c/osmo-upf/+/37825?usp=email )
Change subject: fix EXTRA_DIST for vty test scripts
......................................................................
Patch Set 1: Code-Review+1
--
To view, visit https://gerrit.osmocom.org/c/osmo-upf/+/37825?usp=email
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings?usp=email
Gerrit-MessageType: comment
Gerrit-Project: osmo-upf
Gerrit-Branch: master
Gerrit-Change-Id: If4dca81ce287ce1b1af32057634af912a8b89665
Gerrit-Change-Number: 37825
Gerrit-PatchSet: 1
Gerrit-Owner: neels <nhofmeyr(a)sysmocom.de>
Gerrit-Reviewer: Jenkins Builder
Gerrit-Reviewer: laforge <laforge(a)osmocom.org>
Gerrit-Attention: neels <nhofmeyr(a)sysmocom.de>
Gerrit-Comment-Date: Sat, 17 Aug 2024 05:08:46 +0000
Gerrit-HasComments: No
Gerrit-Has-Labels: Yes
Attention is currently required from: neels.
laforge has posted comments on this change by neels. ( https://gerrit.osmocom.org/c/osmo-upf/+/37824?usp=email )
Change subject: fix msgb memleak on GTP echo response
......................................................................
Patch Set 1: Code-Review+1
(1 comment)
File src/osmo-upf/upf_gtpu_echo.c:
https://gerrit.osmocom.org/c/osmo-upf/+/37824/comment/81f63d2f_8da0a9c0?usp… :
PS1, Line 91: sendto
this is of course a valid fix. Seeing all those hand-rolled socket operations, I'm wondering if it wouldn't make sense to migrate this over to osmo_io. For sure it's not a performance critical code path - but it would avoid having to manually have a read_cb, reading from the socket, etc.
--
To view, visit https://gerrit.osmocom.org/c/osmo-upf/+/37824?usp=email
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings?usp=email
Gerrit-MessageType: comment
Gerrit-Project: osmo-upf
Gerrit-Branch: master
Gerrit-Change-Id: I2bd2e9c57bf392074eed9628a69eb710d4e459a6
Gerrit-Change-Number: 37824
Gerrit-PatchSet: 1
Gerrit-Owner: neels <nhofmeyr(a)sysmocom.de>
Gerrit-Reviewer: Jenkins Builder
Gerrit-Reviewer: laforge <laforge(a)osmocom.org>
Gerrit-Attention: neels <nhofmeyr(a)sysmocom.de>
Gerrit-Comment-Date: Sat, 17 Aug 2024 05:08:30 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: Yes
Attention is currently required from: dexter, fixeria, laforge.
Hello Jenkins Builder, dexter, fixeria,
I'd like you to reexamine a change. Please visit
https://gerrit.osmocom.org/c/pysim/+/37835?usp=email
to look at the new patch set (#3).
The following approvals got outdated and were removed:
Verified-1 by Jenkins Builder
Change subject: pySim.esim.saip: Improve File.from_template feature support
......................................................................
pySim.esim.saip: Improve File.from_template feature support
When populating a File from a FileTemplate, let's make sure we
* correctly treat the maximum file size for BER-TLV files
* respect the default value pattern / repeat pattern
* respect the high_update flag.
Change-Id: I3ba092e0893f53a18264dff5fa37b12ccd9bd47e
---
M pySim/esim/saip/__init__.py
1 file changed, 20 insertions(+), 8 deletions(-)
git pull ssh://gerrit.osmocom.org:29418/pysim refs/changes/35/37835/3
--
To view, visit https://gerrit.osmocom.org/c/pysim/+/37835?usp=email
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings?usp=email
Gerrit-MessageType: newpatchset
Gerrit-Project: pysim
Gerrit-Branch: master
Gerrit-Change-Id: I3ba092e0893f53a18264dff5fa37b12ccd9bd47e
Gerrit-Change-Number: 37835
Gerrit-PatchSet: 3
Gerrit-Owner: laforge <laforge(a)osmocom.org>
Gerrit-Reviewer: Jenkins Builder
Gerrit-Reviewer: dexter <pmaier(a)sysmocom.de>
Gerrit-Reviewer: fixeria <vyanitskiy(a)sysmocom.de>
Gerrit-Attention: laforge <laforge(a)osmocom.org>
Gerrit-Attention: fixeria <vyanitskiy(a)sysmocom.de>
Gerrit-Attention: dexter <pmaier(a)sysmocom.de>
Attention is currently required from: dexter.
laforge has posted comments on this change by dexter. ( https://gerrit.osmocom.org/c/pysim/+/37839?usp=email )
Change subject: pySim-shell: prevent opening/closing logical channel 0
......................................................................
Patch Set 1:
(1 comment)
File pySim-shell.py:
https://gerrit.osmocom.org/c/pysim/+/37839/comment/31ffa4e8_7065ba14?usp=em… :
PS1, Line 974: raise RuntimeError("Cannot create (always existing) basic logical lchan 0")
Id'd have assumed raising a ValueError is more correct, as it's a wrong value. We might also handle this already at the argparse level by introducig a more specific 'type' than 'int'. This is what we do in the type=is_hexstr case.
We could have a is_lchan_nr method which checks for a valid number (not zero, not too high).
Handling those kind of things in argparse is more elegant, IMHO. It avoids open-coding checks all over the code.
--
To view, visit https://gerrit.osmocom.org/c/pysim/+/37839?usp=email
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings?usp=email
Gerrit-MessageType: comment
Gerrit-Project: pysim
Gerrit-Branch: master
Gerrit-Change-Id: I4eebd9f15fadd18e1caeb033fda36c59446fcab8
Gerrit-Change-Number: 37839
Gerrit-PatchSet: 1
Gerrit-Owner: dexter <pmaier(a)sysmocom.de>
Gerrit-Reviewer: Jenkins Builder
Gerrit-CC: laforge <laforge(a)osmocom.org>
Gerrit-Attention: dexter <pmaier(a)sysmocom.de>
Gerrit-Comment-Date: Fri, 16 Aug 2024 17:05:05 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No