Attention is currently required from: laforge, pespin.
Hello Jenkins Builder, laforge,
I'd like you to reexamine a change. Please visit
https://gerrit.osmocom.org/c/osmo-remsim/+/39021?usp=email
to look at the new patch set (#3).
The following approvals got outdated and were removed:
Code-Review-1 by laforge, Verified+1 by Jenkins Builder
Change subject: Remove rspro_client.c which is not used anyway
......................................................................
Remove rspro_client.c which is not used anyway
rspro_client.c was already removed ~6 years ago in
511c51313d4b1994eaa5faebcf01e8e24fb8b5a5, so those APIs where not really
implemented and hence used. Remove the header.
Related: OS#5896
Change-Id: I3bacae853101a79804553175ebd4482acb188597
---
M include/osmocom/rspro/Makefile.am
D include/osmocom/rspro/rspro_client.h
2 files changed, 0 insertions(+), 64 deletions(-)
git pull ssh://gerrit.osmocom.org:29418/osmo-remsim refs/changes/21/39021/3
--
To view, visit https://gerrit.osmocom.org/c/osmo-remsim/+/39021?usp=email
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings?usp=email
Gerrit-MessageType: newpatchset
Gerrit-Project: osmo-remsim
Gerrit-Branch: master
Gerrit-Change-Id: I3bacae853101a79804553175ebd4482acb188597
Gerrit-Change-Number: 39021
Gerrit-PatchSet: 3
Gerrit-Owner: pespin <pespin(a)sysmocom.de>
Gerrit-Reviewer: Jenkins Builder
Gerrit-Reviewer: laforge <laforge(a)osmocom.org>
Gerrit-Attention: laforge <laforge(a)osmocom.org>
Gerrit-Attention: pespin <pespin(a)sysmocom.de>
Attention is currently required from: laforge.
pespin has posted comments on this change by pespin. ( https://gerrit.osmocom.org/c/osmo-remsim/+/39020?usp=email )
Change subject: Makefile:am: Improve formatting and order of CFLAGS and LIBS
......................................................................
Patch Set 1:
(1 comment)
Patchset:
PS1:
> I would always have assumed the most generic comes first, and the more specific libraries later on. […]
Let me have a deeper look, maybe I did it the wrong way.
--
To view, visit https://gerrit.osmocom.org/c/osmo-remsim/+/39020?usp=email
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings?usp=email
Gerrit-MessageType: comment
Gerrit-Project: osmo-remsim
Gerrit-Branch: master
Gerrit-Change-Id: Ia766a09103d2216258a83cc98899e6cae4b0351d
Gerrit-Change-Number: 39020
Gerrit-PatchSet: 1
Gerrit-Owner: pespin <pespin(a)sysmocom.de>
Gerrit-Reviewer: Jenkins Builder
Gerrit-Reviewer: laforge <laforge(a)osmocom.org>
Gerrit-Attention: laforge <laforge(a)osmocom.org>
Gerrit-Comment-Date: Wed, 04 Dec 2024 12:58:38 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Comment-In-Reply-To: laforge <laforge(a)osmocom.org>
Attention is currently required from: fixeria.
pespin has posted comments on this change by pespin. ( https://gerrit.osmocom.org/c/osmo-hlr/+/39006?usp=email )
Change subject: gsup_client: Avoid double memset 0
......................................................................
Patch Set 1:
(1 comment)
Patchset:
PS1:
> Not sure how a struct assignment works internally, but I remember that it's not guaranteed that padd […]
When I mean "all memory" I mean "all meaningful memory not consisting of padding". This doesn't change anyway the fact that memory in fields is set twice.
Why should I use talloc instead? It's common thing that we use talloc_zero and then set the non-zero fields.
TBH I don't see why are you setting a -1 here, it makes no sense to me and I plan to merge this in a while since I already got a +1 and a +2.
--
To view, visit https://gerrit.osmocom.org/c/osmo-hlr/+/39006?usp=email
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings?usp=email
Gerrit-MessageType: comment
Gerrit-Project: osmo-hlr
Gerrit-Branch: master
Gerrit-Change-Id: I66515fc893ffc64a36abedc01a75b57aed7e932d
Gerrit-Change-Number: 39006
Gerrit-PatchSet: 1
Gerrit-Owner: pespin <pespin(a)sysmocom.de>
Gerrit-Reviewer: Jenkins Builder
Gerrit-Reviewer: fixeria <vyanitskiy(a)sysmocom.de>
Gerrit-Reviewer: laforge <laforge(a)osmocom.org>
Gerrit-Reviewer: osmith <osmith(a)sysmocom.de>
Gerrit-Attention: fixeria <vyanitskiy(a)sysmocom.de>
Gerrit-Comment-Date: Wed, 04 Dec 2024 12:56:45 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Comment-In-Reply-To: fixeria <vyanitskiy(a)sysmocom.de>
Attention is currently required from: pespin.
fixeria has posted comments on this change by pespin. ( https://gerrit.osmocom.org/c/osmo-hlr/+/39006?usp=email )
Change subject: gsup_client: Avoid double memset 0
......................................................................
Patch Set 1:
(1 comment)
Patchset:
PS1:
> I don't like this change, TBH. […]
Not sure how a struct assignment works internally, but I remember that it's not guaranteed that padding between struct fields is zero'ed. So I guess it's not really resetting memory to zero.
--
To view, visit https://gerrit.osmocom.org/c/osmo-hlr/+/39006?usp=email
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings?usp=email
Gerrit-MessageType: comment
Gerrit-Project: osmo-hlr
Gerrit-Branch: master
Gerrit-Change-Id: I66515fc893ffc64a36abedc01a75b57aed7e932d
Gerrit-Change-Number: 39006
Gerrit-PatchSet: 1
Gerrit-Owner: pespin <pespin(a)sysmocom.de>
Gerrit-Reviewer: Jenkins Builder
Gerrit-Reviewer: laforge <laforge(a)osmocom.org>
Gerrit-Reviewer: osmith <osmith(a)sysmocom.de>
Gerrit-CC: fixeria <vyanitskiy(a)sysmocom.de>
Gerrit-Attention: pespin <pespin(a)sysmocom.de>
Gerrit-Comment-Date: Wed, 04 Dec 2024 11:33:15 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Comment-In-Reply-To: fixeria <vyanitskiy(a)sysmocom.de>
Attention is currently required from: pespin.
fixeria has posted comments on this change by pespin. ( https://gerrit.osmocom.org/c/osmo-hlr/+/39006?usp=email )
Change subject: gsup_client: Avoid double memset 0
......................................................................
Patch Set 1:
(1 comment)
Patchset:
PS1:
I don't like this change, TBH. Why not just changing `talloc_zero()` to `talloc`?
--
To view, visit https://gerrit.osmocom.org/c/osmo-hlr/+/39006?usp=email
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings?usp=email
Gerrit-MessageType: comment
Gerrit-Project: osmo-hlr
Gerrit-Branch: master
Gerrit-Change-Id: I66515fc893ffc64a36abedc01a75b57aed7e932d
Gerrit-Change-Number: 39006
Gerrit-PatchSet: 1
Gerrit-Owner: pespin <pespin(a)sysmocom.de>
Gerrit-Reviewer: Jenkins Builder
Gerrit-Reviewer: laforge <laforge(a)osmocom.org>
Gerrit-Reviewer: osmith <osmith(a)sysmocom.de>
Gerrit-CC: fixeria <vyanitskiy(a)sysmocom.de>
Gerrit-Attention: pespin <pespin(a)sysmocom.de>
Gerrit-Comment-Date: Wed, 04 Dec 2024 11:29:21 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Attention is currently required from: lynxis lazus.
fixeria has posted comments on this change by lynxis lazus. ( https://gerrit.osmocom.org/c/osmo-ttcn3-hacks/+/39011?usp=email )
Change subject: PCU_Tests_SNS: sns_del: check if removed NS-VC still transmits
......................................................................
Patch Set 1:
(2 comments)
File pcu/PCU_Tests_SNS.ttcn:
https://gerrit.osmocom.org/c/osmo-ttcn3-hacks/+/39011/comment/75231a20_18bb… :
PS1, Line 327: integer idx := 0, integer idx_del := 1, float tout := 20.0
What's the point of adding testcase parameters?
I am not sure if there is a way to pass any parameters when executing a testcase...
https://gerrit.osmocom.org/c/osmo-ttcn3-hacks/+/39011/comment/c969fc33_1570… :
PS1, Line 347: setverdict(fail, "Received unexpected NS-ALIVE ACK");
As the name suggests, `ax_rx_fail_on_any_ns()` already does `setverdict(fail, ...)` internally, so this additional `setverdict()` is redundant.
--
To view, visit https://gerrit.osmocom.org/c/osmo-ttcn3-hacks/+/39011?usp=email
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings?usp=email
Gerrit-MessageType: comment
Gerrit-Project: osmo-ttcn3-hacks
Gerrit-Branch: master
Gerrit-Change-Id: Ied4367a519cf75291ff8766c9efebb0f8a12b11f
Gerrit-Change-Number: 39011
Gerrit-PatchSet: 1
Gerrit-Owner: lynxis lazus <lynxis(a)fe80.eu>
Gerrit-Reviewer: Jenkins Builder
Gerrit-Reviewer: pespin <pespin(a)sysmocom.de>
Gerrit-CC: fixeria <vyanitskiy(a)sysmocom.de>
Gerrit-Attention: lynxis lazus <lynxis(a)fe80.eu>
Gerrit-Comment-Date: Wed, 04 Dec 2024 11:07:39 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No