Attention is currently required from: csaba.sipos, fixeria, laforge.
pespin has posted comments on this change by csaba.sipos. ( https://gerrit.osmocom.org/c/osmo-bsc/+/39416?usp=email )
Change subject: nokia_site: Add object_identity, object_state and object_identity_state attributes
......................................................................
Patch Set 11:
(3 comments)
File src/osmo-bsc/bts_nokia_site.c:
https://gerrit.osmocom.org/c/osmo-bsc/+/39416/comment/f7145f41_536483a2?usp… :
PS11, Line 1828: get_object_identity_string(object_id_state[4]), object_id_state[5], get_object_state_string(object_id_state[10]));
Please, as mentioned, keep lines belows 120chars, otherwise it's a mess. This is far more readable:
LOG_BTS(bts, DNM, LOGL_NOTICE, "State changed: %s=%d, %s\n",
get_object_identity_string(object_id_state[4]),
object_id_state[5],
get_object_state_string(object_id_state[10]));
https://gerrit.osmocom.org/c/osmo-bsc/+/39416/comment/8695f6f3_0ed66c31?usp… :
PS11, Line 1859: find_element(noh->data, len_data, NOKIA_EI_OBJ_STATE, &object_state, sizeof(object_state))
Again, all the indentation choices you are selecting here make it impossible to follow.
btw, did you think about adding a macro or a static inline function helper to make all this much more readable? Something like:
#define FIND_ELEM(data, data_len, ei, var) (find_element(data, data_len, ei, &var, sizeof(var)) == sizeof(var))
if (!FIND_ELEM(noh->data, len_data, NOKIA_EI_OBJ_ID, object_identity) ||
!FIND_ELEM(noh->data, len_data, NOKIA_EI_OBJ_STATE, object_state) {
if (!FIND_ELEM(noh->data, len_data, NOKIA_EI_OBJ_ID_STATE, object_id_state) {
LOG_BTS(bts, DNM, LOGL_NOTICE, "Missing NOKIA_EI_OBJ_ID & NOKIA_EI_OBJ_STATE or NOKIA_EI_OBJ_ID_STATE\n");
return -EINVAL;
}
object_identity[1] = object_id_state[4];
object_identity[2] = object_id_state[5];
object_state = object_id_state[10];
}
See how with a bit more thinking all this becomes much more readable imho.
You could even probably have all that in a separate function find_identity() and find_state(), which would check for both IEs internally.
https://gerrit.osmocom.org/c/osmo-bsc/+/39416/comment/e44f4877_37141021?usp… :
PS11, Line 1863: object_identity[1] = object_id_state[4];
so basically object_identity[0] is left uninitialized in this code path? same for object_identity[3]. Are those nose used? Then let's better have uint8_t identity and a uint8_t severity instead of half initializing some array.
--
To view, visit https://gerrit.osmocom.org/c/osmo-bsc/+/39416?usp=email
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings?usp=email
Gerrit-MessageType: comment
Gerrit-Project: osmo-bsc
Gerrit-Branch: master
Gerrit-Change-Id: Id9f819b0649ba3c247db72d7d738e49c72388dc3
Gerrit-Change-Number: 39416
Gerrit-PatchSet: 11
Gerrit-Owner: csaba.sipos <metro4(a)freemail.hu>
Gerrit-Reviewer: Jenkins Builder
Gerrit-Reviewer: fixeria <vyanitskiy(a)sysmocom.de>
Gerrit-Reviewer: laforge <laforge(a)osmocom.org>
Gerrit-Reviewer: pespin <pespin(a)sysmocom.de>
Gerrit-Attention: csaba.sipos <metro4(a)freemail.hu>
Gerrit-Attention: laforge <laforge(a)osmocom.org>
Gerrit-Attention: fixeria <vyanitskiy(a)sysmocom.de>
Gerrit-Comment-Date: Wed, 05 Feb 2025 20:06:35 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Attention is currently required from: csaba.sipos, fixeria, laforge, pespin.
Hello Jenkins Builder, fixeria, laforge, pespin,
I'd like you to reexamine a change. Please visit
https://gerrit.osmocom.org/c/osmo-bsc/+/39416?usp=email
to look at the new patch set (#11).
The following approvals got outdated and were removed:
Verified-1 by Jenkins Builder
Change subject: nokia_site: Add object_identity, object_state and object_identity_state attributes
......................................................................
nokia_site: Add object_identity, object_state and object_identity_state attributes
Note: these are cosmetic changes so far, the plan is to use them
in the future to finetune the Nokia OML and RSL bootstrap logic.
Thanks Domi for helping with the code!
Change-Id: Id9f819b0649ba3c247db72d7d738e49c72388dc3
---
M src/osmo-bsc/bts_nokia_site.c
1 file changed, 87 insertions(+), 21 deletions(-)
git pull ssh://gerrit.osmocom.org:29418/osmo-bsc refs/changes/16/39416/11
--
To view, visit https://gerrit.osmocom.org/c/osmo-bsc/+/39416?usp=email
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings?usp=email
Gerrit-MessageType: newpatchset
Gerrit-Project: osmo-bsc
Gerrit-Branch: master
Gerrit-Change-Id: Id9f819b0649ba3c247db72d7d738e49c72388dc3
Gerrit-Change-Number: 39416
Gerrit-PatchSet: 11
Gerrit-Owner: csaba.sipos <metro4(a)freemail.hu>
Gerrit-Reviewer: Jenkins Builder
Gerrit-Reviewer: fixeria <vyanitskiy(a)sysmocom.de>
Gerrit-Reviewer: laforge <laforge(a)osmocom.org>
Gerrit-Reviewer: pespin <pespin(a)sysmocom.de>
Gerrit-Attention: csaba.sipos <metro4(a)freemail.hu>
Gerrit-Attention: laforge <laforge(a)osmocom.org>
Gerrit-Attention: pespin <pespin(a)sysmocom.de>
Gerrit-Attention: fixeria <vyanitskiy(a)sysmocom.de>
Attention is currently required from: fixeria, laforge, pespin.
csaba.sipos has posted comments on this change by csaba.sipos. ( https://gerrit.osmocom.org/c/osmo-bsc/+/39416?usp=email )
Change subject: nokia_site: Add object_identity, object_state and object_identity_state attributes
......................................................................
Patch Set 10:
(3 comments)
Patchset:
PS9:
> I'm sorry to keep delaying merge of this, but I ask for simpel changes sometimes and then new versio […]
Apologies for that, but besides what you asked for, we also found an unhandled situation: the OBJ_ID_STATE was checked in the previous version for protocol compliance, but it was not mapped in case that message arrived instead of object_id + object_state. This last version fixed that.
File src/osmo-bsc/bts_nokia_site.c:
https://gerrit.osmocom.org/c/osmo-bsc/+/39416/comment/17172ad2_c6a24e5a?usp… :
PS9, Line 1857: if (find_element(noh->data, len_data, NOKIA_EI_OBJ_ID, object_identity, sizeof(object_identity)) != sizeof(object_identity) ||
> This is now tons of lines >120 chars (the maximum as per osmocom guidelines) and becomes unreadable […]
I fixed those lines (but it is even less readable now).
The reason for the convoluted if/else system is the protocol itself. There are some mandatory cross-dependent elements some optional cross-dependent elements, and they have to go to the same LOG_BTS lines eventually. To make this compact (instead of using even more if..else), this was the chosen solution.
https://gerrit.osmocom.org/c/osmo-bsc/+/39416/comment/26f85298_b6ffd30f?usp… :
PS9, Line 1858: find_element(noh->data, len_data, NOKIA_EI_OBJ_STATE, &object_state, sizeof(object_state)) != sizeof(object_state)) {
> this is not properly aligned to the line above.
Acknowledged
--
To view, visit https://gerrit.osmocom.org/c/osmo-bsc/+/39416?usp=email
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings?usp=email
Gerrit-MessageType: comment
Gerrit-Project: osmo-bsc
Gerrit-Branch: master
Gerrit-Change-Id: Id9f819b0649ba3c247db72d7d738e49c72388dc3
Gerrit-Change-Number: 39416
Gerrit-PatchSet: 10
Gerrit-Owner: csaba.sipos <metro4(a)freemail.hu>
Gerrit-Reviewer: Jenkins Builder
Gerrit-Reviewer: fixeria <vyanitskiy(a)sysmocom.de>
Gerrit-Reviewer: laforge <laforge(a)osmocom.org>
Gerrit-Reviewer: pespin <pespin(a)sysmocom.de>
Gerrit-Attention: laforge <laforge(a)osmocom.org>
Gerrit-Attention: pespin <pespin(a)sysmocom.de>
Gerrit-Attention: fixeria <vyanitskiy(a)sysmocom.de>
Gerrit-Comment-Date: Wed, 05 Feb 2025 18:37:10 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Comment-In-Reply-To: pespin <pespin(a)sysmocom.de>
Attention is currently required from: csaba.sipos, fixeria, laforge.
Hello Jenkins Builder, fixeria, laforge, pespin,
I'd like you to reexamine a change. Please visit
https://gerrit.osmocom.org/c/osmo-bsc/+/39416?usp=email
to look at the new patch set (#10).
The following approvals got outdated and were removed:
Verified+1 by Jenkins Builder
Change subject: nokia_site: Add object_identity, object_state and object_identity_state attributes
......................................................................
nokia_site: Add object_identity, object_state and object_identity_state attributes
Note: these are cosmetic changes so far, the plan is to use them
in the future to finetune the Nokia OML and RSL bootstrap logic.
Thanks Domi for helping with the code!
Change-Id: Id9f819b0649ba3c247db72d7d738e49c72388dc3
---
M src/osmo-bsc/bts_nokia_site.c
1 file changed, 87 insertions(+), 21 deletions(-)
git pull ssh://gerrit.osmocom.org:29418/osmo-bsc refs/changes/16/39416/10
--
To view, visit https://gerrit.osmocom.org/c/osmo-bsc/+/39416?usp=email
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings?usp=email
Gerrit-MessageType: newpatchset
Gerrit-Project: osmo-bsc
Gerrit-Branch: master
Gerrit-Change-Id: Id9f819b0649ba3c247db72d7d738e49c72388dc3
Gerrit-Change-Number: 39416
Gerrit-PatchSet: 10
Gerrit-Owner: csaba.sipos <metro4(a)freemail.hu>
Gerrit-Reviewer: Jenkins Builder
Gerrit-Reviewer: fixeria <vyanitskiy(a)sysmocom.de>
Gerrit-Reviewer: laforge <laforge(a)osmocom.org>
Gerrit-Reviewer: pespin <pespin(a)sysmocom.de>
Gerrit-Attention: csaba.sipos <metro4(a)freemail.hu>
Gerrit-Attention: laforge <laforge(a)osmocom.org>
Gerrit-Attention: fixeria <vyanitskiy(a)sysmocom.de>
Attention is currently required from: Hoernchen.
Hello Jenkins Builder,
I'd like you to reexamine a change. Please visit
https://gerrit.osmocom.org/c/osmo-asf4-dfu/+/39435?usp=email
to look at the new patch set (#10).
The following approvals got outdated and were removed:
Verified+1 by Jenkins Builder
Change subject: errata 2.6.10
......................................................................
errata 2.6.10
set wdt urow bits to ensure nvm cache is clear
Change-Id: Ifbc6a3dfe91462029fce50ed42f20440debaa552
---
M gcc/gcc/startup_same54.c
M hpl/nvmctrl/hpl_nvmctrl.c
M usb_flash_main.c
3 files changed, 25 insertions(+), 1 deletion(-)
git pull ssh://gerrit.osmocom.org:29418/osmo-asf4-dfu refs/changes/35/39435/10
--
To view, visit https://gerrit.osmocom.org/c/osmo-asf4-dfu/+/39435?usp=email
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings?usp=email
Gerrit-MessageType: newpatchset
Gerrit-Project: osmo-asf4-dfu
Gerrit-Branch: master
Gerrit-Change-Id: Ifbc6a3dfe91462029fce50ed42f20440debaa552
Gerrit-Change-Number: 39435
Gerrit-PatchSet: 10
Gerrit-Owner: Hoernchen <ewild(a)sysmocom.de>
Gerrit-Reviewer: Jenkins Builder
Gerrit-CC: laforge <laforge(a)osmocom.org>
Gerrit-Attention: Hoernchen <ewild(a)sysmocom.de>
Attention is currently required from: Hoernchen.
Hello Jenkins Builder, laforge,
I'd like you to reexamine a change. Please visit
https://gerrit.osmocom.org/c/osmo-asf4-dfu/+/39436?usp=email
to look at the new patch set (#10).
The following approvals got outdated and were removed:
Verified+1 by Jenkins Builder
The change is no longer submittable: Verified is unsatisfied now.
Change subject: contrib: add nvm urow parser ipynb
......................................................................
contrib: add nvm urow parser ipynb
Useful when dealing with the urow bits for wdt, bootprot, ..
Change-Id: I588838d7c33be24636e00cec65c3b485a486f747
---
A contrib/same54_urow.ipynb
1 file changed, 135 insertions(+), 0 deletions(-)
git pull ssh://gerrit.osmocom.org:29418/osmo-asf4-dfu refs/changes/36/39436/10
--
To view, visit https://gerrit.osmocom.org/c/osmo-asf4-dfu/+/39436?usp=email
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings?usp=email
Gerrit-MessageType: newpatchset
Gerrit-Project: osmo-asf4-dfu
Gerrit-Branch: master
Gerrit-Change-Id: I588838d7c33be24636e00cec65c3b485a486f747
Gerrit-Change-Number: 39436
Gerrit-PatchSet: 10
Gerrit-Owner: Hoernchen <ewild(a)sysmocom.de>
Gerrit-Reviewer: Jenkins Builder
Gerrit-Reviewer: laforge <laforge(a)osmocom.org>
Gerrit-Attention: Hoernchen <ewild(a)sysmocom.de>
pespin has uploaded this change for review. ( https://gerrit.osmocom.org/c/upf-benchmark/+/39472?usp=email )
Change subject: Remove unused envnvar calling osmo-upf
......................................................................
Remove unused envnvar calling osmo-upf
This is a copy-paste typo from eupf.
Change-Id: I81de16bfe28b800e04bdaaf9e27d51ecbec33dd5
---
M testsuites/gtplab-sysmo2017/tunend/upf/osmo-upf/run.sh
1 file changed, 1 insertion(+), 1 deletion(-)
git pull ssh://gerrit.osmocom.org:29418/upf-benchmark refs/changes/72/39472/1
diff --git a/testsuites/gtplab-sysmo2017/tunend/upf/osmo-upf/run.sh b/testsuites/gtplab-sysmo2017/tunend/upf/osmo-upf/run.sh
index 9dda226..a4951e9 100755
--- a/testsuites/gtplab-sysmo2017/tunend/upf/osmo-upf/run.sh
+++ b/testsuites/gtplab-sysmo2017/tunend/upf/osmo-upf/run.sh
@@ -2,7 +2,7 @@
SCRIPT_DIR=$( cd -- "$( dirname -- "${BASH_SOURCE[0]}" )" &> /dev/null && pwd )
-sudo GIN_MODE=release osmo-upf -c "$SCRIPT_DIR/osmo-upf.cfg"
+sudo osmo-upf -c "$SCRIPT_DIR/osmo-upf.cfg"
# TODO: Route needs to be set up manually on the tun iface once it becomes created, since osmo-upf is not yet doing it (OS#6585).
# For now, run this manually after starting osmo-upf with the current run.sh script:
--
To view, visit https://gerrit.osmocom.org/c/upf-benchmark/+/39472?usp=email
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings?usp=email
Gerrit-MessageType: newchange
Gerrit-Project: upf-benchmark
Gerrit-Branch: master
Gerrit-Change-Id: I81de16bfe28b800e04bdaaf9e27d51ecbec33dd5
Gerrit-Change-Number: 39472
Gerrit-PatchSet: 1
Gerrit-Owner: pespin <pespin(a)sysmocom.de>