pespin has posted comments on this change by pespin. ( https://gerrit.osmocom.org/c/osmo-hnbgw/+/39984?usp=email )
Change subject: Add function helper hnbgw_decode_ranap_ran_co()
......................................................................
Patch Set 1:
(2 comments)
File src/osmo-hnbgw/context_map_sccp.c:
https://gerrit.osmocom.org/c/osmo-hnbgw/+/39984/comment/e5bcf503_35e16300?u… :
PS1, Line 207: rc = ranap_ran_rx_co_decode(NULL, message, msgb_l2(ranap_msg), msgb_l2len(ranap_msg));
THis function is RAN specific. The CN side is using ranap_cn_rx_co_decode().
https://gerrit.osmocom.org/c/osmo-hnbgw/+/39984/comment/1711a4c0_46c0764a?u… :
PS1, Line 212: talloc_set_destructor(message, destruct_ranap_ran_rx_co_ies);
destruct_ranap_ran_rx_co_ies() too, which calls RAN specific ranap_ran_rx_co_free().
--
To view, visit https://gerrit.osmocom.org/c/osmo-hnbgw/+/39984?usp=email
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings?usp=email
Gerrit-MessageType: comment
Gerrit-Project: osmo-hnbgw
Gerrit-Branch: master
Gerrit-Change-Id: Ifbb058d5340a6cb3a1703415e49c0de04fa6aec1
Gerrit-Change-Number: 39984
Gerrit-PatchSet: 1
Gerrit-Owner: pespin <pespin(a)sysmocom.de>
Gerrit-Reviewer: Jenkins Builder
Gerrit-CC: laforge <laforge(a)osmocom.org>
Gerrit-Comment-Date: Tue, 08 Apr 2025 18:16:31 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Attention is currently required from: laforge.
pespin has posted comments on this change by pespin. ( https://gerrit.osmocom.org/c/osmo-hnbgw/+/39983?usp=email )
Change subject: Rename function s/hnbgw_decode_ranap_co/hnbgw_decode_ranap_cn_co/g
......................................................................
Patch Set 1:
(2 comments)
File src/osmo-hnbgw/context_map_rua.c:
https://gerrit.osmocom.org/c/osmo-hnbgw/+/39983/comment/df1321d5_af5483a7?u… :
PS1, Line 140: hnbgw_decode_ranap_cn_co
> now I'm confused. _cn_ seems to indicate from the core network. […]
That's how all code in osmo-iuh is named.
My understanding is that "cn" means "we decode from CN point of view". That means decoding UL traffic and transmitting DL traffic.
In the HNBGW case, that means when traffic comes from RUA we are the "CN" and hence we decode UL traffic and transmit DL traffic.
https://gerrit.osmocom.org/c/osmo-hnbgw/+/39983/comment/939d6a7a_4ff40868?u… :
PS1, Line 148: rc = ranap_cn_rx_co_decode2(message, msgb_l2(ranap_msg), msgb_l2len(ranap_msg));
See how it matches this osmo-iuh naming. "cn".
--
To view, visit https://gerrit.osmocom.org/c/osmo-hnbgw/+/39983?usp=email
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings?usp=email
Gerrit-MessageType: comment
Gerrit-Project: osmo-hnbgw
Gerrit-Branch: master
Gerrit-Change-Id: Ia4e5a21a9724ebf759b62c13759a776189b09e91
Gerrit-Change-Number: 39983
Gerrit-PatchSet: 1
Gerrit-Owner: pespin <pespin(a)sysmocom.de>
Gerrit-Reviewer: Jenkins Builder
Gerrit-CC: laforge <laforge(a)osmocom.org>
Gerrit-Attention: laforge <laforge(a)osmocom.org>
Gerrit-Comment-Date: Tue, 08 Apr 2025 18:15:20 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Comment-In-Reply-To: laforge <laforge(a)osmocom.org>
Attention is currently required from: lynxis lazus.
laforge has posted comments on this change by lynxis lazus. ( https://gerrit.osmocom.org/c/osmo-remsim/+/39985?usp=email )
Change subject: bankd: Remove Mapping: improve logging
......................................................................
Patch Set 1: Code-Review+1
(1 comment)
Patchset:
PS1:
not sure if it made sense to add some kind of macro for it. probably not for those 3 invocations - but if there were more elsewhere, it might make sense
--
To view, visit https://gerrit.osmocom.org/c/osmo-remsim/+/39985?usp=email
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings?usp=email
Gerrit-MessageType: comment
Gerrit-Project: osmo-remsim
Gerrit-Branch: master
Gerrit-Change-Id: I62ddc2f260a6e1a51b1dda5f0822b6caa090452d
Gerrit-Change-Number: 39985
Gerrit-PatchSet: 1
Gerrit-Owner: lynxis lazus <lynxis(a)fe80.eu>
Gerrit-Reviewer: Jenkins Builder
Gerrit-Reviewer: laforge <laforge(a)osmocom.org>
Gerrit-Reviewer: pespin <pespin(a)sysmocom.de>
Gerrit-Attention: lynxis lazus <lynxis(a)fe80.eu>
Gerrit-Comment-Date: Tue, 08 Apr 2025 18:13:17 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: Yes
Attention is currently required from: pespin.
laforge has posted comments on this change by pespin. ( https://gerrit.osmocom.org/c/osmo-hnbgw/+/39984?usp=email )
Change subject: Add function helper hnbgw_decode_ranap_ran_co()
......................................................................
Patch Set 1:
(1 comment)
File src/osmo-hnbgw/context_map_sccp.c:
https://gerrit.osmocom.org/c/osmo-hnbgw/+/39984/comment/bb01aabf_71e3fce3?u… :
PS1, Line 199: static ranap_message *hnbgw_decode_ranap_ran_co(struct msgb *ranap_msg)
I don't get which part of this function is RAN (uplink) specific?
--
To view, visit https://gerrit.osmocom.org/c/osmo-hnbgw/+/39984?usp=email
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings?usp=email
Gerrit-MessageType: comment
Gerrit-Project: osmo-hnbgw
Gerrit-Branch: master
Gerrit-Change-Id: Ifbb058d5340a6cb3a1703415e49c0de04fa6aec1
Gerrit-Change-Number: 39984
Gerrit-PatchSet: 1
Gerrit-Owner: pespin <pespin(a)sysmocom.de>
Gerrit-Reviewer: Jenkins Builder
Gerrit-CC: laforge <laforge(a)osmocom.org>
Gerrit-Attention: pespin <pespin(a)sysmocom.de>
Gerrit-Comment-Date: Tue, 08 Apr 2025 18:11:46 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No