pespin has uploaded a new patch set (#2). ( https://gerrit.osmocom.org/c/osmo-hnbgw/+/40280?usp=email )
Change subject: kpi: count RAB actions received in unexpected state
......................................................................
kpi: count RAB actions received in unexpected state
This allows figuring out that something may be wrong in the network,
with both sides (HNB vs CN) going out of sync, or HNBGW ending up in a
bad state due to eg. a bug where a RAB is lost.
While at it, fix some formatting issues on related counters.
Related: SYS#7455
Change-Id: If3521ba601b9d7448226f2303ed2ef402d861bef
---
M include/osmocom/hnbgw/hnb_persistent.h
M src/osmo-hnbgw/hnb_persistent.c
M src/osmo-hnbgw/kpi_ranap.c
3 files changed, 66 insertions(+), 10 deletions(-)
git pull ssh://gerrit.osmocom.org:29418/osmo-hnbgw refs/changes/80/40280/2
--
To view, visit https://gerrit.osmocom.org/c/osmo-hnbgw/+/40280?usp=email
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings?usp=email
Gerrit-MessageType: newpatchset
Gerrit-Project: osmo-hnbgw
Gerrit-Branch: master
Gerrit-Change-Id: If3521ba601b9d7448226f2303ed2ef402d861bef
Gerrit-Change-Number: 40280
Gerrit-PatchSet: 2
Gerrit-Owner: pespin <pespin(a)sysmocom.de>
Gerrit-CC: Jenkins Builder
Attention is currently required from: laforge, pespin.
Hello Jenkins Builder, laforge,
I'd like you to reexamine a change. Please visit
https://gerrit.osmocom.org/c/osmo-hnbgw/+/40278?usp=email
to look at the new patch set (#5).
The following approvals got outdated and were removed:
Code-Review+1 by laforge, Verified+1 by Jenkins Builder
Change subject: kpi: Increment counters using enum field explicitly
......................................................................
kpi: Increment counters using enum field explicitly
I was first tricked by the increment of ctr_num.
This is wrong for several reasons:
* Assumes one counter will always be immediatelly after the other, and
there's no static assert about that.
* Makes it difficult to grep for users of the counter in the code.
Change-Id: I126973b93e86784adaccbcba49c6322c261f4746
---
M src/osmo-hnbgw/kpi_ranap.c
1 file changed, 8 insertions(+), 12 deletions(-)
git pull ssh://gerrit.osmocom.org:29418/osmo-hnbgw refs/changes/78/40278/5
--
To view, visit https://gerrit.osmocom.org/c/osmo-hnbgw/+/40278?usp=email
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings?usp=email
Gerrit-MessageType: newpatchset
Gerrit-Project: osmo-hnbgw
Gerrit-Branch: master
Gerrit-Change-Id: I126973b93e86784adaccbcba49c6322c261f4746
Gerrit-Change-Number: 40278
Gerrit-PatchSet: 5
Gerrit-Owner: pespin <pespin(a)sysmocom.de>
Gerrit-Reviewer: Jenkins Builder
Gerrit-Reviewer: laforge <laforge(a)osmocom.org>
Gerrit-Attention: laforge <laforge(a)osmocom.org>
Gerrit-Attention: pespin <pespin(a)sysmocom.de>
pespin has uploaded this change for review. ( https://gerrit.osmocom.org/c/osmo-hnbgw/+/40279?usp=email )
Change subject: kpi: Fix wrong counters incremented in RAB Release Failed List
......................................................................
kpi: Fix wrong counters incremented in RAB Release Failed List
Thouse counters are already incremented somewhere else, when
Setup-or-modify is answered with a failure.
This list is for RABs which failed to release, and the correct counter
is already being incremented above.
Change-Id: I0bcb70ca18078bb9201ce6cbf4ea81c05ae4ea68
---
M src/osmo-hnbgw/kpi_ranap.c
1 file changed, 0 insertions(+), 2 deletions(-)
git pull ssh://gerrit.osmocom.org:29418/osmo-hnbgw refs/changes/79/40279/1
diff --git a/src/osmo-hnbgw/kpi_ranap.c b/src/osmo-hnbgw/kpi_ranap.c
index 640f838..cbaa61d 100644
--- a/src/osmo-hnbgw/kpi_ranap.c
+++ b/src/osmo-hnbgw/kpi_ranap.c
@@ -382,11 +382,9 @@
/* differentiate modify / activate */
switch (map->rab_state[rab_id]) {
case RAB_STATE_ACT_REQ:
- HNBP_CTR_INC(hnbp, map->is_ps ? HNB_CTR_RANAP_PS_RAB_ACT_FAIL : HNB_CTR_RANAP_CS_RAB_ACT_FAIL);
map->rab_state[rab_id] = RAB_STATE_INACTIVE;
break;
case RAB_STATE_ACTIVE:
- HNBP_CTR_INC(hnbp, map->is_ps ? HNB_CTR_RANAP_PS_RAB_MOD_FAIL : HNB_CTR_RANAP_CS_RAB_MOD_FAIL);
// FIXME: does it remain active after modification failure?
break;
default:
--
To view, visit https://gerrit.osmocom.org/c/osmo-hnbgw/+/40279?usp=email
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings?usp=email
Gerrit-MessageType: newchange
Gerrit-Project: osmo-hnbgw
Gerrit-Branch: master
Gerrit-Change-Id: I0bcb70ca18078bb9201ce6cbf4ea81c05ae4ea68
Gerrit-Change-Number: 40279
Gerrit-PatchSet: 1
Gerrit-Owner: pespin <pespin(a)sysmocom.de>
Attention is currently required from: laforge, osmith, pespin.
Hello Jenkins Builder, laforge, osmith,
I'd like you to reexamine a change. Please visit
https://gerrit.osmocom.org/c/osmo-hnbgw/+/40267?usp=email
to look at the new patch set (#4).
The following approvals got outdated and were removed:
Code-Review+1 by laforge, Code-Review+1 by osmith
Change subject: cnlink: Cleanup talloc tree
......................................................................
cnlink: Cleanup talloc tree
Previous logic allocating structs was a big convoluted regarding order
of assignments, which then even required a taloc_steal.
Since recently the struct hnbgw_cnpool is a talloc context, and struct
hnbgw_cnlink are allocated as being part of a cnpool, so clean up the
talloc tree by having cnlink under cnpool.
Finally, put the cnlink_fsm and the cnlink counters under the hnbgw_cnlink
talloc context, where they belong.
Change-Id: I90c22f2a2932ede7103c66f2263e72ac2fdae497
---
M src/osmo-hnbgw/cnlink.c
1 file changed, 13 insertions(+), 13 deletions(-)
git pull ssh://gerrit.osmocom.org:29418/osmo-hnbgw refs/changes/67/40267/4
--
To view, visit https://gerrit.osmocom.org/c/osmo-hnbgw/+/40267?usp=email
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings?usp=email
Gerrit-MessageType: newpatchset
Gerrit-Project: osmo-hnbgw
Gerrit-Branch: master
Gerrit-Change-Id: I90c22f2a2932ede7103c66f2263e72ac2fdae497
Gerrit-Change-Number: 40267
Gerrit-PatchSet: 4
Gerrit-Owner: pespin <pespin(a)sysmocom.de>
Gerrit-Reviewer: Jenkins Builder
Gerrit-Reviewer: laforge <laforge(a)osmocom.org>
Gerrit-Reviewer: osmith <osmith(a)sysmocom.de>
Gerrit-Attention: osmith <osmith(a)sysmocom.de>
Gerrit-Attention: laforge <laforge(a)osmocom.org>
Gerrit-Attention: pespin <pespin(a)sysmocom.de>
pespin has posted comments on this change by pespin. ( https://gerrit.osmocom.org/c/osmo-hnbgw/+/40273?usp=email )
Change subject: context_map: Rename ps_rab(_ass) to denote it is a list
......................................................................
Patch Set 4: Code-Review+2
--
To view, visit https://gerrit.osmocom.org/c/osmo-hnbgw/+/40273?usp=email
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings?usp=email
Gerrit-MessageType: comment
Gerrit-Project: osmo-hnbgw
Gerrit-Branch: master
Gerrit-Change-Id: I6ac029e6a820a031a443dae8c83e44f6ae9fb5fa
Gerrit-Change-Number: 40273
Gerrit-PatchSet: 4
Gerrit-Owner: pespin <pespin(a)sysmocom.de>
Gerrit-Reviewer: Jenkins Builder
Gerrit-Reviewer: laforge <laforge(a)osmocom.org>
Gerrit-Reviewer: osmith <osmith(a)sysmocom.de>
Gerrit-Reviewer: pespin <pespin(a)sysmocom.de>
Gerrit-Comment-Date: Mon, 12 May 2025 11:41:17 +0000
Gerrit-HasComments: No
Gerrit-Has-Labels: Yes