lists.osmocom.org
Sign In Sign Up
Manage this list Sign In Sign Up

Keyboard Shortcuts

Thread View

  • j: Next unread message
  • k: Previous unread message
  • j a: Jump to all threads
  • j l: Jump to MailingList overview

gerrit-log

Thread Start a new thread
Download
Threads by month
  • ----- 2026 -----
  • November
  • October
  • September
  • August
  • July
  • June
  • May
  • April
  • March
  • February
  • January
  • ----- 2025 -----
  • December
  • November
  • October
  • September
  • August
  • July
  • June
  • May
  • April
  • March
  • February
  • January
  • ----- 2024 -----
  • December
  • November
  • October
  • September
  • August
  • July
  • June
  • May
  • April
  • March
  • February
  • January
  • ----- 2023 -----
  • December
  • November
  • October
  • September
  • August
  • July
  • June
  • May
  • April
  • March
  • February
  • January
  • ----- 2022 -----
  • December
  • November
  • October
  • September
  • August
  • July
  • June
  • May
  • April
  • March
  • February
  • January
gerrit-log@lists.osmocom.org

December 2025

  • 1 participants
  • 1175 discussions
[M] Change in osmo-bts[master]: bts-trx: Convert trx clk socket to iofd
by pespin 12 Dec '25

12 Dec '25
Attention is currently required from: fixeria. Hello Jenkins Builder, fixeria, I'd like you to reexamine a change. Please visit https://gerrit.osmocom.org/c/osmo-bts/+/41649?usp=email to look at the new patch set (#2). The following approvals got outdated and were removed: Code-Review+1 by fixeria, Verified+1 by Jenkins Builder Change subject: bts-trx: Convert trx clk socket to iofd ...................................................................... bts-trx: Convert trx clk socket to iofd Since now the Tx side is driven by the event loop, we can use (and should) OSMO_SOCK_F_NONBLOCK on the socket, avoiding potential blocking of the entire process. Related: OS#1579 Change-Id: Ia33028a657e7d5dee1a4994b8d6ba33ddea892ec --- M include/osmo-bts/phy_link.h M src/osmo-bts-trx/trx_if.c M src/osmo-bts-trx/trx_vty.c 3 files changed, 53 insertions(+), 28 deletions(-) git pull ssh://gerrit.osmocom.org:29418/osmo-bts refs/changes/49/41649/2 -- To view, visit https://gerrit.osmocom.org/c/osmo-bts/+/41649?usp=email To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings?usp=email Gerrit-MessageType: newpatchset Gerrit-Project: osmo-bts Gerrit-Branch: master Gerrit-Change-Id: Ia33028a657e7d5dee1a4994b8d6ba33ddea892ec Gerrit-Change-Number: 41649 Gerrit-PatchSet: 2 Gerrit-Owner: pespin <pespin(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Attention: fixeria <vyanitskiy(a)sysmocom.de>
1 0
0 0
[M] Change in osmo-bts[master]: bts-trx: get rid of static variables in trx_if_send_burst()
by pespin 12 Dec '25

12 Dec '25
pespin has uploaded a new patch set (#2) to the change originally created by fixeria. ( https://gerrit.osmocom.org/c/osmo-bts/+/41658?usp=email ) The following approvals got outdated and were removed: Verified+1 by Jenkins Builder Change subject: bts-trx: get rid of static variables in trx_if_send_burst() ...................................................................... bts-trx: get rid of static variables in trx_if_send_burst() Change-Id: I431964d6fe02e53771cc0514ac930348f0a86aa1 Related: OS#1579 --- M src/osmo-bts-trx/l1_if.h M src/osmo-bts-trx/trx_if.c 2 files changed, 28 insertions(+), 22 deletions(-) git pull ssh://gerrit.osmocom.org:29418/osmo-bts refs/changes/58/41658/2 -- To view, visit https://gerrit.osmocom.org/c/osmo-bts/+/41658?usp=email To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings?usp=email Gerrit-MessageType: newpatchset Gerrit-Project: osmo-bts Gerrit-Branch: master Gerrit-Change-Id: I431964d6fe02e53771cc0514ac930348f0a86aa1 Gerrit-Change-Number: 41658 Gerrit-PatchSet: 2 Gerrit-Owner: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder
1 0
0 0
[L] Change in osmo-bts[master]: bts-trx: Convert TRXC and TRXD sockets to iofd
by pespin 12 Dec '25

12 Dec '25
Attention is currently required from: fixeria. pespin has posted comments on this change by pespin. ( https://gerrit.osmocom.org/c/osmo-bts/+/41650?usp=email ) Change subject: bts-trx: Convert TRXC and TRXD sockets to iofd ...................................................................... Patch Set 2: (8 comments) File src/osmo-bts-trx/trx_if.c: https://gerrit.osmocom.org/c/osmo-bts/+/41650/comment/29f9ef2b_5d3afbd1?usp… : PS2, Line 1298: trx_udp_open > I still think having a helper function is better to avoid code duplication and copy-paste errors. I prefer it the way it is, to have the setup of both together instead of having to jump from the helepr function to here, which was a pain during working on this patch.Also In the end most of the lines contain different parameters for each iofd. https://gerrit.osmocom.org/c/osmo-bts/+/41650/comment/77274369_458a446b?usp… : PS2, Line 147: msg->data_len > `msgb_length(msg)` here and below No, this is msg->data_len, no msg->len. https://gerrit.osmocom.org/c/osmo-bts/+/41650/comment/89fe2fd5_37ef7457?usp… : PS2, Line 1006: LOGPPHI(l1h->phy_inst, DTRX, LOGL_ERROR, : > ```suggestion […] Done https://gerrit.osmocom.org/c/osmo-bts/+/41650/comment/3880debe_400923d0?usp… : PS2, Line 1110: trx_if_send_burst > This proposal looks good on paper, but not easy to implement. Here's a simpler solution: […] ^ Yes this commit is what I was planning to implement too. https://gerrit.osmocom.org/c/osmo-bts/+/41650/comment/df58690c_d950a0a6?usp… : PS2, Line 1128: buf = msgb_data(trx_data_last_msg); > setting `buf` here is probably not needed? It is strictly not needed indeed, but given the complexity with static variables I prefer being on the safe case so that it becomes clear that buf is always set, even on the "goto sendall" path below, to avoid also potential false positives from static analysis. https://gerrit.osmocom.org/c/osmo-bts/+/41650/comment/aeea7ebc_c12e30b0?usp… : PS2, Line 1164: > ```suggestion […] Done https://gerrit.osmocom.org/c/osmo-bts/+/41650/comment/5866c9f8_b2bb2011?usp… : PS2, Line 1195: LOGPPHI(l1h->phy_inst, DTRX, LOGL_ERROR, : "send() failed on TRXD with rc=%d (%s)\n", : > We're no longer calling `send()` here, right? […] Done https://gerrit.osmocom.org/c/osmo-bts/+/41650/comment/92ad945e_07fc2612?usp… : PS2, Line 1319: i > Copy-paste! […] Done -- To view, visit https://gerrit.osmocom.org/c/osmo-bts/+/41650?usp=email To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings?usp=email Gerrit-MessageType: comment Gerrit-Project: osmo-bts Gerrit-Branch: master Gerrit-Change-Id: I239f91efad43eabd280caf9f852c3aefbc729eaf Gerrit-Change-Number: 41650 Gerrit-PatchSet: 2 Gerrit-Owner: pespin <pespin(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Attention: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Comment-Date: Fri, 12 Dec 2025 11:36:25 +0000 Gerrit-HasComments: Yes Gerrit-Has-Labels: No Comment-In-Reply-To: fixeria <vyanitskiy(a)sysmocom.de>
1 0
0 0
[M] Change in osmo-bts[master]: bts-trx: Convert trx clk socket to iofd
by pespin 12 Dec '25

12 Dec '25
Attention is currently required from: fixeria. pespin has posted comments on this change by pespin. ( https://gerrit.osmocom.org/c/osmo-bts/+/41649?usp=email ) Change subject: bts-trx: Convert trx clk socket to iofd ...................................................................... Patch Set 1: (3 comments) Commit Message: https://gerrit.osmocom.org/c/osmo-bts/+/41649/comment/7a20e060_99a1f25c?usp… : PS1, Line 9: use > nitpick: use twice Done File src/osmo-bts-trx/trx_if.c: https://gerrit.osmocom.org/c/osmo-bts/+/41649/comment/65497424_cc4160d8?usp… : PS1, Line 1355: int rc; > rename to `fd` or `sfd`? Done https://gerrit.osmocom.org/c/osmo-bts/+/41649/comment/407dd634_5b297c85?usp… : PS1, Line 1371: osmo_iofd_setup > cosmetic: line too long, please wrap Done -- To view, visit https://gerrit.osmocom.org/c/osmo-bts/+/41649?usp=email To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings?usp=email Gerrit-MessageType: comment Gerrit-Project: osmo-bts Gerrit-Branch: master Gerrit-Change-Id: Ia33028a657e7d5dee1a4994b8d6ba33ddea892ec Gerrit-Change-Number: 41649 Gerrit-PatchSet: 1 Gerrit-Owner: pespin <pespin(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Attention: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Comment-Date: Fri, 12 Dec 2025 11:21:44 +0000 Gerrit-HasComments: Yes Gerrit-Has-Labels: No Comment-In-Reply-To: fixeria <vyanitskiy(a)sysmocom.de>
1 0
0 0
[XS] Change in osmocom-bb[master]: trx_toolkit: print milliseconds in logging
by pespin 12 Dec '25

12 Dec '25
Attention is currently required from: fixeria. pespin has posted comments on this change by fixeria. ( https://gerrit.osmocom.org/c/osmocom-bb/+/41652?usp=email ) Change subject: trx_toolkit: print milliseconds in logging ...................................................................... Patch Set 1: (1 comment) File src/target/trx_toolkit/app_common.py: https://gerrit.osmocom.org/c/osmocom-bb/+/41652/comment/f67535c5_78d65510?u… : PS1, Line 42: log_fmt = "%(asctime)s.%(msecs)03d " + log_fmt if log_time else log_fmt is it easy to print usecs instead? I'd welcome usec granularity. -- To view, visit https://gerrit.osmocom.org/c/osmocom-bb/+/41652?usp=email To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings?usp=email Gerrit-MessageType: comment Gerrit-Project: osmocom-bb Gerrit-Branch: master Gerrit-Change-Id: I7c53149f4e678670392773bbcf9648997ba4ff1b Gerrit-Change-Number: 41652 Gerrit-PatchSet: 1 Gerrit-Owner: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: pespin <pespin(a)sysmocom.de> Gerrit-Attention: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Comment-Date: Fri, 12 Dec 2025 11:13:35 +0000 Gerrit-HasComments: Yes Gerrit-Has-Labels: No
1 0
0 0
[XS] Change in osmo-bts[master]: debian/control: drop 'libgps-dev' from Build-Depends
by pespin 12 Dec '25

12 Dec '25
Attention is currently required from: fixeria. pespin has posted comments on this change by fixeria. ( https://gerrit.osmocom.org/c/osmo-bts/+/41657?usp=email ) Change subject: debian/control: drop 'libgps-dev' from Build-Depends ...................................................................... Patch Set 1: Code-Review+1 -- To view, visit https://gerrit.osmocom.org/c/osmo-bts/+/41657?usp=email To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings?usp=email Gerrit-MessageType: comment Gerrit-Project: osmo-bts Gerrit-Branch: master Gerrit-Change-Id: If20391546472a63687622c46e0d30119d675a3fb Gerrit-Change-Number: 41657 Gerrit-PatchSet: 1 Gerrit-Owner: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: pespin <pespin(a)sysmocom.de> Gerrit-Attention: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Comment-Date: Fri, 12 Dec 2025 11:11:10 +0000 Gerrit-HasComments: No Gerrit-Has-Labels: Yes
1 0
0 0
[XS] Change in osmo-bts[master]: debian/control: drop 'txt2man' from Build-Depends
by pespin 12 Dec '25

12 Dec '25
Attention is currently required from: fixeria. pespin has posted comments on this change by fixeria. ( https://gerrit.osmocom.org/c/osmo-bts/+/41656?usp=email ) Change subject: debian/control: drop 'txt2man' from Build-Depends ...................................................................... Patch Set 1: Code-Review+1 -- To view, visit https://gerrit.osmocom.org/c/osmo-bts/+/41656?usp=email To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings?usp=email Gerrit-MessageType: comment Gerrit-Project: osmo-bts Gerrit-Branch: master Gerrit-Change-Id: I9b971ae9b748f471e677446f3a8bfc9f01348349 Gerrit-Change-Number: 41656 Gerrit-PatchSet: 1 Gerrit-Owner: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: pespin <pespin(a)sysmocom.de> Gerrit-Attention: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Comment-Date: Fri, 12 Dec 2025 11:10:57 +0000 Gerrit-HasComments: No Gerrit-Has-Labels: Yes
1 0
0 0
[XS] Change in osmo-bts[master]: osmo-bts-{lc15,omldummy,virtual}: drop LIBGPS_{CFLAGS,LIBS}
by pespin 12 Dec '25

12 Dec '25
Attention is currently required from: fixeria. pespin has posted comments on this change by fixeria. ( https://gerrit.osmocom.org/c/osmo-bts/+/41655?usp=email ) Change subject: osmo-bts-{lc15,omldummy,virtual}: drop LIBGPS_{CFLAGS,LIBS} ...................................................................... Patch Set 1: Code-Review+1 -- To view, visit https://gerrit.osmocom.org/c/osmo-bts/+/41655?usp=email To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings?usp=email Gerrit-MessageType: comment Gerrit-Project: osmo-bts Gerrit-Branch: master Gerrit-Change-Id: I951a6ec1dc6a3213dd7b2a0a9460b97e827d98c2 Gerrit-Change-Number: 41655 Gerrit-PatchSet: 1 Gerrit-Owner: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: pespin <pespin(a)sysmocom.de> Gerrit-Attention: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Comment-Date: Fri, 12 Dec 2025 11:10:40 +0000 Gerrit-HasComments: No Gerrit-Has-Labels: Yes
1 0
0 0
[XS] Change in osmo-bts[master]: doc: osmo-bts-virtual.cfg: drop non-existent logging category
by pespin 12 Dec '25

12 Dec '25
Attention is currently required from: fixeria. pespin has posted comments on this change by fixeria. ( https://gerrit.osmocom.org/c/osmo-bts/+/41654?usp=email ) Change subject: doc: osmo-bts-virtual.cfg: drop non-existent logging category ...................................................................... Patch Set 1: Code-Review+1 -- To view, visit https://gerrit.osmocom.org/c/osmo-bts/+/41654?usp=email To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings?usp=email Gerrit-MessageType: comment Gerrit-Project: osmo-bts Gerrit-Branch: master Gerrit-Change-Id: I12dcce71dea0ec2f6cb244a716d997bba4eda1ed Gerrit-Change-Number: 41654 Gerrit-PatchSet: 1 Gerrit-Owner: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: pespin <pespin(a)sysmocom.de> Gerrit-Attention: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Comment-Date: Fri, 12 Dec 2025 11:10:13 +0000 Gerrit-HasComments: No Gerrit-Has-Labels: Yes
1 0
0 0
[L] Change in osmo-bts[master]: bts-trx: Convert TRXC and TRXD sockets to iofd
by fixeria 11 Dec '25

11 Dec '25
Attention is currently required from: pespin. fixeria has posted comments on this change by pespin. ( https://gerrit.osmocom.org/c/osmo-bts/+/41650?usp=email ) Change subject: bts-trx: Convert TRXC and TRXD sockets to iofd ...................................................................... Patch Set 2: (1 comment) File src/osmo-bts-trx/trx_if.c: https://gerrit.osmocom.org/c/osmo-bts/+/41650/comment/cc969963_a732bf97?usp… : PS2, Line 1110: trx_if_send_burst > BTW, we may further improve this API to avoid `static` variables. […] This proposal looks good on paper, but not easy to implement. Here's a simpler solution: https://gerrit.osmocom.org/c/osmo-bts/+/41658 -- To view, visit https://gerrit.osmocom.org/c/osmo-bts/+/41650?usp=email To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings?usp=email Gerrit-MessageType: comment Gerrit-Project: osmo-bts Gerrit-Branch: master Gerrit-Change-Id: I239f91efad43eabd280caf9f852c3aefbc729eaf Gerrit-Change-Number: 41650 Gerrit-PatchSet: 2 Gerrit-Owner: pespin <pespin(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Attention: pespin <pespin(a)sysmocom.de> Gerrit-Comment-Date: Thu, 11 Dec 2025 20:34:54 +0000 Gerrit-HasComments: Yes Gerrit-Has-Labels: No Comment-In-Reply-To: fixeria <vyanitskiy(a)sysmocom.de>
1 0
0 0
  • ← Newer
  • 1
  • ...
  • 61
  • 62
  • 63
  • 64
  • 65
  • 66
  • 67
  • ...
  • 118
  • Older →

HyperKitty Powered by HyperKitty version 1.3.12.