lists.osmocom.org
Sign In Sign Up
Manage this list Sign In Sign Up

Keyboard Shortcuts

Thread View

  • j: Next unread message
  • k: Previous unread message
  • j a: Jump to all threads
  • j l: Jump to MailingList overview

gerrit-log

Thread Start a new thread
Download
Threads by month
  • ----- 2026 -----
  • November
  • October
  • September
  • August
  • July
  • June
  • May
  • April
  • March
  • February
  • January
  • ----- 2025 -----
  • December
  • November
  • October
  • September
  • August
  • July
  • June
  • May
  • April
  • March
  • February
  • January
  • ----- 2024 -----
  • December
  • November
  • October
  • September
  • August
  • July
  • June
  • May
  • April
  • March
  • February
  • January
  • ----- 2023 -----
  • December
  • November
  • October
  • September
  • August
  • July
  • June
  • May
  • April
  • March
  • February
  • January
  • ----- 2022 -----
  • December
  • November
  • October
  • September
  • August
  • July
  • June
  • May
  • April
  • March
  • February
  • January
gerrit-log@lists.osmocom.org

September 2023

  • 1 participants
  • 1947 discussions
[M] Change in osmo-bsc[master]: Includes: Remove enum/include from libosmocore instead
by arehbein 01 Sep '23

01 Sep '23
Attention is currently required from: pespin. arehbein has posted comments on this change. ( https://gerrit.osmocom.org/c/osmo-bsc/+/31304 ) Change subject: Includes: Remove enum/include from libosmocore instead ...................................................................... Patch Set 7: (4 comments) File include/osmocom/bsc/gsm_data.h: https://gerrit.osmocom.org/c/osmo-bsc/+/31304/comment/e264bb73_1a38a20c PS6, Line 657: uint16_t parameter[_NUM_NM_RLC_PAR_OFFSET]; > why changing the name? I don't see the point in adding _OFFSET it just makes stuff larger with no be […] I added the suffix, because this makes clear (self-documenting code and such) that their values aren't to be touched, since these values are used as offsets. The rest of the name change went along with moving the enums from separate headers (iirc all with basename `gsm_data.h`) in `osmo-bsc`/`osmo-bts` (and possibly `osmo-pcu`) to `libosmocore.git:include/osmocom/gsm/protocol/gsm_12_21.h` to avoid duplicating the same enum values across multiple projects when it makes more sense to have them centrally in a library. File include/osmocom/bsc/gsm_data.h: https://gerrit.osmocom.org/c/osmo-bsc/+/31304/comment/e499b600_ef3bdf5e PS1, Line 654: enum gprs_cs { > IIUC the one under gsm_44_06. […] ah yes they have different values and I grepped for the bitmask; it isn't always accessed by use of the enum identifiers either File src/osmo-bsc/bts_ipaccess_nanobts_omlattr.c: https://gerrit.osmocom.org/c/osmo-bsc/+/31304/comment/6557e52d_ba2cbf90 PS6, Line 173: for (offset = NM_RLC_T3142_OFFSET; offset <= NM_CV_COUNTDOWN_OFFSET; > why not simply memcpy? Tbh. we don't have to have a for loop here, I don't care much either way and it might be better to keep it the way it was: Line by line assignments. I have discarded the loop usage. Makes the patch easier to read as well since it's focussing on the core change. `memcpy()` doesn't make much sense since the source is an array of `uint16_t` and the destination is a regular byte-array. https://gerrit.osmocom.org/c/osmo-bsc/+/31304/comment/41b755e1_d62a592d PS6, Line 174: ++offset) > please don't use preincrement unless it really has a purpose over postincrement (code convention in […] Alright I'll keep it in mind, thank you -- To view, visit https://gerrit.osmocom.org/c/osmo-bsc/+/31304 To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: osmo-bsc Gerrit-Branch: master Gerrit-Change-Id: I2883aee12b501a717d5acecd5638882724336e72 Gerrit-Change-Number: 31304 Gerrit-PatchSet: 7 Gerrit-Owner: arehbein <arehbein(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: pespin <pespin(a)sysmocom.de> Gerrit-Attention: pespin <pespin(a)sysmocom.de> Gerrit-Comment-Date: Fri, 01 Sep 2023 12:59:07 +0000 Gerrit-HasComments: Yes Gerrit-Has-Labels: No Comment-In-Reply-To: arehbein <arehbein(a)sysmocom.de> Comment-In-Reply-To: pespin <pespin(a)sysmocom.de> Gerrit-MessageType: comment
1 0
0 0
[S] Change in libosmo-sccp[master]: ipa: use LSBs of file descriptor as SLS in IPA->M3UA direction
by pespin 01 Sep '23

01 Sep '23
Attention is currently required from: laforge. pespin has posted comments on this change. ( https://gerrit.osmocom.org/c/libosmo-sccp/+/34264 ) Change subject: ipa: use LSBs of file descriptor as SLS in IPA->M3UA direction ...................................................................... Patch Set 2: Code-Review+2 -- To view, visit https://gerrit.osmocom.org/c/libosmo-sccp/+/34264 To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: libosmo-sccp Gerrit-Branch: master Gerrit-Change-Id: Ice7bab997b84cfed00c7d6d780c70f4e9fac6002 Gerrit-Change-Number: 34264 Gerrit-PatchSet: 2 Gerrit-Owner: laforge <laforge(a)osmocom.org> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Reviewer: pespin <pespin(a)sysmocom.de> Gerrit-Attention: laforge <laforge(a)osmocom.org> Gerrit-Comment-Date: Fri, 01 Sep 2023 12:54:57 +0000 Gerrit-HasComments: No Gerrit-Has-Labels: Yes Gerrit-MessageType: comment
1 0
0 0
[S] Change in osmo-pcu[master]: pcuif_sock: improve log output (OsmoBTS/OsmoBSC)
by pespin 01 Sep '23

01 Sep '23
Attention is currently required from: dexter. pespin has posted comments on this change. ( https://gerrit.osmocom.org/c/osmo-pcu/+/34275 ) Change subject: pcuif_sock: improve log output (OsmoBTS/OsmoBSC) ...................................................................... Patch Set 1: Code-Review+2 -- To view, visit https://gerrit.osmocom.org/c/osmo-pcu/+/34275 To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: osmo-pcu Gerrit-Branch: master Gerrit-Change-Id: Ibe49064d04dff0617357e3e0b00fea961b657784 Gerrit-Change-Number: 34275 Gerrit-PatchSet: 1 Gerrit-Owner: dexter <pmaier(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Reviewer: pespin <pespin(a)sysmocom.de> Gerrit-Attention: dexter <pmaier(a)sysmocom.de> Gerrit-Comment-Date: Fri, 01 Sep 2023 12:54:17 +0000 Gerrit-HasComments: No Gerrit-Has-Labels: Yes Gerrit-MessageType: comment
1 0
0 0
[S] Change in osmo-pcu[master]: osmobts_sock: cosmetic: rename osmobts_sock.c to pcuif_sock.c
by pespin 01 Sep '23

01 Sep '23
Attention is currently required from: dexter. pespin has posted comments on this change. ( https://gerrit.osmocom.org/c/osmo-pcu/+/34274 ) Change subject: osmobts_sock: cosmetic: rename osmobts_sock.c to pcuif_sock.c ...................................................................... Patch Set 1: Code-Review+2 -- To view, visit https://gerrit.osmocom.org/c/osmo-pcu/+/34274 To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: osmo-pcu Gerrit-Branch: master Gerrit-Change-Id: Ic7f6246265fa31be189e4aea36dfaa89bd0eeddd Gerrit-Change-Number: 34274 Gerrit-PatchSet: 1 Gerrit-Owner: dexter <pmaier(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Reviewer: pespin <pespin(a)sysmocom.de> Gerrit-Attention: dexter <pmaier(a)sysmocom.de> Gerrit-Comment-Date: Fri, 01 Sep 2023 12:54:03 +0000 Gerrit-HasComments: No Gerrit-Has-Labels: Yes Gerrit-MessageType: comment
1 0
0 0
[S] Change in osmo-ttcn3-hacks[master]: NAS_Templates: add template for NAS key set identifier
by pespin 01 Sep '23

01 Sep '23
Attention is currently required from: fixeria, dexter. pespin has posted comments on this change. ( https://gerrit.osmocom.org/c/osmo-ttcn3-hacks/+/34270 ) Change subject: NAS_Templates: add template for NAS key set identifier ...................................................................... Patch Set 2: Code-Review+1 (1 comment) File library/NAS_Templates.ttcn: https://gerrit.osmocom.org/c/osmo-ttcn3-hacks/+/34270/comment/5119c2fe_e1db… PS1, Line 330: const BIT3 c_NAS_KEY_SET_ID_NO_KEY := '111'B; > I am not sure, but I think c_NAS_KEY_SET_ID_NO_KEY is just a reserved value to say that NO_KEY is us […] Ack -- To view, visit https://gerrit.osmocom.org/c/osmo-ttcn3-hacks/+/34270 To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: osmo-ttcn3-hacks Gerrit-Branch: master Gerrit-Change-Id: I2df0c9d1bf4bf0073b5f7b77708b8de59f96a639 Gerrit-Change-Number: 34270 Gerrit-PatchSet: 2 Gerrit-Owner: dexter <pmaier(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Reviewer: pespin <pespin(a)sysmocom.de> Gerrit-Attention: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Attention: dexter <pmaier(a)sysmocom.de> Gerrit-Comment-Date: Fri, 01 Sep 2023 12:52:52 +0000 Gerrit-HasComments: Yes Gerrit-Has-Labels: Yes Comment-In-Reply-To: pespin <pespin(a)sysmocom.de> Comment-In-Reply-To: dexter <pmaier(a)sysmocom.de> Gerrit-MessageType: comment
1 0
0 0
[S] Change in libosmo-sccp[master]: m3ua: Add some TODO comments on where we fall short of our potential
by pespin 01 Sep '23

01 Sep '23
Attention is currently required from: laforge. pespin has posted comments on this change. ( https://gerrit.osmocom.org/c/libosmo-sccp/+/34273 ) Change subject: m3ua: Add some TODO comments on where we fall short of our potential ...................................................................... Patch Set 1: Code-Review+1 -- To view, visit https://gerrit.osmocom.org/c/libosmo-sccp/+/34273 To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: libosmo-sccp Gerrit-Branch: master Gerrit-Change-Id: I75d7b8f3fb6a06f6941b6dff4072287fdbb1d33e Gerrit-Change-Number: 34273 Gerrit-PatchSet: 1 Gerrit-Owner: laforge <laforge(a)osmocom.org> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: pespin <pespin(a)sysmocom.de> Gerrit-Attention: laforge <laforge(a)osmocom.org> Gerrit-Comment-Date: Fri, 01 Sep 2023 12:51:35 +0000 Gerrit-HasComments: No Gerrit-Has-Labels: Yes Gerrit-MessageType: comment
1 0
0 0
[S] Change in osmo-ttcn3-hacks[master]: NAS_Templates: fix ts_NAS_GUTI
by pespin 01 Sep '23

01 Sep '23
Attention is currently required from: dexter. pespin has posted comments on this change. ( https://gerrit.osmocom.org/c/osmo-ttcn3-hacks/+/34267 ) Change subject: NAS_Templates: fix ts_NAS_GUTI ...................................................................... Patch Set 2: Code-Review+1 -- To view, visit https://gerrit.osmocom.org/c/osmo-ttcn3-hacks/+/34267 To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: osmo-ttcn3-hacks Gerrit-Branch: master Gerrit-Change-Id: I9546993987b873e8ae921664238b234608e37bba Gerrit-Change-Number: 34267 Gerrit-PatchSet: 2 Gerrit-Owner: dexter <pmaier(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: pespin <pespin(a)sysmocom.de> Gerrit-Attention: dexter <pmaier(a)sysmocom.de> Gerrit-Comment-Date: Fri, 01 Sep 2023 12:50:40 +0000 Gerrit-HasComments: No Gerrit-Has-Labels: Yes Gerrit-MessageType: comment
1 0
0 0
[S] Change in osmo-ttcn3-hacks[master]: MME_Tests: remove unusued timer variable
by dexter 01 Sep '23

01 Sep '23
dexter has uploaded this change for review. ( https://gerrit.osmocom.org/c/osmo-ttcn3-hacks/+/34279 ) Change subject: MME_Tests: remove unusued timer variable ...................................................................... MME_Tests: remove unusued timer variable The Timer T in TC_RIM_RAN_INF is not used, let's remove it. Related: OS#5760 Change-Id: I3d18cda38789e5a42536fd17b6641efa725f757b --- M mme/MME_Tests.ttcn 1 file changed, 12 insertions(+), 2 deletions(-) git pull ssh://gerrit.osmocom.org:29418/osmo-ttcn3-hacks refs/changes/79/34279/1 diff --git a/mme/MME_Tests.ttcn b/mme/MME_Tests.ttcn index 7a709fd..a517798 100644 --- a/mme/MME_Tests.ttcn +++ b/mme/MME_Tests.ttcn @@ -928,8 +928,6 @@ f_s1ap_setup(0); f_init_gtp(id); - timer T := 3.0; - var ConnHdlrPars pars := f_init_pars(ue_idx := 0); var ConnHdlr vc_conn; vc_conn := f_start_handler_with_pars(refers(f_TC_RIM_RAN_INF), pars); -- To view, visit https://gerrit.osmocom.org/c/osmo-ttcn3-hacks/+/34279 To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: osmo-ttcn3-hacks Gerrit-Branch: master Gerrit-Change-Id: I3d18cda38789e5a42536fd17b6641efa725f757b Gerrit-Change-Number: 34279 Gerrit-PatchSet: 1 Gerrit-Owner: dexter <pmaier(a)sysmocom.de> Gerrit-MessageType: newchange
1 0
0 0
[S] Change in osmo-ttcn3-hacks[master]: NAS_Templates: add template for Tracking Area Update Reject
by dexter 01 Sep '23

01 Sep '23
dexter has uploaded this change for review. ( https://gerrit.osmocom.org/c/osmo-ttcn3-hacks/+/34280 ) Change subject: NAS_Templates: add template for Tracking Area Update Reject ...................................................................... NAS_Templates: add template for Tracking Area Update Reject Change-Id: Id64e8a28e47235766efbef6df0114c3024cc2f47 Related: OS#5760 --- M library/NAS_Templates.ttcn 1 file changed, 27 insertions(+), 0 deletions(-) git pull ssh://gerrit.osmocom.org:29418/osmo-ttcn3-hacks refs/changes/80/34280/1 diff --git a/library/NAS_Templates.ttcn b/library/NAS_Templates.ttcn index 4b98ee8..45f5f8d 100644 --- a/library/NAS_Templates.ttcn +++ b/library/NAS_Templates.ttcn @@ -335,6 +335,23 @@ tSC := tSC } +/* 8.2.28 Tracking Area Update Reject */ +template (present) PDU_NAS_EPS +tr_PDU_NAS_EPS_TrackingAreaUpdateReject(template (present) EMM_CauseV cause := ?) := { + protocolDiscriminator := c_EPS_NAS_PD_EMM, + ePS_messages := { + ePS_MobilityManagement := { + pDU_NAS_EPS_TrackingAreaUpdateReject := { + securityHeaderType := c_EPS_SEC_NONE, + messageType := '01001011'B, + emmCause := cause, + t3346 := *, + extendedEmmCause := * + } + } + } +} + /* 8.2.29 Tracking Area Update Request */ template (value) PDU_NAS_EPS ts_PDU_NAS_EPS_TrackingAreaUpdateRequest(EPS_MobileIdentityLV old_guti) := { -- To view, visit https://gerrit.osmocom.org/c/osmo-ttcn3-hacks/+/34280 To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: osmo-ttcn3-hacks Gerrit-Branch: master Gerrit-Change-Id: Id64e8a28e47235766efbef6df0114c3024cc2f47 Gerrit-Change-Number: 34280 Gerrit-PatchSet: 1 Gerrit-Owner: dexter <pmaier(a)sysmocom.de> Gerrit-MessageType: newchange
1 0
0 0
[M] Change in osmo-ttcn3-hacks[master]: MME_Tests: add new testcase TC_s1ap_tau_unknown_guti
by dexter 01 Sep '23

01 Sep '23
dexter has uploaded this change for review. ( https://gerrit.osmocom.org/c/osmo-ttcn3-hacks/+/34281 ) Change subject: MME_Tests: add new testcase TC_s1ap_tau_unknown_guti ...................................................................... MME_Tests: add new testcase TC_s1ap_tau_unknown_guti A tracking area update that contains an OldGUTI (TMSI) that is unknown to the MME should be rejected. Related: OS#5760 Change-Id: I9306fea69ac930b9642528e2fd32a7091147081e --- M mme/MME_Tests.ttcn 1 file changed, 62 insertions(+), 0 deletions(-) git pull ssh://gerrit.osmocom.org:29418/osmo-ttcn3-hacks refs/changes/81/34281/1 diff --git a/mme/MME_Tests.ttcn b/mme/MME_Tests.ttcn index a517798..ddc1c0a 100644 --- a/mme/MME_Tests.ttcn +++ b/mme/MME_Tests.ttcn @@ -960,11 +960,60 @@ } } +/* Tracking area update with a GUTI (TMSI) that is unknown to the MME. The MME is expected to reject this TAU + * request. */ +private function f_TC_tau_unknown_guti(ConnHdlrPars pars) runs on ConnHdlr { + + f_init_handler(pars); + var template (value) EPS_MobileIdentityV mi := ts_NAS_MobileId_IMSI(pars.ue_pars.imsi); + var template (value) S1AP_PDU tx; + var template (value) PDU_NAS_EPS nas_tau; + timer T := 5.0; + + var hexstring mcc_mnc := f_convert_plmn(g_pars.enb_pars[g_pars.mme_idx].global_enb_id.pLMNidentity); + var EPS_MobileIdentityLV old_guti := valueof(ts_EPS_MobileId_GUTI(mcc_mnc, '0001'O, '01'O, 'AABBCCDD'O)); + nas_tau := ts_PDU_NAS_EPS_TrackingAreaUpdateRequest(old_guti); + + tx := ts_S1AP_InitialUE(p_eNB_value := 0, p_nasPdu := enc_PDU_NAS_EPS(valueof(nas_tau)), + p_tAI := ts_enb_S1AP_TAI(g_pars.enb_pars[g_pars.mme_idx]), + p_eUTRAN_CGI := ts_enb_S1AP_CGI(g_pars.enb_pars[g_pars.mme_idx]), + p_rrcCause := mo_Signalling); + + S1AP.send(tx); + + T.start; + alt { + [] S1AP.receive(tr_PDU_NAS_EPS_TrackingAreaUpdateReject) { + setverdict(pass); + } + [] S1AP.receive { + setverdict(fail, "unexpected S1AP message from MME"); + } + [] T.timeout { + setverdict(fail, "no message from MME"); + } + } + +} +testcase TC_s1ap_tau_unknown_guti() runs on MTC_CT { + var charstring id := testcasename(); + + f_init_diameter(id); + f_init_s1ap(id, 4); + f_s1ap_setup(0); + + var ConnHdlrPars pars := f_init_pars(ue_idx := 0); + var ConnHdlr vc_conn; + vc_conn := f_start_handler_with_pars(refers(f_TC_tau_unknown_guti), pars); + vc_conn.done; +} + control { execute( TC_s1ap_setup_wrong_plmn() ); execute( TC_s1ap_setup_wrong_tac() ); execute( TC_s1ap_setup() ); execute( TC_s1ap_attach() ); + execute( TC_s1ap_tau_unknown_guti() ); execute( TC_gn_echo_request() ); execute( TC_RIM_RAN_INF() ); execute( TC_s1ap_reset() ); -- To view, visit https://gerrit.osmocom.org/c/osmo-ttcn3-hacks/+/34281 To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: osmo-ttcn3-hacks Gerrit-Branch: master Gerrit-Change-Id: I9306fea69ac930b9642528e2fd32a7091147081e Gerrit-Change-Number: 34281 Gerrit-PatchSet: 1 Gerrit-Owner: dexter <pmaier(a)sysmocom.de> Gerrit-MessageType: newchange
1 0
0 0
  • ← Newer
  • 1
  • ...
  • 189
  • 190
  • 191
  • 192
  • 193
  • 194
  • 195
  • Older →

HyperKitty Powered by HyperKitty version 1.3.12.