lists.osmocom.org
Sign In Sign Up
Manage this list Sign In Sign Up

Keyboard Shortcuts

Thread View

  • j: Next unread message
  • k: Previous unread message
  • j a: Jump to all threads
  • j l: Jump to MailingList overview

gerrit-log

Thread Start a new thread
Download
Threads by month
  • ----- 2026 -----
  • November
  • October
  • September
  • August
  • July
  • June
  • May
  • April
  • March
  • February
  • January
  • ----- 2025 -----
  • December
  • November
  • October
  • September
  • August
  • July
  • June
  • May
  • April
  • March
  • February
  • January
  • ----- 2024 -----
  • December
  • November
  • October
  • September
  • August
  • July
  • June
  • May
  • April
  • March
  • February
  • January
  • ----- 2023 -----
  • December
  • November
  • October
  • September
  • August
  • July
  • June
  • May
  • April
  • March
  • February
  • January
  • ----- 2022 -----
  • December
  • November
  • October
  • September
  • August
  • July
  • June
  • May
  • April
  • March
  • February
  • January
gerrit-log@lists.osmocom.org

June 2023

  • 1 participants
  • 2480 discussions
[M] Change in osmo-bts[master]: pcu_sock: use PCUIF version 11 (direct TLLI)
by pespin 27 Jun '23

27 Jun '23
Attention is currently required from: dexter. pespin has posted comments on this change. ( https://gerrit.osmocom.org/c/osmo-bts/+/33522 ) Change subject: pcu_sock: use PCUIF version 11 (direct TLLI) ...................................................................... Patch Set 1: Code-Review-1 (1 comment) File src/common/pcu_sock.c: https://gerrit.osmocom.org/c/osmo-bts/+/33522/comment/b893c546_6510e477 PS1, Line 635: pcu_prim->u.data_cnf_dt = (struct gsm_pcu_if_data_cnf_dt) { iiuc this makes osmo-bts defacto only use the new SAPI, and hence only work properly against an osmo-pcu using/supporting PCUIF 11. IMHO, osmo-bts should store info on which SAPI was used to send the PDH_DATA.req and then use thew old or new SAPI based on that, to stay compatible against older osmo-pcu. -- To view, visit https://gerrit.osmocom.org/c/osmo-bts/+/33522 To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: osmo-bts Gerrit-Branch: master Gerrit-Change-Id: I25816ac12e63cc6b641eb414e6bc7eaa9c85fc25 Gerrit-Change-Number: 33522 Gerrit-PatchSet: 1 Gerrit-Owner: dexter <pmaier(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: pespin <pespin(a)sysmocom.de> Gerrit-Attention: dexter <pmaier(a)sysmocom.de> Gerrit-Comment-Date: Tue, 27 Jun 2023 14:58:27 +0000 Gerrit-HasComments: Yes Gerrit-Has-Labels: Yes Gerrit-MessageType: comment
1 0
0 0
[S] Change in libosmocore[master]: osmo_io: Make the test more deterministic between backends
by daniel 27 Jun '23

27 Jun '23
Attention is currently required from: daniel. Hello Jenkins Builder, fixeria, I'd like you to reexamine a change. Please visit https://gerrit.osmocom.org/c/libosmocore/+/33496 to look at the new patch set (#3). Change subject: osmo_io: Make the test more deterministic between backends ...................................................................... osmo_io: Make the test more deterministic between backends Change-Id: Ibdd26a4aeadfbd6c5039c8a31cc120d3c98be727 --- M tests/osmo_io/osmo_io_test.c 1 file changed, 22 insertions(+), 13 deletions(-) git pull ssh://gerrit.osmocom.org:29418/libosmocore refs/changes/96/33496/3 -- To view, visit https://gerrit.osmocom.org/c/libosmocore/+/33496 To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: libosmocore Gerrit-Branch: master Gerrit-Change-Id: Ibdd26a4aeadfbd6c5039c8a31cc120d3c98be727 Gerrit-Change-Number: 33496 Gerrit-PatchSet: 3 Gerrit-Owner: daniel <dwillmann(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Attention: daniel <dwillmann(a)sysmocom.de> Gerrit-MessageType: newpatchset
1 0
0 0
[S] Change in docker-playground[master]: ttcn3-bts-test/jenkins.sh: set mp_pcuif_version
by pespin 27 Jun '23

27 Jun '23
Attention is currently required from: dexter. pespin has posted comments on this change. ( https://gerrit.osmocom.org/c/docker-playground/+/33521 ) Change subject: ttcn3-bts-test/jenkins.sh: set mp_pcuif_version ...................................................................... Patch Set 1: (1 comment) File ttcn3-bts-test/jenkins.sh: https://gerrit.osmocom.org/c/docker-playground/+/33521/comment/567fd182_720… PS1, Line 130: image_suffix_is_master if image_suffix_is_master; then sed -i 's/PCUIF_Types.mp_pcuif_version := 10/PCUIF_Types.mp_pcuif_version := 11/g' $1 fi -- To view, visit https://gerrit.osmocom.org/c/docker-playground/+/33521 To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: docker-playground Gerrit-Branch: master Gerrit-Change-Id: Ia28bc0d6d3cbfe63be19443db86631fb67bb80fb Gerrit-Change-Number: 33521 Gerrit-PatchSet: 1 Gerrit-Owner: dexter <pmaier(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-CC: pespin <pespin(a)sysmocom.de> Gerrit-Attention: dexter <pmaier(a)sysmocom.de> Gerrit-Comment-Date: Tue, 27 Jun 2023 14:54:05 +0000 Gerrit-HasComments: Yes Gerrit-Has-Labels: No Gerrit-MessageType: comment
1 0
0 0
[M] Change in libosmo-sccp[master]: vty: Improve output of show cs7 instance <0-15> asp
by osmith 27 Jun '23

27 Jun '23
Attention is currently required from: laforge, pespin. osmith has posted comments on this change. ( https://gerrit.osmocom.org/c/libosmo-sccp/+/33518 ) Change subject: vty: Improve output of show cs7 instance <0-15> asp ...................................................................... Patch Set 3: Code-Review+1 (1 comment) File src/osmo_ss7_vty.c: https://gerrit.osmocom.org/c/libosmo-sccp/+/33518/comment/9ab96fea_25178b8b PS3, Line 829: --- shorten the line here too? -- To view, visit https://gerrit.osmocom.org/c/libosmo-sccp/+/33518 To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: libosmo-sccp Gerrit-Branch: master Gerrit-Change-Id: Id22bd4e74fb6f79950adba58862d379203d36760 Gerrit-Change-Number: 33518 Gerrit-PatchSet: 3 Gerrit-Owner: pespin <pespin(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: laforge <laforge(a)osmocom.org> Gerrit-Reviewer: osmith <osmith(a)sysmocom.de> Gerrit-Attention: laforge <laforge(a)osmocom.org> Gerrit-Attention: pespin <pespin(a)sysmocom.de> Gerrit-Comment-Date: Tue, 27 Jun 2023 14:52:49 +0000 Gerrit-HasComments: Yes Gerrit-Has-Labels: Yes Gerrit-MessageType: comment
1 0
0 0
[M] Change in libosmo-sccp[master]: vty: Improve output of show cs7 instance <0-15> asp
by pespin 27 Jun '23

27 Jun '23
Attention is currently required from: osmith, laforge. pespin has posted comments on this change. ( https://gerrit.osmocom.org/c/libosmo-sccp/+/33518 ) Change subject: vty: Improve output of show cs7 instance <0-15> asp ...................................................................... Patch Set 2: (2 comments) Commit Message: https://gerrit.osmocom.org/c/libosmo-sccp/+/33518/comment/a5ea1151_03a21317 PS2, Line 8: > Noting that Role and SCTP Role are now printed would be useful here Done File src/osmo_ss7_vty.c: https://gerrit.osmocom.org/c/libosmo-sccp/+/33518/comment/39a51d4a_e83c8805 PS2, Line 828: Remote IP Addr:Rmt Port > it might be useful to shorten this while at it, to "Remote IP:Port"? Done -- To view, visit https://gerrit.osmocom.org/c/libosmo-sccp/+/33518 To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: libosmo-sccp Gerrit-Branch: master Gerrit-Change-Id: Id22bd4e74fb6f79950adba58862d379203d36760 Gerrit-Change-Number: 33518 Gerrit-PatchSet: 2 Gerrit-Owner: pespin <pespin(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: laforge <laforge(a)osmocom.org> Gerrit-Reviewer: osmith <osmith(a)sysmocom.de> Gerrit-Attention: osmith <osmith(a)sysmocom.de> Gerrit-Attention: laforge <laforge(a)osmocom.org> Gerrit-Comment-Date: Tue, 27 Jun 2023 14:50:26 +0000 Gerrit-HasComments: Yes Gerrit-Has-Labels: No Comment-In-Reply-To: osmith <osmith(a)sysmocom.de> Gerrit-MessageType: comment
1 0
0 0
[M] Change in libosmo-sccp[master]: vty: Improve output of show cs7 instance <0-15> asp
by pespin 27 Jun '23

27 Jun '23
Attention is currently required from: laforge, pespin. Hello osmith, Jenkins Builder, laforge, I'd like you to reexamine a change. Please visit https://gerrit.osmocom.org/c/libosmo-sccp/+/33518 to look at the new patch set (#3). Change subject: vty: Improve output of show cs7 instance <0-15> asp ...................................................................... vty: Improve output of show cs7 instance <0-15> asp Role and SCTP Role are now printed. Several formatting issues are fixed or improved. Related: SYS#6488 Change-Id: Id22bd4e74fb6f79950adba58862d379203d36760 --- M src/osmo_ss7_vty.c M tests/vty/ss7_asp_test.vty 2 files changed, 61 insertions(+), 25 deletions(-) git pull ssh://gerrit.osmocom.org:29418/libosmo-sccp refs/changes/18/33518/3 -- To view, visit https://gerrit.osmocom.org/c/libosmo-sccp/+/33518 To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: libosmo-sccp Gerrit-Branch: master Gerrit-Change-Id: Id22bd4e74fb6f79950adba58862d379203d36760 Gerrit-Change-Number: 33518 Gerrit-PatchSet: 3 Gerrit-Owner: pespin <pespin(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: laforge <laforge(a)osmocom.org> Gerrit-Reviewer: osmith <osmith(a)sysmocom.de> Gerrit-Attention: laforge <laforge(a)osmocom.org> Gerrit-Attention: pespin <pespin(a)sysmocom.de> Gerrit-MessageType: newpatchset
1 0
0 0
[S] Change in libosmo-netif[master]: stream: Rename static function to have correct prefix
by pespin 27 Jun '23

27 Jun '23
pespin has uploaded this change for review. ( https://gerrit.osmocom.org/c/libosmo-netif/+/33523 ) Change subject: stream: Rename static function to have correct prefix ...................................................................... stream: Rename static function to have correct prefix That function is used by the srv_link object, not the srv object. Rename it to avoid confusion. Change-Id: I1a3870b3a269b84ac2a9285ee6fe3389c5c96a94 --- M src/stream.c 1 file changed, 14 insertions(+), 2 deletions(-) git pull ssh://gerrit.osmocom.org:29418/libosmo-netif refs/changes/23/33523/1 diff --git a/src/stream.c b/src/stream.c index fdc1cc1..f007cc4 100644 --- a/src/stream.c +++ b/src/stream.c @@ -1151,7 +1151,7 @@ int flags; }; -static int osmo_stream_srv_ofd_cb(struct osmo_fd *ofd, unsigned int what) +static int osmo_stream_srv_link_ofd_cb(struct osmo_fd *ofd, unsigned int what) { int ret; int sock_fd; @@ -1227,7 +1227,7 @@ link->sk_domain = AF_UNSPEC; link->sk_type = SOCK_STREAM; link->proto = IPPROTO_TCP; - osmo_fd_setup(&link->ofd, -1, OSMO_FD_READ | OSMO_FD_WRITE, osmo_stream_srv_ofd_cb, link, 0); + osmo_fd_setup(&link->ofd, -1, OSMO_FD_READ | OSMO_FD_WRITE, osmo_stream_srv_link_ofd_cb, link, 0); return link; } -- To view, visit https://gerrit.osmocom.org/c/libosmo-netif/+/33523 To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: libosmo-netif Gerrit-Branch: master Gerrit-Change-Id: I1a3870b3a269b84ac2a9285ee6fe3389c5c96a94 Gerrit-Change-Number: 33523 Gerrit-PatchSet: 1 Gerrit-Owner: pespin <pespin(a)sysmocom.de> Gerrit-MessageType: newchange
1 0
0 0
[S] Change in libosmocore[master]: osmo_io: Use bitfield for various boolean flags
by pespin 27 Jun '23

27 Jun '23
Attention is currently required from: fixeria, daniel. pespin has posted comments on this change. ( https://gerrit.osmocom.org/c/libosmocore/+/33495 ) Change subject: osmo_io: Use bitfield for various boolean flags ...................................................................... Patch Set 2: Code-Review+1 -- To view, visit https://gerrit.osmocom.org/c/libosmocore/+/33495 To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: libosmocore Gerrit-Branch: master Gerrit-Change-Id: Ic134e4c8d791c34778202fea98a70bc04007a113 Gerrit-Change-Number: 33495 Gerrit-PatchSet: 2 Gerrit-Owner: daniel <dwillmann(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: pespin <pespin(a)sysmocom.de> Gerrit-CC: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Attention: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Attention: daniel <dwillmann(a)sysmocom.de> Gerrit-Comment-Date: Tue, 27 Jun 2023 14:31:11 +0000 Gerrit-HasComments: No Gerrit-Has-Labels: Yes Gerrit-MessageType: comment
1 0
0 0
[S] Change in libosmocore[master]: osmo_io: Use bitfield for various boolean flags
by daniel 27 Jun '23

27 Jun '23
Attention is currently required from: fixeria. daniel has posted comments on this change. ( https://gerrit.osmocom.org/c/libosmocore/+/33495 ) Change subject: osmo_io: Use bitfield for various boolean flags ...................................................................... Patch Set 2: (5 comments) File src/core/osmo_io_internal.h: https://gerrit.osmocom.org/c/libosmocore/+/33495/comment/0f45e21e_cb6c58be PS1, Line 39: iofd > `(iofd)->flags`, just to be safe Ack https://gerrit.osmocom.org/c/libosmocore/+/33495/comment/78a42cab_daf522e8 PS1, Line 40: } while (0) > Agreeing with the linter, do-while wrapper is not really needed here. Done https://gerrit.osmocom.org/c/libosmocore/+/33495/comment/094d0a26_92910ae9 PS1, Line 47: iofd->flags & flag > same here: `(iofd)->flags & (flag)` Done https://gerrit.osmocom.org/c/libosmocore/+/33495/comment/8a099afd_04c1b77d PS1, Line 58: TODO: Move to bitfield > remove this TODO? Ack File src/core/osmo_io_poll.c: https://gerrit.osmocom.org/c/libosmocore/+/33495/comment/c73bcb46_6990a057 PS1, Line 84: FLAG_ISSET > missing `IOFD_` prefix Done -- To view, visit https://gerrit.osmocom.org/c/libosmocore/+/33495 To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: libosmocore Gerrit-Branch: master Gerrit-Change-Id: Ic134e4c8d791c34778202fea98a70bc04007a113 Gerrit-Change-Number: 33495 Gerrit-PatchSet: 2 Gerrit-Owner: daniel <dwillmann(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-CC: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Attention: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Comment-Date: Tue, 27 Jun 2023 14:12:53 +0000 Gerrit-HasComments: Yes Gerrit-Has-Labels: No Comment-In-Reply-To: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-MessageType: comment
1 0
0 0
[S] Change in libosmocore[master]: osmo_io: Use bitfield for various boolean flags
by daniel 27 Jun '23

27 Jun '23
Attention is currently required from: fixeria. Hello Jenkins Builder, I'd like you to reexamine a change. Please visit https://gerrit.osmocom.org/c/libosmocore/+/33495 to look at the new patch set (#2). Change subject: osmo_io: Use bitfield for various boolean flags ...................................................................... osmo_io: Use bitfield for various boolean flags Change-Id: Ic134e4c8d791c34778202fea98a70bc04007a113 --- M src/core/osmo_io.c M src/core/osmo_io_internal.h M src/core/osmo_io_poll.c 3 files changed, 34 insertions(+), 13 deletions(-) git pull ssh://gerrit.osmocom.org:29418/libosmocore refs/changes/95/33495/2 -- To view, visit https://gerrit.osmocom.org/c/libosmocore/+/33495 To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: libosmocore Gerrit-Branch: master Gerrit-Change-Id: Ic134e4c8d791c34778202fea98a70bc04007a113 Gerrit-Change-Number: 33495 Gerrit-PatchSet: 2 Gerrit-Owner: daniel <dwillmann(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-CC: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Attention: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-MessageType: newpatchset
1 0
0 0
  • ← Newer
  • 1
  • ...
  • 20
  • 21
  • 22
  • 23
  • 24
  • 25
  • 26
  • ...
  • 248
  • Older →

HyperKitty Powered by HyperKitty version 1.3.12.