lists.osmocom.org
Sign In Sign Up
Manage this list Sign In Sign Up

Keyboard Shortcuts

Thread View

  • j: Next unread message
  • k: Previous unread message
  • j a: Jump to all threads
  • j l: Jump to MailingList overview

gerrit-log

Thread Start a new thread
Download
Threads by month
  • ----- 2026 -----
  • November
  • October
  • September
  • August
  • July
  • June
  • May
  • April
  • March
  • February
  • January
  • ----- 2025 -----
  • December
  • November
  • October
  • September
  • August
  • July
  • June
  • May
  • April
  • March
  • February
  • January
  • ----- 2024 -----
  • December
  • November
  • October
  • September
  • August
  • July
  • June
  • May
  • April
  • March
  • February
  • January
  • ----- 2023 -----
  • December
  • November
  • October
  • September
  • August
  • July
  • June
  • May
  • April
  • March
  • February
  • January
  • ----- 2022 -----
  • December
  • November
  • October
  • September
  • August
  • July
  • June
  • May
  • April
  • March
  • February
  • January
gerrit-log@lists.osmocom.org

June 2023

  • 1 participants
  • 2480 discussions
[S] Change in osmo-mgw[master]: mgcp-client: Always mark client as UP if keepalive request-interval d...
by pespin 27 Jun '23

27 Jun '23
pespin has posted comments on this change. ( https://gerrit.osmocom.org/c/osmo-mgw/+/33467 ) Change subject: mgcp-client: Always mark client as UP if keepalive request-interval disabled ...................................................................... Patch Set 2: Code-Review+2 -- To view, visit https://gerrit.osmocom.org/c/osmo-mgw/+/33467 To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: osmo-mgw Gerrit-Branch: master Gerrit-Change-Id: I290f7436f48418ee25179951359c76208796e279 Gerrit-Change-Number: 33467 Gerrit-PatchSet: 2 Gerrit-Owner: pespin <pespin(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Reviewer: osmith <osmith(a)sysmocom.de> Gerrit-Reviewer: pespin <pespin(a)sysmocom.de> Gerrit-Comment-Date: Tue, 27 Jun 2023 15:38:57 +0000 Gerrit-HasComments: No Gerrit-Has-Labels: Yes Gerrit-MessageType: comment
1 0
0 0
[S] Change in osmo-mgw[master]: mgcp-client: Always mark client as UP if keepalive request-interval d...
by pespin 27 Jun '23

27 Jun '23
Attention is currently required from: pespin. Hello osmith, Jenkins Builder, fixeria, I'd like you to reexamine a change. Please visit https://gerrit.osmocom.org/c/osmo-mgw/+/33467 to look at the new patch set (#2). Change subject: mgcp-client: Always mark client as UP if keepalive request-interval disabled ...................................................................... mgcp-client: Always mark client as UP if keepalive request-interval disabled In the previous logic, if "keepalive request-interval" was disabled (value 0, default), then if the client was configured to send a DLCX on startup it would end up in state UP or DOWN depending on whether the MGW answered to that request. As a result, an MGW that wouldn't answer would be left forever in DOWN state since it would have been selected no more and there would be a keepalive configured to re-mark it as UP. Fixes: 563386e8bbf0bc6d9050d87f79208d6784e219cf Related: SYS#6481 Change-Id: I290f7436f48418ee25179951359c76208796e279 --- M src/libosmo-mgcp-client/mgcp_client.c 1 file changed, 25 insertions(+), 6 deletions(-) git pull ssh://gerrit.osmocom.org:29418/osmo-mgw refs/changes/67/33467/2 -- To view, visit https://gerrit.osmocom.org/c/osmo-mgw/+/33467 To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: osmo-mgw Gerrit-Branch: master Gerrit-Change-Id: I290f7436f48418ee25179951359c76208796e279 Gerrit-Change-Number: 33467 Gerrit-PatchSet: 2 Gerrit-Owner: pespin <pespin(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Reviewer: osmith <osmith(a)sysmocom.de> Gerrit-Attention: pespin <pespin(a)sysmocom.de> Gerrit-MessageType: newpatchset
1 0
0 0
[S] Change in osmo-mgw[master]: mgcp-client: Mark client as UP when keepalive request-interval/timeou...
by pespin 27 Jun '23

27 Jun '23
Attention is currently required from: pespin. Hello osmith, Jenkins Builder, fixeria, I'd like you to reexamine a change. Please visit https://gerrit.osmocom.org/c/osmo-mgw/+/33468 to look at the new patch set (#2). Change subject: mgcp-client: Mark client as UP when keepalive request-interval/timeout is disabled through VTY ...................................................................... mgcp-client: Mark client as UP when keepalive request-interval/timeout is disabled through VTY This way if keepalive becomes disabled for an MGW, it can be selected again (otherwise it would become non-selectable forever, and we already have a "blocked" config for that). Fixes: 563386e8bbf0bc6d9050d87f79208d6784e219cf Related: SYS#6481 Change-Id: I263d23885a1a967f844033f9810b96691b8e3b30 --- M src/libosmo-mgcp-client/mgcp_client_vty.c 1 file changed, 31 insertions(+), 6 deletions(-) git pull ssh://gerrit.osmocom.org:29418/osmo-mgw refs/changes/68/33468/2 -- To view, visit https://gerrit.osmocom.org/c/osmo-mgw/+/33468 To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: osmo-mgw Gerrit-Branch: master Gerrit-Change-Id: I263d23885a1a967f844033f9810b96691b8e3b30 Gerrit-Change-Number: 33468 Gerrit-PatchSet: 2 Gerrit-Owner: pespin <pespin(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Reviewer: osmith <osmith(a)sysmocom.de> Gerrit-Attention: pespin <pespin(a)sysmocom.de> Gerrit-MessageType: newpatchset
1 0
0 0
[S] Change in osmo-mgw[master]: mgcp-client: Mark client as UP when keepalive request-interval/timeou...
by osmith 27 Jun '23

27 Jun '23
Attention is currently required from: pespin. osmith has posted comments on this change. ( https://gerrit.osmocom.org/c/osmo-mgw/+/33468 ) Change subject: mgcp-client: Mark client as UP when keepalive request-interval/timeout is disabled through VTY ...................................................................... Patch Set 1: (1 comment) File src/libosmo-mgcp-client/mgcp_client_vty.c: https://gerrit.osmocom.org/c/osmo-mgw/+/33468/comment/c86f7130_6c281542 PS1, Line 388: } /* else: wait until connect() to do first scheduling */ > They act on different timers, it's not really duplicated code. Ack -- To view, visit https://gerrit.osmocom.org/c/osmo-mgw/+/33468 To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: osmo-mgw Gerrit-Branch: master Gerrit-Change-Id: I263d23885a1a967f844033f9810b96691b8e3b30 Gerrit-Change-Number: 33468 Gerrit-PatchSet: 1 Gerrit-Owner: pespin <pespin(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Reviewer: osmith <osmith(a)sysmocom.de> Gerrit-Attention: pespin <pespin(a)sysmocom.de> Gerrit-Comment-Date: Tue, 27 Jun 2023 15:37:51 +0000 Gerrit-HasComments: Yes Gerrit-Has-Labels: No Comment-In-Reply-To: osmith <osmith(a)sysmocom.de> Comment-In-Reply-To: pespin <pespin(a)sysmocom.de> Gerrit-MessageType: comment
1 0
0 0
[S] Change in osmo-mgw[master]: mgcp-client: Mark client as UP when keepalive request-interval/timeou...
by pespin 27 Jun '23

27 Jun '23
Attention is currently required from: osmith. pespin has posted comments on this change. ( https://gerrit.osmocom.org/c/osmo-mgw/+/33468 ) Change subject: mgcp-client: Mark client as UP when keepalive request-interval/timeout is disabled through VTY ...................................................................... Patch Set 1: (1 comment) File src/libosmo-mgcp-client/mgcp_client_vty.c: https://gerrit.osmocom.org/c/osmo-mgw/+/33468/comment/0a8d69a7_17431012 PS1, Line 388: } /* else: wait until connect() to do first scheduling */ > maybe move the whole block into a new function to de-duplicate code? but not that important They act on different timers, it's not really duplicated code. -- To view, visit https://gerrit.osmocom.org/c/osmo-mgw/+/33468 To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: osmo-mgw Gerrit-Branch: master Gerrit-Change-Id: I263d23885a1a967f844033f9810b96691b8e3b30 Gerrit-Change-Number: 33468 Gerrit-PatchSet: 1 Gerrit-Owner: pespin <pespin(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Reviewer: osmith <osmith(a)sysmocom.de> Gerrit-Attention: osmith <osmith(a)sysmocom.de> Gerrit-Comment-Date: Tue, 27 Jun 2023 15:36:38 +0000 Gerrit-HasComments: Yes Gerrit-Has-Labels: No Comment-In-Reply-To: osmith <osmith(a)sysmocom.de> Gerrit-MessageType: comment
1 0
0 0
[S] Change in osmo-mgw[master]: mgcp-client: Mark client as UP when keepalive request-interval/timeou...
by osmith 27 Jun '23

27 Jun '23
Attention is currently required from: pespin. osmith has posted comments on this change. ( https://gerrit.osmocom.org/c/osmo-mgw/+/33468 ) Change subject: mgcp-client: Mark client as UP when keepalive request-interval/timeout is disabled through VTY ...................................................................... Patch Set 1: Code-Review+1 (2 comments) Commit Message: https://gerrit.osmocom.org/c/osmo-mgw/+/33468/comment/c2aeb35c_30dcd32b PS1, Line 12: Add Fixes:...? File src/libosmo-mgcp-client/mgcp_client_vty.c: https://gerrit.osmocom.org/c/osmo-mgw/+/33468/comment/4f2704ef_9258eafc PS1, Line 388: } /* else: wait until connect() to do first scheduling */ maybe move the whole block into a new function to de-duplicate code? but not that important -- To view, visit https://gerrit.osmocom.org/c/osmo-mgw/+/33468 To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: osmo-mgw Gerrit-Branch: master Gerrit-Change-Id: I263d23885a1a967f844033f9810b96691b8e3b30 Gerrit-Change-Number: 33468 Gerrit-PatchSet: 1 Gerrit-Owner: pespin <pespin(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Reviewer: osmith <osmith(a)sysmocom.de> Gerrit-Attention: pespin <pespin(a)sysmocom.de> Gerrit-Comment-Date: Tue, 27 Jun 2023 15:23:24 +0000 Gerrit-HasComments: Yes Gerrit-Has-Labels: Yes Gerrit-MessageType: comment
1 0
0 0
[S] Change in osmo-mgw[master]: mgcp-client: Always mark client as UP if keepalive request-interval d...
by osmith 27 Jun '23

27 Jun '23
Attention is currently required from: pespin. osmith has posted comments on this change. ( https://gerrit.osmocom.org/c/osmo-mgw/+/33467 ) Change subject: mgcp-client: Always mark client as UP if keepalive request-interval disabled ...................................................................... Patch Set 1: Code-Review+1 (2 comments) Commit Message: https://gerrit.osmocom.org/c/osmo-mgw/+/33467/comment/fc0c4429_812d5b1d PS1, Line 14: would wouldn't? https://gerrit.osmocom.org/c/osmo-mgw/+/33467/comment/5fe7cfc8_6038b42c PS1, Line 16: Fixes: ... -- To view, visit https://gerrit.osmocom.org/c/osmo-mgw/+/33467 To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: osmo-mgw Gerrit-Branch: master Gerrit-Change-Id: I290f7436f48418ee25179951359c76208796e279 Gerrit-Change-Number: 33467 Gerrit-PatchSet: 1 Gerrit-Owner: pespin <pespin(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Reviewer: osmith <osmith(a)sysmocom.de> Gerrit-Attention: pespin <pespin(a)sysmocom.de> Gerrit-Comment-Date: Tue, 27 Jun 2023 15:19:32 +0000 Gerrit-HasComments: Yes Gerrit-Has-Labels: Yes Gerrit-MessageType: comment
1 0
0 0
[S] Change in osmo-mgw[master]: mgcp-client: Mark client as UP when keepalive request-interval/timeou...
by pespin 27 Jun '23

27 Jun '23
Attention is currently required from: osmith. pespin has posted comments on this change. ( https://gerrit.osmocom.org/c/osmo-mgw/+/33468 ) Change subject: mgcp-client: Mark client as UP when keepalive request-interval/timeout is disabled through VTY ...................................................................... Patch Set 1: (1 comment) Patchset: PS1: I just tested the ttcn3-bsc-tests and the regression seems fixed once these are applied. -- To view, visit https://gerrit.osmocom.org/c/osmo-mgw/+/33468 To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: osmo-mgw Gerrit-Branch: master Gerrit-Change-Id: I263d23885a1a967f844033f9810b96691b8e3b30 Gerrit-Change-Number: 33468 Gerrit-PatchSet: 1 Gerrit-Owner: pespin <pespin(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Reviewer: osmith <osmith(a)sysmocom.de> Gerrit-Attention: osmith <osmith(a)sysmocom.de> Gerrit-Comment-Date: Tue, 27 Jun 2023 15:03:02 +0000 Gerrit-HasComments: Yes Gerrit-Has-Labels: No Gerrit-MessageType: comment
1 0
0 0
[M] Change in libosmo-sccp[master]: vty: Improve output of show cs7 instance <0-15> asp
by osmith 27 Jun '23

27 Jun '23
Attention is currently required from: laforge, pespin. osmith has posted comments on this change. ( https://gerrit.osmocom.org/c/libosmo-sccp/+/33518 ) Change subject: vty: Improve output of show cs7 instance <0-15> asp ...................................................................... Patch Set 3: (1 comment) File src/osmo_ss7_vty.c: https://gerrit.osmocom.org/c/libosmo-sccp/+/33518/comment/50e74a13_c06a08fa PS3, Line 829: --- > No, I wanted to keep the space since IP addresses can be longer. Ack -- To view, visit https://gerrit.osmocom.org/c/libosmo-sccp/+/33518 To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: libosmo-sccp Gerrit-Branch: master Gerrit-Change-Id: Id22bd4e74fb6f79950adba58862d379203d36760 Gerrit-Change-Number: 33518 Gerrit-PatchSet: 3 Gerrit-Owner: pespin <pespin(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: laforge <laforge(a)osmocom.org> Gerrit-Reviewer: osmith <osmith(a)sysmocom.de> Gerrit-Attention: laforge <laforge(a)osmocom.org> Gerrit-Attention: pespin <pespin(a)sysmocom.de> Gerrit-Comment-Date: Tue, 27 Jun 2023 14:59:25 +0000 Gerrit-HasComments: Yes Gerrit-Has-Labels: No Comment-In-Reply-To: osmith <osmith(a)sysmocom.de> Comment-In-Reply-To: pespin <pespin(a)sysmocom.de> Gerrit-MessageType: comment
1 0
0 0
[M] Change in libosmo-sccp[master]: vty: Improve output of show cs7 instance <0-15> asp
by pespin 27 Jun '23

27 Jun '23
Attention is currently required from: osmith, laforge. pespin has posted comments on this change. ( https://gerrit.osmocom.org/c/libosmo-sccp/+/33518 ) Change subject: vty: Improve output of show cs7 instance <0-15> asp ...................................................................... Patch Set 3: (1 comment) File src/osmo_ss7_vty.c: https://gerrit.osmocom.org/c/libosmo-sccp/+/33518/comment/8b7115a8_0cf3b100 PS3, Line 829: --- > shorten the line here too? No, I wanted to keep the space since IP addresses can be longer. -- To view, visit https://gerrit.osmocom.org/c/libosmo-sccp/+/33518 To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: libosmo-sccp Gerrit-Branch: master Gerrit-Change-Id: Id22bd4e74fb6f79950adba58862d379203d36760 Gerrit-Change-Number: 33518 Gerrit-PatchSet: 3 Gerrit-Owner: pespin <pespin(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: laforge <laforge(a)osmocom.org> Gerrit-Reviewer: osmith <osmith(a)sysmocom.de> Gerrit-Attention: osmith <osmith(a)sysmocom.de> Gerrit-Attention: laforge <laforge(a)osmocom.org> Gerrit-Comment-Date: Tue, 27 Jun 2023 14:59:04 +0000 Gerrit-HasComments: Yes Gerrit-Has-Labels: No Comment-In-Reply-To: osmith <osmith(a)sysmocom.de> Gerrit-MessageType: comment
1 0
0 0
  • ← Newer
  • 1
  • ...
  • 19
  • 20
  • 21
  • 22
  • 23
  • 24
  • 25
  • ...
  • 248
  • Older →

HyperKitty Powered by HyperKitty version 1.3.12.