lists.osmocom.org
Sign In Sign Up
Manage this list Sign In Sign Up

Keyboard Shortcuts

Thread View

  • j: Next unread message
  • k: Previous unread message
  • j a: Jump to all threads
  • j l: Jump to MailingList overview

gerrit-log

Thread Start a new thread
Download
Threads by month
  • ----- 2026 -----
  • November
  • October
  • September
  • August
  • July
  • June
  • May
  • April
  • March
  • February
  • January
  • ----- 2025 -----
  • December
  • November
  • October
  • September
  • August
  • July
  • June
  • May
  • April
  • March
  • February
  • January
  • ----- 2024 -----
  • December
  • November
  • October
  • September
  • August
  • July
  • June
  • May
  • April
  • March
  • February
  • January
  • ----- 2023 -----
  • December
  • November
  • October
  • September
  • August
  • July
  • June
  • May
  • April
  • March
  • February
  • January
  • ----- 2022 -----
  • December
  • November
  • October
  • September
  • August
  • July
  • June
  • May
  • April
  • March
  • February
  • January
gerrit-log@lists.osmocom.org

June 2023

  • 1 participants
  • 2480 discussions
[L] Change in osmo-hlr[master]: Port to new libosmogsm 'struct osmo_sub_auth_data2'
by laforge 17 Jun '23

17 Jun '23
Attention is currently required from: neels. laforge has posted comments on this change. ( https://gerrit.osmocom.org/c/osmo-hlr/+/33097 ) Change subject: Port to new libosmogsm 'struct osmo_sub_auth_data2' ...................................................................... Patch Set 3: Code-Review+2 -- To view, visit https://gerrit.osmocom.org/c/osmo-hlr/+/33097 To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: osmo-hlr Gerrit-Branch: master Gerrit-Change-Id: I3207c7bfb73e9ff5471e5c26b66639549e4d48a2 Gerrit-Change-Number: 33097 Gerrit-PatchSet: 3 Gerrit-Owner: laforge <laforge(a)osmocom.org> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Reviewer: laforge <laforge(a)osmocom.org> Gerrit-Reviewer: neels <nhofmeyr(a)sysmocom.de> Gerrit-Reviewer: pespin <pespin(a)sysmocom.de> Gerrit-Attention: neels <nhofmeyr(a)sysmocom.de> Gerrit-Comment-Date: Sat, 17 Jun 2023 05:56:51 +0000 Gerrit-HasComments: No Gerrit-Has-Labels: Yes Gerrit-MessageType: comment
1 0
0 0
[S] Change in libosmocore[master]: core/osmo_io: Fix reception of partial packets
by laforge 17 Jun '23

17 Jun '23
Attention is currently required from: arehbein. laforge has posted comments on this change. ( https://gerrit.osmocom.org/c/libosmocore/+/33346 ) Change subject: core/osmo_io: Fix reception of partial packets ...................................................................... Patch Set 1: Code-Review-1 (1 comment) File src/core/osmo_io_poll.c: https://gerrit.osmocom.org/c/libosmocore/+/33346/comment/7fba8b2c_1b86ee62 PS1, Line 59: iofd IMHO, the unconditional iov_base = msg->tail should do the trick here. In fact I would even argue msgb_data is wrong, as we below are using the _tailroom_ as length. So data == tail and length == tailroom. -- To view, visit https://gerrit.osmocom.org/c/libosmocore/+/33346 To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: libosmocore Gerrit-Branch: master Gerrit-Change-Id: I0ab8028c807b4181fddd3c00ea2e037c40cf0813 Gerrit-Change-Number: 33346 Gerrit-PatchSet: 1 Gerrit-Owner: arehbein <arehbein(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: laforge <laforge(a)osmocom.org> Gerrit-Attention: arehbein <arehbein(a)sysmocom.de> Gerrit-Comment-Date: Sat, 17 Jun 2023 05:53:15 +0000 Gerrit-HasComments: Yes Gerrit-Has-Labels: Yes Gerrit-MessageType: comment
1 0
0 0
[S] Change in libosmocore[master]: core/osmo_io: Fix reception of partial packets
by laforge 17 Jun '23

17 Jun '23
Attention is currently required from: arehbein. laforge has posted comments on this change. ( https://gerrit.osmocom.org/c/libosmocore/+/33346 ) Change subject: core/osmo_io: Fix reception of partial packets ...................................................................... Patch Set 1: (1 comment) Patchset: PS1: I don't really understand this patch (but then I'm not an expert in the new osmo_io code). But in a newly-allocated msgb head == tail. So why not always append to the tail of the message in the call-back? I don't undertand why another new variable is needed. -- To view, visit https://gerrit.osmocom.org/c/libosmocore/+/33346 To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: libosmocore Gerrit-Branch: master Gerrit-Change-Id: I0ab8028c807b4181fddd3c00ea2e037c40cf0813 Gerrit-Change-Number: 33346 Gerrit-PatchSet: 1 Gerrit-Owner: arehbein <arehbein(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-CC: laforge <laforge(a)osmocom.org> Gerrit-Attention: arehbein <arehbein(a)sysmocom.de> Gerrit-Comment-Date: Sat, 17 Jun 2023 05:51:06 +0000 Gerrit-HasComments: Yes Gerrit-Has-Labels: No Gerrit-MessageType: comment
1 0
0 0
[S] Change in libosmocore[master]: core/osmo_io: Rename variables for readability
by laforge 17 Jun '23

17 Jun '23
Attention is currently required from: arehbein. laforge has posted comments on this change. ( https://gerrit.osmocom.org/c/libosmocore/+/33345 ) Change subject: core/osmo_io: Rename variables for readability ...................................................................... Patch Set 1: Code-Review+1 -- To view, visit https://gerrit.osmocom.org/c/libosmocore/+/33345 To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: libosmocore Gerrit-Branch: master Gerrit-Change-Id: I3d752ce91a1b16c855522f643d10a52ef28a8a84 Gerrit-Change-Number: 33345 Gerrit-PatchSet: 1 Gerrit-Owner: arehbein <arehbein(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: laforge <laforge(a)osmocom.org> Gerrit-Attention: arehbein <arehbein(a)sysmocom.de> Gerrit-Comment-Date: Sat, 17 Jun 2023 05:48:38 +0000 Gerrit-HasComments: No Gerrit-Has-Labels: Yes Gerrit-MessageType: comment
1 0
0 0
[S] Change in libosmocore[master]: core/osmo_io: Rename variables for readability
by arehbein 17 Jun '23

17 Jun '23
arehbein has uploaded this change for review. ( https://gerrit.osmocom.org/c/libosmocore/+/33345 ) Change subject: core/osmo_io: Rename variables for readability ...................................................................... core/osmo_io: Rename variables for readability Rename msg_len -> received_len, len -> expected_len so the variable names have a consistent scheme. For instance, extra_len = msg_len - len becomes extra_len = received_len - expected_len Change-Id: I3d752ce91a1b16c855522f643d10a52ef28a8a84 --- M src/core/osmo_io.c 1 file changed, 26 insertions(+), 9 deletions(-) git pull ssh://gerrit.osmocom.org:29418/libosmocore refs/changes/45/33345/1 diff --git a/src/core/osmo_io.c b/src/core/osmo_io.c index d260da4..b0287ec 100644 --- a/src/core/osmo_io.c +++ b/src/core/osmo_io.c @@ -219,28 +219,29 @@ */ static enum iofd_seg_act iofd_handle_segmentation(struct osmo_io_fd *iofd, struct msgb *msg, struct msgb **pending_out) { - int extra_len, msg_len; + int extra_len, received_len; struct msgb *msg_pending; - msg_len = msgb_length(msg); + received_len = msgb_length(msg); if (!iofd->io_ops.segmentation_cb) { *pending_out = NULL; return IOFD_SEG_ACT_HANDLE_ONE; } - int len = iofd->io_ops.segmentation_cb(msg); - if (len == -EAGAIN) { + int expected_len = iofd->io_ops.segmentation_cb(msg); + if (expected_len == -EAGAIN) { goto defer; - } else if (len < 0) { + } else if (expected_len < 0) { /* Something is wrong, skip this msgb */ - LOGPIO(iofd, LOGL_ERROR, "segmentation_cb returned error (%d), skipping msg of size %d\n", len, msg_len); + LOGPIO(iofd, LOGL_ERROR, "segmentation_cb returned error (%d), skipping msg of size %d\n", + expected_len, received_len); *pending_out = NULL; msgb_free(msg); return IOFD_SEG_ACT_DEFER; } - extra_len = msg_len - len; + extra_len = received_len - expected_len; /* No segmentation needed, return the whole msgb */ if (extra_len == 0) { *pending_out = NULL; @@ -253,12 +254,12 @@ /* msgb contains more than one segment */ /* Copy the trailing data over */ msg_pending = iofd_msgb_alloc(iofd); - memcpy(msgb_data(msg_pending), msgb_data(msg) + len, extra_len); + memcpy(msgb_data(msg_pending), msgb_data(msg) + expected_len, extra_len); msgb_put(msg_pending, extra_len); *pending_out = msg_pending; /* Trim the original msgb to size */ - msgb_trim(msg, len); + msgb_trim(msg, expected_len); return IOFD_SEG_ACT_HANDLE_MORE; defer: -- To view, visit https://gerrit.osmocom.org/c/libosmocore/+/33345 To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: libosmocore Gerrit-Branch: master Gerrit-Change-Id: I3d752ce91a1b16c855522f643d10a52ef28a8a84 Gerrit-Change-Number: 33345 Gerrit-PatchSet: 1 Gerrit-Owner: arehbein <arehbein(a)sysmocom.de> Gerrit-MessageType: newchange
1 0
0 0
[S] Change in libosmocore[master]: gsm/ipa: Add segmentation callback
by arehbein 17 Jun '23

17 Jun '23
Attention is currently required from: arehbein, fixeria, daniel. Hello Jenkins Builder, laforge, pespin, I'd like you to reexamine a change. Please visit https://gerrit.osmocom.org/c/libosmocore/+/33083 to look at the new patch set (#9). Change subject: gsm/ipa: Add segmentation callback ...................................................................... gsm/ipa: Add segmentation callback Add segmentation callback to be used by the streaming backend of libosmo-netif Related: OS#5753, OS#5751 Change-Id: I3a639e6896cc3b3fc8e9b2e1a58254710efa0d3f --- M include/osmocom/gsm/ipa.h M src/gsm/ipa.c M src/gsm/libosmogsm.map 3 files changed, 35 insertions(+), 0 deletions(-) git pull ssh://gerrit.osmocom.org:29418/libosmocore refs/changes/83/33083/9 -- To view, visit https://gerrit.osmocom.org/c/libosmocore/+/33083 To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: libosmocore Gerrit-Branch: master Gerrit-Change-Id: I3a639e6896cc3b3fc8e9b2e1a58254710efa0d3f Gerrit-Change-Number: 33083 Gerrit-PatchSet: 9 Gerrit-Owner: arehbein <arehbein(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: laforge <laforge(a)osmocom.org> Gerrit-Reviewer: pespin <pespin(a)sysmocom.de> Gerrit-CC: daniel <dwillmann(a)sysmocom.de> Gerrit-CC: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Attention: arehbein <arehbein(a)sysmocom.de> Gerrit-Attention: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Attention: daniel <dwillmann(a)sysmocom.de> Gerrit-MessageType: newpatchset
1 0
0 0
[S] Change in libosmocore[master]: core/osmo_io: Fix reception of partial packets
by arehbein 17 Jun '23

17 Jun '23
arehbein has uploaded this change for review. ( https://gerrit.osmocom.org/c/libosmocore/+/33346 ) Change subject: core/osmo_io: Fix reception of partial packets ...................................................................... core/osmo_io: Fix reception of partial packets Add/use field 'pending_incomplete' to 'struct osmo_io_fd', so that osmo_io logic knows when the next incoming octets don't mark the start of a new message. Change-Id: I0ab8028c807b4181fddd3c00ea2e037c40cf0813 --- M src/core/osmo_io.c M src/core/osmo_io_internal.h M src/core/osmo_io_poll.c 3 files changed, 19 insertions(+), 2 deletions(-) git pull ssh://gerrit.osmocom.org:29418/libosmocore refs/changes/46/33346/1 diff --git a/src/core/osmo_io.c b/src/core/osmo_io.c index b0287ec..39e03d6 100644 --- a/src/core/osmo_io.c +++ b/src/core/osmo_io.c @@ -273,6 +273,7 @@ { int res; struct msgb *pending = NULL; + bool pending_incomplete; if (rc <= 0) { iofd->io_ops.read_cb(iofd, rc, msg); @@ -281,7 +282,8 @@ do { res = iofd_handle_segmentation(iofd, msg, &pending); - if (res != IOFD_SEG_ACT_DEFER || rc < 0) + pending_incomplete = (res == IOFD_SEG_ACT_DEFER); + if (!pending_incomplete || rc < 0) iofd->io_ops.read_cb(iofd, rc, msg); if (res == IOFD_SEG_ACT_HANDLE_MORE) msg = pending; @@ -289,6 +291,7 @@ OSMO_ASSERT(iofd->pending == NULL); iofd->pending = pending; + iofd->pending_incomplete = pending_incomplete; } /* Public functions */ diff --git a/src/core/osmo_io_internal.h b/src/core/osmo_io_internal.h index bdd2ac5..b66832b 100644 --- a/src/core/osmo_io_internal.h +++ b/src/core/osmo_io_internal.h @@ -50,6 +50,8 @@ struct osmo_io_ops io_ops; /*! Pending msgb to keep partial data during segmentation */ struct msgb *pending; + /*! 'true' if and only if field 'pending' consists of an incomplete packet */ + bool pending_incomplete; /*! data pointer passed through to call-back function */ void *data; diff --git a/src/core/osmo_io_poll.c b/src/core/osmo_io_poll.c index dd86f29..795390a 100644 --- a/src/core/osmo_io_poll.c +++ b/src/core/osmo_io_poll.c @@ -56,7 +56,7 @@ } hdr.msg = msg; - hdr.iov[0].iov_base = msgb_data(msg); + hdr.iov[0].iov_base = iofd->pending_incomplete ? msg->tail : msgb_data(msg); hdr.iov[0].iov_len = msgb_tailroom(msg); hdr.hdr.msg_iov = &hdr.iov[0]; hdr.hdr.msg_iovlen = 1; -- To view, visit https://gerrit.osmocom.org/c/libosmocore/+/33346 To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: libosmocore Gerrit-Branch: master Gerrit-Change-Id: I0ab8028c807b4181fddd3c00ea2e037c40cf0813 Gerrit-Change-Number: 33346 Gerrit-PatchSet: 1 Gerrit-Owner: arehbein <arehbein(a)sysmocom.de> Gerrit-MessageType: newchange
1 0
0 0
[S] Change in libosmo-netif[master]: stream: Set state to closed before calling disconnect_cb()
by daniel 16 Jun '23

16 Jun '23
Attention is currently required from: fixeria. daniel has posted comments on this change. ( https://gerrit.osmocom.org/c/libosmo-netif/+/33344 ) Change subject: stream: Set state to closed before calling disconnect_cb() ...................................................................... Patch Set 1: (1 comment) Patchset: PS1: I ran the ttcn3 cbc tests here but still hat +8 test failures. No coredump though. I'd appreciate if someone else could test this. -- To view, visit https://gerrit.osmocom.org/c/libosmo-netif/+/33344 To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: libosmo-netif Gerrit-Branch: master Gerrit-Change-Id: I40ceb17c32d1f58f8d0eeda8d1d794cf3f478e83 Gerrit-Change-Number: 33344 Gerrit-PatchSet: 1 Gerrit-Owner: daniel <dwillmann(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Attention: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Comment-Date: Fri, 16 Jun 2023 20:54:49 +0000 Gerrit-HasComments: Yes Gerrit-Has-Labels: No Gerrit-MessageType: comment
1 0
0 0
[S] Change in libosmo-netif[master]: stream: Set state to closed before calling disconnect_cb()
by daniel 16 Jun '23

16 Jun '23
daniel has uploaded this change for review. ( https://gerrit.osmocom.org/c/libosmo-netif/+/33344 ) Change subject: stream: Set state to closed before calling disconnect_cb() ...................................................................... stream: Set state to closed before calling disconnect_cb() Fixes recent crashes in ttcn-cbc-test Change-Id: I40ceb17c32d1f58f8d0eeda8d1d794cf3f478e83 --- M src/stream.c 1 file changed, 16 insertions(+), 3 deletions(-) git pull ssh://gerrit.osmocom.org:29418/libosmo-netif refs/changes/44/33344/1 diff --git a/src/stream.c b/src/stream.c index 31aa058..c710e1b 100644 --- a/src/stream.c +++ b/src/stream.c @@ -337,6 +337,8 @@ * abstraction and close the socket */ void osmo_stream_cli_close(struct osmo_stream_cli *cli) { + int old_state = cli->state; + if (cli->state == STREAM_CLI_STATE_CLOSED) return; if (cli->state == STREAM_CLI_STATE_WAIT_RECONNECT) { @@ -357,13 +359,13 @@ OSMO_ASSERT(false); } - if (cli->state == STREAM_CLI_STATE_CONNECTED) { + cli->state = STREAM_CLI_STATE_CLOSED; + + if (old_state == STREAM_CLI_STATE_CONNECTED) { LOGSCLI(cli, LOGL_DEBUG, "connection closed\n"); if (cli->disconnect_cb) cli->disconnect_cb(cli); } - - cli->state = STREAM_CLI_STATE_CLOSED; } static inline int osmo_stream_cli_fd(const struct osmo_stream_cli *cli) -- To view, visit https://gerrit.osmocom.org/c/libosmo-netif/+/33344 To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: libosmo-netif Gerrit-Branch: master Gerrit-Change-Id: I40ceb17c32d1f58f8d0eeda8d1d794cf3f478e83 Gerrit-Change-Number: 33344 Gerrit-PatchSet: 1 Gerrit-Owner: daniel <dwillmann(a)sysmocom.de> Gerrit-MessageType: newchange
1 0
0 0
[S] Change in osmo-ttcn3-hacks[master]: mgw: Introduce test TC_auep_null
by fixeria 16 Jun '23

16 Jun '23
Attention is currently required from: pespin. fixeria has posted comments on this change. ( https://gerrit.osmocom.org/c/osmo-ttcn3-hacks/+/33322 ) Change subject: mgw: Introduce test TC_auep_null ...................................................................... Patch Set 3: Code-Review+1 -- To view, visit https://gerrit.osmocom.org/c/osmo-ttcn3-hacks/+/33322 To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: osmo-ttcn3-hacks Gerrit-Branch: master Gerrit-Change-Id: I9395cd526cf626974fb0e2ed93ff5d95a433d8c0 Gerrit-Change-Number: 33322 Gerrit-PatchSet: 3 Gerrit-Owner: pespin <pespin(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Reviewer: pespin <pespin(a)sysmocom.de> Gerrit-Attention: pespin <pespin(a)sysmocom.de> Gerrit-Comment-Date: Fri, 16 Jun 2023 16:22:57 +0000 Gerrit-HasComments: No Gerrit-Has-Labels: Yes Gerrit-MessageType: comment
1 0
0 0
  • ← Newer
  • 1
  • ...
  • 100
  • 101
  • 102
  • 103
  • 104
  • 105
  • 106
  • ...
  • 248
  • Older →

HyperKitty Powered by HyperKitty version 1.3.12.