lists.osmocom.org
Sign In Sign Up
Manage this list Sign In Sign Up

Keyboard Shortcuts

Thread View

  • j: Next unread message
  • k: Previous unread message
  • j a: Jump to all threads
  • j l: Jump to MailingList overview

gerrit-log

Thread Start a new thread
Download
Threads by month
  • ----- 2026 -----
  • November
  • October
  • September
  • August
  • July
  • June
  • May
  • April
  • March
  • February
  • January
  • ----- 2025 -----
  • December
  • November
  • October
  • September
  • August
  • July
  • June
  • May
  • April
  • March
  • February
  • January
  • ----- 2024 -----
  • December
  • November
  • October
  • September
  • August
  • July
  • June
  • May
  • April
  • March
  • February
  • January
  • ----- 2023 -----
  • December
  • November
  • October
  • September
  • August
  • July
  • June
  • May
  • April
  • March
  • February
  • January
  • ----- 2022 -----
  • December
  • November
  • October
  • September
  • August
  • July
  • June
  • May
  • April
  • March
  • February
  • January
gerrit-log@lists.osmocom.org

October 2023

  • 1 participants
  • 1843 discussions
[M] Change in osmo-dev[master]: ttcn3.sh: add getopts
by osmith 12 Oct '23

12 Oct '23
osmith has posted comments on this change. ( https://gerrit.osmocom.org/c/osmo-dev/+/34699?usp=email ) Change subject: ttcn3.sh: add getopts ...................................................................... Patch Set 1: Verified+1 -- To view, visit https://gerrit.osmocom.org/c/osmo-dev/+/34699?usp=email To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: osmo-dev Gerrit-Branch: master Gerrit-Change-Id: If55a982d92b2a24a175ab7f3a8f048f054033dc2 Gerrit-Change-Number: 34699 Gerrit-PatchSet: 1 Gerrit-Owner: osmith <osmith(a)sysmocom.de> Gerrit-Reviewer: osmith <osmith(a)sysmocom.de> Gerrit-Comment-Date: Thu, 12 Oct 2023 15:20:22 +0000 Gerrit-HasComments: No Gerrit-Has-Labels: Yes Gerrit-MessageType: comment
1 0
0 0
[M] Change in libosmocore[master]: gsmtap: Hide implementation of gsmtap_inst
by arehbein 12 Oct '23

12 Oct '23
Attention is currently required from: daniel, laforge, pespin. arehbein has posted comments on this change. ( https://gerrit.osmocom.org/c/libosmocore/+/34720?usp=email ) Change subject: gsmtap: Hide implementation of gsmtap_inst ...................................................................... Patch Set 4: (1 comment) File TODO-RELEASE: https://gerrit.osmocom.org/c/libosmocore/+/34720/comment/17382528_3b51da22 PS3, Line 11: core ADD gsmtap_inst_fd2() > append: (Deprecate gsmtap_inst_fd()) Done -- To view, visit https://gerrit.osmocom.org/c/libosmocore/+/34720?usp=email To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: libosmocore Gerrit-Branch: master Gerrit-Change-Id: Ibe1a51205a6df764571b6d074e365825555609a5 Gerrit-Change-Number: 34720 Gerrit-PatchSet: 4 Gerrit-Owner: arehbein <arehbein(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: daniel <dwillmann(a)sysmocom.de> Gerrit-Reviewer: laforge <laforge(a)osmocom.org> Gerrit-Reviewer: pespin <pespin(a)sysmocom.de> Gerrit-Attention: laforge <laforge(a)osmocom.org> Gerrit-Attention: pespin <pespin(a)sysmocom.de> Gerrit-Attention: daniel <dwillmann(a)sysmocom.de> Gerrit-Comment-Date: Thu, 12 Oct 2023 15:10:03 +0000 Gerrit-HasComments: Yes Gerrit-Has-Labels: No Comment-In-Reply-To: pespin <pespin(a)sysmocom.de> Gerrit-MessageType: comment
1 0
0 0
[M] Change in libosmocore[master]: gsmtap: Hide implementation of gsmtap_inst
by arehbein 12 Oct '23

12 Oct '23
Attention is currently required from: daniel, laforge, pespin. arehbein has posted comments on this change. ( https://gerrit.osmocom.org/c/libosmocore/+/34720?usp=email ) Change subject: gsmtap: Hide implementation of gsmtap_inst ...................................................................... Patch Set 4: (3 comments) Patchset: PS3: > BTW, you are missing some sort of comment here regarding the wq field cannot be changed despite bein […] iiuc, this also pertains to the preceding struct member due to possible padding, so I've added a comment for the member `ofd_wq_mode`, too File include/osmocom/core/gsmtap_util.h: https://gerrit.osmocom.org/c/libosmocore/+/34720/comment/14304b99_6d001547 PS3, Line 32: int gsmtap_inst_fd2(struct gsmtap_inst *gti); > while at it, make gti const :) Done File src/core/logging_gsmtap.c: https://gerrit.osmocom.org/c/libosmocore/+/34720/comment/eb560cbb_99bc75f4 PS3, Line 54: struct gsmtap_inst; > This is not needed, you are already adding gsmtap_util.h abovewhich adds this line. Done -- To view, visit https://gerrit.osmocom.org/c/libosmocore/+/34720?usp=email To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: libosmocore Gerrit-Branch: master Gerrit-Change-Id: Ibe1a51205a6df764571b6d074e365825555609a5 Gerrit-Change-Number: 34720 Gerrit-PatchSet: 4 Gerrit-Owner: arehbein <arehbein(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: daniel <dwillmann(a)sysmocom.de> Gerrit-Reviewer: laforge <laforge(a)osmocom.org> Gerrit-Reviewer: pespin <pespin(a)sysmocom.de> Gerrit-Attention: laforge <laforge(a)osmocom.org> Gerrit-Attention: pespin <pespin(a)sysmocom.de> Gerrit-Attention: daniel <dwillmann(a)sysmocom.de> Gerrit-Comment-Date: Thu, 12 Oct 2023 15:09:43 +0000 Gerrit-HasComments: Yes Gerrit-Has-Labels: No Comment-In-Reply-To: pespin <pespin(a)sysmocom.de> Gerrit-MessageType: comment
1 0
0 0
[M] Change in libosmocore[master]: gsmtap: Hide implementation of gsmtap_inst
by arehbein 12 Oct '23

12 Oct '23
Attention is currently required from: arehbein, daniel, laforge, pespin. Hello Jenkins Builder, daniel, laforge, pespin, I'd like you to reexamine a change. Please visit https://gerrit.osmocom.org/c/libosmocore/+/34720?usp=email to look at the new patch set (#4). The following approvals got outdated and were removed: Code-Review-1 by pespin, Verified+1 by Jenkins Builder Change subject: gsmtap: Hide implementation of gsmtap_inst ...................................................................... gsmtap: Hide implementation of gsmtap_inst - Use forward decl. of struct gsmtap_inst in header - Remove 'static inline' attributes from gsmtap_inst_fd() declaration, move function definition to gsmtap_util.c and mark it as deprecated - Add gsmtap_inst_fd2() as replacement for gsmtap_inst_fd() Related: OS#6213 Change-Id: Ibe1a51205a6df764571b6d074e365825555609a5 --- M TODO-RELEASE M include/osmocom/core/gsmtap_util.h M src/core/gsmtap_util.c M src/core/libosmocore.map 4 files changed, 49 insertions(+), 15 deletions(-) git pull ssh://gerrit.osmocom.org:29418/libosmocore refs/changes/20/34720/4 -- To view, visit https://gerrit.osmocom.org/c/libosmocore/+/34720?usp=email To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: libosmocore Gerrit-Branch: master Gerrit-Change-Id: Ibe1a51205a6df764571b6d074e365825555609a5 Gerrit-Change-Number: 34720 Gerrit-PatchSet: 4 Gerrit-Owner: arehbein <arehbein(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: daniel <dwillmann(a)sysmocom.de> Gerrit-Reviewer: laforge <laforge(a)osmocom.org> Gerrit-Reviewer: pespin <pespin(a)sysmocom.de> Gerrit-Attention: arehbein <arehbein(a)sysmocom.de> Gerrit-Attention: laforge <laforge(a)osmocom.org> Gerrit-Attention: pespin <pespin(a)sysmocom.de> Gerrit-Attention: daniel <dwillmann(a)sysmocom.de> Gerrit-MessageType: newpatchset
1 0
0 0
[M] Change in libosmocore[master]: gsmtap: Hide implementation of gsmtap_inst
by pespin 12 Oct '23

12 Oct '23
Attention is currently required from: arehbein, daniel, laforge. pespin has posted comments on this change. ( https://gerrit.osmocom.org/c/libosmocore/+/34720?usp=email ) Change subject: gsmtap: Hide implementation of gsmtap_inst ...................................................................... Patch Set 3: (1 comment) Patchset: PS3: BTW, you are missing some sort of comment here regarding the wq field cannot be changed despite being private, due to struct beign prevoously pulic osmo_gsmtap_fd() acessing it as a static inline. This needs to be done now that the struct is moved to be private! -- To view, visit https://gerrit.osmocom.org/c/libosmocore/+/34720?usp=email To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: libosmocore Gerrit-Branch: master Gerrit-Change-Id: Ibe1a51205a6df764571b6d074e365825555609a5 Gerrit-Change-Number: 34720 Gerrit-PatchSet: 3 Gerrit-Owner: arehbein <arehbein(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: daniel <dwillmann(a)sysmocom.de> Gerrit-Reviewer: laforge <laforge(a)osmocom.org> Gerrit-Reviewer: pespin <pespin(a)sysmocom.de> Gerrit-Attention: arehbein <arehbein(a)sysmocom.de> Gerrit-Attention: laforge <laforge(a)osmocom.org> Gerrit-Attention: daniel <dwillmann(a)sysmocom.de> Gerrit-Comment-Date: Thu, 12 Oct 2023 14:49:58 +0000 Gerrit-HasComments: Yes Gerrit-Has-Labels: No Gerrit-MessageType: comment
1 0
0 0
[M] Change in libosmocore[master]: gsmtap: Hide implementation of gsmtap_inst
by pespin 12 Oct '23

12 Oct '23
Attention is currently required from: daniel, laforge, pespin. pespin has posted comments on this change. ( https://gerrit.osmocom.org/c/libosmocore/+/34720?usp=email ) Change subject: gsmtap: Hide implementation of gsmtap_inst ...................................................................... Patch Set 3: Code-Review-1 (3 comments) File TODO-RELEASE: https://gerrit.osmocom.org/c/libosmocore/+/34720/comment/191b6602_76b8b7be PS3, Line 11: core ADD gsmtap_inst_fd2() append: (Deprecate gsmtap_inst_fd()) File include/osmocom/core/gsmtap_util.h: https://gerrit.osmocom.org/c/libosmocore/+/34720/comment/6c7449f5_c9f7f6e6 PS3, Line 32: int gsmtap_inst_fd2(struct gsmtap_inst *gti); while at it, make gti const :) File src/core/logging_gsmtap.c: https://gerrit.osmocom.org/c/libosmocore/+/34720/comment/14ca953a_3e11f19f PS3, Line 54: struct gsmtap_inst; This is not needed, you are already adding gsmtap_util.h abovewhich adds this line. -- To view, visit https://gerrit.osmocom.org/c/libosmocore/+/34720?usp=email To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: libosmocore Gerrit-Branch: master Gerrit-Change-Id: Ibe1a51205a6df764571b6d074e365825555609a5 Gerrit-Change-Number: 34720 Gerrit-PatchSet: 3 Gerrit-Owner: arehbein <arehbein(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: daniel <dwillmann(a)sysmocom.de> Gerrit-Reviewer: laforge <laforge(a)osmocom.org> Gerrit-Reviewer: pespin <pespin(a)sysmocom.de> Gerrit-Attention: laforge <laforge(a)osmocom.org> Gerrit-Attention: pespin <pespin(a)sysmocom.de> Gerrit-Attention: daniel <dwillmann(a)sysmocom.de> Gerrit-Comment-Date: Thu, 12 Oct 2023 14:48:47 +0000 Gerrit-HasComments: Yes Gerrit-Has-Labels: Yes Gerrit-MessageType: comment
1 0
0 0
[M] Change in libosmocore[master]: gsmtap: Hide implementation of gsmtap_inst
by arehbein 12 Oct '23

12 Oct '23
Attention is currently required from: daniel, laforge, pespin. arehbein has posted comments on this change. ( https://gerrit.osmocom.org/c/libosmocore/+/34720?usp=email ) Change subject: gsmtap: Hide implementation of gsmtap_inst ...................................................................... Patch Set 3: (2 comments) File include/osmocom/core/gsmtap_util.h: https://gerrit.osmocom.org/c/libosmocore/+/34720/comment/d53b48bb_59fe2b8e PS2, Line 30: > in summary: gsmtap_inst_fd() will now become a monster, so better make sure nobody uses that cursed […] Alright... so I have deprecated `gsmtap_inst_fd()` and added `gsmtap_inst_fd2()` without yet changing anything about the implementation (that would be the next commit, I suppose). File src/core/libosmocore.map: https://gerrit.osmocom.org/c/libosmocore/+/34720/comment/f58c7908_ef653696 PS2, Line 42: gsmtap_inst_fd; > Yes, but let's add it as gsmtap_inst_fd2 better. I have added `gsmtap_inst_fd` and `gsmtap_inst_fd2` (the latter as deprecated) to libosmocore.map . I have only added a TODO-RELEASE line for `gsmtap_inst_fd2`. Should I add the deprecated function there, as well? -- To view, visit https://gerrit.osmocom.org/c/libosmocore/+/34720?usp=email To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: libosmocore Gerrit-Branch: master Gerrit-Change-Id: Ibe1a51205a6df764571b6d074e365825555609a5 Gerrit-Change-Number: 34720 Gerrit-PatchSet: 3 Gerrit-Owner: arehbein <arehbein(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: daniel <dwillmann(a)sysmocom.de> Gerrit-Reviewer: laforge <laforge(a)osmocom.org> Gerrit-Reviewer: pespin <pespin(a)sysmocom.de> Gerrit-Attention: laforge <laforge(a)osmocom.org> Gerrit-Attention: pespin <pespin(a)sysmocom.de> Gerrit-Attention: daniel <dwillmann(a)sysmocom.de> Gerrit-Comment-Date: Thu, 12 Oct 2023 14:48:03 +0000 Gerrit-HasComments: Yes Gerrit-Has-Labels: No Comment-In-Reply-To: arehbein <arehbein(a)sysmocom.de> Comment-In-Reply-To: pespin <pespin(a)sysmocom.de> Comment-In-Reply-To: daniel <dwillmann(a)sysmocom.de> Gerrit-MessageType: comment
1 0
0 0
[M] Change in libosmocore[master]: gsmtap: Hide implementation of gsmtap_inst
by arehbein 12 Oct '23

12 Oct '23
Attention is currently required from: arehbein, daniel, laforge. Hello Jenkins Builder, daniel, laforge, pespin, I'd like you to reexamine a change. Please visit https://gerrit.osmocom.org/c/libosmocore/+/34720?usp=email to look at the new patch set (#3). The following approvals got outdated and were removed: Verified+1 by Jenkins Builder Change subject: gsmtap: Hide implementation of gsmtap_inst ...................................................................... gsmtap: Hide implementation of gsmtap_inst - Use forward decl. of struct gsmtap_inst in header - Remove 'static inline' attributes from gsmtap_inst_fd() declaration, move function definition to gsmtap_util.c and mark it as deprecated - Add gsmtap_inst_fd2() as replacement for gsmtap_inst_fd() Related: OS#6213 Change-Id: Ibe1a51205a6df764571b6d074e365825555609a5 --- M TODO-RELEASE M include/osmocom/core/gsmtap_util.h M src/core/gsmtap_util.c M src/core/libosmocore.map M src/core/logging_gsmtap.c 5 files changed, 50 insertions(+), 15 deletions(-) git pull ssh://gerrit.osmocom.org:29418/libosmocore refs/changes/20/34720/3 -- To view, visit https://gerrit.osmocom.org/c/libosmocore/+/34720?usp=email To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: libosmocore Gerrit-Branch: master Gerrit-Change-Id: Ibe1a51205a6df764571b6d074e365825555609a5 Gerrit-Change-Number: 34720 Gerrit-PatchSet: 3 Gerrit-Owner: arehbein <arehbein(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: daniel <dwillmann(a)sysmocom.de> Gerrit-Reviewer: laforge <laforge(a)osmocom.org> Gerrit-Reviewer: pespin <pespin(a)sysmocom.de> Gerrit-Attention: arehbein <arehbein(a)sysmocom.de> Gerrit-Attention: laforge <laforge(a)osmocom.org> Gerrit-Attention: daniel <dwillmann(a)sysmocom.de> Gerrit-MessageType: newpatchset
1 0
0 0
[S] Change in docker-playground[master]: debian-bookworm-titan: add ccache
by osmith 12 Oct '23

12 Oct '23
osmith has submitted this change. ( https://gerrit.osmocom.org/c/docker-playground/+/34703?usp=email ) Change subject: debian-bookworm-titan: add ccache ...................................................................... debian-bookworm-titan: add ccache Add ccache, so it can be used when rebuilding the testsuite from source from a development branch. Ccache is not used by default. Related: osmo-dev I800062d0379295a6905851db29e820ff16217653 Change-Id: I94d22b8da9f897974c5913b2a8138c653c215446 --- M debian-bookworm-titan/Dockerfile 1 file changed, 18 insertions(+), 0 deletions(-) Approvals: pespin: Looks good to me, approved Jenkins Builder: Verified diff --git a/debian-bookworm-titan/Dockerfile b/debian-bookworm-titan/Dockerfile index 99a79c8..fcc00ba 100644 --- a/debian-bookworm-titan/Dockerfile +++ b/debian-bookworm-titan/Dockerfile @@ -19,6 +19,7 @@ apt-get install -y --no-install-recommends \ build-essential \ ca-certificates \ + ccache \ git \ iputils-ping \ netcat-openbsd \ @@ -31,6 +32,10 @@ && \ apt-get clean +# Ccache is installed above so it can be optionally used when rebuilding the +# testsuites inside the docker containers. Don't use it by default. +ENV USE_CCACHE=0 + # Binary-only transcoding library for RANAP/RUA/HNBAP to work around TITAN only implementing BER RUN set -x && \ export DPKG_ARCH="$(dpkg --print-architecture)" && \ -- To view, visit https://gerrit.osmocom.org/c/docker-playground/+/34703?usp=email To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: docker-playground Gerrit-Branch: master Gerrit-Change-Id: I94d22b8da9f897974c5913b2a8138c653c215446 Gerrit-Change-Number: 34703 Gerrit-PatchSet: 3 Gerrit-Owner: osmith <osmith(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: osmith <osmith(a)sysmocom.de> Gerrit-Reviewer: pespin <pespin(a)sysmocom.de> Gerrit-MessageType: merged
1 0
0 0
[S] Change in libosmocore[master]: gsmtap: Hide implementation of gsmtap_inst
by pespin 12 Oct '23

12 Oct '23
Attention is currently required from: arehbein, daniel, laforge. pespin has posted comments on this change. ( https://gerrit.osmocom.org/c/libosmocore/+/34720?usp=email ) Change subject: gsmtap: Hide implementation of gsmtap_inst ...................................................................... Patch Set 2: (1 comment) File include/osmocom/core/gsmtap_util.h: https://gerrit.osmocom.org/c/libosmocore/+/34720/comment/76a73100_4dd62fe2 PS2, Line 30: > No, better move it to a function like you did here. […] in summary: gsmtap_inst_fd() will now become a monster, so better make sure nobody uses that cursed "symbol" name anymore. -- To view, visit https://gerrit.osmocom.org/c/libosmocore/+/34720?usp=email To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: libosmocore Gerrit-Branch: master Gerrit-Change-Id: Ibe1a51205a6df764571b6d074e365825555609a5 Gerrit-Change-Number: 34720 Gerrit-PatchSet: 2 Gerrit-Owner: arehbein <arehbein(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: daniel <dwillmann(a)sysmocom.de> Gerrit-Reviewer: laforge <laforge(a)osmocom.org> Gerrit-Reviewer: pespin <pespin(a)sysmocom.de> Gerrit-Attention: arehbein <arehbein(a)sysmocom.de> Gerrit-Attention: laforge <laforge(a)osmocom.org> Gerrit-Attention: daniel <dwillmann(a)sysmocom.de> Gerrit-Comment-Date: Thu, 12 Oct 2023 13:43:23 +0000 Gerrit-HasComments: Yes Gerrit-Has-Labels: No Comment-In-Reply-To: arehbein <arehbein(a)sysmocom.de> Comment-In-Reply-To: pespin <pespin(a)sysmocom.de> Gerrit-MessageType: comment
1 0
0 0
  • ← Newer
  • 1
  • ...
  • 120
  • 121
  • 122
  • 123
  • 124
  • 125
  • 126
  • ...
  • 185
  • Older →

HyperKitty Powered by HyperKitty version 1.3.12.