lists.osmocom.org
Sign In Sign Up
Manage this list Sign In Sign Up

Keyboard Shortcuts

Thread View

  • j: Next unread message
  • k: Previous unread message
  • j a: Jump to all threads
  • j l: Jump to MailingList overview

gerrit-log

Thread Start a new thread
Download
Threads by month
  • ----- 2026 -----
  • November
  • October
  • September
  • August
  • July
  • June
  • May
  • April
  • March
  • February
  • January
  • ----- 2025 -----
  • December
  • November
  • October
  • September
  • August
  • July
  • June
  • May
  • April
  • March
  • February
  • January
  • ----- 2024 -----
  • December
  • November
  • October
  • September
  • August
  • July
  • June
  • May
  • April
  • March
  • February
  • January
  • ----- 2023 -----
  • December
  • November
  • October
  • September
  • August
  • July
  • June
  • May
  • April
  • March
  • February
  • January
  • ----- 2022 -----
  • December
  • November
  • October
  • September
  • August
  • July
  • June
  • May
  • April
  • March
  • February
  • January
gerrit-log@lists.osmocom.org

June 2023

  • 1 participants
  • 2480 discussions
[S] Change in osmo-ttcn3-hacks[master]: BTS_Tests: cosmetic: fix wrong altstep name in a comment
by fixeria 01 Jun '23

01 Jun '23
fixeria has submitted this change. ( https://gerrit.osmocom.org/c/osmo-ttcn3-hacks/+/33114 ) Change subject: BTS_Tests: cosmetic: fix wrong altstep name in a comment ...................................................................... BTS_Tests: cosmetic: fix wrong altstep name in a comment Change-Id: I4e63f309f2a7d22752f7991ebd7e672939d4e52b --- M bts/BTS_Tests.ttcn 1 file changed, 10 insertions(+), 1 deletion(-) Approvals: Jenkins Builder: Verified laforge: Looks good to me, approved pespin: Looks good to me, approved diff --git a/bts/BTS_Tests.ttcn b/bts/BTS_Tests.ttcn index e715996..d03843d 100644 --- a/bts/BTS_Tests.ttcn +++ b/bts/BTS_Tests.ttcn @@ -7966,7 +7966,7 @@ } -/* Callback function to be called by as_TC_ms_pwr_ctrl_constant(). +/* Callback function to be called by as_TC_ms_pwr_ctrl(). * Return value: Measurement Report to be sent (encoded octetstring). */ type function f_TC_ms_pwr_ctrl_cb(inout SacchL1Header l1h, integer num_blocks) runs on ConnHdlr return octetstring; -- To view, visit https://gerrit.osmocom.org/c/osmo-ttcn3-hacks/+/33114 To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: osmo-ttcn3-hacks Gerrit-Branch: master Gerrit-Change-Id: I4e63f309f2a7d22752f7991ebd7e672939d4e52b Gerrit-Change-Number: 33114 Gerrit-PatchSet: 1 Gerrit-Owner: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Reviewer: laforge <laforge(a)osmocom.org> Gerrit-Reviewer: pespin <pespin(a)sysmocom.de> Gerrit-MessageType: merged
1 0
0 0
[S] Change in osmo-ttcn3-hacks[master]: BTS_Tests: properly release DCCH in f_TC_acch_overpower()
by fixeria 01 Jun '23

01 Jun '23
fixeria has submitted this change. ( https://gerrit.osmocom.org/c/osmo-ttcn3-hacks/+/33115 ) Change subject: BTS_Tests: properly release DCCH in f_TC_acch_overpower() ...................................................................... BTS_Tests: properly release DCCH in f_TC_acch_overpower() Currently the TC_acch_overpower_* testcases are all passing without any sporadic failures. However, most of them start failing due to a DTE (some RSLEM related race condition) if I apply a patch [1] to trxcon removing its internal TDMA clock module. I don't know why this happens, but releasing the DCCH after executing all testcase steps in f_TC_acch_overpower() makes that DTE go away. Change-Id: I658e78ad8d4dc86403d22b5380ddd9a140f8c71c Related: [1] osmocom-bb.git Ic8a5b6277c6b16392026e0557376257d71c9d230 Related: OS#5500 --- M bts/BTS_Tests.ttcn 1 file changed, 23 insertions(+), 0 deletions(-) Approvals: Jenkins Builder: Verified laforge: Looks good to me, but someone else must approve pespin: Looks good to me, approved diff --git a/bts/BTS_Tests.ttcn b/bts/BTS_Tests.ttcn index d03843d..8d02c40 100644 --- a/bts/BTS_Tests.ttcn +++ b/bts/BTS_Tests.ttcn @@ -8656,6 +8656,10 @@ setverdict(pass); } + + f_rsl_chan_deact(); + f_L1CTL_DM_REL_REQ(L1CTL, g_chan_nr); + f_rslem_unregister(g_pars.trx_nr, g_chan_nr); } testcase TC_acch_overpower_rxqual_thresh() runs on test_CT { var ConnHdlrPars pars; -- To view, visit https://gerrit.osmocom.org/c/osmo-ttcn3-hacks/+/33115 To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: osmo-ttcn3-hacks Gerrit-Branch: master Gerrit-Change-Id: I658e78ad8d4dc86403d22b5380ddd9a140f8c71c Gerrit-Change-Number: 33115 Gerrit-PatchSet: 1 Gerrit-Owner: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Reviewer: laforge <laforge(a)osmocom.org> Gerrit-Reviewer: pespin <pespin(a)sysmocom.de> Gerrit-MessageType: merged
1 0
0 0
[S] Change in pysim[master]: Switch from pycryptodome to pycryptodomex
by pespin 01 Jun '23

01 Jun '23
Attention is currently required from: laforge. pespin has posted comments on this change. ( https://gerrit.osmocom.org/c/pysim/+/33124 ) Change subject: Switch from pycryptodome to pycryptodomex ...................................................................... Patch Set 1: Code-Review+1 -- To view, visit https://gerrit.osmocom.org/c/pysim/+/33124 To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: pysim Gerrit-Branch: master Gerrit-Change-Id: I04daed01f51f9702595ef9f9e0d7fcdf1e4adb62 Gerrit-Change-Number: 33124 Gerrit-PatchSet: 1 Gerrit-Owner: laforge <laforge(a)osmocom.org> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: pespin <pespin(a)sysmocom.de> Gerrit-Attention: laforge <laforge(a)osmocom.org> Gerrit-Comment-Date: Thu, 01 Jun 2023 08:01:02 +0000 Gerrit-HasComments: No Gerrit-Has-Labels: Yes Gerrit-MessageType: comment
1 0
0 0
[S] Change in osmo-ttcn3-hacks[master]: BTS_Tests: cosmetic: fix wrong altstep name in a comment
by pespin 01 Jun '23

01 Jun '23
Attention is currently required from: fixeria. pespin has posted comments on this change. ( https://gerrit.osmocom.org/c/osmo-ttcn3-hacks/+/33114 ) Change subject: BTS_Tests: cosmetic: fix wrong altstep name in a comment ...................................................................... Patch Set 1: Code-Review+2 -- To view, visit https://gerrit.osmocom.org/c/osmo-ttcn3-hacks/+/33114 To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: osmo-ttcn3-hacks Gerrit-Branch: master Gerrit-Change-Id: I4e63f309f2a7d22752f7991ebd7e672939d4e52b Gerrit-Change-Number: 33114 Gerrit-PatchSet: 1 Gerrit-Owner: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: laforge <laforge(a)osmocom.org> Gerrit-Reviewer: pespin <pespin(a)sysmocom.de> Gerrit-Attention: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Comment-Date: Thu, 01 Jun 2023 07:59:59 +0000 Gerrit-HasComments: No Gerrit-Has-Labels: Yes Gerrit-MessageType: comment
1 0
0 0
[S] Change in osmo-ttcn3-hacks[master]: BTS_Tests: properly release DCCH in f_TC_acch_overpower()
by pespin 01 Jun '23

01 Jun '23
Attention is currently required from: fixeria. pespin has posted comments on this change. ( https://gerrit.osmocom.org/c/osmo-ttcn3-hacks/+/33115 ) Change subject: BTS_Tests: properly release DCCH in f_TC_acch_overpower() ...................................................................... Patch Set 1: Code-Review+2 -- To view, visit https://gerrit.osmocom.org/c/osmo-ttcn3-hacks/+/33115 To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: osmo-ttcn3-hacks Gerrit-Branch: master Gerrit-Change-Id: I658e78ad8d4dc86403d22b5380ddd9a140f8c71c Gerrit-Change-Number: 33115 Gerrit-PatchSet: 1 Gerrit-Owner: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: laforge <laforge(a)osmocom.org> Gerrit-Reviewer: pespin <pespin(a)sysmocom.de> Gerrit-Attention: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Comment-Date: Thu, 01 Jun 2023 07:59:41 +0000 Gerrit-HasComments: No Gerrit-Has-Labels: Yes Gerrit-MessageType: comment
1 0
0 0
[S] Change in osmo-pcu[master]: Derive FN from RFN once and cache it in struct rach_ind_params
by fixeria 01 Jun '23

01 Jun '23
Attention is currently required from: pespin. fixeria has posted comments on this change. ( https://gerrit.osmocom.org/c/osmo-pcu/+/33121 ) Change subject: Derive FN from RFN once and cache it in struct rach_ind_params ...................................................................... Patch Set 2: Code-Review+2 -- To view, visit https://gerrit.osmocom.org/c/osmo-pcu/+/33121 To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: osmo-pcu Gerrit-Branch: master Gerrit-Change-Id: Iaefb9650dfc5083360a4a24b9c17fdbf3115e51f Gerrit-Change-Number: 33121 Gerrit-PatchSet: 2 Gerrit-Owner: pespin <pespin(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Reviewer: laforge <laforge(a)osmocom.org> Gerrit-Attention: pespin <pespin(a)sysmocom.de> Gerrit-Comment-Date: Thu, 01 Jun 2023 07:57:31 +0000 Gerrit-HasComments: No Gerrit-Has-Labels: Yes Gerrit-MessageType: comment
1 0
0 0
[M] Change in osmo-pcu[master]: encoding: only RFN needed in write_immediate_assignment(_reject)()
by fixeria 01 Jun '23

01 Jun '23
Attention is currently required from: pespin. fixeria has posted comments on this change. ( https://gerrit.osmocom.org/c/osmo-pcu/+/33123 ) Change subject: encoding: only RFN needed in write_immediate_assignment(_reject)() ...................................................................... Patch Set 1: (3 comments) Commit Message: https://gerrit.osmocom.org/c/osmo-pcu/+/33123/comment/0822cf34_bd167880 PS1, Line 7: RFN needed in write_immediate_assignment(_reject)() I don't understand you here. RFN is actually the result of the reduced encoding performed by these functions. This encoding itself does not require the input to be absolute or reduced Fn, it does not really matter. Not sure what do we benefit with this change? https://gerrit.osmocom.org/c/osmo-pcu/+/33123/comment/717b7298_01ded1cd PS1, Line 12: 10.5.2.30 3GPP TS 44.018? File src/bts.cpp: https://gerrit.osmocom.org/c/osmo-pcu/+/33123/comment/795ddf82_1eed4747 PS1, Line 1121: GSM_TDMA_FN_SUM I think you can remove the `GSM_TDMA_FN_SUM` now and simply do: ``` fn2rfn(pdch->last_rts_fn + 21216) ``` BTW, I just realized that `21216` is `RFN_MODULUS / 2`. -- To view, visit https://gerrit.osmocom.org/c/osmo-pcu/+/33123 To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: osmo-pcu Gerrit-Branch: master Gerrit-Change-Id: If9b758434c00f2a3868534d5be84946809c989a9 Gerrit-Change-Number: 33123 Gerrit-PatchSet: 1 Gerrit-Owner: pespin <pespin(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: laforge <laforge(a)osmocom.org> Gerrit-CC: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Attention: pespin <pespin(a)sysmocom.de> Gerrit-Comment-Date: Thu, 01 Jun 2023 07:56:07 +0000 Gerrit-HasComments: Yes Gerrit-Has-Labels: No Gerrit-MessageType: comment
1 0
0 0
[L] Change in osmo-hnbgw[master]: cnpool: make NRI mappings VTY configurable
by laforge 01 Jun '23

01 Jun '23
Attention is currently required from: neels. laforge has posted comments on this change. ( https://gerrit.osmocom.org/c/osmo-hnbgw/+/33130 ) Change subject: cnpool: make NRI mappings VTY configurable ...................................................................... Patch Set 1: Code-Review+1 -- To view, visit https://gerrit.osmocom.org/c/osmo-hnbgw/+/33130 To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: osmo-hnbgw Gerrit-Branch: master Gerrit-Change-Id: Ifb87e01e5971962e5cfe5e127871af4a67806de1 Gerrit-Change-Number: 33130 Gerrit-PatchSet: 1 Gerrit-Owner: neels <nhofmeyr(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: laforge <laforge(a)osmocom.org> Gerrit-Attention: neels <nhofmeyr(a)sysmocom.de> Gerrit-Comment-Date: Thu, 01 Jun 2023 07:43:57 +0000 Gerrit-HasComments: No Gerrit-Has-Labels: Yes Gerrit-MessageType: comment
1 0
0 0
[M] Change in osmo-hnbgw[master]: cnpool: examples and config tests: use 'msc 0'/'sgsn 0' syntax
by laforge 01 Jun '23

01 Jun '23
Attention is currently required from: neels. laforge has posted comments on this change. ( https://gerrit.osmocom.org/c/osmo-hnbgw/+/33129 ) Change subject: cnpool: examples and config tests: use 'msc 0'/'sgsn 0' syntax ...................................................................... Patch Set 1: Code-Review+1 -- To view, visit https://gerrit.osmocom.org/c/osmo-hnbgw/+/33129 To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: osmo-hnbgw Gerrit-Branch: master Gerrit-Change-Id: If999b71a8a8237699f6ccfcaa31d1885e66c0518 Gerrit-Change-Number: 33129 Gerrit-PatchSet: 1 Gerrit-Owner: neels <nhofmeyr(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: laforge <laforge(a)osmocom.org> Gerrit-Attention: neels <nhofmeyr(a)sysmocom.de> Gerrit-Comment-Date: Thu, 01 Jun 2023 07:43:04 +0000 Gerrit-HasComments: No Gerrit-Has-Labels: Yes Gerrit-MessageType: comment
1 0
0 0
[S] Change in osmo-hnbgw[master]: cnpool prep: add SCCP_EV_USER_ABORT
by laforge 01 Jun '23

01 Jun '23
Attention is currently required from: neels. laforge has posted comments on this change. ( https://gerrit.osmocom.org/c/osmo-hnbgw/+/33128 ) Change subject: cnpool prep: add SCCP_EV_USER_ABORT ...................................................................... Patch Set 1: Code-Review+1 (1 comment) File src/osmo-hnbgw/context_map_sccp.c: https://gerrit.osmocom.org/c/osmo-hnbgw/+/33128/comment/20f822dd_b3ec7e2b PS1, Line 451: tx_sccp_rlsd Like in previous review, I'd appreciate if we could rename this mis-nomed function -- To view, visit https://gerrit.osmocom.org/c/osmo-hnbgw/+/33128 To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: osmo-hnbgw Gerrit-Branch: master Gerrit-Change-Id: Idff8e09b5328c904b175e4d4df7d4044a34f4a20 Gerrit-Change-Number: 33128 Gerrit-PatchSet: 1 Gerrit-Owner: neels <nhofmeyr(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: laforge <laforge(a)osmocom.org> Gerrit-Attention: neels <nhofmeyr(a)sysmocom.de> Gerrit-Comment-Date: Thu, 01 Jun 2023 07:42:40 +0000 Gerrit-HasComments: Yes Gerrit-Has-Labels: Yes Gerrit-MessageType: comment
1 0
0 0
  • ← Newer
  • 1
  • ...
  • 242
  • 243
  • 244
  • 245
  • 246
  • 247
  • 248
  • Older →

HyperKitty Powered by HyperKitty version 1.3.12.