lists.osmocom.org
Sign In Sign Up
Manage this list Sign In Sign Up

Keyboard Shortcuts

Thread View

  • j: Next unread message
  • k: Previous unread message
  • j a: Jump to all threads
  • j l: Jump to MailingList overview

gerrit-log

Thread Start a new thread
Download
Threads by month
  • ----- 2026 -----
  • November
  • October
  • September
  • August
  • July
  • June
  • May
  • April
  • March
  • February
  • January
  • ----- 2025 -----
  • December
  • November
  • October
  • September
  • August
  • July
  • June
  • May
  • April
  • March
  • February
  • January
  • ----- 2024 -----
  • December
  • November
  • October
  • September
  • August
  • July
  • June
  • May
  • April
  • March
  • February
  • January
  • ----- 2023 -----
  • December
  • November
  • October
  • September
  • August
  • July
  • June
  • May
  • April
  • March
  • February
  • January
  • ----- 2022 -----
  • December
  • November
  • October
  • September
  • August
  • July
  • June
  • May
  • April
  • March
  • February
  • January
gerrit-log@lists.osmocom.org

June 2023

  • 1 participants
  • 2480 discussions
[M] Change in osmo-hnbgw[master]: add rate_ctr infra; add rate_ctrs for cnpool
by neels 05 Jun '23

05 Jun '23
Attention is currently required from: neels. Hello Jenkins Builder, laforge, pespin, I'd like you to reexamine a change. Please visit https://gerrit.osmocom.org/c/osmo-hnbgw/+/33134 to look at the new patch set (#4). Change subject: add rate_ctr infra; add rate_ctrs for cnpool ...................................................................... add rate_ctr infra; add rate_ctrs for cnpool Introduce rate counter stats to osmo-hnbgw. Add the first rate counters -- they will be fed in upcoming commit "cnpool: select CN link from pool by NRI or round robin" I66fba27cfbe6e2b27ee3443718846ecfbbd8a974 Related: SYS#6412 Change-Id: I0132d053223a38e5756cede74106019c47ddcd94 --- M include/osmocom/hnbgw/hnbgw.h M include/osmocom/hnbgw/hnbgw_cn.h M src/osmo-hnbgw/hnbgw.c M src/osmo-hnbgw/hnbgw_cn.c M src/osmo-hnbgw/osmo_hnbgw_main.c 5 files changed, 153 insertions(+), 0 deletions(-) git pull ssh://gerrit.osmocom.org:29418/osmo-hnbgw refs/changes/34/33134/4 -- To view, visit https://gerrit.osmocom.org/c/osmo-hnbgw/+/33134 To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: osmo-hnbgw Gerrit-Branch: master Gerrit-Change-Id: I0132d053223a38e5756cede74106019c47ddcd94 Gerrit-Change-Number: 33134 Gerrit-PatchSet: 4 Gerrit-Owner: neels <nhofmeyr(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: laforge <laforge(a)osmocom.org> Gerrit-Reviewer: pespin <pespin(a)sysmocom.de> Gerrit-Attention: neels <nhofmeyr(a)sysmocom.de> Gerrit-MessageType: newpatchset
1 0
0 0
[M] Change in osmo-hnbgw[master]: doc/examples/osmo-hnbgw/osmo-hnbgw-cnpool.cfg
by neels 05 Jun '23

05 Jun '23
Attention is currently required from: neels. Hello Jenkins Builder, I'd like you to reexamine a change. Please visit https://gerrit.osmocom.org/c/osmo-hnbgw/+/33168 to look at the new patch set (#2). Change subject: doc/examples/osmo-hnbgw/osmo-hnbgw-cnpool.cfg ...................................................................... doc/examples/osmo-hnbgw/osmo-hnbgw-cnpool.cfg Change-Id: I932eca7489f29eab23d180cd6d1216d26c62dd30 --- M contrib/osmo-hnbgw.spec.in M debian/osmo-hnbgw.install A doc/examples/osmo-hnbgw/osmo-hnbgw-cnpool.cfg 3 files changed, 50 insertions(+), 0 deletions(-) git pull ssh://gerrit.osmocom.org:29418/osmo-hnbgw refs/changes/68/33168/2 -- To view, visit https://gerrit.osmocom.org/c/osmo-hnbgw/+/33168 To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: osmo-hnbgw Gerrit-Branch: master Gerrit-Change-Id: I932eca7489f29eab23d180cd6d1216d26c62dd30 Gerrit-Change-Number: 33168 Gerrit-PatchSet: 2 Gerrit-Owner: neels <nhofmeyr(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Attention: neels <nhofmeyr(a)sysmocom.de> Gerrit-MessageType: newpatchset
1 0
0 0
[S] Change in osmo-hnbgw[master]: dist: package all .cfg files
by neels 05 Jun '23

05 Jun '23
neels has uploaded this change for review. ( https://gerrit.osmocom.org/c/osmo-hnbgw/+/33182 ) Change subject: dist: package all .cfg files ...................................................................... dist: package all .cfg files Fix confusion in doc/examples/Makefile.am: there are two variables, $OSMOCONF_FILES and $CFG_FILES, with various levels of collecting all cfg files and having an effect... Drop $OSMOCONF_FILES. Use $CFG_FILES for EXTRA_DIST. Change-Id: I5fbba1f005c4322a9a11879ebf3dd1d6c25d2cd5 --- M doc/examples/Makefile.am 1 file changed, 17 insertions(+), 8 deletions(-) git pull ssh://gerrit.osmocom.org:29418/osmo-hnbgw refs/changes/82/33182/1 diff --git a/doc/examples/Makefile.am b/doc/examples/Makefile.am index d1c6d51..b31772d 100644 --- a/doc/examples/Makefile.am +++ b/doc/examples/Makefile.am @@ -1,12 +1,5 @@ -OSMOCONF_FILES = \ - osmo-hnbgw/osmo-hnbgw.cfg - -osmoconfdir = $(sysconfdir)/osmocom -osmoconf_DATA = $(OSMOCONF_FILES) - -EXTRA_DIST = $(OSMOCONF_FILES) - CFG_FILES = find $(srcdir) -name '*.cfg*' | sed -e 's,^$(srcdir),,' +EXTRA_DIST = $(CFG_FILES) dist-hook: for f in $$($(CFG_FILES)); do \ -- To view, visit https://gerrit.osmocom.org/c/osmo-hnbgw/+/33182 To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: osmo-hnbgw Gerrit-Branch: master Gerrit-Change-Id: I5fbba1f005c4322a9a11879ebf3dd1d6c25d2cd5 Gerrit-Change-Number: 33182 Gerrit-PatchSet: 1 Gerrit-Owner: neels <nhofmeyr(a)sysmocom.de> Gerrit-MessageType: newchange
1 0
0 0
[S] Change in dahdi-linux[master]: kernel 6.4 API change in DEFINE_SEMAPHORE
by laforge 05 Jun '23

05 Jun '23
laforge has uploaded this change for review. ( https://gerrit.osmocom.org/c/dahdi-linux/+/33181 ) Change subject: kernel 6.4 API change in DEFINE_SEMAPHORE ...................................................................... kernel 6.4 API change in DEFINE_SEMAPHORE This works around build failures with kernel >= v6.4-rc1 where the DEFINE_SEMAPHORE macro is adjusted in upstream kernel commit 48380368dec14859723b9e3fbd43e042638d9a76 Change-Id: I752c903c8a0345af6e51a996d064c9d629578ab4 --- M include/dahdi/kernel.h 1 file changed, 19 insertions(+), 0 deletions(-) git pull ssh://gerrit.osmocom.org:29418/dahdi-linux refs/changes/81/33181/1 diff --git a/include/dahdi/kernel.h b/include/dahdi/kernel.h index 778c2b2..08375f2 100644 --- a/include/dahdi/kernel.h +++ b/include/dahdi/kernel.h @@ -1551,10 +1551,16 @@ #define DEFINE_SPINLOCK(x) spinlock_t x = SPIN_LOCK_UNLOCKED #endif +#if LINUX_VERSION_CODE < KERNEL_VERSION(6, 4, 0) #ifndef DEFINE_SEMAPHORE #define DEFINE_SEMAPHORE(name) \ struct semaphore name = __SEMAPHORE_INITIALIZER(name, 1) #endif +#else /* 6.4.0, speficcally 48380368dec14859723b9e3fbd43e042638d9a76 */ +#undef DEFINE_SEMAPHORE +#define DEFINE_SEMAPHORE(name) \ + struct semaphore name = __SEMAPHORE_INITIALIZER(name, 1) +#endif #ifndef DEFINE_MUTEX struct mutex { -- To view, visit https://gerrit.osmocom.org/c/dahdi-linux/+/33181 To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: dahdi-linux Gerrit-Branch: master Gerrit-Change-Id: I752c903c8a0345af6e51a996d064c9d629578ab4 Gerrit-Change-Number: 33181 Gerrit-PatchSet: 1 Gerrit-Owner: laforge <laforge(a)osmocom.org> Gerrit-MessageType: newchange
1 0
0 0
[S] Change in libosmocore[master]: struct osmo_sub_auth_data: remove OSMO_DEPRECATED_OUTSIDE
by laforge 05 Jun '23

05 Jun '23
laforge has submitted this change. ( https://gerrit.osmocom.org/c/libosmocore/+/33164 ) Change subject: struct osmo_sub_auth_data: remove OSMO_DEPRECATED_OUTSIDE ...................................................................... struct osmo_sub_auth_data: remove OSMO_DEPRECATED_OUTSIDE I was the one who suggested adding this attribute during code review, and now, having realized it was a bad idea, I am removing it. The problem is that this attribute spams compilation logs of projects including file <osmocom/crypt/auth.h>, even if the deprecated struct is not used directly at all. Change-Id: Ia5d365206207872d5d3fdd4ae40273eab909fb33 Fixes: 08450c9e "libosmogsm: Support authentication with 256-bit K and/or OP/OPc" --- M include/osmocom/crypt/auth.h 1 file changed, 17 insertions(+), 1 deletion(-) Approvals: laforge: Looks good to me, approved Jenkins Builder: Verified diff --git a/include/osmocom/crypt/auth.h b/include/osmocom/crypt/auth.h index f73a48b..1499ef8 100644 --- a/include/osmocom/crypt/auth.h +++ b/include/osmocom/crypt/auth.h @@ -83,7 +83,7 @@ uint8_t ki[OSMO_A5_MAX_KEY_LEN_BYTES]; /*!< secret key */ } gsm; } u; -} OSMO_DEPRECATED_OUTSIDE("Use osmo_sub_auth_data2 instead"); +}; /* data structure describing a computed auth vector, generated by AuC */ struct osmo_auth_vector { -- To view, visit https://gerrit.osmocom.org/c/libosmocore/+/33164 To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: libosmocore Gerrit-Branch: master Gerrit-Change-Id: Ia5d365206207872d5d3fdd4ae40273eab909fb33 Gerrit-Change-Number: 33164 Gerrit-PatchSet: 2 Gerrit-Owner: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: laforge <laforge(a)osmocom.org> Gerrit-MessageType: merged
1 0
0 0
[S] Change in libosmocore[master]: struct osmo_sub_auth_data: remove OSMO_DEPRECATED_OUTSIDE
by laforge 05 Jun '23

05 Jun '23
Attention is currently required from: fixeria. laforge has posted comments on this change. ( https://gerrit.osmocom.org/c/libosmocore/+/33164 ) Change subject: struct osmo_sub_auth_data: remove OSMO_DEPRECATED_OUTSIDE ...................................................................... Patch Set 1: Code-Review+2 -- To view, visit https://gerrit.osmocom.org/c/libosmocore/+/33164 To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: libosmocore Gerrit-Branch: master Gerrit-Change-Id: Ia5d365206207872d5d3fdd4ae40273eab909fb33 Gerrit-Change-Number: 33164 Gerrit-PatchSet: 1 Gerrit-Owner: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: laforge <laforge(a)osmocom.org> Gerrit-Attention: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Comment-Date: Mon, 05 Jun 2023 18:33:46 +0000 Gerrit-HasComments: No Gerrit-Has-Labels: Yes Gerrit-MessageType: comment
1 0
0 0
[M] Change in osmo-bts[master]: paging: parse PCUIF data indication outside of paging.c
by Jenkins Builder 05 Jun '23

05 Jun '23
Attention is currently required from: fixeria, pespin. Jenkins Builder has posted comments on this change. ( https://gerrit.osmocom.org/c/osmo-bts/+/32733 ) Change subject: paging: parse PCUIF data indication outside of paging.c ...................................................................... Patch Set 6: (1 comment) File src/common/pcu_sock.c: Robot Comment from checkpatch (run ID jenkins-gerrit-lint-7831): https://gerrit.osmocom.org/c/osmo-bts/+/32733/comment/864ee77a_4ac2325e PS6, Line 679: osmo_strlcpy(&imsi[0], (char*)data_req->data, sizeof(imsi)); "(foo*)" should be "(foo *)" -- To view, visit https://gerrit.osmocom.org/c/osmo-bts/+/32733 To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: osmo-bts Gerrit-Branch: master Gerrit-Change-Id: I9f3799916e8102bf1ce0f21891f2d24f43091f01 Gerrit-Change-Number: 32733 Gerrit-PatchSet: 6 Gerrit-Owner: dexter <pmaier(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Reviewer: pespin <pespin(a)sysmocom.de> Gerrit-Attention: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Attention: pespin <pespin(a)sysmocom.de> Gerrit-Comment-Date: Mon, 05 Jun 2023 15:34:41 +0000 Gerrit-HasComments: Yes Gerrit-Has-Labels: No Gerrit-MessageType: comment
1 0
0 0
[M] Change in osmo-bts[master]: paging: parse PCUIF data indication outside of paging.c
by dexter 05 Jun '23

05 Jun '23
Attention is currently required from: fixeria, pespin. dexter has posted comments on this change. ( https://gerrit.osmocom.org/c/osmo-bts/+/32733 ) Change subject: paging: parse PCUIF data indication outside of paging.c ...................................................................... Patch Set 6: (2 comments) File src/common/paging.c: https://gerrit.osmocom.org/c/osmo-bts/+/32733/comment/5e89f3d6_7d6e0f53 PS5, Line 273: uint8_t macblock_len > In GSM all MAC blocks must have `length == GSM_MACBLOCK_LEN`. […] That is correct. In the new protocol the field is GSM_MACBLOCK_LEN, so we can be sure that the length always fits. I have moved the check now to pcu_sock.c. File src/common/pcu_sock.c: https://gerrit.osmocom.org/c/osmo-bts/+/32733/comment/c028ab60_25db7ad3 PS5, Line 679: memcpy(imsi, data_req->data, 3); > `osmo_strlcpy(&imsi[0], data_req->data, sizeof(imsi))` - this looks more readable and requires no pr […] (This code section will be removed when we change to PCUIF v.11) -- To view, visit https://gerrit.osmocom.org/c/osmo-bts/+/32733 To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: osmo-bts Gerrit-Branch: master Gerrit-Change-Id: I9f3799916e8102bf1ce0f21891f2d24f43091f01 Gerrit-Change-Number: 32733 Gerrit-PatchSet: 6 Gerrit-Owner: dexter <pmaier(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Reviewer: pespin <pespin(a)sysmocom.de> Gerrit-Attention: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Attention: pespin <pespin(a)sysmocom.de> Gerrit-Comment-Date: Mon, 05 Jun 2023 15:33:12 +0000 Gerrit-HasComments: Yes Gerrit-Has-Labels: No Comment-In-Reply-To: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-MessageType: comment
1 0
0 0
[M] Change in osmo-bts[master]: paging: parse PCUIF data indication outside of paging.c
by dexter 05 Jun '23

05 Jun '23
Attention is currently required from: fixeria, pespin. Hello Jenkins Builder, pespin, fixeria, I'd like you to reexamine a change. Please visit https://gerrit.osmocom.org/c/osmo-bts/+/32733 to look at the new patch set (#6). Change subject: paging: parse PCUIF data indication outside of paging.c ...................................................................... paging: parse PCUIF data indication outside of paging.c The function paging_add_macblock takes a data and length parameter. The first three byte of that string are the last three digits of the IMSI from which the paging group is calculated. As the layout of this data buffer is a property of the PCUIF interface API, we should do this separation outside of paging.c. Also we should supply the IMSI as a valid null terminated string since PCUIF v.11 also uses this format. Change-Id: I9f3799916e8102bf1ce0f21891f2d24f43091f01 Related: OS#5927 --- M include/osmo-bts/paging.h M src/common/paging.c M src/common/pcu_sock.c 3 files changed, 42 insertions(+), 16 deletions(-) git pull ssh://gerrit.osmocom.org:29418/osmo-bts refs/changes/33/32733/6 -- To view, visit https://gerrit.osmocom.org/c/osmo-bts/+/32733 To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: osmo-bts Gerrit-Branch: master Gerrit-Change-Id: I9f3799916e8102bf1ce0f21891f2d24f43091f01 Gerrit-Change-Number: 32733 Gerrit-PatchSet: 6 Gerrit-Owner: dexter <pmaier(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Reviewer: pespin <pespin(a)sysmocom.de> Gerrit-Attention: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Attention: pespin <pespin(a)sysmocom.de> Gerrit-MessageType: newpatchset
1 0
0 0
[S] Change in osmo-bts[master]: paging: do not confirm PAGING COMMAND messages
by dexter 05 Jun '23

05 Jun '23
Attention is currently required from: fixeria. Hello Jenkins Builder, pespin, fixeria, I'd like you to reexamine a change. Please visit https://gerrit.osmocom.org/c/osmo-bts/+/32734 to look at the new patch set (#7). Change subject: paging: do not confirm PAGING COMMAND messages ...................................................................... paging: do not confirm PAGING COMMAND messages when osmo-bts receives a MAC block from osmo-pcu through the PCUIF it puts it in the review queue without further interpreting it. This also means that it will send confirmations to the PCU for IMMEDIATE ASSIGNMENT and PAGING COMMAND. This is not entirely correct because only IMMEDIATE ASSIGNMENT messages should be confirmed. osmo-pcu has no problem with this since it silently drops the confirmations for PAGING COMMAND messages. This peculiarity of the PCUIF implementation makes the confirmation logic hard to understand, so let's add some logic to osmo-bts that makes sure that only IMMEDIATE ASSIGNMENT messages are confirmed. Related: OS#5927 Change-Id: I8b8264d28b1b1deb08774cdba58dd4c6dafe115d --- M include/osmo-bts/paging.h M src/common/paging.c M src/common/pcu_sock.c 3 files changed, 35 insertions(+), 5 deletions(-) git pull ssh://gerrit.osmocom.org:29418/osmo-bts refs/changes/34/32734/7 -- To view, visit https://gerrit.osmocom.org/c/osmo-bts/+/32734 To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: osmo-bts Gerrit-Branch: master Gerrit-Change-Id: I8b8264d28b1b1deb08774cdba58dd4c6dafe115d Gerrit-Change-Number: 32734 Gerrit-PatchSet: 7 Gerrit-Owner: dexter <pmaier(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Reviewer: pespin <pespin(a)sysmocom.de> Gerrit-Attention: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-MessageType: newpatchset
1 0
0 0
  • ← Newer
  • 1
  • ...
  • 210
  • 211
  • 212
  • 213
  • 214
  • 215
  • 216
  • ...
  • 248
  • Older →

HyperKitty Powered by HyperKitty version 1.3.12.