[M] Change in osmo-bts[master]: paging: parse PCUIF data indication outside of paging.c
Attention is currently required from: fixeria, pespin. dexter has posted comments on this change. ( https://gerrit.osmocom.org/c/osmo-bts/+/32733 ) Change subject: paging: parse PCUIF data indication outside of paging.c ...................................................................... Patch Set 6: (2 comments) File src/common/paging.c: https://gerrit.osmocom.org/c/osmo-bts/+/32733/comment/5e89f3d6_7d6e0f53 PS5, Line 273: uint8_t macblock_len
In GSM all MAC blocks must have `length == GSM_MACBLOCK_LEN`. […] That is correct. In the new protocol the field is GSM_MACBLOCK_LEN, so we can be sure that the length always fits. I have moved the check now to pcu_sock.c.
File src/common/pcu_sock.c: https://gerrit.osmocom.org/c/osmo-bts/+/32733/comment/c028ab60_25db7ad3 PS5, Line 679: memcpy(imsi, data_req->data, 3);
`osmo_strlcpy(&imsi[0], data_req->data, sizeof(imsi))` - this looks more readable and requires no pr […] (This code section will be removed when we change to PCUIF v.11)
-- To view, visit https://gerrit.osmocom.org/c/osmo-bts/+/32733 To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: osmo-bts Gerrit-Branch: master Gerrit-Change-Id: I9f3799916e8102bf1ce0f21891f2d24f43091f01 Gerrit-Change-Number: 32733 Gerrit-PatchSet: 6 Gerrit-Owner: dexter <pmaier@sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: fixeria <vyanitskiy@sysmocom.de> Gerrit-Reviewer: pespin <pespin@sysmocom.de> Gerrit-Attention: fixeria <vyanitskiy@sysmocom.de> Gerrit-Attention: pespin <pespin@sysmocom.de> Gerrit-Comment-Date: Mon, 05 Jun 2023 15:33:12 +0000 Gerrit-HasComments: Yes Gerrit-Has-Labels: No Comment-In-Reply-To: fixeria <vyanitskiy@sysmocom.de> Gerrit-MessageType: comment
participants (1)
-
dexter