lists.osmocom.org
Sign In Sign Up
Manage this list Sign In Sign Up

Keyboard Shortcuts

Thread View

  • j: Next unread message
  • k: Previous unread message
  • j a: Jump to all threads
  • j l: Jump to MailingList overview

gerrit-log

Thread Start a new thread
Download
Threads by month
  • ----- 2026 -----
  • October
  • September
  • August
  • July
  • June
  • May
  • April
  • March
  • February
  • January
  • ----- 2025 -----
  • December
  • November
  • October
  • September
  • August
  • July
  • June
  • May
  • April
  • March
  • February
  • January
  • ----- 2024 -----
  • December
  • November
  • October
  • September
  • August
  • July
  • June
  • May
  • April
  • March
  • February
  • January
  • ----- 2023 -----
  • December
  • November
  • October
  • September
  • August
  • July
  • June
  • May
  • April
  • March
  • February
  • January
  • ----- 2022 -----
  • December
  • November
  • October
  • September
  • August
  • July
  • June
  • May
  • April
  • March
  • February
  • January
gerrit-log@lists.osmocom.org

March 2023

  • 1 participants
  • 3642 discussions
[L] Change in libosmocore[master]: fix gsm0808_sc_cfg <-> gsm48_mr_cfg conversion
by pespin 01 Mar '23

01 Mar '23
Attention is currently required from: neels, dexter. pespin has posted comments on this change. ( https://gerrit.osmocom.org/c/libosmocore/+/29475 ) Change subject: fix gsm0808_sc_cfg <-> gsm48_mr_cfg conversion ...................................................................... Patch Set 4: Code-Review+1 -- To view, visit https://gerrit.osmocom.org/c/libosmocore/+/29475 To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: libosmocore Gerrit-Branch: master Gerrit-Change-Id: I900fda192742fa8f6dd54e9131ef1704b14cc41a Gerrit-Change-Number: 29475 Gerrit-PatchSet: 4 Gerrit-Owner: neels <nhofmeyr(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: dexter <pmaier(a)sysmocom.de> Gerrit-Reviewer: laforge <laforge(a)osmocom.org> Gerrit-Reviewer: pespin <pespin(a)sysmocom.de> Gerrit-CC: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Attention: neels <nhofmeyr(a)sysmocom.de> Gerrit-Attention: dexter <pmaier(a)sysmocom.de> Gerrit-Comment-Date: Wed, 01 Mar 2023 14:04:55 +0000 Gerrit-HasComments: No Gerrit-Has-Labels: Yes Gerrit-MessageType: comment
1 0
0 0
[S] Change in osmo-bsc[master]: utils: fix incorrect string checks in meas_db_insert()
by pespin 01 Mar '23

01 Mar '23
Attention is currently required from: iedemam, fixeria. pespin has posted comments on this change. ( https://gerrit.osmocom.org/c/osmo-bsc/+/31617 ) Change subject: utils: fix incorrect string checks in meas_db_insert() ...................................................................... Patch Set 1: Code-Review+1 (1 comment) File src/utils/meas_db.c: https://gerrit.osmocom.org/c/osmo-bsc/+/31617/comment/6c3b3c1d_f58c58a7 PS1, Line 97: if (mfm->imsi[0] != '\0') > Let's see what the others think. If people find `strlen()` more readable, I can amend the patch. […] I'm totally happy with checking "mfm->imsi[0] != '\0'". It's clear you are speecifically checking for the string being empty. -- To view, visit https://gerrit.osmocom.org/c/osmo-bsc/+/31617 To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: osmo-bsc Gerrit-Branch: master Gerrit-Change-Id: I8a41078070119bc22d594c0dfff5d98b5d16f970 Gerrit-Change-Number: 31617 Gerrit-PatchSet: 1 Gerrit-Owner: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: iedemam <michael(a)kapsulate.com> Gerrit-Reviewer: pespin <pespin(a)sysmocom.de> Gerrit-Attention: iedemam <michael(a)kapsulate.com> Gerrit-Attention: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Comment-Date: Wed, 01 Mar 2023 14:01:14 +0000 Gerrit-HasComments: Yes Gerrit-Has-Labels: Yes Comment-In-Reply-To: iedemam <michael(a)kapsulate.com> Comment-In-Reply-To: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-MessageType: comment
1 0
0 0
[S] Change in osmo-bsc[master]: vty: add 'osmodyn' as alias for 'tch/f_tch/h_sdcch8_pdch'
by pespin 01 Mar '23

01 Mar '23
Attention is currently required from: neels. pespin has posted comments on this change. ( https://gerrit.osmocom.org/c/osmo-bsc/+/31615 ) Change subject: vty: add 'osmodyn' as alias for 'tch/f_tch/h_sdcch8_pdch' ...................................................................... Patch Set 1: (1 comment) File src/osmo-bsc/gsm_data.c: https://gerrit.osmocom.org/c/osmo-bsc/+/31615/comment/10a8cba9_a7353659 PS1, Line 192: { GSM_PCHAN_OSMO_DYN, "OSMODYN" }, We use "OSMO_DYN", see line 209. -- To view, visit https://gerrit.osmocom.org/c/osmo-bsc/+/31615 To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: osmo-bsc Gerrit-Branch: master Gerrit-Change-Id: I37719edd867c777d1ce944b8e2f1efffac38f00e Gerrit-Change-Number: 31615 Gerrit-PatchSet: 1 Gerrit-Owner: neels <nhofmeyr(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-CC: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-CC: pespin <pespin(a)sysmocom.de> Gerrit-Attention: neels <nhofmeyr(a)sysmocom.de> Gerrit-Comment-Date: Wed, 01 Mar 2023 13:59:27 +0000 Gerrit-HasComments: Yes Gerrit-Has-Labels: No Gerrit-MessageType: comment
1 0
0 0
[S] Change in osmo-bsc[master]: select_codecs(): constify ct arg
by pespin 01 Mar '23

01 Mar '23
Attention is currently required from: neels. pespin has posted comments on this change. ( https://gerrit.osmocom.org/c/osmo-bsc/+/31614 ) Change subject: select_codecs(): constify ct arg ...................................................................... Patch Set 1: Code-Review+2 -- To view, visit https://gerrit.osmocom.org/c/osmo-bsc/+/31614 To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: osmo-bsc Gerrit-Branch: master Gerrit-Change-Id: Icb07374b40629e48d811a036b9a56d026c1d897c Gerrit-Change-Number: 31614 Gerrit-PatchSet: 1 Gerrit-Owner: neels <nhofmeyr(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Reviewer: pespin <pespin(a)sysmocom.de> Gerrit-Attention: neels <nhofmeyr(a)sysmocom.de> Gerrit-Comment-Date: Wed, 01 Mar 2023 13:57:21 +0000 Gerrit-HasComments: No Gerrit-Has-Labels: Yes Gerrit-MessageType: comment
1 0
0 0
[S] Change in osmo-bsc[master]: cosmetic: clarify test_codec_support_bts()
by pespin 01 Mar '23

01 Mar '23
Attention is currently required from: neels, fixeria. pespin has posted comments on this change. ( https://gerrit.osmocom.org/c/osmo-bsc/+/31612 ) Change subject: cosmetic: clarify test_codec_support_bts() ...................................................................... Patch Set 1: (2 comments) File src/osmo-bsc/codec_pref.c: https://gerrit.osmocom.org/c/osmo-bsc/+/31612/comment/12914904_79835f03 PS1, Line 197: switch (pchan) { > Not sure if using `switch` here is a big improvement. […] I prefer the new version :) https://gerrit.osmocom.org/c/osmo-bsc/+/31612/comment/68995d08_de0d4fc2 PS1, Line 225: return (bool)bts_codec->efr; You probably want to (bool)(!!bts_codec->efr); to make sure values are 1 or 0? -- To view, visit https://gerrit.osmocom.org/c/osmo-bsc/+/31612 To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: osmo-bsc Gerrit-Branch: master Gerrit-Change-Id: I13d9b158d08f4938c5aa47ef3134819a4b1f7d29 Gerrit-Change-Number: 31612 Gerrit-PatchSet: 1 Gerrit-Owner: neels <nhofmeyr(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-CC: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-CC: pespin <pespin(a)sysmocom.de> Gerrit-Attention: neels <nhofmeyr(a)sysmocom.de> Gerrit-Attention: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Comment-Date: Wed, 01 Mar 2023 13:56:56 +0000 Gerrit-HasComments: Yes Gerrit-Has-Labels: No Comment-In-Reply-To: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-MessageType: comment
1 0
0 0
[S] Change in osmo-bsc[master]: vty: msc / codec-list: forbid invalid codec versions
by pespin 01 Mar '23

01 Mar '23
Attention is currently required from: neels. pespin has posted comments on this change. ( https://gerrit.osmocom.org/c/osmo-bsc/+/31611 ) Change subject: vty: msc / codec-list: forbid invalid codec versions ...................................................................... Patch Set 1: Code-Review+1 -- To view, visit https://gerrit.osmocom.org/c/osmo-bsc/+/31611 To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: osmo-bsc Gerrit-Branch: master Gerrit-Change-Id: I421c306aa22dfdad0f30c6ba8b482e1eff188a8e Gerrit-Change-Number: 31611 Gerrit-PatchSet: 1 Gerrit-Owner: neels <nhofmeyr(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Reviewer: pespin <pespin(a)sysmocom.de> Gerrit-Attention: neels <nhofmeyr(a)sysmocom.de> Gerrit-Comment-Date: Wed, 01 Mar 2023 13:54:43 +0000 Gerrit-HasComments: No Gerrit-Has-Labels: Yes Gerrit-MessageType: comment
1 0
0 0
[M] Change in osmo-bsc[master]: vty: msc / codec-list: forbid duplicate entries
by pespin 01 Mar '23

01 Mar '23
Attention is currently required from: neels. pespin has posted comments on this change. ( https://gerrit.osmocom.org/c/osmo-bsc/+/31610 ) Change subject: vty: msc / codec-list: forbid duplicate entries ...................................................................... Patch Set 1: (3 comments) File src/osmo-bsc/bsc_vty.c: https://gerrit.osmocom.org/c/osmo-bsc/+/31610/comment/0c04234f_d42e1e86 PS1, Line 2730: || argv[i][1] != 'r' this indentation looks wrong. https://gerrit.osmocom.org/c/osmo-bsc/+/31610/comment/3b06bb68_1103b6ee PS1, Line 2731: || (argv[i][0] != 'h' && argv[i][0] != 'f') comparing first argv[i][0] and after argv[i][1] is way more "expected" ;) https://gerrit.osmocom.org/c/osmo-bsc/+/31610/comment/18f844c5_349f7874 PS1, Line 2740: if (strncmp("hr", argv[i], 2) == 0) tmp[i].hr = (argv[i][0] == 'h' ? 1 : 0); -- To view, visit https://gerrit.osmocom.org/c/osmo-bsc/+/31610 To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: osmo-bsc Gerrit-Branch: master Gerrit-Change-Id: Ifdc9e04bf1d623da65bfb8a2fddea765601f6d9b Gerrit-Change-Number: 31610 Gerrit-PatchSet: 1 Gerrit-Owner: neels <nhofmeyr(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-CC: pespin <pespin(a)sysmocom.de> Gerrit-Attention: neels <nhofmeyr(a)sysmocom.de> Gerrit-Comment-Date: Wed, 01 Mar 2023 13:53:45 +0000 Gerrit-HasComments: Yes Gerrit-Has-Labels: No Gerrit-MessageType: comment
1 0
0 0
[M] Change in osmo-bsc[master]: simplify storage of bsc_msc_data->audio_support
by pespin 01 Mar '23

01 Mar '23
Attention is currently required from: neels, fixeria. pespin has posted comments on this change. ( https://gerrit.osmocom.org/c/osmo-bsc/+/31609 ) Change subject: simplify storage of bsc_msc_data->audio_support ...................................................................... Patch Set 1: (2 comments) File include/osmocom/bsc/bsc_msc_data.h: https://gerrit.osmocom.org/c/osmo-bsc/+/31609/comment/672a290a_d680efb1 PS1, Line 140: struct gsm_audio_support audio_support[16]; you say there's 14 but you put 16 here? File src/osmo-bsc/bsc_vty.c: https://gerrit.osmocom.org/c/osmo-bsc/+/31609/comment/2d274324_7d1395ba PS1, Line 2729: int > Why not just using `%lu`? It's actually a size_t afaiu, so %zu. -- To view, visit https://gerrit.osmocom.org/c/osmo-bsc/+/31609 To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: osmo-bsc Gerrit-Branch: master Gerrit-Change-Id: I625cedc4bb040d649fd6e1794ba468f4c6ad6adc Gerrit-Change-Number: 31609 Gerrit-PatchSet: 1 Gerrit-Owner: neels <nhofmeyr(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-CC: pespin <pespin(a)sysmocom.de> Gerrit-Attention: neels <nhofmeyr(a)sysmocom.de> Gerrit-Attention: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Comment-Date: Wed, 01 Mar 2023 13:48:04 +0000 Gerrit-HasComments: Yes Gerrit-Has-Labels: No Comment-In-Reply-To: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-MessageType: comment
1 0
0 0
[S] Change in osmo-bsc[master]: vty: msc / codec-list: tweak error msg
by pespin 01 Mar '23

01 Mar '23
Attention is currently required from: neels. pespin has posted comments on this change. ( https://gerrit.osmocom.org/c/osmo-bsc/+/31608 ) Change subject: vty: msc / codec-list: tweak error msg ...................................................................... Patch Set 1: Code-Review+1 -- To view, visit https://gerrit.osmocom.org/c/osmo-bsc/+/31608 To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: osmo-bsc Gerrit-Branch: master Gerrit-Change-Id: I7ba508cceccb8a25db0936f756f3e4a28ec1333f Gerrit-Change-Number: 31608 Gerrit-PatchSet: 1 Gerrit-Owner: neels <nhofmeyr(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Reviewer: pespin <pespin(a)sysmocom.de> Gerrit-Attention: neels <nhofmeyr(a)sysmocom.de> Gerrit-Comment-Date: Wed, 01 Mar 2023 13:45:22 +0000 Gerrit-HasComments: No Gerrit-Has-Labels: Yes Gerrit-MessageType: comment
1 0
0 0
[S] Change in osmo-bsc[master]: bsc_vty.c write_msc(): fix weird printf format
by pespin 01 Mar '23

01 Mar '23
Attention is currently required from: neels. pespin has posted comments on this change. ( https://gerrit.osmocom.org/c/osmo-bsc/+/31607 ) Change subject: bsc_vty.c write_msc(): fix weird printf format ...................................................................... Patch Set 1: (1 comment) Patchset: PS1: any explanation what was that doing and ther ein first place and why don't we want it? -- To view, visit https://gerrit.osmocom.org/c/osmo-bsc/+/31607 To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: osmo-bsc Gerrit-Branch: master Gerrit-Change-Id: I856c2d620b89efcf3239186ef53c6941577dbccc Gerrit-Change-Number: 31607 Gerrit-PatchSet: 1 Gerrit-Owner: neels <nhofmeyr(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-CC: pespin <pespin(a)sysmocom.de> Gerrit-Attention: neels <nhofmeyr(a)sysmocom.de> Gerrit-Comment-Date: Wed, 01 Mar 2023 13:44:53 +0000 Gerrit-HasComments: Yes Gerrit-Has-Labels: No Gerrit-MessageType: comment
1 0
0 0
  • ← Newer
  • 1
  • ...
  • 355
  • 356
  • 357
  • 358
  • 359
  • 360
  • 361
  • ...
  • 365
  • Older →

HyperKitty Powered by HyperKitty version 1.3.12.