lists.osmocom.org
Sign In Sign Up
Manage this list Sign In Sign Up

Keyboard Shortcuts

Thread View

  • j: Next unread message
  • k: Previous unread message
  • j a: Jump to all threads
  • j l: Jump to MailingList overview

gerrit-log

Thread Start a new thread
Download
Threads by month
  • ----- 2026 -----
  • November
  • October
  • September
  • August
  • July
  • June
  • May
  • April
  • March
  • February
  • January
  • ----- 2025 -----
  • December
  • November
  • October
  • September
  • August
  • July
  • June
  • May
  • April
  • March
  • February
  • January
  • ----- 2024 -----
  • December
  • November
  • October
  • September
  • August
  • July
  • June
  • May
  • April
  • March
  • February
  • January
  • ----- 2023 -----
  • December
  • November
  • October
  • September
  • August
  • July
  • June
  • May
  • April
  • March
  • February
  • January
  • ----- 2022 -----
  • December
  • November
  • October
  • September
  • August
  • July
  • June
  • May
  • April
  • March
  • February
  • January
gerrit-log@lists.osmocom.org

November 2023

  • 1 participants
  • 1508 discussions
[S] Change in osmocom-bb[master]: mobile: cosmetic: rename TCH_IOFF_RTP to TCH_IOFF_OSMO
by fixeria 03 Nov '23

03 Nov '23
fixeria has abandoned this change. ( https://gerrit.osmocom.org/c/osmocom-bb/+/34913?usp=email ) Change subject: mobile: cosmetic: rename TCH_IOFF_RTP to TCH_IOFF_OSMO ...................................................................... Abandoned -- To view, visit https://gerrit.osmocom.org/c/osmocom-bb/+/34913?usp=email To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: osmocom-bb Gerrit-Branch: master Gerrit-Change-Id: I780d0a9fc20244ffa34307fb3d00f3848b6dcc76 Gerrit-Change-Number: 34913 Gerrit-PatchSet: 2 Gerrit-Owner: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: jolly <andreas(a)eversberg.eu> Gerrit-CC: laforge <laforge(a)osmocom.org> Gerrit-CC: pespin <pespin(a)sysmocom.de> Gerrit-MessageType: abandon
1 0
0 0
[M] Change in osmocom-bb[master]: mobile: clarify TCH I/O {handler,format} naming
by fixeria 03 Nov '23

03 Nov '23
Attention is currently required from: fixeria, jolly, laforge, pespin. Hello Jenkins Builder, jolly, laforge, pespin, I'd like you to reexamine a change. Please visit https://gerrit.osmocom.org/c/osmocom-bb/+/34912?usp=email to look at the new patch set (#3). The following approvals got outdated and were removed: Code-Review+1 by jolly, Code-Review+1 by laforge, Code-Review+1 by pespin, Verified+1 by Jenkins Builder Change subject: mobile: clarify TCH I/O {handler,format} naming ...................................................................... mobile: clarify TCH I/O {handler,format} naming Before we add handling of TCH I/O for data calls, let's rename the existing voice related symbols and struct fields to have 'voice' in their names. Change-Id: If6c799d11e225ad00ca5da5ae63dca20568a0ce0 Related: OS#4396 --- M src/host/layer23/include/osmocom/bb/common/settings.h M src/host/layer23/src/common/settings.c M src/host/layer23/src/mobile/gapk_io.c M src/host/layer23/src/mobile/gsm48_rr.c M src/host/layer23/src/mobile/voice.c M src/host/layer23/src/mobile/vty_interface.c 6 files changed, 92 insertions(+), 78 deletions(-) git pull ssh://gerrit.osmocom.org:29418/osmocom-bb refs/changes/12/34912/3 -- To view, visit https://gerrit.osmocom.org/c/osmocom-bb/+/34912?usp=email To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: osmocom-bb Gerrit-Branch: master Gerrit-Change-Id: If6c799d11e225ad00ca5da5ae63dca20568a0ce0 Gerrit-Change-Number: 34912 Gerrit-PatchSet: 3 Gerrit-Owner: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: jolly <andreas(a)eversberg.eu> Gerrit-Reviewer: laforge <laforge(a)osmocom.org> Gerrit-Reviewer: pespin <pespin(a)sysmocom.de> Gerrit-Attention: jolly <andreas(a)eversberg.eu> Gerrit-Attention: laforge <laforge(a)osmocom.org> Gerrit-Attention: pespin <pespin(a)sysmocom.de> Gerrit-Attention: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-MessageType: newpatchset
1 0
0 0
[M] Change in osmocom-bb[master]: mobile: rename 'audio' node to 'tch-voice' node
by fixeria 03 Nov '23

03 Nov '23
Attention is currently required from: fixeria, jolly, laforge. Hello Jenkins Builder, jolly, laforge, I'd like you to reexamine a change. Please visit https://gerrit.osmocom.org/c/osmocom-bb/+/34911?usp=email to look at the new patch set (#3). The following approvals got outdated and were removed: Code-Review+1 by jolly, Code-Review+1 by laforge, Verified+1 by Jenkins Builder Change subject: mobile: rename 'audio' node to 'tch-voice' node ...................................................................... mobile: rename 'audio' node to 'tch-voice' node Change-Id: I2cab597c5de92ecb343cad7aaaa48035ca5f8365 Related: OS#4396 --- M src/host/layer23/include/osmocom/bb/mobile/vty.h M src/host/layer23/src/mobile/vty_interface.c 2 files changed, 37 insertions(+), 20 deletions(-) git pull ssh://gerrit.osmocom.org:29418/osmocom-bb refs/changes/11/34911/3 -- To view, visit https://gerrit.osmocom.org/c/osmocom-bb/+/34911?usp=email To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: osmocom-bb Gerrit-Branch: master Gerrit-Change-Id: I2cab597c5de92ecb343cad7aaaa48035ca5f8365 Gerrit-Change-Number: 34911 Gerrit-PatchSet: 3 Gerrit-Owner: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: jolly <andreas(a)eversberg.eu> Gerrit-Reviewer: laforge <laforge(a)osmocom.org> Gerrit-CC: pespin <pespin(a)sysmocom.de> Gerrit-Attention: jolly <andreas(a)eversberg.eu> Gerrit-Attention: laforge <laforge(a)osmocom.org> Gerrit-Attention: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-MessageType: newpatchset
1 0
0 0
[L] Change in osmocom-bb[master]: mobile: add support for Circuit Switched Data calls
by fixeria 03 Nov '23

03 Nov '23
Attention is currently required from: jolly, laforge. Hello Jenkins Builder, jolly, laforge, I'd like you to reexamine a change. Please visit https://gerrit.osmocom.org/c/osmocom-bb/+/34762?usp=email to look at the new patch set (#7). The following approvals got outdated and were removed: Code-Review+1 by jolly, Code-Review+1 by laforge, Verified+1 by Jenkins Builder Change subject: mobile: add support for Circuit Switched Data calls ...................................................................... mobile: add support for Circuit Switched Data calls This patch implements the signalling part for mobile originating and mobile terminating CSD calls. The user plane interface is to be implemented in follow-up patches. Change-Id: I1995fa0a7a68d9b980852b664d472d4633777ac6 Related: OS#4396 --- M src/host/layer23/include/osmocom/bb/common/settings.h M src/host/layer23/include/osmocom/bb/common/support.h M src/host/layer23/include/osmocom/bb/mobile/mncc_ms.h M src/host/layer23/src/common/settings.c M src/host/layer23/src/common/support.c M src/host/layer23/src/mobile/gsm48_rr.c M src/host/layer23/src/mobile/mnccms.c M src/host/layer23/src/mobile/vty_interface.c 8 files changed, 530 insertions(+), 14 deletions(-) git pull ssh://gerrit.osmocom.org:29418/osmocom-bb refs/changes/62/34762/7 -- To view, visit https://gerrit.osmocom.org/c/osmocom-bb/+/34762?usp=email To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: osmocom-bb Gerrit-Branch: master Gerrit-Change-Id: I1995fa0a7a68d9b980852b664d472d4633777ac6 Gerrit-Change-Number: 34762 Gerrit-PatchSet: 7 Gerrit-Owner: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: jolly <andreas(a)eversberg.eu> Gerrit-Reviewer: laforge <laforge(a)osmocom.org> Gerrit-CC: pespin <pespin(a)sysmocom.de> Gerrit-Attention: jolly <andreas(a)eversberg.eu> Gerrit-Attention: laforge <laforge(a)osmocom.org> Gerrit-MessageType: newpatchset
1 0
0 0
[S] Change in osmocom-bb[master]: mobile: gsm_settings_init(): set TCH frame format explicitly
by fixeria 03 Nov '23

03 Nov '23
Attention is currently required from: fixeria, jolly, laforge, pespin. Hello Jenkins Builder, jolly, laforge, pespin, I'd like you to reexamine a change. Please visit https://gerrit.osmocom.org/c/osmocom-bb/+/34914?usp=email to look at the new patch set (#3). The following approvals got outdated and were removed: Code-Review+1 by jolly, Code-Review+1 by pespin, Code-Review+2 by laforge, Verified+1 by Jenkins Builder The change is no longer submittable: Code-Review and Verified are unsatisfied now. Change subject: mobile: gsm_settings_init(): set TCH frame format explicitly ...................................................................... mobile: gsm_settings_init(): set TCH frame format explicitly Change-Id: I4660b07977b6701ad5dc4bf25f12cba374101f8b Related: OS#4396 --- M src/host/layer23/src/common/settings.c 1 file changed, 11 insertions(+), 0 deletions(-) git pull ssh://gerrit.osmocom.org:29418/osmocom-bb refs/changes/14/34914/3 -- To view, visit https://gerrit.osmocom.org/c/osmocom-bb/+/34914?usp=email To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: osmocom-bb Gerrit-Branch: master Gerrit-Change-Id: I4660b07977b6701ad5dc4bf25f12cba374101f8b Gerrit-Change-Number: 34914 Gerrit-PatchSet: 3 Gerrit-Owner: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: jolly <andreas(a)eversberg.eu> Gerrit-Reviewer: laforge <laforge(a)osmocom.org> Gerrit-Reviewer: pespin <pespin(a)sysmocom.de> Gerrit-Attention: jolly <andreas(a)eversberg.eu> Gerrit-Attention: laforge <laforge(a)osmocom.org> Gerrit-Attention: pespin <pespin(a)sysmocom.de> Gerrit-Attention: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-MessageType: newpatchset
1 0
0 0
[M] Change in osmocom-bb[master]: mobile: rename voice.[ch] to tch.[ch]
by fixeria 03 Nov '23

03 Nov '23
Attention is currently required from: fixeria, jolly, laforge, pespin. Hello Jenkins Builder, jolly, laforge, pespin, I'd like you to reexamine a change. Please visit https://gerrit.osmocom.org/c/osmocom-bb/+/34917?usp=email to look at the new patch set (#3). The following approvals got outdated and were removed: Code-Review+1 by laforge, Code-Review+2 by pespin, Verified+1 by Jenkins Builder The change is no longer submittable: Code-Review and Verified are unsatisfied now. Change subject: mobile: rename voice.[ch] to tch.[ch] ...................................................................... mobile: rename voice.[ch] to tch.[ch] Also take a chance to change the 'tch_' prefix for all functions. Change-Id: I05e1ae777add73672db61565c77c68d8ab2b08f0 Related: OS#4396 --- M src/host/layer23/include/osmocom/bb/mobile/Makefile.am A src/host/layer23/include/osmocom/bb/mobile/tch.h D src/host/layer23/include/osmocom/bb/mobile/voice.h M src/host/layer23/src/mobile/Makefile.am M src/host/layer23/src/mobile/app_mobile.c M src/host/layer23/src/mobile/gapk_io.c M src/host/layer23/src/mobile/gsm44068_gcc_bcc.c M src/host/layer23/src/mobile/gsm48_cc.c R src/host/layer23/src/mobile/tch.c 9 files changed, 43 insertions(+), 31 deletions(-) git pull ssh://gerrit.osmocom.org:29418/osmocom-bb refs/changes/17/34917/3 -- To view, visit https://gerrit.osmocom.org/c/osmocom-bb/+/34917?usp=email To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: osmocom-bb Gerrit-Branch: master Gerrit-Change-Id: I05e1ae777add73672db61565c77c68d8ab2b08f0 Gerrit-Change-Number: 34917 Gerrit-PatchSet: 3 Gerrit-Owner: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: jolly <andreas(a)eversberg.eu> Gerrit-Reviewer: laforge <laforge(a)osmocom.org> Gerrit-Reviewer: pespin <pespin(a)sysmocom.de> Gerrit-Attention: jolly <andreas(a)eversberg.eu> Gerrit-Attention: laforge <laforge(a)osmocom.org> Gerrit-Attention: pespin <pespin(a)sysmocom.de> Gerrit-Attention: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-MessageType: newpatchset
1 0
0 0
[S] Change in osmocom-bb[master]: mobile: cosmetic: rename gsm48_rr_tx_{voice->traffic}()
by fixeria 03 Nov '23

03 Nov '23
Attention is currently required from: fixeria, jolly. Hello Jenkins Builder, jolly, laforge, pespin, I'd like you to reexamine a change. Please visit https://gerrit.osmocom.org/c/osmocom-bb/+/34916?usp=email to look at the new patch set (#3). The following approvals got outdated and were removed: Verified+1 by Jenkins Builder The change is no longer submittable: Verified is unsatisfied now. Change subject: mobile: cosmetic: rename gsm48_rr_tx_{voice->traffic}() ...................................................................... mobile: cosmetic: rename gsm48_rr_tx_{voice->traffic}() Not only this function can be used to transmit a voice frame, but also a data frame during a CSD call. Change-Id: I920300ae477e3c3d7c413cd1a35f2bc385266960 Related: OS#4396 --- M src/host/layer23/include/osmocom/bb/mobile/gsm48_rr.h M src/host/layer23/src/mobile/gsm48_rr.c M src/host/layer23/src/mobile/voice.c 3 files changed, 16 insertions(+), 3 deletions(-) git pull ssh://gerrit.osmocom.org:29418/osmocom-bb refs/changes/16/34916/3 -- To view, visit https://gerrit.osmocom.org/c/osmocom-bb/+/34916?usp=email To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: osmocom-bb Gerrit-Branch: master Gerrit-Change-Id: I920300ae477e3c3d7c413cd1a35f2bc385266960 Gerrit-Change-Number: 34916 Gerrit-PatchSet: 3 Gerrit-Owner: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: jolly <andreas(a)eversberg.eu> Gerrit-Reviewer: laforge <laforge(a)osmocom.org> Gerrit-Reviewer: pespin <pespin(a)sysmocom.de> Gerrit-Attention: jolly <andreas(a)eversberg.eu> Gerrit-Attention: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-MessageType: newpatchset
1 0
0 0
[L] Change in osmocom-bb[master]: mobile: add support for Circuit Switched Data calls
by fixeria 03 Nov '23

03 Nov '23
Attention is currently required from: laforge. fixeria has posted comments on this change. ( https://gerrit.osmocom.org/c/osmocom-bb/+/34762?usp=email ) Change subject: mobile: add support for Circuit Switched Data calls ...................................................................... Patch Set 6: (2 comments) File src/host/layer23/include/osmocom/bb/common/settings.h: https://gerrit.osmocom.org/c/osmocom-bb/+/34762/comment/9e06fb6e_ac01a9bd PS6, Line 101: enum data_call_ce { > what is 'ce' mean in this context? I'd appreciate at least a comment above the enum to explain that. […] Done File src/host/layer23/src/mobile/gsm48_rr.c: https://gerrit.osmocom.org/c/osmocom-bb/+/34762/comment/23ee3228_6b999a79 PS6, Line 379: LOGP(DRR, LOGL_ERROR, > at first sigt it looks like trhose lines don't need to be wrapped within 120chars? I was aiming for consistence with the existing code in this function, but at least the format strings can be on the same line with `LOGP`. Marking as resolved. -- To view, visit https://gerrit.osmocom.org/c/osmocom-bb/+/34762?usp=email To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: osmocom-bb Gerrit-Branch: master Gerrit-Change-Id: I1995fa0a7a68d9b980852b664d472d4633777ac6 Gerrit-Change-Number: 34762 Gerrit-PatchSet: 6 Gerrit-Owner: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: jolly <andreas(a)eversberg.eu> Gerrit-Reviewer: laforge <laforge(a)osmocom.org> Gerrit-CC: pespin <pespin(a)sysmocom.de> Gerrit-Attention: laforge <laforge(a)osmocom.org> Gerrit-Comment-Date: Fri, 03 Nov 2023 06:44:46 +0000 Gerrit-HasComments: Yes Gerrit-Has-Labels: No Comment-In-Reply-To: laforge <laforge(a)osmocom.org> Gerrit-MessageType: comment
1 0
0 0
[M] Change in pysim[master]: Use construct 'Flag' instead of 'Bit' for type descriptions
by fixeria 03 Nov '23

03 Nov '23
Attention is currently required from: laforge. fixeria has posted comments on this change. ( https://gerrit.osmocom.org/c/pysim/+/34957?usp=email ) Change subject: Use construct 'Flag' instead of 'Bit' for type descriptions ...................................................................... Patch Set 1: Code-Review+1 (1 comment) File pySim/sysmocom_sja2.py: https://gerrit.osmocom.org/c/pysim/+/34957/comment/0801e19e_19c863eb PS1, Line 325: print("#####################") debugging leftover? -- To view, visit https://gerrit.osmocom.org/c/pysim/+/34957?usp=email To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: pysim Gerrit-Branch: master Gerrit-Change-Id: Ib025f9c4551af7cf57090a0678ab0f66a6684fa4 Gerrit-Change-Number: 34957 Gerrit-PatchSet: 1 Gerrit-Owner: laforge <laforge(a)osmocom.org> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Attention: laforge <laforge(a)osmocom.org> Gerrit-Comment-Date: Fri, 03 Nov 2023 06:08:04 +0000 Gerrit-HasComments: Yes Gerrit-Has-Labels: Yes Gerrit-MessageType: comment
1 0
0 0
[M] Change in pysim[master]: pySim-shell: Move init_card() function to new pySim.app module
by fixeria 03 Nov '23

03 Nov '23
Attention is currently required from: laforge. fixeria has posted comments on this change. ( https://gerrit.osmocom.org/c/pysim/+/34956?usp=email ) Change subject: pySim-shell: Move init_card() function to new pySim.app module ...................................................................... Patch Set 1: Code-Review+1 -- To view, visit https://gerrit.osmocom.org/c/pysim/+/34956?usp=email To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: pysim Gerrit-Branch: master Gerrit-Change-Id: Icf557ed3064ef613ed693ce28bd3514a97a938bd Gerrit-Change-Number: 34956 Gerrit-PatchSet: 1 Gerrit-Owner: laforge <laforge(a)osmocom.org> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Attention: laforge <laforge(a)osmocom.org> Gerrit-Comment-Date: Fri, 03 Nov 2023 06:07:25 +0000 Gerrit-HasComments: No Gerrit-Has-Labels: Yes Gerrit-MessageType: comment
1 0
0 0
  • ← Newer
  • 1
  • ...
  • 133
  • 134
  • 135
  • 136
  • 137
  • 138
  • 139
  • ...
  • 151
  • Older →

HyperKitty Powered by HyperKitty version 1.3.12.