lists.osmocom.org
Sign In Sign Up
Manage this list Sign In Sign Up

Keyboard Shortcuts

Thread View

  • j: Next unread message
  • k: Previous unread message
  • j a: Jump to all threads
  • j l: Jump to MailingList overview

gerrit-log

Thread Start a new thread
Download
Threads by month
  • ----- 2026 -----
  • November
  • October
  • September
  • August
  • July
  • June
  • May
  • April
  • March
  • February
  • January
  • ----- 2025 -----
  • December
  • November
  • October
  • September
  • August
  • July
  • June
  • May
  • April
  • March
  • February
  • January
  • ----- 2024 -----
  • December
  • November
  • October
  • September
  • August
  • July
  • June
  • May
  • April
  • March
  • February
  • January
  • ----- 2023 -----
  • December
  • November
  • October
  • September
  • August
  • July
  • June
  • May
  • April
  • March
  • February
  • January
  • ----- 2022 -----
  • December
  • November
  • October
  • September
  • August
  • July
  • June
  • May
  • April
  • March
  • February
  • January
gerrit-log@lists.osmocom.org

June 2023

  • 1 participants
  • 2480 discussions
[S] Change in libosmo-netif[master]: cosmetic: Change name of osmo_stream_src_fd_cb()
by pespin 08 Jun '23

08 Jun '23
Attention is currently required from: daniel. pespin has posted comments on this change. ( https://gerrit.osmocom.org/c/libosmo-netif/+/33233 ) Change subject: cosmetic: Change name of osmo_stream_src_fd_cb() ...................................................................... Patch Set 1: Code-Review+2 -- To view, visit https://gerrit.osmocom.org/c/libosmo-netif/+/33233 To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: libosmo-netif Gerrit-Branch: master Gerrit-Change-Id: I8a9d27856ebdd5405b1977d12e91f8dcbdcd1d6b Gerrit-Change-Number: 33233 Gerrit-PatchSet: 1 Gerrit-Owner: daniel <dwillmann(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: pespin <pespin(a)sysmocom.de> Gerrit-Attention: daniel <dwillmann(a)sysmocom.de> Gerrit-Comment-Date: Thu, 08 Jun 2023 15:44:43 +0000 Gerrit-HasComments: No Gerrit-Has-Labels: Yes Gerrit-MessageType: comment
1 0
0 0
[L] Change in libosmocore[master]: ASCI: Add message definition and encoding according to 3GPP TS 48.008
by pespin 08 Jun '23

08 Jun '23
Attention is currently required from: jolly. pespin has posted comments on this change. ( https://gerrit.osmocom.org/c/libosmocore/+/32932 ) Change subject: ASCI: Add message definition and encoding according to 3GPP TS 48.008 ...................................................................... Patch Set 12: (1 comment) File include/osmocom/gsm/gsm0808.h: https://gerrit.osmocom.org/c/libosmocore/+/32932/comment/d51ac71b_f6dcaa3a PS12, Line 22: #ifdef HAVE_SYS_SOCKET_H the problem I see here is that this will actually be evaluated when building the app against libosmocore reading the header. As a result, if the app doesn't have the configure.ac check setting this ifdef, this will end up in weird situations. Probably the best solutions would be, instead of HAVE_SYS_SOCKET_H here, to avoid adding this .h and .h/.c depending on it into build targets if EMBEDDED is defined. -- To view, visit https://gerrit.osmocom.org/c/libosmocore/+/32932 To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: libosmocore Gerrit-Branch: master Gerrit-Change-Id: Ib94c64136c31ce4af67c314a8550d93946cc844f Gerrit-Change-Number: 32932 Gerrit-PatchSet: 12 Gerrit-Owner: jolly <andreas(a)eversberg.eu> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: laforge <laforge(a)osmocom.org> Gerrit-Reviewer: pespin <pespin(a)sysmocom.de> Gerrit-CC: dexter <pmaier(a)sysmocom.de> Gerrit-Attention: jolly <andreas(a)eversberg.eu> Gerrit-Comment-Date: Thu, 08 Jun 2023 15:44:26 +0000 Gerrit-HasComments: Yes Gerrit-Has-Labels: No Gerrit-MessageType: comment
1 0
0 0
[S] Change in pysim[master]: SJA5: EF.USIM_AUTH_KEY: Display / enforce proper length TUAK K
by laforge 08 Jun '23

08 Jun '23
Hello Jenkins Builder, I'd like you to reexamine a change. Please visit https://gerrit.osmocom.org/c/pysim/+/33234 to look at the new patch set (#2). Change subject: SJA5: EF.USIM_AUTH_KEY: Display / enforce proper length TUAK K ...................................................................... SJA5: EF.USIM_AUTH_KEY: Display / enforce proper length TUAK K The K value in case of TUAK can be 16 or 32 bytes long. We used to permit/parse/display 32 bytes even if only 16 bytes was configured. Let's enforce the correct length of "K". Fixes: OS#6053 Change-Id: Ia0f9a2138f16dce72f3118001e95baa1c80f23ce --- M pySim/sysmocom_sja2.py 1 file changed, 16 insertions(+), 1 deletion(-) git pull ssh://gerrit.osmocom.org:29418/pysim refs/changes/34/33234/2 -- To view, visit https://gerrit.osmocom.org/c/pysim/+/33234 To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: pysim Gerrit-Branch: master Gerrit-Change-Id: Ia0f9a2138f16dce72f3118001e95baa1c80f23ce Gerrit-Change-Number: 33234 Gerrit-PatchSet: 2 Gerrit-Owner: laforge <laforge(a)osmocom.org> Gerrit-Reviewer: Jenkins Builder Gerrit-MessageType: newpatchset
1 0
0 0
[S] Change in libosmocore[master]: gsm/ipa: Add segmentation callback
by arehbein 08 Jun '23

08 Jun '23
Attention is currently required from: pespin, fixeria, daniel. arehbein has posted comments on this change. ( https://gerrit.osmocom.org/c/libosmocore/+/33083 ) Change subject: gsm/ipa: Add segmentation callback ...................................................................... Patch Set 7: (2 comments) File src/gsm/ipa.c: https://gerrit.osmocom.org/c/libosmocore/+/33083/comment/4a90f3af_263bed01 PS5, Line 722: int ipa_segmentation_cb(struct msgb *msg) > Documentation should be added in the same commit where the function is added. Ah I see now that my message was cut off. The change mentioned adds a Doxygen-comment to the `struct osmo_io_ops` definition explaining semantics. I have added a comment referring to the struct def.. https://gerrit.osmocom.org/c/libosmocore/+/33083/comment/699e8871_5f383e51 PS5, Line 725: /* Haven't even the read entire header */ > this sentence looks wrongly written I don't see anything wrong with it -- To view, visit https://gerrit.osmocom.org/c/libosmocore/+/33083 To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: libosmocore Gerrit-Branch: master Gerrit-Change-Id: I3a639e6896cc3b3fc8e9b2e1a58254710efa0d3f Gerrit-Change-Number: 33083 Gerrit-PatchSet: 7 Gerrit-Owner: arehbein <arehbein(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: laforge <laforge(a)osmocom.org> Gerrit-Reviewer: pespin <pespin(a)sysmocom.de> Gerrit-CC: daniel <dwillmann(a)sysmocom.de> Gerrit-CC: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Attention: pespin <pespin(a)sysmocom.de> Gerrit-Attention: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Attention: daniel <dwillmann(a)sysmocom.de> Gerrit-Comment-Date: Thu, 08 Jun 2023 15:29:06 +0000 Gerrit-HasComments: Yes Gerrit-Has-Labels: No Comment-In-Reply-To: arehbein <arehbein(a)sysmocom.de> Comment-In-Reply-To: pespin <pespin(a)sysmocom.de> Gerrit-MessageType: comment
1 0
0 0
[S] Change in libosmocore[master]: gsm/ipa: Add segmentation callback
by arehbein 08 Jun '23

08 Jun '23
Attention is currently required from: arehbein, fixeria, daniel. Hello Jenkins Builder, laforge, pespin, I'd like you to reexamine a change. Please visit https://gerrit.osmocom.org/c/libosmocore/+/33083 to look at the new patch set (#7). Change subject: gsm/ipa: Add segmentation callback ...................................................................... gsm/ipa: Add segmentation callback Add segmentation callback to be used by the streaming backend of libosmo-netif Related: OS#5753, OS#5751 Change-Id: I3a639e6896cc3b3fc8e9b2e1a58254710efa0d3f --- M include/osmocom/gsm/ipa.h M src/gsm/ipa.c M src/gsm/libosmogsm.map 3 files changed, 37 insertions(+), 0 deletions(-) git pull ssh://gerrit.osmocom.org:29418/libosmocore refs/changes/83/33083/7 -- To view, visit https://gerrit.osmocom.org/c/libosmocore/+/33083 To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: libosmocore Gerrit-Branch: master Gerrit-Change-Id: I3a639e6896cc3b3fc8e9b2e1a58254710efa0d3f Gerrit-Change-Number: 33083 Gerrit-PatchSet: 7 Gerrit-Owner: arehbein <arehbein(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: laforge <laforge(a)osmocom.org> Gerrit-Reviewer: pespin <pespin(a)sysmocom.de> Gerrit-CC: daniel <dwillmann(a)sysmocom.de> Gerrit-CC: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Attention: arehbein <arehbein(a)sysmocom.de> Gerrit-Attention: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Attention: daniel <dwillmann(a)sysmocom.de> Gerrit-MessageType: newpatchset
1 0
0 0
[L] Change in libosmo-netif[master]: Add osmo_io support to osmo_stream_cli and osmo_stream_srv
by daniel 08 Jun '23

08 Jun '23
Attention is currently required from: arehbein, laforge, pespin. daniel has posted comments on this change. ( https://gerrit.osmocom.org/c/libosmo-netif/+/33193 ) Change subject: Add osmo_io support to osmo_stream_cli and osmo_stream_srv ...................................................................... Patch Set 6: (1 comment) Patchset: PS5: > Internally, the osmo_stream code calls the read_cb() if non NULL, or/and the iofd_read_cb() if not NULL (the only difference afaiu is the extra msg ptr being passed). I really don't like the and/or here since the difference is read_cb() will need to read from the fd itself and iofd does it for you. So there can only ever be an XOR relationship between these. I'd go as far as (if we went for this API) to assert that you never call the new api on a conn created with the old one. Since we need to stay backwards compatible with the old API we need to keep the old functions: osmo_stream_cli_create(), osmo_stream_cli_set_read_cb(), osmo_stream_srv_create() New functions using osmo_io would then be: * osmo_stream_cli_create2() with name param * osmo_stream_cli_set_iofd_read_cb() (?) * osmo_stream_srv_create2() with name param and no function pointers * osmo_stream_srv_set_iofd_read_cb() (could be just read_cb, but would be confusing as the client already has that) * osmo_stream_srv_set_closed_cb() -- To view, visit https://gerrit.osmocom.org/c/libosmo-netif/+/33193 To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: libosmo-netif Gerrit-Branch: master Gerrit-Change-Id: I2f52c7107c392b6f4b0bf2a84f8c873c084a200c Gerrit-Change-Number: 33193 Gerrit-PatchSet: 6 Gerrit-Owner: arehbein <arehbein(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: laforge <laforge(a)osmocom.org> Gerrit-CC: daniel <dwillmann(a)sysmocom.de> Gerrit-CC: pespin <pespin(a)sysmocom.de> Gerrit-Attention: arehbein <arehbein(a)sysmocom.de> Gerrit-Attention: laforge <laforge(a)osmocom.org> Gerrit-Attention: pespin <pespin(a)sysmocom.de> Gerrit-Comment-Date: Thu, 08 Jun 2023 15:25:05 +0000 Gerrit-HasComments: Yes Gerrit-Has-Labels: No Comment-In-Reply-To: laforge <laforge(a)osmocom.org> Comment-In-Reply-To: pespin <pespin(a)sysmocom.de> Gerrit-MessageType: comment
1 0
0 0
[M] Change in pysim[master]: test_ota: Add one first OTA SMS AES128 unit test
by laforge 08 Jun '23

08 Jun '23
laforge has uploaded this change for review. ( https://gerrit.osmocom.org/c/pysim/+/33235 ) Change subject: test_ota: Add one first OTA SMS AES128 unit test ...................................................................... test_ota: Add one first OTA SMS AES128 unit test Change-Id: Id4a66bbfaec2d8610e8a7a2c72c0dfd08332edcd --- M tests/test_ota.py 1 file changed, 72 insertions(+), 0 deletions(-) git pull ssh://gerrit.osmocom.org:29418/pysim refs/changes/35/33235/1 diff --git a/tests/test_ota.py b/tests/test_ota.py index 277f178..c58a69d 100644 --- a/tests/test_ota.py +++ b/tests/test_ota.py @@ -4,6 +4,69 @@ from pySim.utils import h2b, b2h from pySim.ota import * +# pre-defined SPI values for use in test cases below +SPI_CC_POR_CIPHERED_CC = { + 'counter':'no_counter', + 'ciphering':True, + 'rc_cc_ds': 'cc', + 'por_in_submit':False, + 'por_shall_be_ciphered':True, + 'por_rc_cc_ds': 'cc', + 'por': 'por_required' + } + +SPI_CC_POR_UNCIPHERED_CC = { + 'counter':'no_counter', + 'ciphering':True, + 'rc_cc_ds': 'cc', + 'por_in_submit':False, + 'por_shall_be_ciphered':False, + 'por_rc_cc_ds': 'cc', + 'por': 'por_required' +} + +SPI_CC_POR_UNCIPHERED_NOCC = { + 'counter':'no_counter', + 'ciphering':True, + 'rc_cc_ds': 'cc', + 'por_in_submit':False, + 'por_shall_be_ciphered':False, + 'por_rc_cc_ds': 'no_rc_cc_ds', + 'por': 'por_required' +} + + +class Test_SMS_AES128(unittest.TestCase): + tar = h2b('B00011') + """Test the OtaDialectSms for AES128 algorithms.""" + def __init__(self, foo, **kwargs): + super().__init__(foo, **kwargs) + self.od = OtaKeyset(algo_crypt='aes_cbc', kic_idx=2, + algo_auth='aes_cmac', kid_idx=2, + kic=h2b('200102030405060708090a0b0c0d0e0f'), + kid=h2b('201102030405060708090a0b0c0d0e0f')) + self.dialect = OtaDialectSms() + self.spi_base = SPI_CC_POR_CIPHERED_CC + + def _check_response(self, r, d): + self.assertEqual(d['number_of_commands'], 1) + self.assertEqual(d['last_status_word'], '6132') + self.assertEqual(d['last_response_data'], u'') + self.assertEqual(r['response_status'], 'por_ok') + + def test_resp_aes128_ciphered(self): + spi = self.spi_base + r, d = self.dialect.decode_resp(self.od, spi, '027100002412b00011ebc6b497e2cad7aedf36ace0e3a29b38853f0fe9ccde81913be5702b73abce1f') + self._check_response(r, d) + + def test_cmd_aes128_ciphered(self): + spi = self.spi_base + r = self.dialect.encode_cmd(self.od, self.tar, spi, h2b('00a40004023f00')) + self.assertEqual(b2h(r), '00281506192222b00011e87cceebb2d93083011ce294f93fc4d8de80da1abae8c37ca3e72ec4432e5058') + + + + class Test_SMS_3DES(unittest.TestCase): tar = h2b('b00000') """Test the OtaDialectSms for 3DES algorithms.""" -- To view, visit https://gerrit.osmocom.org/c/pysim/+/33235 To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: pysim Gerrit-Branch: master Gerrit-Change-Id: Id4a66bbfaec2d8610e8a7a2c72c0dfd08332edcd Gerrit-Change-Number: 33235 Gerrit-PatchSet: 1 Gerrit-Owner: laforge <laforge(a)osmocom.org> Gerrit-MessageType: newchange
1 0
0 0
[S] Change in pysim[master]: SJA5: EF.USIM_AUTH_KEY: don't display padding of TUAK K
by laforge 08 Jun '23

08 Jun '23
laforge has uploaded this change for review. ( https://gerrit.osmocom.org/c/pysim/+/33234 ) Change subject: SJA5: EF.USIM_AUTH_KEY: don't display padding of TUAK K ...................................................................... SJA5: EF.USIM_AUTH_KEY: don't display padding of TUAK K The K value in case of TUAK can be 16 or 32 bytes long. In case of the 16 byte variant, it is padded with FF to the end. Use Rpad() to remove that padding. This is not perfect, as it would also strip any consecutive ff even at the end of the first 16 bytes (when displaying). But then, this is a rather artificial situation, as proper keys have high entropy and there shouldn't be any consecutive ff... at any point in it. Change-Id: Ia0f9a2138f16dce72f3118001e95baa1c80f23ce --- M pySim/sysmocom_sja2.py 1 file changed, 19 insertions(+), 1 deletion(-) git pull ssh://gerrit.osmocom.org:29418/pysim refs/changes/34/33234/1 diff --git a/pySim/sysmocom_sja2.py b/pySim/sysmocom_sja2.py index 8b1fc04..b5fbd2b 100644 --- a/pySim/sysmocom_sja2.py +++ b/pySim/sysmocom_sja2.py @@ -207,7 +207,7 @@ 'tuak_cfg'/TuakCfgByte, 'num_of_keccak_iterations'/Int8ub, 'op_opc'/HexAdapter(Bytes(32)), - 'k'/HexAdapter(Bytes(32))) + 'k'/HexAdapter(Rpad(Bytes(32)))) def _decode_bin(self, raw_bin_data: bytearray) -> dict: if raw_bin_data[0] & 0x0F == 0x06: -- To view, visit https://gerrit.osmocom.org/c/pysim/+/33234 To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: pysim Gerrit-Branch: master Gerrit-Change-Id: Ia0f9a2138f16dce72f3118001e95baa1c80f23ce Gerrit-Change-Number: 33234 Gerrit-PatchSet: 1 Gerrit-Owner: laforge <laforge(a)osmocom.org> Gerrit-MessageType: newchange
1 0
0 0
[M] Change in libosmo-netif[master]: examples: Use osmo_io in {ipa-,}stream-{client,server}
by Jenkins Builder 08 Jun '23

08 Jun '23
Attention is currently required from: arehbein, pespin, daniel. Jenkins Builder has posted comments on this change. ( https://gerrit.osmocom.org/c/libosmo-netif/+/33194 ) Change subject: examples: Use osmo_io in {ipa-,}stream-{client,server} ...................................................................... Patch Set 5: (2 comments) File examples/stream-client.c: Robot Comment from checkpatch (run ID jenkins-gerrit-lint-8053): https://gerrit.osmocom.org/c/libosmo-netif/+/33194/comment/8840cb82_cab74203 PS5, Line 53: static int read_cb(struct osmo_stream_cli *conn, struct msgb* msg) "foo* bar" should be "foo *bar" File examples/stream-server.c: Robot Comment from checkpatch (run ID jenkins-gerrit-lint-8053): https://gerrit.osmocom.org/c/libosmo-netif/+/33194/comment/98e86b86_24dae425 PS5, Line 45: int read_cb(struct osmo_stream_srv *conn, struct msgb* msg) "foo* bar" should be "foo *bar" -- To view, visit https://gerrit.osmocom.org/c/libosmo-netif/+/33194 To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: libosmo-netif Gerrit-Branch: master Gerrit-Change-Id: I97a9979199c816686b32080534627f6f033e009e Gerrit-Change-Number: 33194 Gerrit-PatchSet: 5 Gerrit-Owner: arehbein <arehbein(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-CC: daniel <dwillmann(a)sysmocom.de> Gerrit-CC: laforge <laforge(a)osmocom.org> Gerrit-CC: pespin <pespin(a)sysmocom.de> Gerrit-Attention: arehbein <arehbein(a)sysmocom.de> Gerrit-Attention: pespin <pespin(a)sysmocom.de> Gerrit-Attention: daniel <dwillmann(a)sysmocom.de> Gerrit-Comment-Date: Thu, 08 Jun 2023 15:11:25 +0000 Gerrit-HasComments: Yes Gerrit-Has-Labels: No Gerrit-MessageType: comment
1 0
0 0
[L] Change in libosmo-netif[master]: Add osmo_io support to osmo_stream_cli and osmo_stream_srv
by daniel 08 Jun '23

08 Jun '23
Attention is currently required from: arehbein, laforge, pespin. daniel has uploaded a new patch set (#6) to the change originally created by arehbein. ( https://gerrit.osmocom.org/c/libosmo-netif/+/33193 ) Change subject: Add osmo_io support to osmo_stream_cli and osmo_stream_srv ...................................................................... Add osmo_io support to osmo_stream_cli and osmo_stream_srv Change-Id: I2f52c7107c392b6f4b0bf2a84f8c873c084a200c --- M include/osmocom/netif/stream.h M src/stream.c 2 files changed, 340 insertions(+), 25 deletions(-) git pull ssh://gerrit.osmocom.org:29418/libosmo-netif refs/changes/93/33193/6 -- To view, visit https://gerrit.osmocom.org/c/libosmo-netif/+/33193 To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: libosmo-netif Gerrit-Branch: master Gerrit-Change-Id: I2f52c7107c392b6f4b0bf2a84f8c873c084a200c Gerrit-Change-Number: 33193 Gerrit-PatchSet: 6 Gerrit-Owner: arehbein <arehbein(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: laforge <laforge(a)osmocom.org> Gerrit-CC: daniel <dwillmann(a)sysmocom.de> Gerrit-CC: pespin <pespin(a)sysmocom.de> Gerrit-Attention: arehbein <arehbein(a)sysmocom.de> Gerrit-Attention: laforge <laforge(a)osmocom.org> Gerrit-Attention: pespin <pespin(a)sysmocom.de> Gerrit-MessageType: newpatchset
1 0
0 0
  • ← Newer
  • 1
  • ...
  • 168
  • 169
  • 170
  • 171
  • 172
  • 173
  • 174
  • ...
  • 248
  • Older →

HyperKitty Powered by HyperKitty version 1.3.12.