lists.osmocom.org
Sign In Sign Up
Manage this list Sign In Sign Up

Keyboard Shortcuts

Thread View

  • j: Next unread message
  • k: Previous unread message
  • j a: Jump to all threads
  • j l: Jump to MailingList overview

gerrit-log

Thread Start a new thread
Download
Threads by month
  • ----- 2026 -----
  • November
  • October
  • September
  • August
  • July
  • June
  • May
  • April
  • March
  • February
  • January
  • ----- 2025 -----
  • December
  • November
  • October
  • September
  • August
  • July
  • June
  • May
  • April
  • March
  • February
  • January
  • ----- 2024 -----
  • December
  • November
  • October
  • September
  • August
  • July
  • June
  • May
  • April
  • March
  • February
  • January
  • ----- 2023 -----
  • December
  • November
  • October
  • September
  • August
  • July
  • June
  • May
  • April
  • March
  • February
  • January
  • ----- 2022 -----
  • December
  • November
  • October
  • September
  • August
  • July
  • June
  • May
  • April
  • March
  • February
  • January
gerrit-log@lists.osmocom.org

March 2023

  • 1 participants
  • 3642 discussions
[S] Change in osmo-bsc[master]: bts: is_xyz_bts check functions should return bool
by dexter 10 Mar '23

10 Mar '23
dexter has uploaded this change for review. ( https://gerrit.osmocom.org/c/osmo-bsc/+/31818 ) Change subject: bts: is_xyz_bts check functions should return bool ...................................................................... bts: is_xyz_bts check functions should return bool The check functions that we use to distinguish between the various types of BTSs return an integer that can be 0 or 1. Let's change the return type to bool Change-Id: I3de957f228452c9d3aa4fed342f73bfb17363b40 --- M include/osmocom/bsc/bts.h 1 file changed, 31 insertions(+), 18 deletions(-) git pull ssh://gerrit.osmocom.org:29418/osmo-bsc refs/changes/18/31818/1 diff --git a/include/osmocom/bsc/bts.h b/include/osmocom/bsc/bts.h index 4faf5f2..ea396cc 100644 --- a/include/osmocom/bsc/bts.h +++ b/include/osmocom/bsc/bts.h @@ -678,77 +678,77 @@ #define GSM_BTS_SI(bts, i) (void *)((bts)->si_buf[i][0]) /* this actually refers to the IPA transport, not the BTS model */ -static inline int is_ipaccess_bts(const struct gsm_bts *bts) +static inline bool is_ipaccess_bts(const struct gsm_bts *bts) { switch (bts->type) { case GSM_BTS_TYPE_NANOBTS: case GSM_BTS_TYPE_OSMOBTS: - return 1; + return true; default: break; } - return 0; + return false; } -static inline int is_osmobts(const struct gsm_bts *bts) +static inline bool is_osmobts(const struct gsm_bts *bts) { switch (bts->type) { case GSM_BTS_TYPE_OSMOBTS: - return 1; + return true; default: break; } - return 0; + return false; } -static inline int is_siemens_bts(const struct gsm_bts *bts) +static inline bool is_siemens_bts(const struct gsm_bts *bts) { switch (bts->type) { case GSM_BTS_TYPE_BS11: - return 1; + return true; default: break; } - return 0; + return false; } -static inline int is_nokia_bts(const struct gsm_bts *bts) +static inline bool is_nokia_bts(const struct gsm_bts *bts) { switch (bts->type) { case GSM_BTS_TYPE_NOKIA_SITE: - return 1; + return true; default: break; } - return 0; + return false; } -static inline int is_ericsson_bts(const struct gsm_bts *bts) +static inline bool is_ericsson_bts(const struct gsm_bts *bts) { switch (bts->type) { case GSM_BTS_TYPE_RBS2000: - return 1; + return true; default: break; } - return 0; + return false; } -static inline int is_e1_bts(const struct gsm_bts *bts) +static inline bool is_e1_bts(const struct gsm_bts *bts) { switch (bts->type) { case GSM_BTS_TYPE_BS11: case GSM_BTS_TYPE_RBS2000: case GSM_BTS_TYPE_NOKIA_SITE: - return 1; + return true; default: break; } - return 0; + return false; } static inline const struct osmo_location_area_id *bts_lai(struct gsm_bts *bts) -- To view, visit https://gerrit.osmocom.org/c/osmo-bsc/+/31818 To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: osmo-bsc Gerrit-Branch: master Gerrit-Change-Id: I3de957f228452c9d3aa4fed342f73bfb17363b40 Gerrit-Change-Number: 31818 Gerrit-PatchSet: 1 Gerrit-Owner: dexter <pmaier(a)sysmocom.de> Gerrit-MessageType: newchange
1 0
0 0
[S] Change in osmo-bsc[master]: bts: add function to check if a BTS has a BSC co located PCU
by dexter 10 Mar '23

10 Mar '23
Attention is currently required from: pespin. Hello Jenkins Builder, pespin, I'd like you to reexamine a change. Please visit https://gerrit.osmocom.org/c/osmo-bsc/+/31801 to look at the new patch set (#2). Change subject: bts: add function to check if a BTS has a BSC co located PCU ...................................................................... bts: add function to check if a BTS has a BSC co located PCU At the momemnt we use is_ericsson_bts() to check if the BTS uses a BSC co-located PCU, this is a bit ambiguous, lets have a function that explicitly checks for a BSC co-located PCU and nothing else. Change-Id: I23ed4219e5ebd188867c17f387ca877efa9bc3b0 Related: OS#5198 --- M include/osmocom/bsc/bts.h M src/osmo-bsc/timeslot_fsm.c 2 files changed, 27 insertions(+), 1 deletion(-) git pull ssh://gerrit.osmocom.org:29418/osmo-bsc refs/changes/01/31801/2 -- To view, visit https://gerrit.osmocom.org/c/osmo-bsc/+/31801 To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: osmo-bsc Gerrit-Branch: master Gerrit-Change-Id: I23ed4219e5ebd188867c17f387ca877efa9bc3b0 Gerrit-Change-Number: 31801 Gerrit-PatchSet: 2 Gerrit-Owner: dexter <pmaier(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: pespin <pespin(a)sysmocom.de> Gerrit-Attention: pespin <pespin(a)sysmocom.de> Gerrit-MessageType: newpatchset
1 0
0 0
[S] Change in osmo-bsc[master]: get_bsc_conn_by_conn_id(): Properly match sccp_instance
by fixeria 10 Mar '23

10 Mar '23
Attention is currently required from: neels, pespin. fixeria has posted comments on this change. ( https://gerrit.osmocom.org/c/osmo-bsc/+/31798 ) Change subject: get_bsc_conn_by_conn_id(): Properly match sccp_instance ...................................................................... Patch Set 1: (2 comments) File src/osmo-bsc/osmo_bsc_sigtran.c: https://gerrit.osmocom.org/c/osmo-bsc/+/31798/comment/307fb3e5_15597dd4 PS1, Line 49: struct osmo_sccp_user *scu const https://gerrit.osmocom.org/c/osmo-bsc/+/31798/comment/0ad3f3a0_7074585a PS1, Line 53: struct osmo_sccp_instance *sccp also const? -- To view, visit https://gerrit.osmocom.org/c/osmo-bsc/+/31798 To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: osmo-bsc Gerrit-Branch: master Gerrit-Change-Id: I80a54bdec3973917e88483a62bfc2e968b8c0490 Gerrit-Change-Number: 31798 Gerrit-PatchSet: 1 Gerrit-Owner: pespin <pespin(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: daniel <dwillmann(a)sysmocom.de> Gerrit-Reviewer: laforge <laforge(a)osmocom.org> Gerrit-Reviewer: neels <nhofmeyr(a)sysmocom.de> Gerrit-CC: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Attention: neels <nhofmeyr(a)sysmocom.de> Gerrit-Attention: pespin <pespin(a)sysmocom.de> Gerrit-Comment-Date: Fri, 10 Mar 2023 08:59:44 +0000 Gerrit-HasComments: Yes Gerrit-Has-Labels: No Gerrit-MessageType: comment
1 0
0 0
[M] Change in osmo-bsc[master]: Clarify type and values of sccp.conn_id
by fixeria 10 Mar '23

10 Mar '23
Attention is currently required from: pespin. fixeria has posted comments on this change. ( https://gerrit.osmocom.org/c/osmo-bsc/+/31796 ) Change subject: Clarify type and values of sccp.conn_id ...................................................................... Patch Set 2: (1 comment) File include/osmocom/bsc/gsm_data.h: https://gerrit.osmocom.org/c/osmo-bsc/+/31796/comment/3e62b7dc_081a1edf PS2, Line 332: 0xFFFFFFFF If this was not your patch, I would expect you to comment on this and suggest defining these values somewhere: ``` #define SCCP_SIGTRAN_CID_UNSET 0xFFFFFFFF #define SCCP_SIGTRAN_CID_MAX 0x00FFFFFF ``` I think it makes sense here, to improve code readability. -- To view, visit https://gerrit.osmocom.org/c/osmo-bsc/+/31796 To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: osmo-bsc Gerrit-Branch: master Gerrit-Change-Id: If019bcbc1e28929fe8d981fef9103835fc6ead2e Gerrit-Change-Number: 31796 Gerrit-PatchSet: 2 Gerrit-Owner: pespin <pespin(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: laforge <laforge(a)osmocom.org> Gerrit-CC: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Attention: pespin <pespin(a)sysmocom.de> Gerrit-Comment-Date: Fri, 10 Mar 2023 08:56:53 +0000 Gerrit-HasComments: Yes Gerrit-Has-Labels: No Gerrit-MessageType: comment
1 0
0 0
[S] Change in osmo-bsc[master]: cosmetic: gsm_data.h: Fix typo in comment
by fixeria 10 Mar '23

10 Mar '23
Attention is currently required from: neels, laforge, pespin. fixeria has posted comments on this change. ( https://gerrit.osmocom.org/c/osmo-bsc/+/31783 ) Change subject: cosmetic: gsm_data.h: Fix typo in comment ...................................................................... Patch Set 1: Code-Review+1 -- To view, visit https://gerrit.osmocom.org/c/osmo-bsc/+/31783 To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: osmo-bsc Gerrit-Branch: master Gerrit-Change-Id: Id59eb176551b2546ee6ff9c7f0eee4d8dd6ed199 Gerrit-Change-Number: 31783 Gerrit-PatchSet: 1 Gerrit-Owner: pespin <pespin(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: daniel <dwillmann(a)sysmocom.de> Gerrit-Reviewer: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Reviewer: laforge <laforge(a)osmocom.org> Gerrit-Reviewer: neels <nhofmeyr(a)sysmocom.de> Gerrit-Attention: neels <nhofmeyr(a)sysmocom.de> Gerrit-Attention: laforge <laforge(a)osmocom.org> Gerrit-Attention: pespin <pespin(a)sysmocom.de> Gerrit-Comment-Date: Fri, 10 Mar 2023 08:46:19 +0000 Gerrit-HasComments: No Gerrit-Has-Labels: Yes Gerrit-MessageType: comment
1 0
0 0
[S] Change in osmo-bsc[master]: ipaccess_drop_oml(): invalidate the feature vector
by fixeria 09 Mar '23

09 Mar '23
fixeria has uploaded this change for review. ( https://gerrit.osmocom.org/c/osmo-bsc/+/31817 ) Change subject: ipaccess_drop_oml(): invalidate the feature vector ...................................................................... ipaccess_drop_oml(): invalidate the feature vector It's possible that a BTS gets disconnected, updated to a more recent version or downgraded to an older version, and then connects to the BSC again. That more recent or older BTS version may have a different set of supported features, so osmo-bsc must not trust the previously reported feature vector. Change-Id: Ie93af849d7771b4fff3cdf647c82510cd8543975 --- M src/osmo-bsc/bts_ipaccess_nanobts.c 1 file changed, 19 insertions(+), 0 deletions(-) git pull ssh://gerrit.osmocom.org:29418/osmo-bsc refs/changes/17/31817/1 diff --git a/src/osmo-bsc/bts_ipaccess_nanobts.c b/src/osmo-bsc/bts_ipaccess_nanobts.c index 9f17359..1a57deb 100644 --- a/src/osmo-bsc/bts_ipaccess_nanobts.c +++ b/src/osmo-bsc/bts_ipaccess_nanobts.c @@ -641,6 +641,10 @@ bts->ip_access.flags = 0; + /* Reset the feature vector */ + memset(bts->_features_data, 0, sizeof(bts->_features_data)); + bts->features_known = false; + /* * Go through the list and see if we are the depndency of a BTS * and then drop the BTS. This can lead to some recursion but it -- To view, visit https://gerrit.osmocom.org/c/osmo-bsc/+/31817 To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: osmo-bsc Gerrit-Branch: master Gerrit-Change-Id: Ie93af849d7771b4fff3cdf647c82510cd8543975 Gerrit-Change-Number: 31817 Gerrit-PatchSet: 1 Gerrit-Owner: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-MessageType: newchange
1 0
0 0
[S] Change in libosmocore[master]: cosmetic: stats_tcp: Fix typo in comment
by pespin 09 Mar '23

09 Mar '23
pespin has submitted this change. ( https://gerrit.osmocom.org/c/libosmocore/+/31807 ) Change subject: cosmetic: stats_tcp: Fix typo in comment ...................................................................... cosmetic: stats_tcp: Fix typo in comment Take the chance to shorten a bit the lengthy lines Change-Id: I3215dea7e3198b728745a779ad1b6ebfa3795cb5 --- M src/core/stats_tcp.c 1 file changed, 15 insertions(+), 2 deletions(-) Approvals: laforge: Looks good to me, approved Jenkins Builder: Verified diff --git a/src/core/stats_tcp.c b/src/core/stats_tcp.c index ebb380e..c6459fe 100644 --- a/src/core/stats_tcp.c +++ b/src/core/stats_tcp.c @@ -247,8 +247,10 @@ pthread_mutex_lock(&stats_tcp_lock); llist_for_each_entry(stats_tcp_entry, &stats_tcp, entry) { if (fd->fd == stats_tcp_entry->fd->fd) { - /* In case we want to remove exactly that item which is also selected as the current itemy, we - * must designate either a different item or invalidate the current item. */ + /* In case we want to remove exactly that item which is also + * selected as the current item, we must designate either a + * different item or invalidate the current item. + */ if (stats_tcp_entry == stats_tcp_entry_cur) { if (llist_count(&stats_tcp) > 2) next_stats_tcp_entry(); -- To view, visit https://gerrit.osmocom.org/c/libosmocore/+/31807 To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: libosmocore Gerrit-Branch: master Gerrit-Change-Id: I3215dea7e3198b728745a779ad1b6ebfa3795cb5 Gerrit-Change-Number: 31807 Gerrit-PatchSet: 2 Gerrit-Owner: pespin <pespin(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: laforge <laforge(a)osmocom.org> Gerrit-Reviewer: pespin <pespin(a)sysmocom.de> Gerrit-MessageType: merged
1 0
0 0
[S] Change in osmo-pcu[master]: Makefile.am: remove phy specific EXTRA_DIST variables
by pespin 09 Mar '23

09 Mar '23
Attention is currently required from: dexter. pespin has posted comments on this change. ( https://gerrit.osmocom.org/c/osmo-pcu/+/31816 ) Change subject: Makefile.am: remove phy specific EXTRA_DIST variables ...................................................................... Patch Set 1: Code-Review+1 -- To view, visit https://gerrit.osmocom.org/c/osmo-pcu/+/31816 To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: osmo-pcu Gerrit-Branch: master Gerrit-Change-Id: If8b9b8cfaad22a093a74c418651bc76f48f2d071 Gerrit-Change-Number: 31816 Gerrit-PatchSet: 1 Gerrit-Owner: dexter <pmaier(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Reviewer: pespin <pespin(a)sysmocom.de> Gerrit-Attention: dexter <pmaier(a)sysmocom.de> Gerrit-Comment-Date: Thu, 09 Mar 2023 21:16:41 +0000 Gerrit-HasComments: No Gerrit-Has-Labels: Yes Gerrit-MessageType: comment
1 0
0 0
[M] Change in libosmocore[master]: select: Optimize osmo_fd_get_by_fd
by pespin 09 Mar '23

09 Mar '23
Attention is currently required from: laforge. pespin has posted comments on this change. ( https://gerrit.osmocom.org/c/libosmocore/+/31808 ) Change subject: select: Optimize osmo_fd_get_by_fd ...................................................................... Patch Set 2: (2 comments) Patchset: PS2: > we can OSMO_ASSERT if we back-port a fix to osmo-mgw and release patch releases for at least the la […] ACK I'll submit a backport for osmo-mgw patch. File src/core/select.c: https://gerrit.osmocom.org/c/libosmocore/+/31808/comment/a3c7fbbd_26ba80ef PS2, Line 78: 1024B > 1024B as in bytes? Every pointer surely is 4/8 bytes large, so number of entries != bytes yes, 1024 bytes = 128 fds in 64bit systems. The idea is to allocate mem blocks which are power of 2. -- To view, visit https://gerrit.osmocom.org/c/libosmocore/+/31808 To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: libosmocore Gerrit-Branch: master Gerrit-Change-Id: I8b71547df8bed84192cb160479fa3debf9b7eade Gerrit-Change-Number: 31808 Gerrit-PatchSet: 2 Gerrit-Owner: pespin <pespin(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: daniel <dwillmann(a)sysmocom.de> Gerrit-Reviewer: laforge <laforge(a)osmocom.org> Gerrit-Attention: laforge <laforge(a)osmocom.org> Gerrit-Comment-Date: Thu, 09 Mar 2023 21:11:09 +0000 Gerrit-HasComments: Yes Gerrit-Has-Labels: No Comment-In-Reply-To: laforge <laforge(a)osmocom.org> Gerrit-MessageType: comment
1 0
0 0
[S] Change in pysim[master]: pySim-shell.py: add a command for RUN GSM ALGORITHM
by fixeria 09 Mar '23

09 Mar '23
Attention is currently required from: laforge. fixeria has posted comments on this change. ( https://gerrit.osmocom.org/c/pysim/+/31815 ) Change subject: pySim-shell.py: add a command for RUN GSM ALGORITHM ...................................................................... Patch Set 1: Code-Review+1 -- To view, visit https://gerrit.osmocom.org/c/pysim/+/31815 To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: pysim Gerrit-Branch: master Gerrit-Change-Id: Id7876d83d018aca79253784411d3a9d54a249a0a Gerrit-Change-Number: 31815 Gerrit-PatchSet: 1 Gerrit-Owner: laforge <laforge(a)osmocom.org> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Attention: laforge <laforge(a)osmocom.org> Gerrit-Comment-Date: Thu, 09 Mar 2023 20:44:57 +0000 Gerrit-HasComments: No Gerrit-Has-Labels: Yes Gerrit-MessageType: comment
1 0
0 0
  • ← Newer
  • 1
  • ...
  • 222
  • 223
  • 224
  • 225
  • 226
  • 227
  • 228
  • ...
  • 365
  • Older →

HyperKitty Powered by HyperKitty version 1.3.12.