lists.osmocom.org
Sign In Sign Up
Manage this list Sign In Sign Up

Keyboard Shortcuts

Thread View

  • j: Next unread message
  • k: Previous unread message
  • j a: Jump to all threads
  • j l: Jump to MailingList overview

gerrit-log

Thread Start a new thread
Download
Threads by month
  • ----- 2026 -----
  • November
  • October
  • September
  • August
  • July
  • June
  • May
  • April
  • March
  • February
  • January
  • ----- 2025 -----
  • December
  • November
  • October
  • September
  • August
  • July
  • June
  • May
  • April
  • March
  • February
  • January
  • ----- 2024 -----
  • December
  • November
  • October
  • September
  • August
  • July
  • June
  • May
  • April
  • March
  • February
  • January
  • ----- 2023 -----
  • December
  • November
  • October
  • September
  • August
  • July
  • June
  • May
  • April
  • March
  • February
  • January
  • ----- 2022 -----
  • December
  • November
  • October
  • September
  • August
  • July
  • June
  • May
  • April
  • March
  • February
  • January
gerrit-log@lists.osmocom.org

October 2023

  • 1 participants
  • 1843 discussions
[S] Change in osmo-remsim[master]: bankd: Use gsmtap_inst_fd2()
by arehbein 30 Oct '23

30 Oct '23
Attention is currently required from: pespin. arehbein has posted comments on this change. ( https://gerrit.osmocom.org/c/osmo-remsim/+/34919?usp=email ) Change subject: bankd: Use gsmtap_inst_fd2() ...................................................................... Patch Set 1: (1 comment) Patchset: PS1: Not entirely sure if the TODO-RELEASE line should look like this -- To view, visit https://gerrit.osmocom.org/c/osmo-remsim/+/34919?usp=email To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: osmo-remsim Gerrit-Branch: master Gerrit-Change-Id: I2a7736d6fba795b2c479b2a0bc371b90f838ed61 Gerrit-Change-Number: 34919 Gerrit-PatchSet: 1 Gerrit-Owner: arehbein <arehbein(a)sysmocom.de> Gerrit-Reviewer: pespin <pespin(a)sysmocom.de> Gerrit-CC: Jenkins Builder Gerrit-Attention: pespin <pespin(a)sysmocom.de> Gerrit-Comment-Date: Mon, 30 Oct 2023 11:16:24 +0000 Gerrit-HasComments: Yes Gerrit-Has-Labels: No Gerrit-MessageType: comment
1 0
0 0
[S] Change in osmo-remsim[master]: bankd: Use gsmtap_inst_fd2()
by arehbein 30 Oct '23

30 Oct '23
arehbein has uploaded this change for review. ( https://gerrit.osmocom.org/c/osmo-remsim/+/34919?usp=email ) Change subject: bankd: Use gsmtap_inst_fd2() ...................................................................... bankd: Use gsmtap_inst_fd2() - Use gsmtap_inst_fd2() because gsmtap_inst_fd() is deprecated - Add TODO-RELEASE file Related: OS#6213 Change-Id: I2a7736d6fba795b2c479b2a0bc371b90f838ed61 --- A TODO-RELEASE M src/bankd/gsmtap.c 2 files changed, 24 insertions(+), 1 deletion(-) git pull ssh://gerrit.osmocom.org:29418/osmo-remsim refs/changes/19/34919/1 diff --git a/TODO-RELEASE b/TODO-RELEASE new file mode 100644 index 0000000..4a35f50 --- /dev/null +++ b/TODO-RELEASE @@ -0,0 +1,10 @@ +# When cleaning up this file: bump API version in corresponding Makefile.am and rename corresponding debian/lib*.install +# according to https://www.gnu.org/software/libtool/manual/html_node/Updating-version-info… +# In short: +# LIBVERSION=c:r:a +# If the library source code has changed at all since the last update, then increment revision: c:r + 1:a. +# If any interfaces have been added, removed, or changed since the last update: c + 1:0:0. +# If any interfaces have been added since the last public release: c:r:a + 1. +# If any interfaces have been removed or changed since the last public release: c:r:0. +#library what description / commit summary line +libosmocore > 1.9.0 working (compiling) gsmtap_inst_fd2() diff --git a/src/bankd/gsmtap.c b/src/bankd/gsmtap.c index 8aced6a..7bdbe51 100644 --- a/src/bankd/gsmtap.c +++ b/src/bankd/gsmtap.c @@ -97,7 +97,7 @@ LOGP(DGSMTAP, LOGL_DEBUG, "sending APDU sub_type=%u, mdm_tpdu len=%u, sim_tpdu len=%u, iov cnt=%u\n", sub_type, mdm_tpdu_len, sim_tpdu_len, cnt); - const int rc = writev(gsmtap_inst_fd(g_gti), iov, cnt); + const int rc = writev(gsmtap_inst_fd2(g_gti), iov, cnt); if (rc < 0) { char errtxt[128]; LOGP(DGSMTAP, LOGL_ERROR, "writev() failed with errno=%d: %s\n", errno, strerror_r(errno, -- To view, visit https://gerrit.osmocom.org/c/osmo-remsim/+/34919?usp=email To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: osmo-remsim Gerrit-Branch: master Gerrit-Change-Id: I2a7736d6fba795b2c479b2a0bc371b90f838ed61 Gerrit-Change-Number: 34919 Gerrit-PatchSet: 1 Gerrit-Owner: arehbein <arehbein(a)sysmocom.de> Gerrit-MessageType: newchange
1 0
0 0
[L] Change in osmocom-bb[master]: mobile: add support for Circuit Switched Data calls
by jolly 30 Oct '23

30 Oct '23
Attention is currently required from: fixeria. jolly has posted comments on this change. ( https://gerrit.osmocom.org/c/osmocom-bb/+/34762?usp=email ) Change subject: mobile: add support for Circuit Switched Data calls ...................................................................... Patch Set 6: Code-Review+1 -- To view, visit https://gerrit.osmocom.org/c/osmocom-bb/+/34762?usp=email To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: osmocom-bb Gerrit-Branch: master Gerrit-Change-Id: I1995fa0a7a68d9b980852b664d472d4633777ac6 Gerrit-Change-Number: 34762 Gerrit-PatchSet: 6 Gerrit-Owner: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: jolly <andreas(a)eversberg.eu> Gerrit-Reviewer: laforge <laforge(a)osmocom.org> Gerrit-CC: pespin <pespin(a)sysmocom.de> Gerrit-Attention: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Comment-Date: Mon, 30 Oct 2023 10:23:53 +0000 Gerrit-HasComments: No Gerrit-Has-Labels: Yes Gerrit-MessageType: comment
1 0
0 0
[M] Change in osmocom-bb[master]: mobile: rename voice.[ch] to tch.[ch]
by pespin 30 Oct '23

30 Oct '23
Attention is currently required from: fixeria, jolly. pespin has posted comments on this change. ( https://gerrit.osmocom.org/c/osmocom-bb/+/34917?usp=email ) Change subject: mobile: rename voice.[ch] to tch.[ch] ...................................................................... Patch Set 2: Code-Review+2 -- To view, visit https://gerrit.osmocom.org/c/osmocom-bb/+/34917?usp=email To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: osmocom-bb Gerrit-Branch: master Gerrit-Change-Id: I05e1ae777add73672db61565c77c68d8ab2b08f0 Gerrit-Change-Number: 34917 Gerrit-PatchSet: 2 Gerrit-Owner: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: jolly <andreas(a)eversberg.eu> Gerrit-Reviewer: laforge <laforge(a)osmocom.org> Gerrit-Reviewer: pespin <pespin(a)sysmocom.de> Gerrit-Attention: jolly <andreas(a)eversberg.eu> Gerrit-Attention: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Comment-Date: Mon, 30 Oct 2023 09:55:56 +0000 Gerrit-HasComments: No Gerrit-Has-Labels: Yes Gerrit-MessageType: comment
1 0
0 0
[S] Change in osmocom-bb[master]: mobile: cosmetic: rename gsm48_rr_tx_{voice->traffic}()
by pespin 30 Oct '23

30 Oct '23
Attention is currently required from: fixeria, jolly. pespin has posted comments on this change. ( https://gerrit.osmocom.org/c/osmocom-bb/+/34916?usp=email ) Change subject: mobile: cosmetic: rename gsm48_rr_tx_{voice->traffic}() ...................................................................... Patch Set 2: Code-Review+2 -- To view, visit https://gerrit.osmocom.org/c/osmocom-bb/+/34916?usp=email To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: osmocom-bb Gerrit-Branch: master Gerrit-Change-Id: I920300ae477e3c3d7c413cd1a35f2bc385266960 Gerrit-Change-Number: 34916 Gerrit-PatchSet: 2 Gerrit-Owner: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: jolly <andreas(a)eversberg.eu> Gerrit-Reviewer: laforge <laforge(a)osmocom.org> Gerrit-Reviewer: pespin <pespin(a)sysmocom.de> Gerrit-Attention: jolly <andreas(a)eversberg.eu> Gerrit-Attention: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Comment-Date: Mon, 30 Oct 2023 09:55:19 +0000 Gerrit-HasComments: No Gerrit-Has-Labels: Yes Gerrit-MessageType: comment
1 0
0 0
[S] Change in osmocom-bb[master]: mobile: cosmetic: use '#pragma once' in mncc.h
by fixeria 30 Oct '23

30 Oct '23
fixeria has submitted this change. ( https://gerrit.osmocom.org/c/osmocom-bb/+/34909?usp=email ) Change subject: mobile: cosmetic: use '#pragma once' in mncc.h ...................................................................... mobile: cosmetic: use '#pragma once' in mncc.h Change-Id: I2f350c5b67e57097b71b12ba42c90ce0941b8fea --- M src/host/layer23/include/osmocom/bb/mobile/mncc.h 1 file changed, 10 insertions(+), 5 deletions(-) Approvals: laforge: Looks good to me, approved Jenkins Builder: Verified diff --git a/src/host/layer23/include/osmocom/bb/mobile/mncc.h b/src/host/layer23/include/osmocom/bb/mobile/mncc.h index 1ab83ef..f587e1f 100644 --- a/src/host/layer23/include/osmocom/bb/mobile/mncc.h +++ b/src/host/layer23/include/osmocom/bb/mobile/mncc.h @@ -19,8 +19,7 @@ * */ -#ifndef _MNCC_H -#define _MNCC_H +#pragma once #include <osmocom/core/linuxlist.h> #include <osmocom/core/timer.h> @@ -174,6 +173,3 @@ const char *get_mncc_name(int value); int mncc_recv(struct osmocom_ms *ms, int msg_type, void *arg); void mncc_set_cause(struct gsm_mncc *data, int loc, int val); - -#endif - -- To view, visit https://gerrit.osmocom.org/c/osmocom-bb/+/34909?usp=email To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: osmocom-bb Gerrit-Branch: master Gerrit-Change-Id: I2f350c5b67e57097b71b12ba42c90ce0941b8fea Gerrit-Change-Number: 34909 Gerrit-PatchSet: 1 Gerrit-Owner: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Reviewer: laforge <laforge(a)osmocom.org> Gerrit-MessageType: merged
1 0
0 0
[S] Change in osmocom-bb[master]: layer23: rework L1CTL TRAFFIC.{ind,req} related logging
by fixeria 30 Oct '23

30 Oct '23
fixeria has submitted this change. ( https://gerrit.osmocom.org/c/osmocom-bb/+/34908?usp=email ) Change subject: layer23: rework L1CTL TRAFFIC.{ind,req} related logging ...................................................................... layer23: rework L1CTL TRAFFIC.{ind,req} related logging Make these Rx/Tx messages more informative. Change-Id: I9c73db3c3650547030b8c354016e65195daebb62 Related: OS#4396 --- M src/host/layer23/src/common/l1ctl.c 1 file changed, 16 insertions(+), 12 deletions(-) Approvals: Jenkins Builder: Verified laforge: Looks good to me, approved diff --git a/src/host/layer23/src/common/l1ctl.c b/src/host/layer23/src/common/l1ctl.c index c4589f0..349f048 100644 --- a/src/host/layer23/src/common/l1ctl.c +++ b/src/host/layer23/src/common/l1ctl.c @@ -844,7 +844,6 @@ { struct l1ctl_info_dl *dl; struct l1ctl_traffic_ind *ti; - size_t frame_len; uint8_t *frame; if (msgb_l1len(msg) < sizeof(*dl)) { @@ -861,11 +860,8 @@ msg->l2h = dl->payload; msg->l3h = frame; - /* Calculate the frame length */ - frame_len = msgb_l3len(msg); - - DEBUGP(DL1C, "TRAFFIC IND len=%zu (%s)\n", frame_len, - osmo_hexdump(frame, frame_len)); + LOGP(DL1C, LOGL_DEBUG, "Rx TRAFFIC.ind (fn=%u, chan_nr=0x%02x, len=%u): %s\n", + ntohl(dl->frame_nr), dl->chan_nr, msgb_l3len(msg), msgb_hexdump_l3(msg)); /* distribute or drop */ if (ms->l1_entity.l1_traffic_ind) @@ -882,7 +878,6 @@ struct l1ctl_hdr *l1h; struct l1ctl_info_ul *l1i_ul; struct l1ctl_traffic_req *tr; - size_t frame_len; uint8_t *frame; /* Header handling */ @@ -890,11 +885,8 @@ frame = (uint8_t *) tr->data; msg->l3h = frame; - /* Calculate the frame length */ - frame_len = msgb_l3len(msg); - - DEBUGP(DL1C, "TRAFFIC REQ len=%zu (%s)\n", frame_len, - osmo_hexdump(frame, frame_len)); + LOGP(DL1C, LOGL_DEBUG, "Tx TRAFFIC.req (chan_nr=0x%02x, len=%u): %s\n", + chan_nr, msgb_l3len(msg), msgb_hexdump_l3(msg)); /* prepend uplink info header */ l1i_ul = (struct l1ctl_info_ul *) msgb_push(msg, sizeof(*l1i_ul)); -- To view, visit https://gerrit.osmocom.org/c/osmocom-bb/+/34908?usp=email To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: osmocom-bb Gerrit-Branch: master Gerrit-Change-Id: I9c73db3c3650547030b8c354016e65195daebb62 Gerrit-Change-Number: 34908 Gerrit-PatchSet: 1 Gerrit-Owner: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Reviewer: laforge <laforge(a)osmocom.org> Gerrit-MessageType: merged
1 0
0 0
[M] Change in osmocom-bb[master]: mobile: move 'struct gsm_call' from <mncc.h> to <mncc_ms.h>
by fixeria 30 Oct '23

30 Oct '23
fixeria has submitted this change. ( https://gerrit.osmocom.org/c/osmocom-bb/+/34910?usp=email ) Change subject: mobile: move 'struct gsm_call' from <mncc.h> to <mncc_ms.h> ...................................................................... mobile: move 'struct gsm_call' from <mncc.h> to <mncc_ms.h> The only file using this structure is mnccms.c. Change-Id: Iaa43609849ac3c755d47258d3aca4bfe7a6b3a49 Related: OS#4396 --- M src/host/layer23/include/osmocom/bb/mobile/mncc.h M src/host/layer23/include/osmocom/bb/mobile/mncc_ms.h 2 files changed, 38 insertions(+), 19 deletions(-) Approvals: Jenkins Builder: Verified laforge: Looks good to me, but someone else must approve pespin: Looks good to me, approved diff --git a/src/host/layer23/include/osmocom/bb/mobile/mncc.h b/src/host/layer23/include/osmocom/bb/mobile/mncc.h index f587e1f..d6facbb 100644 --- a/src/host/layer23/include/osmocom/bb/mobile/mncc.h +++ b/src/host/layer23/include/osmocom/bb/mobile/mncc.h @@ -21,27 +21,8 @@ #pragma once -#include <osmocom/core/linuxlist.h> -#include <osmocom/core/timer.h> #include <osmocom/gsm/mncc.h> -struct gsm_call { - struct llist_head entry; - - struct osmocom_ms *ms; - - uint32_t callref; - - bool init; /* call initiated, no response yet */ - bool hold; /* call on hold */ - bool ring; /* call ringing/knocking */ - - struct osmo_timer_list dtmf_timer; - uint8_t dtmf_state; - uint8_t dtmf_index; - char dtmf[32]; /* dtmf sequence */ -}; - #define DTMF_ST_IDLE 0 /* no DTMF active */ #define DTMF_ST_START 1 /* DTMF started, waiting for resp. */ #define DTMF_ST_MARK 2 /* wait tone duration */ @@ -127,6 +108,8 @@ #define MNCC_F_KEYPAD 0x1000 #define MNCC_F_SIGNAL 0x2000 +struct osmocom_ms; + struct gsm_mncc { /* context based information */ uint32_t msg_type; diff --git a/src/host/layer23/include/osmocom/bb/mobile/mncc_ms.h b/src/host/layer23/include/osmocom/bb/mobile/mncc_ms.h index 705c681..4006688 100644 --- a/src/host/layer23/include/osmocom/bb/mobile/mncc_ms.h +++ b/src/host/layer23/include/osmocom/bb/mobile/mncc_ms.h @@ -1,5 +1,29 @@ #pragma once +#include <stdint.h> + +#include <osmocom/core/linuxlist.h> +#include <osmocom/core/timer.h> + +struct osmocom_ms; + +struct gsm_call { + struct llist_head entry; + + struct osmocom_ms *ms; + + uint32_t callref; + + bool init; /* call initiated, no response yet */ + bool hold; /* call on hold */ + bool ring; /* call ringing/knocking */ + + struct osmo_timer_list dtmf_timer; + uint8_t dtmf_state; + uint8_t dtmf_index; + char dtmf[32]; /* dtmf sequence */ +}; + int mncc_call(struct osmocom_ms *ms, const char *number); int mncc_hangup(struct osmocom_ms *ms); int mncc_answer(struct osmocom_ms *ms); -- To view, visit https://gerrit.osmocom.org/c/osmocom-bb/+/34910?usp=email To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: osmocom-bb Gerrit-Branch: master Gerrit-Change-Id: Iaa43609849ac3c755d47258d3aca4bfe7a6b3a49 Gerrit-Change-Number: 34910 Gerrit-PatchSet: 1 Gerrit-Owner: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Reviewer: laforge <laforge(a)osmocom.org> Gerrit-Reviewer: pespin <pespin(a)sysmocom.de> Gerrit-MessageType: merged
1 0
0 0
[S] Change in osmocom-bb[master]: mobile: gsm_settings_init(): set TCH frame format explicitly
by pespin 30 Oct '23

30 Oct '23
Attention is currently required from: fixeria, jolly. pespin has posted comments on this change. ( https://gerrit.osmocom.org/c/osmocom-bb/+/34914?usp=email ) Change subject: mobile: gsm_settings_init(): set TCH frame format explicitly ...................................................................... Patch Set 2: Code-Review+1 -- To view, visit https://gerrit.osmocom.org/c/osmocom-bb/+/34914?usp=email To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: osmocom-bb Gerrit-Branch: master Gerrit-Change-Id: I4660b07977b6701ad5dc4bf25f12cba374101f8b Gerrit-Change-Number: 34914 Gerrit-PatchSet: 2 Gerrit-Owner: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: jolly <andreas(a)eversberg.eu> Gerrit-Reviewer: laforge <laforge(a)osmocom.org> Gerrit-Reviewer: pespin <pespin(a)sysmocom.de> Gerrit-Attention: jolly <andreas(a)eversberg.eu> Gerrit-Attention: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Comment-Date: Mon, 30 Oct 2023 09:51:39 +0000 Gerrit-HasComments: No Gerrit-Has-Labels: Yes Gerrit-MessageType: comment
1 0
0 0
[S] Change in osmocom-bb[master]: mobile: cosmetic: rename TCH_IOFF_RTP to TCH_IOFF_OSMO
by pespin 30 Oct '23

30 Oct '23
Attention is currently required from: fixeria, jolly, laforge. pespin has posted comments on this change. ( https://gerrit.osmocom.org/c/osmocom-bb/+/34913?usp=email ) Change subject: mobile: cosmetic: rename TCH_IOFF_RTP to TCH_IOFF_OSMO ...................................................................... Patch Set 2: (1 comment) File src/host/layer23/src/mobile/vty_interface.c: https://gerrit.osmocom.org/c/osmocom-bb/+/34913/comment/2ef03260_a809923d PS2, Line 2569: "(same as 'osmo', kept for backwards-compatibility)\n" better put the rtp in a different cmd and mark is a deprecated. -- To view, visit https://gerrit.osmocom.org/c/osmocom-bb/+/34913?usp=email To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: osmocom-bb Gerrit-Branch: master Gerrit-Change-Id: I780d0a9fc20244ffa34307fb3d00f3848b6dcc76 Gerrit-Change-Number: 34913 Gerrit-PatchSet: 2 Gerrit-Owner: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: jolly <andreas(a)eversberg.eu> Gerrit-CC: laforge <laforge(a)osmocom.org> Gerrit-CC: pespin <pespin(a)sysmocom.de> Gerrit-Attention: jolly <andreas(a)eversberg.eu> Gerrit-Attention: laforge <laforge(a)osmocom.org> Gerrit-Attention: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Comment-Date: Mon, 30 Oct 2023 09:51:18 +0000 Gerrit-HasComments: Yes Gerrit-Has-Labels: No Gerrit-MessageType: comment
1 0
0 0
  • ← Newer
  • 1
  • ...
  • 6
  • 7
  • 8
  • 9
  • 10
  • 11
  • 12
  • ...
  • 185
  • Older →

HyperKitty Powered by HyperKitty version 1.3.12.