lists.osmocom.org
Sign In Sign Up
Manage this list Sign In Sign Up

Keyboard Shortcuts

Thread View

  • j: Next unread message
  • k: Previous unread message
  • j a: Jump to all threads
  • j l: Jump to MailingList overview

gerrit-log

Thread Start a new thread
Download
Threads by month
  • ----- 2026 -----
  • November
  • October
  • September
  • August
  • July
  • June
  • May
  • April
  • March
  • February
  • January
  • ----- 2025 -----
  • December
  • November
  • October
  • September
  • August
  • July
  • June
  • May
  • April
  • March
  • February
  • January
  • ----- 2024 -----
  • December
  • November
  • October
  • September
  • August
  • July
  • June
  • May
  • April
  • March
  • February
  • January
  • ----- 2023 -----
  • December
  • November
  • October
  • September
  • August
  • July
  • June
  • May
  • April
  • March
  • February
  • January
  • ----- 2022 -----
  • December
  • November
  • October
  • September
  • August
  • July
  • June
  • May
  • April
  • March
  • February
  • January
gerrit-log@lists.osmocom.org

October 2023

  • 1 participants
  • 1843 discussions
[S] Change in osmo-ttcn3-hacks[master]: IPA_Emulation. Fix error if IPAC_MSGT_ID_GET with no tags is received
by laforge 15 Oct '23

15 Oct '23
Attention is currently required from: pespin. laforge has posted comments on this change. ( https://gerrit.osmocom.org/c/osmo-ttcn3-hacks/+/34724?usp=email ) Change subject: IPA_Emulation. Fix error if IPAC_MSGT_ID_GET with no tags is received ...................................................................... Patch Set 2: Code-Review+2 -- To view, visit https://gerrit.osmocom.org/c/osmo-ttcn3-hacks/+/34724?usp=email To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: osmo-ttcn3-hacks Gerrit-Branch: master Gerrit-Change-Id: I69cd519cb3b8f10d10b4724e6354d31d5c5b9da5 Gerrit-Change-Number: 34724 Gerrit-PatchSet: 2 Gerrit-Owner: pespin <pespin(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Reviewer: laforge <laforge(a)osmocom.org> Gerrit-Attention: pespin <pespin(a)sysmocom.de> Gerrit-Comment-Date: Sun, 15 Oct 2023 12:25:41 +0000 Gerrit-HasComments: No Gerrit-Has-Labels: Yes Gerrit-MessageType: comment
1 0
0 0
[M] Change in libosmocore[master]: gsmtap: Hide implementation of gsmtap_inst
by laforge 15 Oct '23

15 Oct '23
Attention is currently required from: arehbein, daniel, pespin. laforge has posted comments on this change. ( https://gerrit.osmocom.org/c/libosmocore/+/34720?usp=email ) Change subject: gsmtap: Hide implementation of gsmtap_inst ...................................................................... Patch Set 5: Code-Review+1 -- To view, visit https://gerrit.osmocom.org/c/libosmocore/+/34720?usp=email To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: libosmocore Gerrit-Branch: master Gerrit-Change-Id: Ibe1a51205a6df764571b6d074e365825555609a5 Gerrit-Change-Number: 34720 Gerrit-PatchSet: 5 Gerrit-Owner: arehbein <arehbein(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: daniel <dwillmann(a)sysmocom.de> Gerrit-Reviewer: laforge <laforge(a)osmocom.org> Gerrit-Reviewer: pespin <pespin(a)sysmocom.de> Gerrit-Attention: arehbein <arehbein(a)sysmocom.de> Gerrit-Attention: pespin <pespin(a)sysmocom.de> Gerrit-Attention: daniel <dwillmann(a)sysmocom.de> Gerrit-Comment-Date: Sun, 15 Oct 2023 12:23:28 +0000 Gerrit-HasComments: No Gerrit-Has-Labels: Yes Gerrit-MessageType: comment
1 0
0 0
[S] Change in libgtpnl[master]: gtp-genl: allocate room for maximum IPv6 address
by laforge 15 Oct '23

15 Oct '23
Attention is currently required from: osmith. laforge has posted comments on this change. ( https://gerrit.osmocom.org/c/libgtpnl/+/34738?usp=email ) Change subject: gtp-genl: allocate room for maximum IPv6 address ...................................................................... Patch Set 1: Code-Review+2 -- To view, visit https://gerrit.osmocom.org/c/libgtpnl/+/34738?usp=email To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: libgtpnl Gerrit-Branch: master Gerrit-Change-Id: I2283e0c3112bec8e6e7e7b5c96657facc09d0a7a Gerrit-Change-Number: 34738 Gerrit-PatchSet: 1 Gerrit-Owner: osmith <osmith(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: laforge <laforge(a)osmocom.org> Gerrit-Reviewer: pespin <pespin(a)sysmocom.de> Gerrit-Attention: osmith <osmith(a)sysmocom.de> Gerrit-Comment-Date: Sun, 15 Oct 2023 12:21:02 +0000 Gerrit-HasComments: No Gerrit-Has-Labels: Yes Gerrit-MessageType: comment
1 0
0 0
[M] Change in libgtpnl[master]: tools: gtp-tunnel: add IPv6 support
by laforge 15 Oct '23

15 Oct '23
Attention is currently required from: osmith. laforge has posted comments on this change. ( https://gerrit.osmocom.org/c/libgtpnl/+/34737?usp=email ) Change subject: tools: gtp-tunnel: add IPv6 support ...................................................................... Patch Set 1: (1 comment) File tools/gtp-tunnel.c: https://gerrit.osmocom.org/c/libgtpnl/+/34737/comment/d1d5146c_c519dd2c PS1, Line 105: if (!strcmp(argv[optidx], "ip")) { probably the same question like in the other commit: should we really call ipv4 just "ip"? I don't know where this kind of notation is used. I only know ipv4/ipv6 or ip4/ip6. The only situation where I know the 4 suffix is often skipped is inet/inet6, as that's how AF_INET/AF_INET6 are called. -- To view, visit https://gerrit.osmocom.org/c/libgtpnl/+/34737?usp=email To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: libgtpnl Gerrit-Branch: master Gerrit-Change-Id: Ifdc104b158afa6343e3aa6142ffa9591db209c4f Gerrit-Change-Number: 34737 Gerrit-PatchSet: 1 Gerrit-Owner: osmith <osmith(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: pespin <pespin(a)sysmocom.de> Gerrit-CC: laforge <laforge(a)osmocom.org> Gerrit-Attention: osmith <osmith(a)sysmocom.de> Gerrit-Comment-Date: Sun, 15 Oct 2023 12:20:50 +0000 Gerrit-HasComments: Yes Gerrit-Has-Labels: No Gerrit-MessageType: comment
1 0
0 0
[S] Change in libgtpnl[master]: add IPv6 API for GTP tunnel
by laforge 15 Oct '23

15 Oct '23
Attention is currently required from: osmith. laforge has posted comments on this change. ( https://gerrit.osmocom.org/c/libgtpnl/+/34736?usp=email ) Change subject: add IPv6 API for GTP tunnel ...................................................................... Patch Set 1: Code-Review+2 -- To view, visit https://gerrit.osmocom.org/c/libgtpnl/+/34736?usp=email To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: libgtpnl Gerrit-Branch: master Gerrit-Change-Id: Ic9c1a5cd791b285d214e7f2aeb76f8bf372e01c6 Gerrit-Change-Number: 34736 Gerrit-PatchSet: 1 Gerrit-Owner: osmith <osmith(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: laforge <laforge(a)osmocom.org> Gerrit-Reviewer: pespin <pespin(a)sysmocom.de> Gerrit-Attention: osmith <osmith(a)sysmocom.de> Gerrit-Comment-Date: Sun, 15 Oct 2023 12:19:14 +0000 Gerrit-HasComments: No Gerrit-Has-Labels: Yes Gerrit-MessageType: comment
1 0
0 0
[M] Change in libgtpnl[master]: add IPv6 support
by laforge 15 Oct '23

15 Oct '23
Attention is currently required from: osmith, pespin. laforge has posted comments on this change. ( https://gerrit.osmocom.org/c/libgtpnl/+/34735?usp=email ) Change subject: add IPv6 support ...................................................................... Patch Set 1: (1 comment) File include/linux/gtp.h: https://gerrit.osmocom.org/c/libgtpnl/+/34735/comment/df2ba139_0260363b PS1, Line 27: #define GTPA_SGSN_ADDRESS GTPA_PEER_ADDRESS /* maintain legacy attr name */ > I'm not sure I'm following here. […] The kernel code used to call it GTPA_SGSN_ADDRESS initially at the time the kernel GTP only supported the "GGSN role". We later renamed it to the more generic PEER_ADDRESS when introducing support for SGSN role to kernel GTP. See linux.git: commit ae6336b57ede8cdf801b04e6d943617bb945e3f9 Author: Jonas Bonn <jonas(a)southpole.se> Date: Fri Mar 24 23:23:20 2017 +0100 gtp: rename SGSN netlink attribute Which contains - GTPA_SGSN_ADDRESS, + GTPA_PEER_ADDRESS, /* Remote GSN peer, either SGSN or GGSN */ +#define GTPA_SGSN_ADDRESS GTPA_PEER_ADDRESS /* maintain legacy attr name */ I don't know why in libgtpnl we didn't introduce the compat #define in commit 6e9afbbc3037c9e003260077b33dad202d5c55df Author: Jonas Bonn <jonas(a)southpole.se> Date: Fri Mar 24 15:19:19 2017 +0100 -- in any case, I think we can continue to live without that #define in userspace, or we simply add it here to avoid any confusing diff to the kernel header file. -- To view, visit https://gerrit.osmocom.org/c/libgtpnl/+/34735?usp=email To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: libgtpnl Gerrit-Branch: master Gerrit-Change-Id: If864c9170f74af52a95cbc4cdb1b866e0309306b Gerrit-Change-Number: 34735 Gerrit-PatchSet: 1 Gerrit-Owner: osmith <osmith(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-CC: laforge <laforge(a)osmocom.org> Gerrit-CC: pespin <pespin(a)sysmocom.de> Gerrit-Attention: osmith <osmith(a)sysmocom.de> Gerrit-Attention: pespin <pespin(a)sysmocom.de> Gerrit-Comment-Date: Sun, 15 Oct 2023 12:18:50 +0000 Gerrit-HasComments: Yes Gerrit-Has-Labels: No Comment-In-Reply-To: pespin <pespin(a)sysmocom.de> Gerrit-MessageType: comment
1 0
0 0
[M] Change in libgtpnl[master]: update to prepare for IPv6 support
by laforge 15 Oct '23

15 Oct '23
Attention is currently required from: osmith, pespin. laforge has posted comments on this change. ( https://gerrit.osmocom.org/c/libgtpnl/+/34734?usp=email ) Change subject: update to prepare for IPv6 support ...................................................................... Patch Set 1: (2 comments) Commit Message: https://gerrit.osmocom.org/c/libgtpnl/+/34734/comment/ad8c7b90_428385e2 PS1, Line 7: update to p Please expand a little bit what the change does. Like "Introduce a union in struct foo ..." File src/internal.h: https://gerrit.osmocom.org/c/libgtpnl/+/34734/comment/0ab12524_f31f88b9 PS1, Line 22: } ip; > given that we'll have an ip6 counterpart, naming this one "ip4" may be easier to understand for read […] I would agree, it should be ip4/ip6, or something else that is clearly understood. "ip" is unspecific and includes any version of IP -- To view, visit https://gerrit.osmocom.org/c/libgtpnl/+/34734?usp=email To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: libgtpnl Gerrit-Branch: master Gerrit-Change-Id: Ifc7e3b03a723fb544d1c7b789101102b2c27b60e Gerrit-Change-Number: 34734 Gerrit-PatchSet: 1 Gerrit-Owner: osmith <osmith(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: pespin <pespin(a)sysmocom.de> Gerrit-CC: laforge <laforge(a)osmocom.org> Gerrit-Attention: osmith <osmith(a)sysmocom.de> Gerrit-Attention: pespin <pespin(a)sysmocom.de> Gerrit-Comment-Date: Sun, 15 Oct 2023 12:12:29 +0000 Gerrit-HasComments: Yes Gerrit-Has-Labels: No Comment-In-Reply-To: pespin <pespin(a)sysmocom.de> Gerrit-MessageType: comment
1 0
0 0
[S] Change in ...osmo-epdg[master]: Add config envvars to change GSUP server listen IP addr and port
by laforge 15 Oct '23

15 Oct '23
Attention is currently required from: pespin. laforge has posted comments on this change. ( https://gerrit.osmocom.org/c/erlang/osmo-epdg/+/34741?usp=email ) Change subject: Add config envvars to change GSUP server listen IP addr and port ...................................................................... Patch Set 1: Code-Review+2 -- To view, visit https://gerrit.osmocom.org/c/erlang/osmo-epdg/+/34741?usp=email To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: erlang/osmo-epdg Gerrit-Branch: master Gerrit-Change-Id: I55244df82ee50b268ef0cbbe698e691707e8a716 Gerrit-Change-Number: 34741 Gerrit-PatchSet: 1 Gerrit-Owner: pespin <pespin(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Reviewer: laforge <laforge(a)osmocom.org> Gerrit-Attention: pespin <pespin(a)sysmocom.de> Gerrit-Comment-Date: Sun, 15 Oct 2023 12:10:08 +0000 Gerrit-HasComments: No Gerrit-Has-Labels: Yes Gerrit-MessageType: comment
1 0
0 0
[S] Change in ...osmo-epdg[master]: Several fixes and improvement around env config use
by laforge 15 Oct '23

15 Oct '23
Attention is currently required from: pespin. laforge has posted comments on this change. ( https://gerrit.osmocom.org/c/erlang/osmo-epdg/+/34740?usp=email ) Change subject: Several fixes and improvement around env config use ...................................................................... Patch Set 1: Code-Review+2 -- To view, visit https://gerrit.osmocom.org/c/erlang/osmo-epdg/+/34740?usp=email To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: erlang/osmo-epdg Gerrit-Branch: master Gerrit-Change-Id: I729513ff1f904b78971d22e49622707c8bc0e4aa Gerrit-Change-Number: 34740 Gerrit-PatchSet: 1 Gerrit-Owner: pespin <pespin(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Reviewer: laforge <laforge(a)osmocom.org> Gerrit-Attention: pespin <pespin(a)sysmocom.de> Gerrit-Comment-Date: Sun, 15 Oct 2023 12:09:54 +0000 Gerrit-HasComments: No Gerrit-Has-Labels: Yes Gerrit-MessageType: comment
1 0
0 0
[S] Change in libosmocore[master]: gsm48_ie.c: change bearer cap structure in outgoing CSD calls
by laforge 15 Oct '23

15 Oct '23
Attention is currently required from: manawyrm. laforge has posted comments on this change. ( https://gerrit.osmocom.org/c/libosmocore/+/34746?usp=email ) Change subject: gsm48_ie.c: change bearer cap structure in outgoing CSD calls ...................................................................... Patch Set 4: Code-Review+1 (1 comment) Patchset: PS4: For refreence, GSM 02.01 Section 1.4 defines those values. -- To view, visit https://gerrit.osmocom.org/c/libosmocore/+/34746?usp=email To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: libosmocore Gerrit-Branch: master Gerrit-Change-Id: Ieb5bca3d3578abd28e18808752e1c312ce7c4ce0 Gerrit-Change-Number: 34746 Gerrit-PatchSet: 4 Gerrit-Owner: manawyrm <osmocom.account(a)tbspace.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Reviewer: laforge <laforge(a)osmocom.org> Gerrit-Attention: manawyrm <osmocom.account(a)tbspace.de> Gerrit-Comment-Date: Sun, 15 Oct 2023 12:09:10 +0000 Gerrit-HasComments: Yes Gerrit-Has-Labels: Yes Gerrit-MessageType: comment
1 0
0 0
  • ← Newer
  • 1
  • ...
  • 109
  • 110
  • 111
  • 112
  • 113
  • 114
  • 115
  • ...
  • 185
  • Older →

HyperKitty Powered by HyperKitty version 1.3.12.