lists.osmocom.org
Sign In Sign Up
Manage this list Sign In Sign Up

Keyboard Shortcuts

Thread View

  • j: Next unread message
  • k: Previous unread message
  • j a: Jump to all threads
  • j l: Jump to MailingList overview

gerrit-log

Thread Start a new thread
Download
Threads by month
  • ----- 2026 -----
  • November
  • October
  • September
  • August
  • July
  • June
  • May
  • April
  • March
  • February
  • January
  • ----- 2025 -----
  • December
  • November
  • October
  • September
  • August
  • July
  • June
  • May
  • April
  • March
  • February
  • January
  • ----- 2024 -----
  • December
  • November
  • October
  • September
  • August
  • July
  • June
  • May
  • April
  • March
  • February
  • January
  • ----- 2023 -----
  • December
  • November
  • October
  • September
  • August
  • July
  • June
  • May
  • April
  • March
  • February
  • January
  • ----- 2022 -----
  • December
  • November
  • October
  • September
  • August
  • July
  • June
  • May
  • April
  • March
  • February
  • January
gerrit-log@lists.osmocom.org

June 2023

  • 1 participants
  • 2480 discussions
[S] Change in osmo-gsm-tester[master]: templates: fix osmo-msc.cfg.tmpl: add 'role asp', 'sctp-role client'
by fixeria 19 Jun '23

19 Jun '23
fixeria has posted comments on this change. ( https://gerrit.osmocom.org/c/osmo-gsm-tester/+/33349 ) Change subject: templates: fix osmo-msc.cfg.tmpl: add 'role asp', 'sctp-role client' ...................................................................... Patch Set 1: Verified+1 -- To view, visit https://gerrit.osmocom.org/c/osmo-gsm-tester/+/33349 To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: osmo-gsm-tester Gerrit-Branch: master Gerrit-Change-Id: Ie29589b46c65707089ff2b22c3b139b7b435cc95 Gerrit-Change-Number: 33349 Gerrit-PatchSet: 1 Gerrit-Owner: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Reviewer: pespin <pespin(a)sysmocom.de> Gerrit-Comment-Date: Mon, 19 Jun 2023 09:50:08 +0000 Gerrit-HasComments: No Gerrit-Has-Labels: Yes Gerrit-MessageType: comment
1 0
0 0
[M] Change in libosmo-sccp[master]: Forbid partial VTY configurations of ASPs with name asp-clnt-*
by fixeria 19 Jun '23

19 Jun '23
Attention is currently required from: pespin. fixeria has posted comments on this change. ( https://gerrit.osmocom.org/c/libosmo-sccp/+/33325 ) Change subject: Forbid partial VTY configurations of ASPs with name asp-clnt-* ...................................................................... Patch Set 2: (1 comment) File include/osmocom/sigtran/osmo_ss7.h: https://gerrit.osmocom.org/c/libosmo-sccp/+/33325/comment/f7391e9b_e8fcbdae PS2, Line 433: bool role_set_by_vty; This looks like a public API, and you're adding stuff at the middle of a public struct? -- To view, visit https://gerrit.osmocom.org/c/libosmo-sccp/+/33325 To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: libosmo-sccp Gerrit-Branch: master Gerrit-Change-Id: I65b5fad2ec06a9d9c521f1e3ce8aab633da95a47 Gerrit-Change-Number: 33325 Gerrit-PatchSet: 2 Gerrit-Owner: pespin <pespin(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: laforge <laforge(a)osmocom.org> Gerrit-CC: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Attention: pespin <pespin(a)sysmocom.de> Gerrit-Comment-Date: Mon, 19 Jun 2023 09:49:39 +0000 Gerrit-HasComments: Yes Gerrit-Has-Labels: No Gerrit-MessageType: comment
1 0
0 0
[S] Change in osmo-gsm-tester[master]: templates: fix osmo-msc.cfg.tmpl: add 'role asp', 'sctp-role client'
by pespin 19 Jun '23

19 Jun '23
Attention is currently required from: fixeria. pespin has posted comments on this change. ( https://gerrit.osmocom.org/c/osmo-gsm-tester/+/33349 ) Change subject: templates: fix osmo-msc.cfg.tmpl: add 'role asp', 'sctp-role client' ...................................................................... Patch Set 1: Code-Review+2 -- To view, visit https://gerrit.osmocom.org/c/osmo-gsm-tester/+/33349 To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: osmo-gsm-tester Gerrit-Branch: master Gerrit-Change-Id: Ie29589b46c65707089ff2b22c3b139b7b435cc95 Gerrit-Change-Number: 33349 Gerrit-PatchSet: 1 Gerrit-Owner: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Reviewer: pespin <pespin(a)sysmocom.de> Gerrit-CC: Jenkins Builder Gerrit-Attention: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Comment-Date: Mon, 19 Jun 2023 09:36:58 +0000 Gerrit-HasComments: No Gerrit-Has-Labels: Yes Gerrit-MessageType: comment
1 0
0 0
[S] Change in osmo-gsm-tester[master]: templates: fix osmo-msc.cfg.tmpl: add 'role asp', 'sctp-role client'
by fixeria 19 Jun '23

19 Jun '23
fixeria has uploaded this change for review. ( https://gerrit.osmocom.org/c/osmo-gsm-tester/+/33349 ) Change subject: templates: fix osmo-msc.cfg.tmpl: add 'role asp', 'sctp-role client' ...................................................................... templates: fix osmo-msc.cfg.tmpl: add 'role asp', 'sctp-role client' This commit fixes osmo-gsm-tester_virtual, which currently fails because osmo-msc is unable to start: DLSCCP NOTICE sccp_user.c:656 OsmoMSC-A-Iu: Requesting an SCCP simple client on ASP asp-clnt-OsmoMSC-A configured with 'sctp-role server' DLSCCP ERROR sccp_user.c:661 OsmoMSC-A-Iu: Requesting an SCCP simple client on ASP asp-clnt-OsmoMSC-A configured with 'sctp-role server' but no matching xUA server was configured! Change-Id: Ie29589b46c65707089ff2b22c3b139b7b435cc95 --- M src/osmo_gsm_tester/templates/osmo-msc.cfg.tmpl 1 file changed, 22 insertions(+), 0 deletions(-) git pull ssh://gerrit.osmocom.org:29418/osmo-gsm-tester refs/changes/49/33349/1 diff --git a/src/osmo_gsm_tester/templates/osmo-msc.cfg.tmpl b/src/osmo_gsm_tester/templates/osmo-msc.cfg.tmpl index 1b91672..2893619 100644 --- a/src/osmo_gsm_tester/templates/osmo-msc.cfg.tmpl +++ b/src/osmo_gsm_tester/templates/osmo-msc.cfg.tmpl @@ -27,6 +27,8 @@ asp asp0 2905 0 m3ua local-ip ${msc.ip_address.addr} remote-ip ${stp.ip_address.addr} + role asp + sctp-role client as as0 m3ua asp asp0 routing-key 1 0.0.1 -- To view, visit https://gerrit.osmocom.org/c/osmo-gsm-tester/+/33349 To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: osmo-gsm-tester Gerrit-Branch: master Gerrit-Change-Id: Ie29589b46c65707089ff2b22c3b139b7b435cc95 Gerrit-Change-Number: 33349 Gerrit-PatchSet: 1 Gerrit-Owner: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-MessageType: newchange
1 0
0 0
[S] Change in libosmo-sccp[master]: Set stream_cli/srv name to contain ASP + sockname
by pespin 19 Jun '23

19 Jun '23
Attention is currently required from: pespin, daniel. Hello Jenkins Builder, fixeria, daniel, I'd like you to reexamine a change. Please visit https://gerrit.osmocom.org/c/libosmo-sccp/+/33335 to look at the new patch set (#6). Change subject: Set stream_cli/srv name to contain ASP + sockname ...................................................................... Set stream_cli/srv name to contain ASP + sockname Upon connect/accept, update the name to contain both the ASP and the sockname of the established socked. This allows easily identifying the stream based on IP layer as well as upper xUA layer. Example logs: """ stream.c:1193 SRV(::1:2905) accept()ed new link from ::1 to port 2905 stream.c:1672 SRVCONN(asp-dyn-0,(r=::1:43568<->l=::1:2905)) connected read/write (what=0x1) stream.c:1589 SRVCONN(asp-dyn-0,(r=::1:43568<->l=::1:2905)) message received """ """ stream.c:521 CLICONN(asp0){CONNECTING} connection established stream.c:552 CLICONN(asp0,(r=::1:2905<->l=::ffff:127.0.0.2:35911)){CONNECTED} connected read stream.c:401 CLICONN(asp0,(r=::1:2905<->l=::ffff:127.0.0.2:35911)){CONNECTED} message received """ Depends: libosmo-netif.git I539a0d29d11348efe702f971965a55cf56db5c59 Change-Id: I05bc5f6c7795f62c1814c1c774287b41ee85a475 --- M TODO-RELEASE M src/osmo_ss7.c 2 files changed, 38 insertions(+), 0 deletions(-) git pull ssh://gerrit.osmocom.org:29418/libosmo-sccp refs/changes/35/33335/6 -- To view, visit https://gerrit.osmocom.org/c/libosmo-sccp/+/33335 To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: libosmo-sccp Gerrit-Branch: master Gerrit-Change-Id: I05bc5f6c7795f62c1814c1c774287b41ee85a475 Gerrit-Change-Number: 33335 Gerrit-PatchSet: 6 Gerrit-Owner: pespin <pespin(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: daniel <dwillmann(a)sysmocom.de> Gerrit-Reviewer: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-CC: laforge <laforge(a)osmocom.org> Gerrit-Attention: pespin <pespin(a)sysmocom.de> Gerrit-Attention: daniel <dwillmann(a)sysmocom.de> Gerrit-MessageType: newpatchset
1 0
0 0
[S] Change in libosmocore[master]: gsm/ipa: Add segmentation callback
by pespin 19 Jun '23

19 Jun '23
Attention is currently required from: arehbein, fixeria, daniel. pespin has posted comments on this change. ( https://gerrit.osmocom.org/c/libosmocore/+/33083 ) Change subject: gsm/ipa: Add segmentation callback ...................................................................... Patch Set 11: Code-Review+1 (2 comments) File src/gsm/ipa.c: https://gerrit.osmocom.org/c/libosmocore/+/33083/comment/154fe41d_312c931e PS8, Line 728: * -EIO, if the header declares a payload too large */ > hmm weird, I remember reading somewhere that Osmocom comments do *not* put the comment end marker on […] There's no specific stone-written rule anywhere I'm aware of, and both are accepted. In function documentation though, where lots of comments is written in a formatted way, I believe it's clearer leaving the */ at the end. Up to you. https://gerrit.osmocom.org/c/libosmocore/+/33083/comment/1e9e63a5_ca27445f PS8, Line 729: int ipa_segmentation_cb(struct msgb *msg) > So what's wrong with the Doxygen style comment? It doesn't contradict the description you quote. I was just sharing it here to make it easy for others (and myself) while reviewing, since this function didn't provide how it expected to do the segmentation. -- To view, visit https://gerrit.osmocom.org/c/libosmocore/+/33083 To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: libosmocore Gerrit-Branch: master Gerrit-Change-Id: I3a639e6896cc3b3fc8e9b2e1a58254710efa0d3f Gerrit-Change-Number: 33083 Gerrit-PatchSet: 11 Gerrit-Owner: arehbein <arehbein(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Reviewer: laforge <laforge(a)osmocom.org> Gerrit-Reviewer: pespin <pespin(a)sysmocom.de> Gerrit-CC: daniel <dwillmann(a)sysmocom.de> Gerrit-Attention: arehbein <arehbein(a)sysmocom.de> Gerrit-Attention: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Attention: daniel <dwillmann(a)sysmocom.de> Gerrit-Comment-Date: Mon, 19 Jun 2023 09:14:58 +0000 Gerrit-HasComments: Yes Gerrit-Has-Labels: Yes Comment-In-Reply-To: arehbein <arehbein(a)sysmocom.de> Comment-In-Reply-To: pespin <pespin(a)sysmocom.de> Gerrit-MessageType: comment
1 0
0 0
[S] Change in libosmocore[master]: core/osmo_io: Fix reception of partial packets
by pespin 19 Jun '23

19 Jun '23
Attention is currently required from: arehbein. pespin has posted comments on this change. ( https://gerrit.osmocom.org/c/libosmocore/+/33346 ) Change subject: core/osmo_io: Fix reception of partial packets ...................................................................... Patch Set 2: Code-Review+1 -- To view, visit https://gerrit.osmocom.org/c/libosmocore/+/33346 To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: libosmocore Gerrit-Branch: master Gerrit-Change-Id: I0ab8028c807b4181fddd3c00ea2e037c40cf0813 Gerrit-Change-Number: 33346 Gerrit-PatchSet: 2 Gerrit-Owner: arehbein <arehbein(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Reviewer: laforge <laforge(a)osmocom.org> Gerrit-Reviewer: pespin <pespin(a)sysmocom.de> Gerrit-Attention: arehbein <arehbein(a)sysmocom.de> Gerrit-Comment-Date: Mon, 19 Jun 2023 09:05:06 +0000 Gerrit-HasComments: No Gerrit-Has-Labels: Yes Gerrit-MessageType: comment
1 0
0 0
[S] Change in libosmocore[master]: core/osmo_io: Rename variables for readability
by pespin 19 Jun '23

19 Jun '23
Attention is currently required from: arehbein. pespin has posted comments on this change. ( https://gerrit.osmocom.org/c/libosmocore/+/33345 ) Change subject: core/osmo_io: Rename variables for readability ...................................................................... Patch Set 1: Code-Review+1 -- To view, visit https://gerrit.osmocom.org/c/libosmocore/+/33345 To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: libosmocore Gerrit-Branch: master Gerrit-Change-Id: I3d752ce91a1b16c855522f643d10a52ef28a8a84 Gerrit-Change-Number: 33345 Gerrit-PatchSet: 1 Gerrit-Owner: arehbein <arehbein(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Reviewer: laforge <laforge(a)osmocom.org> Gerrit-Reviewer: pespin <pespin(a)sysmocom.de> Gerrit-Attention: arehbein <arehbein(a)sysmocom.de> Gerrit-Comment-Date: Mon, 19 Jun 2023 09:04:44 +0000 Gerrit-HasComments: No Gerrit-Has-Labels: Yes Gerrit-MessageType: comment
1 0
0 0
[M] Change in osmo-mgw[master]: mgw: Allow auditing speciall 'null' endpoint
by pespin 19 Jun '23

19 Jun '23
Attention is currently required from: laforge, dexter. pespin has posted comments on this change. ( https://gerrit.osmocom.org/c/osmo-mgw/+/33312 ) Change subject: mgw: Allow auditing speciall 'null' endpoint ...................................................................... Patch Set 3: (1 comment) File src/libosmo-mgcp/mgcp_protocol.c: https://gerrit.osmocom.org/c/osmo-mgw/+/33312/comment/97aeebbd_012b61d6 PS2, Line 473: > I would think of the null endpoint as something global, not per-trunk Then having an endp outside of a trunk would makde things more complex and confusing for no good reason (at least for now given the features we want to use it for). So my opinion is let's merge this as is. -- To view, visit https://gerrit.osmocom.org/c/osmo-mgw/+/33312 To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: osmo-mgw Gerrit-Branch: master Gerrit-Change-Id: Ia409b16e9211e6261e2e0f21288544289d6f3733 Gerrit-Change-Number: 33312 Gerrit-PatchSet: 3 Gerrit-Owner: pespin <pespin(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: dexter <pmaier(a)sysmocom.de> Gerrit-Reviewer: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Reviewer: laforge <laforge(a)osmocom.org> Gerrit-Reviewer: osmith <osmith(a)sysmocom.de> Gerrit-Attention: laforge <laforge(a)osmocom.org> Gerrit-Attention: dexter <pmaier(a)sysmocom.de> Gerrit-Comment-Date: Mon, 19 Jun 2023 09:00:35 +0000 Gerrit-HasComments: Yes Gerrit-Has-Labels: No Comment-In-Reply-To: laforge <laforge(a)osmocom.org> Comment-In-Reply-To: pespin <pespin(a)sysmocom.de> Comment-In-Reply-To: dexter <pmaier(a)sysmocom.de> Gerrit-MessageType: comment
1 0
0 0
[S] Change in libosmocore[master]: osmo_io: Make name optional, add _set_name() API
by pespin 19 Jun '23

19 Jun '23
Attention is currently required from: laforge, daniel. pespin has posted comments on this change. ( https://gerrit.osmocom.org/c/libosmocore/+/33341 ) Change subject: osmo_io: Make name optional, add _set_name() API ...................................................................... Patch Set 2: (1 comment) Patchset: PS2: > I think the ability to change it is definitely good. […] in the end is not making the implementation more complex though (just 2 extra checks) and it spares checking the input of set_name(), so all in all it's the same while allowing NULL cases being passed instead of erroring, which makes the API less prone to errors. -- To view, visit https://gerrit.osmocom.org/c/libosmocore/+/33341 To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: libosmocore Gerrit-Branch: master Gerrit-Change-Id: If2772a3ccaa98616e0189862a49ab0243435e343 Gerrit-Change-Number: 33341 Gerrit-PatchSet: 2 Gerrit-Owner: pespin <pespin(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: daniel <dwillmann(a)sysmocom.de> Gerrit-Reviewer: laforge <laforge(a)osmocom.org> Gerrit-Attention: laforge <laforge(a)osmocom.org> Gerrit-Attention: daniel <dwillmann(a)sysmocom.de> Gerrit-Comment-Date: Mon, 19 Jun 2023 08:58:18 +0000 Gerrit-HasComments: Yes Gerrit-Has-Labels: No Comment-In-Reply-To: laforge <laforge(a)osmocom.org> Comment-In-Reply-To: daniel <dwillmann(a)sysmocom.de> Gerrit-MessageType: comment
1 0
0 0
  • ← Newer
  • 1
  • ...
  • 94
  • 95
  • 96
  • 97
  • 98
  • 99
  • 100
  • ...
  • 248
  • Older →

HyperKitty Powered by HyperKitty version 1.3.12.