lists.osmocom.org
Sign In Sign Up
Manage this list Sign In Sign Up

Keyboard Shortcuts

Thread View

  • j: Next unread message
  • k: Previous unread message
  • j a: Jump to all threads
  • j l: Jump to MailingList overview

gerrit-log

Thread Start a new thread
Download
Threads by month
  • ----- 2026 -----
  • October
  • September
  • August
  • July
  • June
  • May
  • April
  • March
  • February
  • January
  • ----- 2025 -----
  • December
  • November
  • October
  • September
  • August
  • July
  • June
  • May
  • April
  • March
  • February
  • January
  • ----- 2024 -----
  • December
  • November
  • October
  • September
  • August
  • July
  • June
  • May
  • April
  • March
  • February
  • January
  • ----- 2023 -----
  • December
  • November
  • October
  • September
  • August
  • July
  • June
  • May
  • April
  • March
  • February
  • January
  • ----- 2022 -----
  • December
  • November
  • October
  • September
  • August
  • July
  • June
  • May
  • April
  • March
  • February
  • January
gerrit-log@lists.osmocom.org

March 2023

  • 1 participants
  • 3642 discussions
[S] Change in osmo-mgw[master]: mgcp_e1: cosmetic: reqrite comment
by dexter 02 Mar '23

02 Mar '23
dexter has uploaded this change for review. ( https://gerrit.osmocom.org/c/osmo-mgw/+/31637 ) Change subject: mgcp_e1: cosmetic: reqrite comment ...................................................................... mgcp_e1: cosmetic: reqrite comment Change-Id: I405cf464c052a2ab1461c3a8ba96665a3bc30341 --- M src/libosmo-mgcp/mgcp_e1.c 1 file changed, 10 insertions(+), 1 deletion(-) git pull ssh://gerrit.osmocom.org:29418/osmo-mgw refs/changes/37/31637/1 diff --git a/src/libosmo-mgcp/mgcp_e1.c b/src/libosmo-mgcp/mgcp_e1.c index 6d1f891..40f976b 100644 --- a/src/libosmo-mgcp/mgcp_e1.c +++ b/src/libosmo-mgcp/mgcp_e1.c @@ -361,7 +361,7 @@ /* Trigger sending of pending E1 traffic */ e1_send_ts_frame(ts, trunk); - /* e1inp_rx_ts() does not free() msgb */ + /* e1inp_rx_ts(), the caller of this callback does not free() msgb. */ msgb_free(msg); } -- To view, visit https://gerrit.osmocom.org/c/osmo-mgw/+/31637 To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: osmo-mgw Gerrit-Branch: master Gerrit-Change-Id: I405cf464c052a2ab1461c3a8ba96665a3bc30341 Gerrit-Change-Number: 31637 Gerrit-PatchSet: 1 Gerrit-Owner: dexter <pmaier(a)sysmocom.de> Gerrit-MessageType: newchange
1 0
0 0
[S] Change in osmo-bsc[master]: cosmetic: clarify test_codec_support_bts()
by pespin 02 Mar '23

02 Mar '23
Attention is currently required from: neels, fixeria. pespin has posted comments on this change. ( https://gerrit.osmocom.org/c/osmo-bsc/+/31612 ) Change subject: cosmetic: clarify test_codec_support_bts() ...................................................................... Patch Set 2: Code-Review+1 -- To view, visit https://gerrit.osmocom.org/c/osmo-bsc/+/31612 To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: osmo-bsc Gerrit-Branch: master Gerrit-Change-Id: I13d9b158d08f4938c5aa47ef3134819a4b1f7d29 Gerrit-Change-Number: 31612 Gerrit-PatchSet: 2 Gerrit-Owner: neels <nhofmeyr(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: pespin <pespin(a)sysmocom.de> Gerrit-CC: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Attention: neels <nhofmeyr(a)sysmocom.de> Gerrit-Attention: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Comment-Date: Thu, 02 Mar 2023 11:04:18 +0000 Gerrit-HasComments: No Gerrit-Has-Labels: Yes Gerrit-MessageType: comment
1 0
0 0
[S] Change in osmo-bsc[master]: cosmetic: clarify test_codec_support_bts()
by pespin 02 Mar '23

02 Mar '23
Attention is currently required from: neels, fixeria. pespin has posted comments on this change. ( https://gerrit.osmocom.org/c/osmo-bsc/+/31612 ) Change subject: cosmetic: clarify test_codec_support_bts() ...................................................................... Patch Set 2: (1 comment) File src/osmo-bsc/codec_pref.c: https://gerrit.osmocom.org/c/osmo-bsc/+/31612/comment/429f1d76_75d47d28 PS1, Line 225: return (bool)bts_codec->efr; > the return value is a bool, so casting to bool is the logic fit, and even that is just syntactic sug […] Ah I see they are always ever set to 0 or 1. Those should be actually moved to be bools there. -- To view, visit https://gerrit.osmocom.org/c/osmo-bsc/+/31612 To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: osmo-bsc Gerrit-Branch: master Gerrit-Change-Id: I13d9b158d08f4938c5aa47ef3134819a4b1f7d29 Gerrit-Change-Number: 31612 Gerrit-PatchSet: 2 Gerrit-Owner: neels <nhofmeyr(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-CC: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-CC: pespin <pespin(a)sysmocom.de> Gerrit-Attention: neels <nhofmeyr(a)sysmocom.de> Gerrit-Attention: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Comment-Date: Thu, 02 Mar 2023 11:04:10 +0000 Gerrit-HasComments: Yes Gerrit-Has-Labels: No Comment-In-Reply-To: neels <nhofmeyr(a)sysmocom.de> Comment-In-Reply-To: pespin <pespin(a)sysmocom.de> Gerrit-MessageType: comment
1 0
0 0
[S] Change in osmo-mgw[master]: mgcp_e1: rename e1_send to e1_send_ts_frame
by dexter 02 Mar '23

02 Mar '23
dexter has uploaded this change for review. ( https://gerrit.osmocom.org/c/osmo-mgw/+/31636 ) Change subject: mgcp_e1: rename e1_send to e1_send_ts_frame ...................................................................... mgcp_e1: rename e1_send to e1_send_ts_frame The function name e1_send is very generic, lets make clear that one E1 timeslot frame is sent. Change-Id: I5fba7993860a63149a13d943edbfabc4008680ef --- M src/libosmo-mgcp/mgcp_e1.c 1 file changed, 14 insertions(+), 2 deletions(-) git pull ssh://gerrit.osmocom.org:29418/osmo-mgw refs/changes/36/31636/1 diff --git a/src/libosmo-mgcp/mgcp_e1.c b/src/libosmo-mgcp/mgcp_e1.c index 80a48ab..6d1f891 100644 --- a/src/libosmo-mgcp/mgcp_e1.c +++ b/src/libosmo-mgcp/mgcp_e1.c @@ -310,7 +310,7 @@ } /* handle outgoing E1 traffic */ -static void e1_send(struct e1inp_ts *ts, struct mgcp_trunk *trunk) +static void e1_send_ts_frame(struct e1inp_ts *ts, struct mgcp_trunk *trunk) { struct msgb *msg = msgb_alloc_c(trunk, E1_TS_BYTES, "E1-TX-timeslot-bytes"); uint8_t *ptr; @@ -359,7 +359,7 @@ osmo_i460_demux_in(&trunk->e1.i460_ts[ts->num - 1], msgb_data(msg), msgb_length(msg)); /* Trigger sending of pending E1 traffic */ - e1_send(ts, trunk); + e1_send_ts_frame(ts, trunk); /* e1inp_rx_ts() does not free() msgb */ msgb_free(msg); -- To view, visit https://gerrit.osmocom.org/c/osmo-mgw/+/31636 To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: osmo-mgw Gerrit-Branch: master Gerrit-Change-Id: I5fba7993860a63149a13d943edbfabc4008680ef Gerrit-Change-Number: 31636 Gerrit-PatchSet: 1 Gerrit-Owner: dexter <pmaier(a)sysmocom.de> Gerrit-MessageType: newchange
1 0
0 0
[M] Change in osmo-ttcn3-hacks[master]: library/RSL_Types: RSL_SpeechAlgo: support CSD
by osmith 02 Mar '23

02 Mar '23
Attention is currently required from: laforge, fixeria. osmith has posted comments on this change. ( https://gerrit.osmocom.org/c/osmo-ttcn3-hacks/+/31556 ) Change subject: library/RSL_Types: RSL_SpeechAlgo: support CSD ...................................................................... Patch Set 3: (2 comments) File library/RSL_Types.ttcn: https://gerrit.osmocom.org/c/osmo-ttcn3-hacks/+/31556/comment/f9ba18f5_7591… PS2, Line 389: RSL_SpeechAlgoDataRate > I am currently looking at 3GPP TS 48.058 section 9.3.6, and I see the following: […] Done https://gerrit.osmocom.org/c/osmo-ttcn3-hacks/+/31556/comment/37e49396_c20c… PS2, Line 397: SL_CMOD_DT_NT2 ('00100010'B), : RSL_CMOD_DT_NT3 ('00100011'B), : RSL_CMOD_DT_NT4 ('00101001'B), : RSL_CMOD_DT_NT5 ('00101010'B), : RSL_CMOD_DT_NT6 ('00101011'B), : RSL_CMOD_DT_NT7 ('00110100'B), : RSL_CMOD_DT_NT9 ('00011000'B), : RSL_CMOD_DT_T1 ('01111000'B), : RSL_CMOD_DT_T2 ('01111001'B), : RSL_CMOD_DT_T3 ('01011000'B), : RSL_CMOD_DT_T4 ('01010000'B), : RSL_CMOD_DT_T5 ('01010001'B), : RSL_CMOD_DT_T6 ('01010010'B), : RSL_CMOD_DT_T7 ('01010011'B), : RSL_CMOD_DT_T8 ('01010100'B), : RSL_CMOD_DT_T9 > Why would those be called _NT1 or _T2 rather than something that indicates their actual data rate? l […] Done, changed it to the same names as in libosmocore. -- To view, visit https://gerrit.osmocom.org/c/osmo-ttcn3-hacks/+/31556 To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: osmo-ttcn3-hacks Gerrit-Branch: master Gerrit-Change-Id: Ief2d95c7e9d71afb26fa74da755294226c8e158d Gerrit-Change-Number: 31556 Gerrit-PatchSet: 3 Gerrit-Owner: osmith <osmith(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: laforge <laforge(a)osmocom.org> Gerrit-Reviewer: pespin <pespin(a)sysmocom.de> Gerrit-CC: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Attention: laforge <laforge(a)osmocom.org> Gerrit-Attention: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Comment-Date: Thu, 02 Mar 2023 10:55:15 +0000 Gerrit-HasComments: Yes Gerrit-Has-Labels: No Comment-In-Reply-To: laforge <laforge(a)osmocom.org> Comment-In-Reply-To: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-MessageType: comment
1 0
0 0
[M] Change in osmo-ttcn3-hacks[master]: bsc: TC_assignment_csd: expect BSC to handle CSD
by osmith 02 Mar '23

02 Mar '23
Attention is currently required from: laforge, fixeria. osmith has posted comments on this change. ( https://gerrit.osmocom.org/c/osmo-ttcn3-hacks/+/31557 ) Change subject: bsc: TC_assignment_csd: expect BSC to handle CSD ...................................................................... Patch Set 3: (2 comments) File bsc/BSC_Tests.ttcn: https://gerrit.osmocom.org/c/osmo-ttcn3-hacks/+/31557/comment/000f6709_3812… PS2, Line 1844: octetstring > `OCT1`? Done https://gerrit.osmocom.org/c/osmo-ttcn3-hacks/+/31557/comment/13ae0e9e_ab43… PS2, Line 1850: o > we might want some kind of convenience constants (of OCT1 type) that we can use here and in other up […] I'm not sure what you mean exactly. I've changed it to OCT1 as fixeria suggested. -- To view, visit https://gerrit.osmocom.org/c/osmo-ttcn3-hacks/+/31557 To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: osmo-ttcn3-hacks Gerrit-Branch: master Gerrit-Change-Id: Iff19dc704af09d09d2265d8da38fc745a3936ce4 Gerrit-Change-Number: 31557 Gerrit-PatchSet: 3 Gerrit-Owner: osmith <osmith(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Reviewer: pespin <pespin(a)sysmocom.de> Gerrit-CC: laforge <laforge(a)osmocom.org> Gerrit-Attention: laforge <laforge(a)osmocom.org> Gerrit-Attention: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Comment-Date: Thu, 02 Mar 2023 10:54:47 +0000 Gerrit-HasComments: Yes Gerrit-Has-Labels: No Comment-In-Reply-To: laforge <laforge(a)osmocom.org> Comment-In-Reply-To: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-MessageType: comment
1 0
0 0
[M] Change in osmo-ttcn3-hacks[master]: bsc: TC_assignment_csd: expect BSC to handle CSD
by osmith 02 Mar '23

02 Mar '23
Attention is currently required from: osmith. Hello Jenkins Builder, fixeria, pespin, I'd like you to reexamine a change. Please visit https://gerrit.osmocom.org/c/osmo-ttcn3-hacks/+/31557 to look at the new patch set (#3). Change subject: bsc: TC_assignment_csd: expect BSC to handle CSD ...................................................................... bsc: TC_assignment_csd: expect BSC to handle CSD Related: OS#4393 Change-Id: Iff19dc704af09d09d2265d8da38fc745a3936ce4 --- M bsc/BSC_Tests.ttcn M library/BSSMAP_Templates.ttcn 2 files changed, 51 insertions(+), 5 deletions(-) git pull ssh://gerrit.osmocom.org:29418/osmo-ttcn3-hacks refs/changes/57/31557/3 -- To view, visit https://gerrit.osmocom.org/c/osmo-ttcn3-hacks/+/31557 To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: osmo-ttcn3-hacks Gerrit-Branch: master Gerrit-Change-Id: Iff19dc704af09d09d2265d8da38fc745a3936ce4 Gerrit-Change-Number: 31557 Gerrit-PatchSet: 3 Gerrit-Owner: osmith <osmith(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Reviewer: pespin <pespin(a)sysmocom.de> Gerrit-CC: laforge <laforge(a)osmocom.org> Gerrit-Attention: osmith <osmith(a)sysmocom.de> Gerrit-MessageType: newpatchset
1 0
0 0
[M] Change in osmo-ttcn3-hacks[master]: library/RSL_Types: RSL_SpeechAlgo: support CSD
by osmith 02 Mar '23

02 Mar '23
Attention is currently required from: osmith. Hello Jenkins Builder, laforge, pespin, I'd like you to reexamine a change. Please visit https://gerrit.osmocom.org/c/osmo-ttcn3-hacks/+/31556 to look at the new patch set (#3). Change subject: library/RSL_Types: RSL_SpeechAlgo: support CSD ...................................................................... library/RSL_Types: RSL_SpeechAlgo: support CSD Prepare to test CSD in BSC_Tests.ttcn. After sending a BSSAP assignment request to the BSC with channel type data, the BSC will send a channel activation via RSL to the BTS (which is emulated by the testsuite). Without CSD support in the RSL template, the testsuite is unable to decode the message, prints "Data remained at the end of the stream after successful decoding" and the test fails. Related: OS#4393 Change-Id: Ief2d95c7e9d71afb26fa74da755294226c8e158d --- M bsc/BSC_Tests.ttcn M library/RSL_Types.ttcn 2 files changed, 67 insertions(+), 15 deletions(-) git pull ssh://gerrit.osmocom.org:29418/osmo-ttcn3-hacks refs/changes/56/31556/3 -- To view, visit https://gerrit.osmocom.org/c/osmo-ttcn3-hacks/+/31556 To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: osmo-ttcn3-hacks Gerrit-Branch: master Gerrit-Change-Id: Ief2d95c7e9d71afb26fa74da755294226c8e158d Gerrit-Change-Number: 31556 Gerrit-PatchSet: 3 Gerrit-Owner: osmith <osmith(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: laforge <laforge(a)osmocom.org> Gerrit-Reviewer: pespin <pespin(a)sysmocom.de> Gerrit-CC: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Attention: osmith <osmith(a)sysmocom.de> Gerrit-MessageType: newpatchset
1 0
0 0
[M] Change in osmo-pcu[master]: bts: add IMMEDIATE ASSIGNMENT via PCH transmission
by pespin 02 Mar '23

02 Mar '23
Attention is currently required from: neels, fixeria, dexter. pespin has posted comments on this change. ( https://gerrit.osmocom.org/c/osmo-pcu/+/31145 ) Change subject: bts: add IMMEDIATE ASSIGNMENT via PCH transmission ...................................................................... Patch Set 19: (5 comments) File include/osmocom/pcu/pcuif_proto.h: https://gerrit.osmocom.org/c/osmo-pcu/+/31145/comment/fcea5d5e_7f36fc99 PS19, Line 279: uint8_t pgroup; > > And AFAIR, yes, it can be bigger than 255. […] What do we need to calculate the paging group? Some specific SI? we are already passing some SIs to the PCU, and we may have the relevant information in osmo-pcu already. File include/osmocom/pcu/pcuif_proto.h: https://gerrit.osmocom.org/c/osmo-pcu/+/31145/comment/8cb077ba_a38a7b1b PS18, Line 43: PCU_IF_SAPI_PCH_DT > The patch for `osmo-bts.git` is already in Gerrit (currently WIP to avoid merging before this one). […] I do see a real need: This allows running a new osmo-pcu with older osmo-bts. So I'm all in favour for the approach submitted by dexter here. File include/osmocom/pcu/pcuif_proto.h: https://gerrit.osmocom.org/c/osmo-pcu/+/31145/comment/7b840485_b4942e3a PS17, Line 280: uint8_t pgroup[3]; > As per 3GPP TS 45.002 section 6.5.2 it's defined as follows: […] So let's provide the SI (if we don't do that already) to osmo-pcu so it can calculate the paging group? Either that or better pass the entire IMSI and let osmo-bts figure out the whole pgroup calculation. File src/bts.cpp: https://gerrit.osmocom.org/c/osmo-pcu/+/31145/comment/22aa73e1_01d8d68e PS17, Line 1134: pcu_l1if_tx_pch(bts, immediate_assignment, plen, ms_paging_group(tbf_ms(tbf))); > If we go this way (backwards compatibility), we would have to keep both `PCU_IF_MSG_DATA_CNF` and `P […] I think you are not thinking about users with deployments out there. If it's easy to add backward compatibility in osmo-pcu (which seems to be the case), why not doing it? This also allows testing when comparing for regressions with older versions of osmo-bts. File src/pcu_l1_if.cpp: https://gerrit.osmocom.org/c/osmo-pcu/+/31145/comment/8f21a066_b3c89da4 PS19, Line 771: } else { > He's adding `info_ind->version != 0x0a` there, so it can be reached. According to above block (like 752), only PCU_IF_VERSION and 0x0a are allows to reach here. PCU_IF_VERSION is checked in line 766. 0x0a is checked in line 768. So this "else" branch can never be entered! -- To view, visit https://gerrit.osmocom.org/c/osmo-pcu/+/31145 To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: osmo-pcu Gerrit-Branch: master Gerrit-Change-Id: I2a78651593323e8b9627c39918d949a33497b70f Gerrit-Change-Number: 31145 Gerrit-PatchSet: 19 Gerrit-Owner: dexter <pmaier(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Reviewer: laforge <laforge(a)osmocom.org> Gerrit-Reviewer: pespin <pespin(a)sysmocom.de> Gerrit-CC: neels <nhofmeyr(a)sysmocom.de> Gerrit-Attention: neels <nhofmeyr(a)sysmocom.de> Gerrit-Attention: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Attention: dexter <pmaier(a)sysmocom.de> Gerrit-Comment-Date: Thu, 02 Mar 2023 10:53:23 +0000 Gerrit-HasComments: Yes Gerrit-Has-Labels: No Comment-In-Reply-To: fixeria <vyanitskiy(a)sysmocom.de> Comment-In-Reply-To: pespin <pespin(a)sysmocom.de> Comment-In-Reply-To: dexter <pmaier(a)sysmocom.de> Gerrit-MessageType: comment
1 0
0 0
[M] Change in osmo-bsc[master]: vty: msc / codec-list: forbid duplicate entries
by pespin 02 Mar '23

02 Mar '23
Attention is currently required from: neels. pespin has posted comments on this change. ( https://gerrit.osmocom.org/c/osmo-bsc/+/31610 ) Change subject: vty: msc / codec-list: forbid duplicate entries ...................................................................... Patch Set 2: Code-Review+2 (2 comments) File src/osmo-bsc/bsc_vty.c: https://gerrit.osmocom.org/c/osmo-bsc/+/31610/comment/88cd6589_2e15ea0e PS1, Line 2730: || argv[i][1] != 'r' > not mine, just moving code around. yeah well, but while moving the code around you can move it using the proper indentation ;) https://gerrit.osmocom.org/c/osmo-bsc/+/31610/comment/a161117f_2ea8f314 PS1, Line 2740: if (strncmp("hr", argv[i], 2) == 0) > still just moving code Ok fine. How can you submit an extra patch fixing all those weird things I pointed out? -- To view, visit https://gerrit.osmocom.org/c/osmo-bsc/+/31610 To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: osmo-bsc Gerrit-Branch: master Gerrit-Change-Id: Ifdc9e04bf1d623da65bfb8a2fddea765601f6d9b Gerrit-Change-Number: 31610 Gerrit-PatchSet: 2 Gerrit-Owner: neels <nhofmeyr(a)sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: fixeria <vyanitskiy(a)sysmocom.de> Gerrit-Reviewer: pespin <pespin(a)sysmocom.de> Gerrit-Attention: neels <nhofmeyr(a)sysmocom.de> Gerrit-Comment-Date: Thu, 02 Mar 2023 10:45:37 +0000 Gerrit-HasComments: Yes Gerrit-Has-Labels: Yes Comment-In-Reply-To: neels <nhofmeyr(a)sysmocom.de> Comment-In-Reply-To: pespin <pespin(a)sysmocom.de> Gerrit-MessageType: comment
1 0
0 0
  • ← Newer
  • 1
  • ...
  • 345
  • 346
  • 347
  • 348
  • 349
  • 350
  • 351
  • ...
  • 365
  • Older →

HyperKitty Powered by HyperKitty version 1.3.12.