Attention is currently required from: neels. pespin has posted comments on this change. ( https://gerrit.osmocom.org/c/osmo-msc/+/30126 ) Change subject: [codecs filter] use filter result in Assignment ...................................................................... Patch Set 4: (1 comment) File src/libmsc/gsm_04_08_cc.c: https://gerrit.osmocom.org/c/osmo-msc/+/30126/comment/d53fd5b4_bc0e3fc1 PS4, Line 1797: codec_filter_run(&trans->cc.codecs);
Previously we discussed that codec_filter_run() should be called just before its result is used. […] I think that was an unconclusive discussion, and probably I was not really happy about that 😊
What's the point in calling that function (which I guess is quite expensive) every time you need to use the result, instead of calling it when you *modify* the inputs? -- To view, visit https://gerrit.osmocom.org/c/osmo-msc/+/30126 To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: osmo-msc Gerrit-Branch: master Gerrit-Change-Id: I66e7c8c5e401f4f3a7d3d42b9525b2c6e99691d9 Gerrit-Change-Number: 30126 Gerrit-PatchSet: 4 Gerrit-Owner: neels <nhofmeyr@sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-CC: pespin <pespin@sysmocom.de> Gerrit-Attention: neels <nhofmeyr@sysmocom.de> Gerrit-Comment-Date: Tue, 07 Mar 2023 17:01:13 +0000 Gerrit-HasComments: Yes Gerrit-Has-Labels: No Comment-In-Reply-To: neels <nhofmeyr@sysmocom.de> Comment-In-Reply-To: pespin <pespin@sysmocom.de> Gerrit-MessageType: comment