Attention is currently required from: laforge, pespin, keith, dexter. fixeria has posted comments on this change. ( https://gerrit.osmocom.org/c/osmo-pcu/+/32423 ) Change subject: er_ccu_l1_if: use one ccu_desr per timeslot ...................................................................... Patch Set 2: (1 comment) File src/ericsson-rbs/er_ccu_descr.h: https://gerrit.osmocom.org/c/osmo-pcu/+/32423/comment/f63b3502_4ae42410 PS1, Line 52: 8
I am also not so happy with this. I was searching for a define constant, but I couldn't fine one. […] I wouldn't bother adding this to libosmocore. It's a well-known constant for everyone working with GSM, which is not that hard to remember (compared to number of frames in a multiframe, for instance). I am fine with writing `foo[8]` in `*.h` files and then using `ARRAY_SIZE(foo)` in `*.c` files.
Maybe clarify the field name a but? How about `ts_ccu_descr` or `per_ts_ccu_descr`? -- To view, visit https://gerrit.osmocom.org/c/osmo-pcu/+/32423 To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: osmo-pcu Gerrit-Branch: master Gerrit-Change-Id: I09a51f34ce0edef79a797c4686c7b1d27c376e49 Gerrit-Change-Number: 32423 Gerrit-PatchSet: 2 Gerrit-Owner: dexter <pmaier@sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: keith <keith@rhizomatica.org> Gerrit-Reviewer: laforge <laforge@osmocom.org> Gerrit-Reviewer: pespin <pespin@sysmocom.de> Gerrit-CC: fixeria <vyanitskiy@sysmocom.de> Gerrit-Attention: laforge <laforge@osmocom.org> Gerrit-Attention: pespin <pespin@sysmocom.de> Gerrit-Attention: keith <keith@rhizomatica.org> Gerrit-Attention: dexter <pmaier@sysmocom.de> Gerrit-Comment-Date: Mon, 01 May 2023 17:48:17 +0000 Gerrit-HasComments: Yes Gerrit-Has-Labels: No Comment-In-Reply-To: laforge <laforge@osmocom.org> Comment-In-Reply-To: pespin <pespin@sysmocom.de> Comment-In-Reply-To: dexter <pmaier@sysmocom.de> Gerrit-MessageType: comment