Attention is currently required from: pespin, dexter. fixeria has posted comments on this change. ( https://gerrit.osmocom.org/c/osmo-bts/+/32733 ) Change subject: paging: parse PCUIF data indication outside of paging.c ...................................................................... Patch Set 5: (2 comments) File src/common/paging.c: https://gerrit.osmocom.org/c/osmo-bts/+/32733/comment/13119fcf_1b03b1df PS5, Line 273: uint8_t macblock_len In GSM all MAC blocks must have `length == GSM_MACBLOCK_LEN`. IMO, it should be responsibility of the calling function to ensure the correct length. I see no need to pass and enforce the length here in this function. Not critical though. File src/common/pcu_sock.c: https://gerrit.osmocom.org/c/osmo-bts/+/32733/comment/e73b003b_8a8d5a4a PS5, Line 679: memcpy(imsi, data_req->data, 3); `osmo_strlcpy(&imsi[0], data_req->data, sizeof(imsi))` - this looks more readable and requires no prior initialization of `imsi[]`. -- To view, visit https://gerrit.osmocom.org/c/osmo-bts/+/32733 To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: osmo-bts Gerrit-Branch: master Gerrit-Change-Id: I9f3799916e8102bf1ce0f21891f2d24f43091f01 Gerrit-Change-Number: 32733 Gerrit-PatchSet: 5 Gerrit-Owner: dexter <pmaier@sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: fixeria <vyanitskiy@sysmocom.de> Gerrit-Reviewer: pespin <pespin@sysmocom.de> Gerrit-Attention: pespin <pespin@sysmocom.de> Gerrit-Attention: dexter <pmaier@sysmocom.de> Gerrit-Comment-Date: Mon, 05 Jun 2023 12:39:03 +0000 Gerrit-HasComments: Yes Gerrit-Has-Labels: No Gerrit-MessageType: comment