Attention is currently required from: pespin.
lynxis lazus has posted comments on this change by lynxis lazus. ( https://gerrit.osmocom.org/c/osmo-sgsn/+/39562?usp=email )
Change subject: Rework SGSN code to use new libvlr code ......................................................................
Patch Set 19:
(6 comments)
File include/osmocom/sgsn/debug.h:
https://gerrit.osmocom.org/c/osmo-sgsn/+/39562/comment/485c2271_3f90a840?usp... : PS16, Line 31: DSGS, /* only as placeholder, SGS isn't used by the SGSN */
because libvlr is using it. I improved the comment.
I removed it.
File src/sgsn/gprs_gmm.c:
https://gerrit.osmocom.org/c/osmo-sgsn/+/39562/comment/c52baeb1_692aec49?usp... : PS17, Line 2602: osmo_vlr_set_log_cat(OSMO_VLR_LOGC_VLR, DVLR);
If we can set the log category here, I wonder why it does use the SGS category hardcoded as you ment […]
I'm using it now. Still not happy with the usage of SGS fsm, but it doesn't hurt atm. I want to remove it from the SGSN later, when libvlr only uses SGS on CS.
File src/sgsn/gprs_gmm_fsm.c:
https://gerrit.osmocom.org/c/osmo-sgsn/+/39562/comment/8b33f704_83775b61?usp... : PS16, Line 262: /* fixme: this state seems to be wrong. When in COMMON_PROC_INIT, we shouldn't go into deregistered. */
FIXME
Done
https://gerrit.osmocom.org/c/osmo-sgsn/+/39562/comment/a78d2e54_ec510f2c?usp... : PS16, Line 307: .allstate_event_mask = X(E_GMM_CLEANUP) | X(E_GMM_RAT_CHANGE) | X(E_GMM_SERVICE_ACCEPT) | X(E_GMM_SERVICE_REJECT),
plese better move to one per line, it's much easier to read.
Done
File src/sgsn/gprs_rau_fsm.c:
https://gerrit.osmocom.org/c/osmo-sgsn/+/39562/comment/70685dfa_e5ed2078?usp... : PS16, Line 303: .action = gmm_rau_fsm_s_init,
I'd really welcome using at least "st" for state, not only "s".
Done
File src/sgsn/sgsn_libgtp.c:
https://gerrit.osmocom.org/c/osmo-sgsn/+/39562/comment/8cb49ea2_cbd10987?usp... : PS16, Line 534: return 0; /* Nothing to do */
This is the kind of fixes which can be done in a separate patch. […]
another white space slipped through...