Attention is currently required from: pespin.
6 comments:
File include/osmocom/sgsn/debug.h:
Patch Set #16, Line 31: DSGS, /* only as placeholder, SGS isn't used by the SGSN */
because libvlr is using it. I improved the comment.
I removed it.
File src/sgsn/gprs_gmm.c:
Patch Set #17, Line 2602: osmo_vlr_set_log_cat(OSMO_VLR_LOGC_VLR, DVLR);
If we can set the log category here, I wonder why it does use the SGS category hardcoded as you ment […]
I'm using it now. Still not happy with the usage of SGS fsm, but it doesn't hurt atm.
I want to remove it from the SGSN later, when libvlr only uses SGS on CS.
File src/sgsn/gprs_gmm_fsm.c:
Patch Set #16, Line 262: /* fixme: this state seems to be wrong. When in COMMON_PROC_INIT, we shouldn't go into deregistered. */
FIXME
Done
Patch Set #16, Line 307: .allstate_event_mask = X(E_GMM_CLEANUP) | X(E_GMM_RAT_CHANGE) | X(E_GMM_SERVICE_ACCEPT) | X(E_GMM_SERVICE_REJECT),
plese better move to one per line, it's much easier to read.
Done
File src/sgsn/gprs_rau_fsm.c:
Patch Set #16, Line 303: .action = gmm_rau_fsm_s_init,
I'd really welcome using at least "st" for state, not only "s".
Done
File src/sgsn/sgsn_libgtp.c:
Patch Set #16, Line 534: return 0; /* Nothing to do */
This is the kind of fixes which can be done in a separate patch. […]
another white space slipped through...
To view, visit change 39562. To unsubscribe, or for help writing mail filters, visit settings.